devel/qca:

- Update to 2.1.1
- Remove patches integrated upstream
- Amend COMMENT
- tarballs are now hosted by KDE Project

devel/qca-qt5:
- Use build switch to avoid conflict with QCA Qt4 instead of patching library
  name and install path for headers
- Make port a slave of devel/qca
- Pass maintainership to kde@

PR:		204305
Approved by:	pawel
This commit is contained in:
Max Brazhnikov 2015-11-06 12:56:36 +00:00
parent 6f92585f78
commit f8449eb419
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=400930
12 changed files with 58 additions and 230 deletions

View file

@ -1,39 +1,10 @@
# Created by: Vsevolod Stakhov <vsevolod@highsecure.ru>
# $FreeBSD$
PORTNAME= qca
PORTVERSION= 2.1.0
CATEGORIES= devel
MASTER_SITES= http://delta.affinix.com/download/qca/2.0/
PKGNAMESUFFIX= -qt5
MAINTAINER= pawel@FreeBSD.org
COMMENT= Cross-platform crypto API for Qt5
COMMENT= Cross-platform crypto API for Qt 5
BUILD_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
PLIST= ${PKGDIR}/pkg-plist.qt5
USES= cmake:outsource
CMAKE_ARGS= -DBUILD_PLUGINS=none -DBUILD_TESTS=no -DQT5_BUILD=yes \
-DPKGCONFIG_INSTALL_PREFIX=${PREFIX}/libdata/pkgconfig \
-DQCA_FEATURE_INSTALL_DIR=${QT_MKSPECDIR}/features \
-DQCA_MAN_INSTALL_DIR=${MANPREFIX}/man \
-DQCA_SUFFIX=qt5
CONFIGURE_ENV= QC_CERTSTORE_PATH=${LOCALBASE}/share/certs/ca-root-nss.crt
USE_LDCONFIG= yes
USE_QT5= buildtools_build core network qmake_build
OPTIONS_DEFINE= GNUPG OPENSSL SASL
OPTIONS_DEFAULT=GNUPG OPENSSL
OPTIONS_SUB= yes
GNUPG_CMAKE_ON= -DWITH_gnupg_PLUGIN=yes
GNUPG_RUN_DEPENDS= gpg2:${PORTSDIR}/security/gnupg
OPENSSL_CMAKE_ON= -DWITH_ossl_PLUGIN=yes
OPENSSL_USE= OPENSSL=yes
SASL_CMAKE_ON= -DWITH_cyrus-sasl_PLUGIN=yes
SASL_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
.include <bsd.port.mk>
MASTERDIR= ${.CURDIR}/../qca
.include "${MASTERDIR}/Makefile"

View file

@ -1,2 +0,0 @@
SHA256 (qca-2.1.0.tar.gz) = 226dcd76138c3738cdc15863607a96b3758a4c3efd3c47295939bcea4e7a9284
SIZE (qca-2.1.0.tar.gz) = 978473

View file

@ -1,63 +0,0 @@
--- CMakeLists.txt.orig 2014-11-06 08:15:45 UTC
+++ CMakeLists.txt
@@ -170,8 +170,8 @@ else( QCA_INSTALL_IN_QT_PREFIX )
set(QCA_BINARY_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/bin" CACHE PATH "Directory where qca plugins will install")
set(QCA_LIBRARY_INSTALL_DIR "${LIB_INSTALL_DIR}" CACHE PATH "Directory where qca library will install")
set(QCA_FEATURE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/mkspecs/features" CACHE PATH "Directory where qca feature file will install")
- set(QCA_INCLUDE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/include" CACHE PATH "Directory where qca public headers will install")
- set(QCA_PRIVATE_INCLUDE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/include" CACHE PATH "Directory where qca headers will install")
+ set(QCA_INCLUDE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/include/qca-${QCA_SUFFIX}" CACHE PATH "Directory where qca public headers will install")
+ set(QCA_PRIVATE_INCLUDE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/include/qca-${QCA_SUFFIX}" CACHE PATH "Directory where qca headers will install")
set(QCA_DOC_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/share/doc/${QCA_LIB_NAME}/html" CACHE PATH "Directory where qca documentation will install")
set(QCA_MAN_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/share/man" CACHE PATH "Directory where qca man pages will install")
endif( QCA_INSTALL_IN_QT_PREFIX )
@@ -262,13 +262,13 @@ message(STATUS "Checking for certstore..
if( WIN32 )
# USE BUILTIN
else ( WIN32 )
- if ( ENV{QC_CERTSTORE_PATH} )
- if(EXISTS ENV{QC_CERTSTORE_PATH})
+ if ( DEFINED ENV{QC_CERTSTORE_PATH} )
+ if(EXISTS $ENV{QC_CERTSTORE_PATH})
set( qca_CERTSTORE $ENV{QC_CERTSTORE_PATH})
- else(EXISTS ENV{QC_CERTSTORE_PATH})
+ else(EXISTS $ENV{QC_CERTSTORE_PATH})
# path to try
- endif(EXISTS ENV{QC_CERTSTORE_PATH})
- else( ENV{QC_CERTSTORE_PATH} )
+ endif(EXISTS $ENV{QC_CERTSTORE_PATH})
+ else( DEFINED ENV{QC_CERTSTORE_PATH} )
set( toTry
"/etc/ssl/certs/ca-certificates.crt"
"/usr/share/ssl/cert.pem"
@@ -282,7 +282,7 @@ else ( WIN32 )
set( qca_CERTSTORE ${_current_try})
endif(EXISTS ${_current_try})
endforeach (_current_try)
- endif( ENV{QC_CERTSTORE_PATH} )
+ endif( DEFINED ENV{QC_CERTSTORE_PATH} )
endif(WIN32)
if (qca_CERTSTORE)
@@ -374,7 +374,7 @@ include(CMakePackageConfigHelpers)
configure_package_config_file(
"${CMAKE_CURRENT_SOURCE_DIR}/QcaConfig.cmake.in"
"${CMAKE_CURRENT_BINARY_DIR}/lib/cmake/Qca/QcaConfig.cmake"
- INSTALL_DESTINATION ${QCA_LIBRARY_INSTALL_DIR}/cmake/Qca
+ INSTALL_DESTINATION ${QCA_LIBRARY_INSTALL_DIR}/cmake/Qca-${QCA_SUFFIX}
)
write_basic_config_version_file("${CMAKE_CURRENT_BINARY_DIR}/lib/cmake/Qca/QcaConfigVersion.cmake" VERSION ${QCA_LIB_VERSION_STRING} COMPATIBILITY AnyNewerVersion)
@@ -434,10 +434,10 @@ if(NOT DEVELOPER_MODE)
endif()
message("")
- install(EXPORT QCATargets DESTINATION ${QCA_LIBRARY_INSTALL_DIR}/cmake/Qca FILE QcaTargets.cmake)
+ install(EXPORT QCATargets DESTINATION ${QCA_LIBRARY_INSTALL_DIR}/cmake/Qca-${QCA_SUFFIX} FILE QcaTargets.cmake)
install(FILES
"${CMAKE_CURRENT_BINARY_DIR}/lib/cmake/Qca/QcaConfig.cmake"
"${CMAKE_CURRENT_BINARY_DIR}/lib/cmake/Qca/QcaConfigVersion.cmake"
- DESTINATION ${QCA_LIBRARY_INSTALL_DIR}/cmake/Qca
+ DESTINATION ${QCA_LIBRARY_INSTALL_DIR}/cmake/Qca-${QCA_SUFFIX}
)
endif()

View file

@ -1,22 +0,0 @@
commit d4e9444f9dd2741cc2a4b3f4d6c510e4a1d7413c
Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
Date: Sat Jan 17 15:12:03 2015 +0200
Do not end Cipher::Mode with a comma.
This solves a build failure with compilers such as GCC 4.2:
/usr/local/include/QtCrypto/qca_basic.h:598: error: comma at end of enumerator list
REVIEW: 122107
--- include/QtCrypto/qca_basic.h
+++ include/QtCrypto/qca_basic.h
@@ -595,7 +595,7 @@ public:
CFB, ///< operate in %Cipher FeedBack mode
ECB, ///< operate in Electronic Code Book mode
OFB, ///< operate in Output FeedBack Mode
- CTR, ///< operate in CounTer Mode
+ CTR ///< operate in CounTer Mode
};
/**

View file

@ -1,13 +0,0 @@
QCA aims to provide a straightforward and cross-platform crypto API,
using Qt datatypes and conventions.
Supported features:
* SSL/TLS
* X509
* SASL
* RSA
* Hashing (SHA1, MD5)
* Ciphers (Blowfish, 3DES, AES)
WWW: http://delta.affinix.com/qca/

View file

@ -1,32 +0,0 @@
bin/mozcerts-qt5
bin/qcatool-qt5
include/qca-qt5/QtCrypto/QtCrypto
include/qca-qt5/QtCrypto/qca.h
include/qca-qt5/QtCrypto/qca_basic.h
include/qca-qt5/QtCrypto/qca_cert.h
include/qca-qt5/QtCrypto/qca_core.h
include/qca-qt5/QtCrypto/qca_export.h
include/qca-qt5/QtCrypto/qca_keystore.h
include/qca-qt5/QtCrypto/qca_publickey.h
include/qca-qt5/QtCrypto/qca_safetimer.h
include/qca-qt5/QtCrypto/qca_securelayer.h
include/qca-qt5/QtCrypto/qca_securemessage.h
include/qca-qt5/QtCrypto/qca_support.h
include/qca-qt5/QtCrypto/qca_textfilter.h
include/qca-qt5/QtCrypto/qca_tools.h
include/qca-qt5/QtCrypto/qca_version.h
include/qca-qt5/QtCrypto/qcaprovider.h
include/qca-qt5/QtCrypto/qpipe.h
lib/cmake/Qca-qt5/QcaConfig.cmake
lib/cmake/Qca-qt5/QcaConfigVersion.cmake
lib/cmake/Qca-qt5/QcaTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/Qca-qt5/QcaTargets.cmake
lib/libqca-qt5.so
lib/libqca-qt5.so.2
lib/libqca-qt5.so.2.1.0
%%SASL%%lib/qca-qt5/crypto/libqca-cyrus-sasl.so
%%GNUPG%%lib/qca-qt5/crypto/libqca-gnupg.so
%%OPENSSL%%lib/qca-qt5/crypto/libqca-ossl.so
%%QT_MKSPECDIR%%/features/crypto.prf
libdata/pkgconfig/qca2-qt5.pc
man/man1/qcatool-qt5.1.gz

View file

@ -2,25 +2,33 @@
# $FreeBSD$
PORTNAME= qca
PORTVERSION= 2.1.0
PORTREVISION= 3
PORTVERSION= 2.1.1
CATEGORIES= devel
MASTER_SITES= http://delta.affinix.com/download/qca/2.0/
MASTER_SITES= KDE/stable/qca/${PORTVERSION}/src
MAINTAINER= kde@FreeBSD.org
COMMENT= Cross-platform crypto API for Qt
COMMENT= Cross-platform crypto API for Qt 4
BUILD_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
USES= cmake:outsource
CMAKE_ARGS= -DBUILD_PLUGINS=none -DBUILD_TESTS=no -DQT4_BUILD=yes \
USES= cmake:outsource tar:xz
CMAKE_ARGS= -DBUILD_PLUGINS=none -DBUILD_TESTS=no \
-DPKGCONFIG_INSTALL_PREFIX=${PREFIX}/libdata/pkgconfig \
-DQCA_FEATURE_INSTALL_DIR=${QT_MKSPECDIR}/features \
-DQCA_MAN_INSTALL_DIR=${MANPREFIX}/man
-DQCA_MAN_INSTALL_DIR=${PREFIX}/man
CONFIGURE_ENV= QC_CERTSTORE_PATH=${LOCALBASE}/share/certs/ca-root-nss.crt
USE_LDCONFIG= yes
.if defined(PKGNAMESUFFIX)
CMAKE_ARGS+= -DQCA_SUFFIX=qt5
USE_QT5= core buildtools_build qmake_build
.else
USE_QT4= corelib moc_build qmake_build rcc_build
CMAKE_ARGS+= -DQT4_BUILD=yes
.endif
PLIST_SUB= SHLIB_VER=${PORTVERSION}
OPTIONS_DEFINE= GNUPG OPENSSL SASL
OPTIONS_DEFAULT=GNUPG OPENSSL
@ -35,4 +43,8 @@ OPENSSL_USE= OPENSSL=yes
SASL_CMAKE_ON= -DWITH_cyrus-sasl_PLUGIN=yes
SASL_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
post-patch:
# Qt Network module is used for tests only
${REINPLACE_CMD} 's,Core Network,Core,' ${WRKSRC}/CMakeLists.txt
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (qca-2.1.0.tar.gz) = 226dcd76138c3738cdc15863607a96b3758a4c3efd3c47295939bcea4e7a9284
SIZE (qca-2.1.0.tar.gz) = 978473
SHA256 (qca-2.1.1.tar.xz) = 95de3e7910b5f9ec7084169989c9d98bfb527e6a4865fe17269c3b24308be983
SIZE (qca-2.1.1.tar.xz) = 688460

View file

@ -1,33 +0,0 @@
Fix a few syntax errors such that the QC_CERTSTORE_PATH environment
variable is used correctly.
--- CMakeLists.txt.orig 2014-11-06 08:15:45 UTC
+++ CMakeLists.txt
@@ -262,13 +262,13 @@ message(STATUS "Checking for certstore..
if( WIN32 )
# USE BUILTIN
else ( WIN32 )
- if ( ENV{QC_CERTSTORE_PATH} )
- if(EXISTS ENV{QC_CERTSTORE_PATH})
+ if ( DEFINED ENV{QC_CERTSTORE_PATH} )
+ if(EXISTS $ENV{QC_CERTSTORE_PATH})
set( qca_CERTSTORE $ENV{QC_CERTSTORE_PATH})
- else(EXISTS ENV{QC_CERTSTORE_PATH})
+ else(EXISTS $ENV{QC_CERTSTORE_PATH})
# path to try
- endif(EXISTS ENV{QC_CERTSTORE_PATH})
- else( ENV{QC_CERTSTORE_PATH} )
+ endif(EXISTS $ENV{QC_CERTSTORE_PATH})
+ else( DEFINED ENV{QC_CERTSTORE_PATH} )
set( toTry
"/etc/ssl/certs/ca-certificates.crt"
"/usr/share/ssl/cert.pem"
@@ -282,7 +282,7 @@ else ( WIN32 )
set( qca_CERTSTORE ${_current_try})
endif(EXISTS ${_current_try})
endforeach (_current_try)
- endif( ENV{QC_CERTSTORE_PATH} )
+ endif( DEFINED ENV{QC_CERTSTORE_PATH} )
endif(WIN32)
if (qca_CERTSTORE)

View file

@ -1,22 +0,0 @@
commit d4e9444f9dd2741cc2a4b3f4d6c510e4a1d7413c
Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
Date: Sat Jan 17 15:12:03 2015 +0200
Do not end Cipher::Mode with a comma.
This solves a build failure with compilers such as GCC 4.2:
/usr/local/include/QtCrypto/qca_basic.h:598: error: comma at end of enumerator list
REVIEW: 122107
--- include/QtCrypto/qca_basic.h
+++ include/QtCrypto/qca_basic.h
@@ -595,7 +595,7 @@ public:
CFB, ///< operate in %Cipher FeedBack mode
ECB, ///< operate in Electronic Code Book mode
OFB, ///< operate in Output FeedBack Mode
- CTR, ///< operate in CounTer Mode
+ CTR ///< operate in CounTer Mode
};
/**

View file

@ -23,7 +23,7 @@ lib/cmake/Qca/QcaTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/Qca/QcaTargets.cmake
lib/libqca.so
lib/libqca.so.2
lib/libqca.so.2.1.0
lib/libqca.so.%%SHLIB_VER%%
%%SASL%%lib/qca/crypto/libqca-cyrus-sasl.so
%%GNUPG%%lib/qca/crypto/libqca-gnupg.so
%%OPENSSL%%lib/qca/crypto/libqca-ossl.so

32
devel/qca/pkg-plist.qt5 Normal file
View file

@ -0,0 +1,32 @@
bin/mozcerts-qt5
bin/qcatool-qt5
include/Qca-qt5/QtCrypto/QtCrypto
include/Qca-qt5/QtCrypto/qca.h
include/Qca-qt5/QtCrypto/qca_basic.h
include/Qca-qt5/QtCrypto/qca_cert.h
include/Qca-qt5/QtCrypto/qca_core.h
include/Qca-qt5/QtCrypto/qca_export.h
include/Qca-qt5/QtCrypto/qca_keystore.h
include/Qca-qt5/QtCrypto/qca_publickey.h
include/Qca-qt5/QtCrypto/qca_safetimer.h
include/Qca-qt5/QtCrypto/qca_securelayer.h
include/Qca-qt5/QtCrypto/qca_securemessage.h
include/Qca-qt5/QtCrypto/qca_support.h
include/Qca-qt5/QtCrypto/qca_textfilter.h
include/Qca-qt5/QtCrypto/qca_tools.h
include/Qca-qt5/QtCrypto/qca_version.h
include/Qca-qt5/QtCrypto/qcaprovider.h
include/Qca-qt5/QtCrypto/qpipe.h
%%QT_LIBDIR%%/cmake/Qca-qt5/Qca-qt5Config.cmake
%%QT_LIBDIR%%/cmake/Qca-qt5/Qca-qt5ConfigVersion.cmake
%%QT_LIBDIR%%/cmake/Qca-qt5/Qca-qt5Targets-%%CMAKE_BUILD_TYPE%%.cmake
%%QT_LIBDIR%%/cmake/Qca-qt5/Qca-qt5Targets.cmake
%%QT_LIBDIR%%/libqca-qt5.so
%%QT_LIBDIR%%/libqca-qt5.so.2
%%QT_LIBDIR%%/libqca-qt5.so.%%SHLIB_VER%%
%%SASL%%%%QT_LIBDIR%%/qca-qt5/crypto/libqca-cyrus-sasl.so
%%GNUPG%%%%QT_LIBDIR%%/qca-qt5/crypto/libqca-gnupg.so
%%OPENSSL%%%%QT_LIBDIR%%/qca-qt5/crypto/libqca-ossl.so
%%QT_MKSPECDIR%%/features/crypto.prf
libdata/pkgconfig/qca2-qt5.pc
man/man1/qcatool-qt5.1.gz