Add pico 3.7, PIne's message COmposition editor.

PR:		23596
Submitted by:	Jeremy Shaffner <jeremy@external.org>
Approved by:	asami (no repository copy necessary)
This commit is contained in:
Will Andrews 2001-01-02 09:04:10 +00:00
parent e8e05d06ae
commit f88fe6dcdc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36595
11 changed files with 260 additions and 0 deletions

View file

@ -72,6 +72,7 @@
SUBDIR += nvi-perl
SUBDIR += offix-editor
SUBDIR += openoffice
SUBDIR += pico
SUBDIR += psgml-emacs
SUBDIR += psgml-emacs20
SUBDIR += psgml-mule

32
editors/pico/Makefile Normal file
View file

@ -0,0 +1,32 @@
# New ports collection makefile for: pico
# Date created: 16 December 2000
# Whom: Jeremy Shaffner <jeremy@external.org>
#
# $FreeBSD$
#
# This port tracks Pine4
# All patch files have been taken from mail/pine4
PORTNAME= pico
PORTVERSION= 3.7
CATEGORIES= editors
MASTER_SITES= ftp://ftp.cac.washington.edu/pine/
DISTNAME= pine${pineversion}
MAINTAINER= jeremy@external.org
WRKSRC= ${WRKDIR}/pine${pineversion}/pico
PATCH_WRKSRC= ${WRKSRC}/..
pineversion= 4.21
MAKEFILE= makefile.bsf
ALL_TARGET= pico
MAN1= pico.1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pico ${PREFIX}/bin/pico
${INSTALL_MAN} ${WRKSRC}/../doc/pico.1 ${PREFIX}/man/man1/pico.1
.include <bsd.port.mk>

1
editors/pico/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (pine4.21.tar.gz) = 9252a061387de806f8aa1ced885d41f6

View file

@ -0,0 +1,31 @@
--- pico/search.c.old Tue Oct 5 01:49:41 1999
+++ pico/search.c Wed Feb 16 03:41:45 2000
@@ -97,12 +97,15 @@
int bc;
int pc;
{
+ bc = (unsigned char)bc;
+ pc = (unsigned char)pc;
+
if ((curwp->w_bufp->b_mode & MDEXACT) == 0){
- if (bc>='a' && bc<='z')
- bc -= 0x20;
+ if (islower(bc))
+ bc = toupper(bc);
- if (pc>='a' && pc<='z')
- pc -= 0x20;
+ if (islower(pc))
+ pc = toupper(pc);
}
return(bc == pc);
@@ -804,7 +807,7 @@
int maxlength; /* maximum chars in destination */
{
- char c; /* current char to translate */
+ unsigned char c; /* current char to translate */
/* scan through the string */
while ((c = *srcstr++) != 0) {

View file

@ -0,0 +1,36 @@
*** pico/osdep/os-bsf.h.orig Wed Jul 8 19:37:28 1998
--- pico/osdep/os-bsf.h Fri Jul 10 12:57:37 1998
***************
*** 23,29 ****
#define USE_DIRENT
#include <sys/types.h>
! #include <sys/dir.h>
#include <stdlib.h>
#include <string.h>
--- 23,29 ----
#define USE_DIRENT
#include <sys/types.h>
! #include <dirent.h>
#include <stdlib.h>
#include <string.h>
***************
*** 152,158 ****
/*
* Place where mail gets delivered (for pico's new mail checking)
*/
! #define MAILDIR "/usr/spool/mail"
/*
* What and where the tool that checks spelling is located. If this is
--- 152,158 ----
/*
* Place where mail gets delivered (for pico's new mail checking)
*/
! #define MAILDIR "/var/mail"
/*
* What and where the tool that checks spelling is located. If this is

View file

@ -0,0 +1,20 @@
*** pico/osdep/term.cap.orig Sat Feb 28 02:14:53 1998
--- pico/osdep/term.cap Wed Jul 15 01:58:58 1998
***************
*** 270,276 ****
_kppu = tgetstr("kP", &p);
_kppd = tgetstr("kN", &p);
_kphome = tgetstr("kh", &p);
! _kpend = tgetstr("kH", &p);
_kpdel = tgetstr("kD", &p);
_kf1 = tgetstr("k1", &p);
_kf2 = tgetstr("k2", &p);
--- 270,277 ----
_kppu = tgetstr("kP", &p);
_kppd = tgetstr("kN", &p);
_kphome = tgetstr("kh", &p);
! if((_kpend = tgetstr("@7", &p)) == NULL)
! _kpend = tgetstr("kH",&p);
_kpdel = tgetstr("kD", &p);
_kf1 = tgetstr("k1", &p);
_kf2 = tgetstr("k2", &p);

View file

@ -0,0 +1,57 @@
*** pico/display.c.orig Fri Jun 19 20:19:53 1998
--- pico/display.c Mon Jul 13 01:36:38 1998
***************
*** 77,83 ****
{"^X", "Exit", KS_EXIT}, {"^J", "Justify", KS_JUSTIFY},
{"^W", "Where is", KS_WHEREIS}, {"^V", "Next Pg", KS_NEXTPAGE},
{"^U", NULL, KS_NONE},
! #ifdef SPELLER
{"^T", "To Spell", KS_SPELLCHK}
#else
{"^D", "Del Char", KS_NONE}
--- 77,83 ----
{"^X", "Exit", KS_EXIT}, {"^J", "Justify", KS_JUSTIFY},
{"^W", "Where is", KS_WHEREIS}, {"^V", "Next Pg", KS_NEXTPAGE},
{"^U", NULL, KS_NONE},
! #if defined(SPELLER) && !defined(__FreeBSD__)
{"^T", "To Spell", KS_SPELLCHK}
#else
{"^D", "Del Char", KS_NONE}
*** pico/ebind.h.orig Sat Feb 28 02:10:31 1998
--- pico/ebind.h Mon Jul 13 01:36:39 1998
***************
*** 145,151 ****
{CTRL|'O', filewrite},
{CTRL|'P', backline},
{CTRL|'R', insfile},
! #ifdef SPELLER
{CTRL|'T', spell},
#endif /* SPELLER */
{CTRL|'U', yank},
--- 145,151 ----
{CTRL|'O', filewrite},
{CTRL|'P', backline},
{CTRL|'R', insfile},
! #if defined(SPELLER) && !defined(__FreeBSD__)
{CTRL|'T', spell},
#endif /* SPELLER */
{CTRL|'U', yank},
*** pico/main.c.orig Tue Apr 21 20:28:08 1998
--- pico/main.c Mon Jul 13 01:36:39 1998
***************
*** 66,72 ****
{ F9, (CTRL|'K')},
{ F10, (CTRL|'U')},
{ F11, (CTRL|'C')},
! #ifdef SPELLER
{ F12, (CTRL|'T')}
#else
{ F12, (CTRL|'D')}
--- 66,72 ----
{ F9, (CTRL|'K')},
{ F10, (CTRL|'U')},
{ F11, (CTRL|'C')},
! #if defined(SPELLER) && !defined(__FreeBSD__)
{ F12, (CTRL|'T')}
#else
{ F12, (CTRL|'D')}

View file

@ -0,0 +1,76 @@
*** pine/init.c.orig Tue Jan 26 21:57:56 1999
--- pine/init.c Tue Feb 9 22:14:08 1999
***************
*** 326,332 ****
/*----------------------------------------------------------------------
These are the variables that control a number of pine functions. They
! come out of the .pinerc and the /usr/local/lib/pine.conf files. Some can
be set by the user while in Pine. Eventually all the local ones should
be so and maybe the global ones too.
--- 326,332 ----
/*----------------------------------------------------------------------
These are the variables that control a number of pine functions. They
! come out of the .pinerc and the @@PREFIX@@/etc/pine.conf files. Some can
be set by the user while in Pine. Eventually all the local ones should
be so and maybe the global ones too.
*** pico/edef.h.orig Thu Apr 23 02:53:44 1998
--- pico/edef.h Tue Feb 9 22:14:08 1999
***************
*** 59,65 ****
int ComposerEditing = FALSE; /* TRUE if message line is open */
int revexist = FALSE; /* does reverse video exist? */
char modecode[] = "WCSEVO"; /* letters to represent modes */
! long gmode = MDWRAP; /* global editor mode */
int sgarbf = TRUE; /* TRUE if screen is garbage */
int mpresf = FALSE; /* TRUE if message in last line */
int clexec = FALSE; /* command line execution flag */
--- 59,65 ----
int ComposerEditing = FALSE; /* TRUE if message line is open */
int revexist = FALSE; /* does reverse video exist? */
char modecode[] = "WCSEVO"; /* letters to represent modes */
! long gmode = MDWRAP | MDTCAPWINS; /* global editor mode */
int sgarbf = TRUE; /* TRUE if screen is garbage */
int mpresf = FALSE; /* TRUE if message in last line */
int clexec = FALSE; /* command line execution flag */
*** pico/main.c.orig Tue Feb 9 21:46:54 1999
--- pico/main.c Tue Feb 9 22:14:08 1999
***************
*** 443,449 ****
gmode ^= MDSSPD;
break;
case 'q': /* -q for termcap takes precedence */
! gmode ^= MDTCAPWINS;
break;
case 'w': /* -w turn off word wrap */
gmode ^= MDWRAP;
--- 443,449 ----
gmode ^= MDSSPD;
break;
case 'q': /* -q for termcap takes precedence */
! gmode |= MDTCAPWINS;
break;
case 'w': /* -w turn off word wrap */
gmode ^= MDWRAP;
*** pico/pilot.c.orig Mon Aug 24 20:37:39 1998
--- pico/pilot.c Tue Feb 9 22:14:09 1999
***************
*** 222,228 ****
sup_keyhelp = !sup_keyhelp;
break;
case 'q': /* -q for termcap takes precedence */
! gmode ^= MDTCAPWINS;
break;
case 'z': /* -z to suspend */
gmode ^= MDSSPD;
--- 222,228 ----
sup_keyhelp = !sup_keyhelp;
break;
case 'q': /* -q for termcap takes precedence */
! gmode |= MDTCAPWINS;
break;
case 'z': /* -z to suspend */
gmode ^= MDSSPD;

1
editors/pico/pkg-comment Normal file
View file

@ -0,0 +1 @@
PIne's message COmposition editor

4
editors/pico/pkg-descr Normal file
View file

@ -0,0 +1,4 @@
PICO is a very simple and easy-to-use text editor offering paragraph
justification, cut/paste, and a spelling checker.
WWW: http://www.washington.edu/pine/

1
editors/pico/pkg-plist Normal file
View file

@ -0,0 +1 @@
bin/pico