- Delete expired port net/p5-Net-Z3950: does not compile with yaz 3.x,
deprecated in favor of ZOOM-Perl (net/p5-Net-Z3950-ZOOM)
This commit is contained in:
parent
17f6802000
commit
f8b4192949
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=215167
7 changed files with 1 additions and 73 deletions
1
MOVED
1
MOVED
|
@ -3502,3 +3502,4 @@ math/umfpack|||2008-06-18|Has expired: Outdated subset of math/suitesparse
|
|||
net/apache-soap|||2008-06-18|Has expired: Development has been ceased, superseded by www/axis.
|
||||
net/archie|||2008-06-18|Has expired: No servers active anymore
|
||||
net/xarchie|||2008-06-18|Has expired: No servers active anymore
|
||||
net/p5-Net-Z3950|||2008-06-18|Has expired: does not compile with yaz 3.x, deprecated in favor of ZOOM-Perl (net/p5-Net-Z3950-ZOOM)
|
||||
|
|
|
@ -571,7 +571,6 @@
|
|||
SUBDIR += p5-Net-Write
|
||||
SUBDIR += p5-Net-XWhois
|
||||
SUBDIR += p5-Net-Yadis
|
||||
SUBDIR += p5-Net-Z3950
|
||||
SUBDIR += p5-Net-Z3950-SimpleServer
|
||||
SUBDIR += p5-Net-Z3950-ZOOM
|
||||
SUBDIR += p5-Net-ext
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
# New ports collection makefile for: p5-Net-Z3950
|
||||
# Date created: 23 December 2001
|
||||
# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= Net-Z3950
|
||||
PORTVERSION= 0.51
|
||||
CATEGORIES= net perl5
|
||||
MASTER_SITES= http://perl.z3950.org/download/
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= demon@FreeBSD.org
|
||||
COMMENT= A perl interface to the Z39.50 information retrieval protocol
|
||||
|
||||
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event
|
||||
LIB_DEPENDS= yaz.3:${PORTSDIR}/net/yaz
|
||||
RUN_DEPENDS= ${SITE_PERL}/MARC/Record.pm:${PORTSDIR}/textproc/p5-MARC-Record \
|
||||
${SITE_PERL}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event
|
||||
|
||||
BROKEN= does not compile with yaz 3.x, deprecated in favor of ZOOM-Perl (net/p5-Net-Z3950-ZOOM)
|
||||
DEPRECATED= ${BROKEN}
|
||||
EXPIRATION_DATE=2008-05-04
|
||||
|
||||
PERL_CONFIGURE= yes
|
||||
|
||||
MAN3= Net::Z3950::ResultSet.3 Net::Z3950::Manager.3 \
|
||||
Net::Z3950::Tutorial.3 Net::Z3950::Record.3 \
|
||||
Net::Z3950::Connection.3 Net::Z3950::APDU.3 Net::Z3950.3 \
|
||||
Net::Z3950::ScanSet.3
|
||||
|
||||
CONFLICTS= p5-Net-Z3950-ZOOM-[0-9]*
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (Net-Z3950-0.51.tar.gz) = 9570c710dfab1c3d6af418557b07a2cd
|
||||
SHA256 (Net-Z3950-0.51.tar.gz) = 2f5cb42dc9c3a4f1c63f86d924489b4796fdf46bd1b82c5c9fc2eae3745b2c3b
|
||||
SIZE (Net-Z3950-0.51.tar.gz) = 87884
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile.PL.orig 2007-10-30 15:18:30.000000000 -0700
|
||||
+++ Makefile.PL 2007-10-30 15:18:48.000000000 -0700
|
||||
@@ -6,7 +6,7 @@
|
||||
# my $yazconf = "/home/me/stuff/yaz-2.0.4/yaz-config";
|
||||
|
||||
my $yazconf = "yaz-config";
|
||||
-my $yazinc = `$yazconf --cflags`;
|
||||
+my $yazinc = `$yazconf --cflags | sed 's/ -pthread / /'`;
|
||||
my $yazlibs = `$yazconf --libs`;
|
||||
if (!$yazinc || !$yazlibs) {
|
||||
die "ERROR: Unable to call script 'yaz-config': is YAZ installed?";
|
|
@ -1,7 +0,0 @@
|
|||
This Perl module provides interface to the Z39.50 information
|
||||
retrieval protocol (aka ISO 23950), a mature and powerful protocol
|
||||
used in application domains as diverse as bibliographic information,
|
||||
geo-spatial mapping, museums and other cultural heritage information,
|
||||
and structured vocabulary navigation.
|
||||
|
||||
WWW: http://perl.z3950.org/
|
|
@ -1,16 +0,0 @@
|
|||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Z3950/.packlist
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Z3950/autosplit.ix
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Z3950/Z3950.bs
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Z3950/Z3950.so
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/Net/Z3950.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/Net/Z3950/APDU.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/Net/Z3950/Connection.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/Net/Z3950/Manager.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/Net/Z3950/Record.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/Net/Z3950/ResultSet.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/Net/Z3950/ScanSet.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/Net/Z3950/Tutorial.pm
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Z3950
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Net/Z3950
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Net
|
Loading…
Reference in a new issue