Remove expired port:
2016-02-14 ports-mgmt/tinderbox-devel: use newer stable version (ports-mgmt/tinderbox)
This commit is contained in:
parent
4e42cc6108
commit
f8c734b5a1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=408853
10 changed files with 1 additions and 531 deletions
1
MOVED
1
MOVED
|
@ -8136,3 +8136,4 @@ graphics/py-graphviz|graphics/py-pygraphviz|2016-02-07|Renamed to match upstream
|
|||
security/polarssl||2016-02-07|Has expired: Upstream is ending support for 1.2.x
|
||||
multimedia/xbmc-addon-pvr||2016-02-12|Has expired: Does not work with multimedia/kodi 15.x and newer
|
||||
security/py-openid|security/py-python-openid|2016-02-13|Renamed to match upstream (PyPI) name
|
||||
ports-mgmt/tinderbox-devel|ports-mgmt/tinderbox|2016-02-14|Has expired: use newer stable version (ports-mgmt/tinderbox)
|
||||
|
|
|
@ -67,7 +67,6 @@
|
|||
SUBDIR += symports
|
||||
SUBDIR += synth
|
||||
SUBDIR += tinderbox
|
||||
SUBDIR += tinderbox-devel
|
||||
SUBDIR += wanted-ports
|
||||
SUBDIR += xps
|
||||
|
||||
|
|
|
@ -1,134 +0,0 @@
|
|||
# Created by: Edwin Groothuis <edwin@mavetju.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= tinderbox
|
||||
DISTVERSION= 4.0.0.b2
|
||||
PORTREVISION= 2
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= ports-mgmt
|
||||
MASTER_SITES= http://tinderbox.marcuscom.com/ \
|
||||
http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
|
||||
PKGNAMESUFFIX= -devel
|
||||
DIST_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= crees@FreeBSD.org
|
||||
COMMENT= Port build tinderbox system, devel version
|
||||
|
||||
CONFLICTS= tinderbox-[0-9]*
|
||||
|
||||
IGNORE= much older than stable version (ports-mgmt/tinderbox)
|
||||
DEPRECATED= use newer stable version (ports-mgmt/tinderbox)
|
||||
EXPIRATION_DATE= 2016-02-14
|
||||
|
||||
OPTIONS_MULTI= DB
|
||||
OPTIONS_MULTI_DB= PGSQL MYSQL SQLITE
|
||||
|
||||
OPTIONS_RADIO= WEB
|
||||
OPTIONS_RADIO_WEB= APACHE HIAWATHA LIGHTTPD NGINX
|
||||
|
||||
OPTIONS_DEFINE= CHECK_ROOT EMAILS LSOF LOG_COMPRESS \
|
||||
PARALLEL TMPFS
|
||||
|
||||
CHECK_ROOT_DESC= Check if ./tc is run by uid 0
|
||||
EMAILS_DESC= Support for build failure/completion emails
|
||||
LSOF_DESC= For killMountProcesses() when using nullfs
|
||||
LOG_COMPRESS_DESC= Support bzip log compression
|
||||
PARALLEL_DESC= Apply PARALLEL extra patch
|
||||
TMPFS_DESC= Apply TMPFS extra patch
|
||||
HIAWATHA_DESC= Hiawatha server
|
||||
NGINX_DESC= Nginx server
|
||||
|
||||
OPTIONS_DEFAULT= MYSQL APACHE CHECK_ROOT EMAILS LSOF \
|
||||
LOG_COMPRESS PARALLEL
|
||||
|
||||
USES= shebangfix
|
||||
SHEBANG_FILES= lib/makemake
|
||||
NO_BUILD= yes
|
||||
WANT_PERL= yes
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
#SNAP= .r3-20120404
|
||||
#SNAP= -20110101 # 22:28:07 UTC
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MAPACHE} || ${PORT_OPTIONS:MHIAWATHA} || ${PORT_OPTIONS:MLIGHTTPD} || ${PORT_OPTIONS:MNGINX}
|
||||
WEBUI= yes
|
||||
.endif
|
||||
|
||||
.if defined(WEBUI)
|
||||
WANT_PHP_WEB= yes
|
||||
USE_PHP= session
|
||||
PLIST_SUB+= WEBUI=""
|
||||
.else
|
||||
PLIST_SUB+= WEBUI="@comment "
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MPGSQL}
|
||||
USES+= pgsql
|
||||
.if defined(WEBUI)
|
||||
USE_PHP+= pgsql pdo_pgsql
|
||||
.endif
|
||||
RUN_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MMYSQL}
|
||||
.if defined(WEBUI)
|
||||
USE_PHP+= mysql pdo_mysql
|
||||
.endif
|
||||
USE_MYSQL= yes
|
||||
RUN_DEPENDS+= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MSQLITE}
|
||||
.if defined(WEBUI)
|
||||
USE_PHP+= sqlite3 pdo_sqlite
|
||||
.endif
|
||||
RUN_DEPENDS+= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MAPACHE}
|
||||
USE_APACHE_RUN= 22+
|
||||
.elif ${PORT_OPTIONS:MLIGHTTPD}
|
||||
RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
|
||||
.elif ${PORT_OPTIONS:MHIAWATHA}
|
||||
RUN_DEPENDS+= hiawatha:${PORTSDIR}/www/hiawatha
|
||||
.elif ${PORT_OPTIONS:MNGINX}
|
||||
RUN_DEPENDS+= nginx:${PORTSDIR}/www/nginx
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MEMAILS}
|
||||
RUN_DEPENDS+= p5-Net>=0:${PORTSDIR}/net/p5-Net
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MLSOF}
|
||||
RUN_DEPENDS+= lsof:${PORTSDIR}/sysutils/lsof
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MLOG_COMPRESS}
|
||||
RUN_DEPENDS+= p5-Compress-Bzip2>=0:${PORTSDIR}/archivers/p5-Compress-Bzip2
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MTMPFS} && ${PORT_OPTIONS:MPARALLEL}
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-tmpfs_para.patch
|
||||
.elif ${PORT_OPTIONS:MTMPFS}
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-tmpfs.patch
|
||||
.elif ${PORT_OPTIONS:MPARALLEL}
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-parallel.patch
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
.if ! ${PORT_OPTIONS:MCHECK_ROOT}
|
||||
${REINPLACE_CMD} -e 's/^if \[ `id -u` != 0 \]; then/if false; then/' \
|
||||
${WRKSRC}/tc
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/tinderbox/scripts
|
||||
${TAR} -C ${WRKSRC} --exclude man --exclude '*.orig' --exclude '*.bak' -cf - . \
|
||||
| tar -xf - --unlink -C ${STAGEDIR}${PREFIX}/tinderbox/scripts
|
||||
${TAR} -C ${WRKSRC}/man/man1 --exclude '*.orig' --exclude '*.bak' -cf - . \
|
||||
| tar -xf - --unlink -C ${STAGEDIR}${MAN1PREFIX}/man/man1
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/etc/rc.d/tinderd ${STAGEDIR}${PREFIX}/etc/rc.d/${PORTNAME}
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (tinderbox/tinderbox-4.0.0.b2.tar.gz) = 0b05c59a10789e64a0dcc61150aa2229b89ce881f67cfb4416ad1a95160a9c31
|
||||
SIZE (tinderbox/tinderbox-4.0.0.b2.tar.gz) = 150213
|
|
@ -1,60 +0,0 @@
|
|||
diff -u etc/rc.d/tinderd.orig etc/rc.d/tinderd
|
||||
--- etc/rc.d/tinderd.orig 2008-12-05 18:21:16.402721853 +0300
|
||||
+++ etc/rc.d/tinderd 2008-12-06 01:08:58.000000000 +0300
|
||||
@@ -24,6 +24,7 @@
|
||||
: ${tinderd_directory="/space/scripts"}
|
||||
: ${tinderd_flags=""}
|
||||
: ${tinderd_debug="NO"}
|
||||
+: ${tinderd_instances="1"}
|
||||
|
||||
# path to your executable, might be libexec, bin, sbin, ...
|
||||
command="${tinderd_directory}/tinderd"
|
||||
@@ -39,4 +40,13 @@
|
||||
command_args=">/dev/null &"
|
||||
fi
|
||||
|
||||
+start_cmd="${name}_start"
|
||||
+
|
||||
+tinderd_start()
|
||||
+{
|
||||
+ for i in `jot - 1 ${tinderd_instances}`; do
|
||||
+ ${command} ${tinderd_flags} >/dev/null 2>&1 &
|
||||
+ done
|
||||
+}
|
||||
+
|
||||
run_rc_command "$1"
|
||||
diff -u scripts/tinderd.orig scripts/tinderd
|
||||
--- tinderd.orig 2008-12-05 18:21:16.412782070 +0300
|
||||
+++ tinderd 2008-12-06 01:36:56.435417070 +0300
|
||||
@@ -19,7 +19,22 @@
|
||||
do
|
||||
trap "" 1
|
||||
|
||||
- ENTRY=$(${pb}/scripts/tc listBuildPortsQueue -s ENQUEUED -r | head -1)
|
||||
+ ENTRY=""
|
||||
+
|
||||
+ if mkdir /tmp/tinderdlock >/dev/null 2>&1; then
|
||||
+ ${pb}/scripts/tc listBuildPortsQueue -s ENQUEUED -r > /tmp/tinderd.$$
|
||||
+ while read line; do
|
||||
+ BUILD=$(echo ${line} | cut -d: -f3)
|
||||
+ if [ ! -f $pb/builds/$BUILD/tinderdlock -a ! -f $pb/builds/$BUILD/lock ]; then
|
||||
+ touch $pb/builds/$BUILD/tinderdlock
|
||||
+ ENTRY=$line
|
||||
+ break
|
||||
+ fi
|
||||
+ done < /tmp/tinderd.$$
|
||||
+ rm /tmp/tinderd.$$
|
||||
+ rmdir /tmp/tinderdlock
|
||||
+ fi
|
||||
+
|
||||
ID=$(echo ${ENTRY} | cut -d: -f1)
|
||||
USER=$(echo ${ENTRY} | cut -d: -f2)
|
||||
BUILD=$(echo ${ENTRY} | cut -d: -f3)
|
||||
@@ -52,6 +67,7 @@
|
||||
|
||||
${pb}/scripts/tc reorgBuildPortsQueue
|
||||
|
||||
+ rm $pb/builds/$BUILD/tinderdlock
|
||||
else
|
||||
tinderEcho "INFO: Nothing to do. Sleeping ${TINDERD_SLEEPTIME} seconds."
|
||||
trap main_loop 1
|
|
@ -1,25 +0,0 @@
|
|||
--- tinderd.orig 2010-01-04 21:12:37.000000000 +0100
|
||||
+++ tinderd 2010-01-04 21:14:28.000000000 +0100
|
||||
@@ -36,12 +36,14 @@
|
||||
MAIL=$(echo ${ENTRY} | cut -d: -f5)
|
||||
|
||||
if [ -n "${BUILD}" -a -n "${PORT}" -a -n "${ID}" ] ; then
|
||||
+ mount -t tmpfs tmpfs ${pb}/${BUILD}
|
||||
tinderEcho "INFO: Going to build ${PORT} on ${BUILD}"
|
||||
${pb}/scripts/tc updateBuildPortsQueueEntryStatus \
|
||||
-i "${ID}" -s PROCESSING
|
||||
if ! ${pb}/scripts/tc addPort -b "${BUILD}" -d "${PORT}"; then
|
||||
${pb}/scripts/tc updateBuildPortsQueueEntryStatus \
|
||||
-i "${ID}" -s FAIL
|
||||
+ umount ${pb}/${BUILD}
|
||||
continue
|
||||
fi
|
||||
|
||||
@@ -64,6 +66,7 @@
|
||||
fi
|
||||
|
||||
${pb}/scripts/tc reorgBuildPortsQueue
|
||||
+ umount ${pb}/${BUILD}
|
||||
|
||||
else
|
||||
tinderEcho "INFO: Nothing to do. Sleeping ${TINDERD_SLEEPTIME} seconds."
|
|
@ -1,75 +0,0 @@
|
|||
--- tinderd.orig 2010-01-04 20:56:05.000000000 +0100
|
||||
+++ tinderd 2010-01-05 20:13:58.000000000 +0100
|
||||
@@ -28,7 +28,22 @@
|
||||
do
|
||||
trap "" 1
|
||||
|
||||
- ENTRY=$(${pb}/scripts/tc listBuildPortsQueue -s ENQUEUED -r | head -1)
|
||||
+ ENTRY=""
|
||||
+
|
||||
+ if mkdir /tmp/tinderdlock >/dev/null 2>&1; then
|
||||
+ ${pb}/scripts/tc listBuildPortsQueue -s ENQUEUED -r > /tmp/tinderd.$$
|
||||
+ while read line; do
|
||||
+ BUILD=$(echo ${line} | cut -d: -f3)
|
||||
+ if [ ! -f $pb/builds/$BUILD/tinderdlock -a ! -f $pb/builds/$BUILD/lock ]; then
|
||||
+ touch $pb/builds/$BUILD/tinderdlock
|
||||
+ ENTRY=$line
|
||||
+ break
|
||||
+ fi
|
||||
+ done < /tmp/tinderd.$$
|
||||
+ rm /tmp/tinderd.$$
|
||||
+ rmdir /tmp/tinderdlock
|
||||
+ fi
|
||||
+
|
||||
ID=$(echo ${ENTRY} | cut -d: -f1)
|
||||
USER=$(echo ${ENTRY} | cut -d: -f2)
|
||||
BUILD=$(echo ${ENTRY} | cut -d: -f3)
|
||||
@@ -36,12 +51,14 @@
|
||||
MAIL=$(echo ${ENTRY} | cut -d: -f5)
|
||||
|
||||
if [ -n "${BUILD}" -a -n "${PORT}" -a -n "${ID}" ] ; then
|
||||
+ mount -t tmpfs tmpfs ${pb}/${BUILD}
|
||||
tinderEcho "INFO: Going to build ${PORT} on ${BUILD}"
|
||||
${pb}/scripts/tc updateBuildPortsQueueEntryStatus \
|
||||
-i "${ID}" -s PROCESSING
|
||||
if ! ${pb}/scripts/tc addPort -b "${BUILD}" -d "${PORT}"; then
|
||||
${pb}/scripts/tc updateBuildPortsQueueEntryStatus \
|
||||
-i "${ID}" -s FAIL
|
||||
+ umount ${pb}/${BUILD}
|
||||
continue
|
||||
fi
|
||||
|
||||
@@ -64,7 +81,9 @@
|
||||
fi
|
||||
|
||||
${pb}/scripts/tc reorgBuildPortsQueue
|
||||
+ umount ${pb}/${BUILD}
|
||||
|
||||
+ rm $pb/builds/$BUILD/tinderdlock
|
||||
else
|
||||
tinderEcho "INFO: Nothing to do. Sleeping ${TINDERD_SLEEPTIME} seconds."
|
||||
trap main_loop 1
|
||||
--- etc/rc.d/tinderd.orig 2010-01-04 20:56:05.000000000 +0100
|
||||
+++ etc/rc.d/tinderd 2010-01-05 20:11:17.000000000 +0100
|
||||
@@ -24,6 +24,7 @@
|
||||
: ${tinderd_directory="/space/scripts"}
|
||||
: ${tinderd_flags=""}
|
||||
: ${tinderd_debug="NO"}
|
||||
+: ${tinderd_instances="1"}
|
||||
|
||||
# path to your executable, might be libexec, bin, sbin, ...
|
||||
command="${tinderd_directory}/tinderd"
|
||||
@@ -39,4 +40,13 @@
|
||||
command_args=">/dev/null &"
|
||||
fi
|
||||
|
||||
+start_cmd="${name}_start"
|
||||
+
|
||||
+tinderd_start()
|
||||
+{
|
||||
+ for i in `jot - 1 ${tinderd_instances}`; do
|
||||
+ ${command} ${tinderd_flags} >/dev/null 2>&1 &
|
||||
+ done
|
||||
+}
|
||||
+
|
||||
run_rc_command "$1"
|
|
@ -1,66 +0,0 @@
|
|||
|
||||
===============================================================================
|
||||
ports-mgmt/tinderbox is now installed, but it requires some additional setup.
|
||||
|
||||
****************************************************
|
||||
Please do read: %%PREFIX%%/tinderbox/scripts/README
|
||||
****************************************************
|
||||
|
||||
=============================================================================
|
||||
|
||||
If you installed the port with WITH_TMPFS option:
|
||||
To enable the usage of FreeBSD's tmpfs implementation you need to add the
|
||||
tmpfs kernel module to your /boot/loader.conf:
|
||||
tmpfs_load="YES"
|
||||
|
||||
If you installed the port WITH_PARALLEL option:
|
||||
The parallel patch allows to run multiple tinderd instances at the same time.
|
||||
You can enable multiple tinderd instances via /etc/rc.conf with:
|
||||
tinderd_instances="N"
|
||||
|
||||
Both patches are experimental and are not official supported by the Tinderbox
|
||||
distribution.
|
||||
|
||||
=============================================================================
|
||||
|
||||
|
||||
The following walkthrough is the webserver setup, if you installed the WebUI:
|
||||
|
||||
- In your Apache configuration add the following lines:
|
||||
|
||||
Alias /tb/logs/ "%%PREFIX%%/tinderbox/logs/"
|
||||
Alias /tb/packages/ "%%PREFIX%%/tinderbox/packages/"
|
||||
Alias /tb/errors/ "%%PREFIX%%/tinderbox/errors/"
|
||||
Alias /tb/wrkdirs/ "%%PREFIX%%/tinderbox/wrkdirs/"
|
||||
Alias /tb/ "%%PREFIX%%/tinderbox/scripts/webui/"
|
||||
<Directory "%%PREFIX%%/tinderbox/">
|
||||
Order allow,deny
|
||||
Allow from all
|
||||
</Directory>
|
||||
|
||||
- In your Lighttpd configuration:
|
||||
|
||||
Turn on "mod_alias" and add the following lines:
|
||||
|
||||
alias.url = ( "/tb/logs/" => "%%PREFIX%%/tinderbox/logs/",
|
||||
"/tb/packages/" => "%%PREFIX%%/tinderbox/packages/",
|
||||
"/tb/errors/" => "%%PREFIX%%/tinderbox/errors/",
|
||||
"/tb/wrkdirs/" => "%%PREFIX%%/tinderbox/wrkdirs/",
|
||||
"/tb/" => "%%PREFIX%%/tinderbox/scripts/webui/" )
|
||||
dir-listing.activate = "enable"
|
||||
|
||||
|
||||
- In your Hiawatha configuration:
|
||||
|
||||
Alias is a built in command, no need to load any special mod
|
||||
|
||||
Alias = /tb/logs:%%PREFIX%%/tinderbox/logs
|
||||
Alias = /tb/packages:%%PREFIX%%/tinderbox/packages
|
||||
Alias = /tb/errors:%%PREFIX%%/tinderbox/errors
|
||||
Alias = /tb/wrkdirs:%%PREFIX%%/tinderbox/wrkdirs
|
||||
Alias = /tb/:%%PREFIX%%/tinderbox/scripts/webui
|
||||
|
||||
Check your system by going to http://localhost/tb/
|
||||
|
||||
=============================================================================
|
||||
|
|
@ -1,20 +0,0 @@
|
|||
Tinderbox is a package building system for FreeBSD ports, based on
|
||||
official Portbuild scripts used on pointyhat building cluster.
|
||||
Tinderbox was written by Joe Marcus Clarke.
|
||||
|
||||
You can define multiple jails (base system versions) and multiple
|
||||
portstrees. The combination of jail and portstree is called a build.
|
||||
A Tinderbox jail is not what is understood as a jail in FreeBSD,
|
||||
it is in fact a given world in a chroot. Tinderbox supports automatic
|
||||
tracking of dependencies and only rebuilds packages that changed
|
||||
since last run. Tinderbox has support for email notification of
|
||||
failed builds. Tinderbox also integrates well with ccache.
|
||||
|
||||
Tinderbox is designed to easily provide package sets of ports you
|
||||
need, for platforms and architectures you need. Tinderbox is also
|
||||
excellent tool for testing new ports and port upgrades, especially
|
||||
for testing dependencies and packing lists. It's also useful for
|
||||
testing ports on various releases of FreeBSD, since you can run
|
||||
FreeBSD 6.X world as a jail on FreeBSD 7.X/8.X host.
|
||||
|
||||
WWW: http://tinderbox.marcuscom.com/
|
|
@ -1,148 +0,0 @@
|
|||
etc/rc.d/tinderbox
|
||||
man/man1/tc-configCcache.1.gz
|
||||
man/man1/tc-configDistfile.1.gz
|
||||
man/man1/tc-configGet.1.gz
|
||||
man/man1/tc-configJail.1.gz
|
||||
man/man1/tc-configTinderd.1.gz
|
||||
man/man1/tc-init.1.gz
|
||||
tinderbox/scripts/.version
|
||||
tinderbox/scripts/README
|
||||
tinderbox/scripts/contrib/hooks/compress_wrkdir/README.txt
|
||||
tinderbox/scripts/contrib/hooks/compress_wrkdir/compress_wrkdir.sh
|
||||
tinderbox/scripts/contrib/hooks/create-pkgng-repo/README.txt
|
||||
tinderbox/scripts/contrib/hooks/create-pkgng-repo/create-pkgng-repo.sh
|
||||
tinderbox/scripts/contrib/hooks/kse-fix/README.txt
|
||||
tinderbox/scripts/contrib/hooks/kse-fix/kse-fix.sh
|
||||
tinderbox/scripts/contrib/hooks/kse-fix/libmap.conf
|
||||
tinderbox/scripts/contrib/hooks/make-jobs-safe/README.txt
|
||||
tinderbox/scripts/contrib/hooks/make-jobs-safe/make-jobs-safe.sh
|
||||
tinderbox/scripts/contrib/hooks/mass-build-pgsql/README.txt
|
||||
tinderbox/scripts/contrib/hooks/mass-build-pgsql/mass-build-pgsql.sh
|
||||
tinderbox/scripts/ds.ph.dist
|
||||
tinderbox/scripts/etc/env/.keep_me
|
||||
tinderbox/scripts/etc/rc.d/tinderd
|
||||
tinderbox/scripts/lib/Tinderbox/Build.pm
|
||||
tinderbox/scripts/lib/Tinderbox/BuildPortsQueue.pm
|
||||
tinderbox/scripts/lib/Tinderbox/Config.pm
|
||||
tinderbox/scripts/lib/Tinderbox/Hook.pm
|
||||
tinderbox/scripts/lib/Tinderbox/Jail.pm
|
||||
tinderbox/scripts/lib/Tinderbox/MakeCache.pm
|
||||
tinderbox/scripts/lib/Tinderbox/Port.pm
|
||||
tinderbox/scripts/lib/Tinderbox/PortFailPattern.pm
|
||||
tinderbox/scripts/lib/Tinderbox/PortFailReason.pm
|
||||
tinderbox/scripts/lib/Tinderbox/PortsTree.pm
|
||||
tinderbox/scripts/lib/Tinderbox/TinderObject.pm
|
||||
tinderbox/scripts/lib/Tinderbox/TinderboxDS.pm
|
||||
tinderbox/scripts/lib/Tinderbox/User.pm
|
||||
tinderbox/scripts/lib/buildscript
|
||||
tinderbox/scripts/lib/db-mysql.sh
|
||||
tinderbox/scripts/lib/db-pgsql.sh
|
||||
tinderbox/scripts/lib/db-sqlite.sh
|
||||
tinderbox/scripts/lib/enterbuild
|
||||
tinderbox/scripts/lib/makemake
|
||||
tinderbox/scripts/lib/pnohang.c
|
||||
tinderbox/scripts/lib/portbuild
|
||||
tinderbox/scripts/lib/tc_command.pl
|
||||
tinderbox/scripts/lib/tc_command.sh
|
||||
tinderbox/scripts/lib/tinderbox.env
|
||||
tinderbox/scripts/lib/tinderlib.pl
|
||||
tinderbox/scripts/lib/tinderlib.sh
|
||||
tinderbox/scripts/sql/genschema
|
||||
tinderbox/scripts/sql/schema.mysql.post
|
||||
tinderbox/scripts/sql/schema.mysql.pre
|
||||
tinderbox/scripts/sql/schema.pgsql.post
|
||||
tinderbox/scripts/sql/schema.pgsql.pre
|
||||
tinderbox/scripts/sql/schema.sqlite.post
|
||||
tinderbox/scripts/sql/schema.sqlite.pre
|
||||
tinderbox/scripts/sql/values.config
|
||||
tinderbox/scripts/sql/values.hooks
|
||||
tinderbox/scripts/sql/values.lp
|
||||
tinderbox/scripts/sql/values.pfp
|
||||
tinderbox/scripts/sql/values.pfr
|
||||
tinderbox/scripts/tc
|
||||
tinderbox/scripts/tinderbox.ph.dist
|
||||
tinderbox/scripts/tinderd
|
||||
tinderbox/scripts/upgrade/build_ports.map
|
||||
tinderbox/scripts/upgrade/build_ports_queue.map
|
||||
tinderbox/scripts/upgrade/builds.map
|
||||
tinderbox/scripts/upgrade/config.map
|
||||
tinderbox/scripts/upgrade/hooks.map
|
||||
tinderbox/scripts/upgrade/jails.map
|
||||
tinderbox/scripts/upgrade/mig_mysql_tinderbox-3.3_to_4.0.0.sql
|
||||
tinderbox/scripts/upgrade/mig_pgsql_tinderbox-3.3_to_4.0.0.sql
|
||||
tinderbox/scripts/upgrade/order.lst
|
||||
tinderbox/scripts/upgrade/user_permissions.map
|
||||
%%WEBUI%%tinderbox/scripts/webui/core/Build.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/core/BuildGroups.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/core/BuildPortsQueue.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/core/Config.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/core/Hooks.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/core/Jail.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/core/LogfilePattern.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/core/Port.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/core/PortFailPattern.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/core/PortFailReason.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/core/PortsTree.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/core/TinderObject.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/core/TinderboxDS.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/core/User.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/core/functions.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/favicon.ico
|
||||
%%WEBUI%%tinderbox/scripts/webui/inc_ds.php.dist
|
||||
%%WEBUI%%tinderbox/scripts/webui/inc_tinderbox.php.dist
|
||||
%%WEBUI%%tinderbox/scripts/webui/index.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/module/module.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/module/moduleBuildGroups.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/module/moduleBuildPorts.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/module/moduleBuilds.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/module/moduleConfig.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/module/moduleLogs.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/module/modulePortFailureReasons.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/module/modulePorts.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/module/moduleRss.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/module/moduleSession.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/module/moduleTinderd.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/module/moduleUsers.php
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/config.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/current_buildports.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/describe_port.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/display_build_groups.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/display_login.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/display_markup_log.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/failed_buildports.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/latest_buildports.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/list_buildports.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/list_builds.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/list_failure_reasons.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/list_tinderd_queue.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/messages.inc
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/please_login.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/rss.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/tinderstyle.css
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/tinderstyle.js
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/user_admin.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/user_permissions.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/default/user_properties.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/config.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/current_buildports.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/describe_port.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/display_build_groups.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/display_login.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/display_markup_log.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/failed_buildports.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/footer.inc.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/header.inc.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/images/hdr_fill.png
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/latest_buildports.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/list_buildports.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/list_builds.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/list_failure_reasons.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/list_tinderd_queue.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/messages.inc
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/please_login.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/rss.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/tinderstyle.css
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/tinderstyle.js
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/user_admin.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/user_permissions.tpl
|
||||
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/user_properties.tpl
|
Loading…
Reference in a new issue