An open source C library for efficient image processing and

image analysis operations.

WWW: http://code.google.com/p/leptonica/

PR:		134717
Submitted by:	Hiroto Kagotani <hiroto.kagotani@gmail.com>
This commit is contained in:
Dmitry Marakasov 2009-05-31 20:23:11 +00:00
parent 3f4de75ac3
commit f8d5253d25
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=234938
13 changed files with 213 additions and 0 deletions

View file

@ -389,6 +389,7 @@
SUBDIR += lcms
SUBDIR += leafpak
SUBDIR += lensfun
SUBDIR += leptonlib
SUBDIR += lfview
SUBDIR += lib3ds
SUBDIR += libGL

View file

@ -0,0 +1,38 @@
# New ports collection makefile for: leptonlib
# Date created: 2009-05-20
# Whom: Hiroto Kagotani <hiroto.kagotani@gmail.com>
#
# $FreeBSD$
#
PORTNAME= leptonlib
PORTVERSION= 1.60
CATEGORIES= graphics
MASTER_SITES= GOOGLE_CODE
MAINTAINER= hiroto.kagotani@gmail.com
COMMENT= C library for efficient image processing and image analysis operations
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
PROJECTHOST= leptonica
MAKE_JOBS_SAFE= yes
USE_AUTOTOOLS= libtool:15 aclocal:110 automake:110 autoconf:262
ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I${LOCALBASE}/share/aclocal
USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
post-patch:
@${MV} ${WRKSRC}/src/makefile ${WRKSRC}/src/makefile.linux
@${RM} ${WRKSRC}/src/jpeglib.h ${WRKSRC}/src/jmorecfg.h
pre-configure:
@(cd ${CONFIGURE_WRKSRC} \
&& ${SETENV} ${AUTOTOOLS_ENV} ${LIBTOOLIZE} --automake)
run-autotools:: run-autotools-aclocal run-autotools-automake run-autotools-autoconf
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
MD5 (leptonlib-1.60.tar.gz) = 8f13a190a86f73388e9901bd59ebfa25
SHA256 (leptonlib-1.60.tar.gz) = 9c9b7710418a33aad35dcd7b76b6b69affdc90b2b62cce56b6c6dc93f5e7a072
SIZE (leptonlib-1.60.tar.gz) = 4115391

View file

@ -0,0 +1,11 @@
--- ./configure.ac.orig 2009-01-19 14:30:19.000000000 +0900
+++ ./configure.ac 2009-05-21 00:15:20.000000000 +0900
@@ -114,7 +114,7 @@
# Check where all the following programs are and set
# variables accordingly:
-AC_PROG_RANLIB
+AM_PROG_LIBTOOL
# AC_PROG_LN_S
# AC_PATH_PROG(MV, mv)
# AC_PATH_PROG(CP, cp)

View file

@ -0,0 +1,24 @@
--- src/Makefile.am.orig 2009-01-19 08:30:19.000000000 +0300
+++ src/Makefile.am 2009-05-21 21:55:01.000000000 +0400
@@ -6,10 +6,9 @@
MAKE = make -f Makefile
AM_CFLAGS = -D_BSD_SOURCE -DANSI -fPIC
AM_CPPFLAGS = $(ENDIANNESS)
-CFLAGS = -O2
-lib_LIBRARIES = liblept.a
-liblept_a_SOURCES = adaptmap.c \
+lib_LTLIBRARIES = liblept.la
+liblept_la_SOURCES = adaptmap.c \
affine.c affinecompose.c \
arithlow.c arrayaccess.c \
bardecode.c \
@@ -73,7 +72,7 @@
include_HEADERS = allheaders.h alltypes.h arrayaccess.h \
array.h bbuffer.h bmf.h bmp.h ccbord.h environ.h \
- gplot.h imageio.h jbclass.h jmorecfg.h jpeglib.h leptprotos.h list.h \
+ gplot.h imageio.h jbclass.h leptprotos.h list.h \
morph.h pheap.h pix.h pqueue.h readbarcode.h stack.h watershed.h
EXTRA_DIST = Makefile.mingw arrayaccess.h.vc arrayaccess.h.vc60 \

View file

@ -0,0 +1,4 @@
An open source C library for efficient image processing and
image analysis operations.
WWW: http://code.google.com/p/leptonica/

View file

@ -0,0 +1,26 @@
include/liblept/allheaders.h
include/liblept/alltypes.h
include/liblept/arrayaccess.h
include/liblept/array.h
include/liblept/bbuffer.h
include/liblept/bmf.h
include/liblept/bmp.h
include/liblept/ccbord.h
include/liblept/environ.h
include/liblept/gplot.h
include/liblept/imageio.h
include/liblept/jbclass.h
include/liblept/leptprotos.h
include/liblept/list.h
include/liblept/morph.h
include/liblept/pheap.h
include/liblept/pix.h
include/liblept/pqueue.h
include/liblept/readbarcode.h
include/liblept/stack.h
include/liblept/watershed.h
lib/liblept.a
lib/liblept.la
lib/liblept.so
lib/liblept.so.0
@dirrm include/liblept

View file

@ -0,0 +1,38 @@
# New ports collection makefile for: leptonlib
# Date created: 2009-05-20
# Whom: Hiroto Kagotani <hiroto.kagotani@gmail.com>
#
# $FreeBSD$
#
PORTNAME= leptonlib
PORTVERSION= 1.60
CATEGORIES= graphics
MASTER_SITES= GOOGLE_CODE
MAINTAINER= hiroto.kagotani@gmail.com
COMMENT= C library for efficient image processing and image analysis operations
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
PROJECTHOST= leptonica
MAKE_JOBS_SAFE= yes
USE_AUTOTOOLS= libtool:15 aclocal:110 automake:110 autoconf:262
ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I${LOCALBASE}/share/aclocal
USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
post-patch:
@${MV} ${WRKSRC}/src/makefile ${WRKSRC}/src/makefile.linux
@${RM} ${WRKSRC}/src/jpeglib.h ${WRKSRC}/src/jmorecfg.h
pre-configure:
@(cd ${CONFIGURE_WRKSRC} \
&& ${SETENV} ${AUTOTOOLS_ENV} ${LIBTOOLIZE} --automake)
run-autotools:: run-autotools-aclocal run-autotools-automake run-autotools-autoconf
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
MD5 (leptonlib-1.60.tar.gz) = 8f13a190a86f73388e9901bd59ebfa25
SHA256 (leptonlib-1.60.tar.gz) = 9c9b7710418a33aad35dcd7b76b6b69affdc90b2b62cce56b6c6dc93f5e7a072
SIZE (leptonlib-1.60.tar.gz) = 4115391

View file

@ -0,0 +1,11 @@
--- ./configure.ac.orig 2009-01-19 14:30:19.000000000 +0900
+++ ./configure.ac 2009-05-21 00:15:20.000000000 +0900
@@ -114,7 +114,7 @@
# Check where all the following programs are and set
# variables accordingly:
-AC_PROG_RANLIB
+AM_PROG_LIBTOOL
# AC_PROG_LN_S
# AC_PATH_PROG(MV, mv)
# AC_PATH_PROG(CP, cp)

View file

@ -0,0 +1,24 @@
--- src/Makefile.am.orig 2009-01-19 08:30:19.000000000 +0300
+++ src/Makefile.am 2009-05-21 21:55:01.000000000 +0400
@@ -6,10 +6,9 @@
MAKE = make -f Makefile
AM_CFLAGS = -D_BSD_SOURCE -DANSI -fPIC
AM_CPPFLAGS = $(ENDIANNESS)
-CFLAGS = -O2
-lib_LIBRARIES = liblept.a
-liblept_a_SOURCES = adaptmap.c \
+lib_LTLIBRARIES = liblept.la
+liblept_la_SOURCES = adaptmap.c \
affine.c affinecompose.c \
arithlow.c arrayaccess.c \
bardecode.c \
@@ -73,7 +72,7 @@
include_HEADERS = allheaders.h alltypes.h arrayaccess.h \
array.h bbuffer.h bmf.h bmp.h ccbord.h environ.h \
- gplot.h imageio.h jbclass.h jmorecfg.h jpeglib.h leptprotos.h list.h \
+ gplot.h imageio.h jbclass.h leptprotos.h list.h \
morph.h pheap.h pix.h pqueue.h readbarcode.h stack.h watershed.h
EXTRA_DIST = Makefile.mingw arrayaccess.h.vc arrayaccess.h.vc60 \

View file

@ -0,0 +1,4 @@
An open source C library for efficient image processing and
image analysis operations.
WWW: http://code.google.com/p/leptonica/

View file

@ -0,0 +1,26 @@
include/liblept/allheaders.h
include/liblept/alltypes.h
include/liblept/arrayaccess.h
include/liblept/array.h
include/liblept/bbuffer.h
include/liblept/bmf.h
include/liblept/bmp.h
include/liblept/ccbord.h
include/liblept/environ.h
include/liblept/gplot.h
include/liblept/imageio.h
include/liblept/jbclass.h
include/liblept/leptprotos.h
include/liblept/list.h
include/liblept/morph.h
include/liblept/pheap.h
include/liblept/pix.h
include/liblept/pqueue.h
include/liblept/readbarcode.h
include/liblept/stack.h
include/liblept/watershed.h
lib/liblept.a
lib/liblept.la
lib/liblept.so
lib/liblept.so.0
@dirrm include/liblept