Update to version 1.5. Changes from 1.4 are:

o  patch-aa has been incorporated into the distribution,
o  the port and distribution can use an alternate source
   tree by setting SRCDIR (defaults to /usr/src),
o  depends on linux_devtools-7 instead of linux_devtools-6.

Alternate source tree courtecy of:
PR: ports/42649
Submitted by: jhein at timing dot com
This commit is contained in:
Marcel Moolenaar 2004-02-14 07:56:42 +00:00
parent 3a759003cb
commit f97fb3d8f7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=100902
3 changed files with 15 additions and 20 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= linux_kdump
PORTVERSION= 1.4
PORTVERSION= 1.5
CATEGORIES= devel linux
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= marcel
@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= marcel
MAINTAINER= marcel@FreeBSD.org
COMMENT= Linux-compatability ktrace.out processor
BUILD_DEPENDS= /compat/linux/usr/bin/gcc:${PORTSDIR}/devel/linux_devtools-6
BUILD_DEPENDS= /compat/linux/usr/bin/gcc:${PORTSDIR}/devel/linux_devtools-7
ONLY_FOR_ARCHS= i386
MAN1= linux_kdump.1
@ -22,11 +22,18 @@ PLIST_FILES= bin/linux_kdump
.include <bsd.port.pre.mk>
.if !exists(/sys/i386/linux/syscalls.master)
IGNORE= "requires kernel source present in /sys"
.ifndef(SRCDIR)
SRCDIR= /usr/src
pre-everything::
@${ECHO_MSG} '===> Using the FreeBSD source tree under /usr/src'
@${ECHO_MSG} '===> Set SRCDIR to use an alternate source tree'
.endif
.if !exists(/usr/src/usr.bin/ktrace/subr.c)
IGNORE= "requires ktrace source present in /usr/src/usr.bin/ktrace"
.if !exists(${SRCDIR}/sys/i386/linux/syscalls.master)
IGNORE= "requires kernel source present in ${SRCDIR}/sys"
.endif
.if !exists(${SRCDIR}/usr.bin/ktrace/subr.c)
IGNORE= "requires ktrace source present in ${SRCDIR}/usr.bin/ktrace"
.endif
.include <bsd.port.post.mk>

View file

@ -1 +1,2 @@
MD5 (linux_kdump-1.4.tar.gz) = 5fd27d1e231c1b01e011ace7eb193a51
MD5 (linux_kdump-1.5.tar.gz) = 9af097e1a868c4db05f9a50367a6a91d
SIZE (linux_kdump-1.5.tar.gz) = 6166

View file

@ -1,13 +0,0 @@
--- kdump.c.orig Sat Oct 9 19:57:45 1999
+++ kdump.c Sun Jan 9 11:19:14 2000
@@ -46,8 +46,10 @@
#endif /* not lint */
#define KERNEL
+#define _KERNEL
extern int errno;
#include <sys/errno.h>
+#undef _KERNEL
#undef KERNEL
#include <sys/param.h>
#include <sys/errno.h>