- Fix the build with GCC 4.2 [1]

- Usual round of Makefile nits

Reported by:	pointyhat (logs) [1]
This commit is contained in:
Alexey Dokuchaev 2007-07-04 22:55:38 +00:00
parent bf7b9a0c0e
commit f9ad0cfce3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=194960
2 changed files with 31 additions and 11 deletions

View file

@ -1,6 +1,6 @@
# New ports collection makefile for: middleman
# Date created: Sun Apr 27 15:48:16 CEST 2003
# Whom: Kirill Ponomarew <ponomarew@oberon.net>
# New ports collection makefile for: middleman
# Date created: Sun Apr 27 15:48:16 CEST 2003
# Whom: Kirill Ponomarew <ponomarew@oberon.net>
#
# $FreeBSD$
#
@ -40,12 +40,6 @@ CONFIGURE_ARGS+= --enable-mtime
MMAN_CACHE= /var/cache/mman
PLIST_SUB+= MMAN_CACHE=${MMAN_CACHE}
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
BROKEN= Broken with gcc 4.2
.endif
post-patch:
@${REINPLACE_CMD} -e \
's|/usr/bin/mman|${PREFIX}/bin/mman|g ; \
@ -62,9 +56,9 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/scripts/mman.init \
${PREFIX}/etc/rc.d/mman.sh.sample
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/scripts/filter.pl ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.html ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -0,0 +1,26 @@
--- include/macros.h.orig Sat Jul 19 05:53:50 2003
+++ include/macros.h Thu Jul 5 05:45:33 2007
@@ -103,9 +103,10 @@
/*
this macro will shift a node in a linked list up or down one
*/
-#define SHIFTNODE(t, x, a, d) { \
+#define SHIFTNODE(t, _x, a, d) { \
do { \
t tmp_node = NULL; \
+ t x = _x; \
if (d == UP && a != (x)) { \
if ((x) == a->prev) (x) = a; \
if (a->prev->prev != NULL) a->prev->prev->next = a; \
@@ -131,9 +132,10 @@
/*
this macro moves a list node to top or bottom of list
*/
-#define SETNODE(t, x, a, d) { \
+#define SETNODE(t, _x, a, d) { \
do { \
t tmp_node = NULL; \
+ t x = _x; \
if (d == TOP && a != (x)) { \
if (a->next != NULL) a->next->prev = a->prev; \
a->prev->next = a->next; \