Add tftpgrab 0.2, a TFTP stream extractor.
PR: 116532 Submitted by: Wesley Shields <wxs at atarininja.org>
This commit is contained in:
parent
577559d74c
commit
f9b82747ba
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=199914
5 changed files with 42 additions and 0 deletions
|
@ -858,6 +858,7 @@
|
|||
SUBDIR += tcpxtract
|
||||
SUBDIR += tdetect
|
||||
SUBDIR += telserv
|
||||
SUBDIR += tftpgrab
|
||||
SUBDIR += thcrut
|
||||
SUBDIR += throttled
|
||||
SUBDIR += tightvnc
|
||||
|
|
21
net/tftpgrab/Makefile
Normal file
21
net/tftpgrab/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
# Ports collection makefile for: tftpgrab
|
||||
# Date created: 21 Sep 2007
|
||||
# Whom: Wesley Shields <wxs@atarininja.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= tftpgrab
|
||||
PORTVERSION= 0.2
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://pseudo-flaw.net/tftpgrab/ \
|
||||
http://www.atarininja.org/~wxs/distfiles/
|
||||
|
||||
MAINTAINER= wxs@atarininja.org
|
||||
COMMENT= TFTP stream extractor
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
PLIST_FILES= bin/tftpgrab
|
||||
|
||||
.include <bsd.port.mk>
|
3
net/tftpgrab/distinfo
Normal file
3
net/tftpgrab/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (tftpgrab-0.2.tar.gz) = 4c42995a50557f4ff3cd930672811554
|
||||
SHA256 (tftpgrab-0.2.tar.gz) = eb6309a23a6be83291659e7f5731dbc82e121f9ef9c4c4c7014e0c0a1af1e367
|
||||
SIZE (tftpgrab-0.2.tar.gz) = 109852
|
13
net/tftpgrab/files/patch-Makefile.in
Normal file
13
net/tftpgrab/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- ./Makefile.in.orig 2007-09-21 18:12:03.000000000 -0400
|
||||
+++ ./Makefile.in 2007-09-21 18:12:25.000000000 -0400
|
||||
@@ -237,8 +237,8 @@
|
||||
if test -f $$p \
|
||||
; then \
|
||||
f=`echo "$$p1" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`; \
|
||||
- echo " $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) '$$p' '$(DESTDIR)$(bindir)/$$f'"; \
|
||||
- $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) "$$p" "$(DESTDIR)$(bindir)/$$f" || exit 1; \
|
||||
+ echo " $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) '$$p' '$(DESTDIR)$(bindir)/$$p'"; \
|
||||
+ $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) "$$p" "$(DESTDIR)$(bindir)/$$p" || exit 1; \
|
||||
else :; fi; \
|
||||
done
|
||||
|
4
net/tftpgrab/pkg-descr
Normal file
4
net/tftpgrab/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
A TFTP stream extractor. It reads in a pcap file and attempts to
|
||||
reconstruct the files transfered via TFTP.
|
||||
|
||||
WWW: http://pseudo-flaw.net/tftpgrab/
|
Loading…
Reference in a new issue