- Update to 2.1.11

- Unbreak (--enable-mio=poll)
- Add patch against SVN rev 314 to fix memleaks

Approved by:	garga (mentor, implicit)
This commit is contained in:
Martin Matuska 2007-07-30 10:04:24 +00:00
parent c710730117
commit f9d02bd2ba
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=196704
3 changed files with 112 additions and 5 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= jabberd
PORTVERSION= 2.1.10
PORTVERSION= 2.1.11
CATEGORIES= net-im
MASTER_SITES= http://ftp.xiaoka.com/jabberd2/releases/
DIST_SUBDIR= jabber
@ -35,7 +35,7 @@ USE_RC_SUBR= jabberd
USE_LDCONFIG= ${TARGETDIR}/lib/jabberd
CONFIGURE_ARGS+= --localstatedir=/var \
--sysconfdir=${PREFIX}/etc/jabberd \
--enable-ssl \
--enable-ssl --enable-mio=poll \
--with-extra-include-path="${LOCALBASE}/include ${EIP}" \
--with-extra-library-path="${LOCALBASE}/lib ${ELP}" \
--enable-fs
@ -61,6 +61,9 @@ DOCFILES= AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROTOCOL README \
.include <bsd.port.pre.mk>
ELP+= ${OPENSSLLIB}
EIP+= ${OPENSSLINC}
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+=--enable-debug
.endif

View file

@ -1,3 +1,3 @@
MD5 (jabber/jabberd-2.1.10.tar.gz) = d0d938395c1eda5d37b2af4f99477ccd
SHA256 (jabber/jabberd-2.1.10.tar.gz) = 9acc8bdfc0f24bd40c6b95ca84f4213d5e17fb4020f969adfa5798b8b7790c58
SIZE (jabber/jabberd-2.1.10.tar.gz) = 1397275
MD5 (jabber/jabberd-2.1.11.tar.gz) = 77ddfa7d94f1f61c08fcb9bcd31bea6c
SHA256 (jabber/jabberd-2.1.11.tar.gz) = 4432cb65cd3f5029e97565d742c122d890c6e5fcb536ba80470ee6e71497fa4a
SIZE (jabber/jabberd-2.1.11.tar.gz) = 1394797

View file

@ -0,0 +1,104 @@
Index: sm/mod_privacy.c
===================================================================
--- sm/mod_privacy.c (revision 310)
+++ sm/mod_privacy.c (working copy)
@@ -205,7 +205,7 @@
continue;
}
- pool_cleanup(zlist->p, free, zitem->jid);
+ pool_cleanup(zlist->p, jid_free, zitem->jid);
log_debug(ZONE, "jid item with value '%s'", jid_full(zitem->jid));
@@ -696,7 +696,7 @@
return -stanza_err_BAD_REQUEST;
}
- pool_cleanup(p, free, zitem->jid);
+ pool_cleanup(p, jid_free, zitem->jid);
log_debug(ZONE, "jid item with value '%s'", jid_full(zitem->jid));
Index: sm/main.c
===================================================================
--- sm/main.c (revision 310)
+++ sm/main.c (working copy)
@@ -392,6 +392,7 @@
xhash_free(sm->acls);
xhash_free(sm->features);
xhash_free(sm->xmlns);
+ xhash_free(sm->xmlns_refcount);
xhash_free(sm->users);
sx_free(sm->router);
Index: c2s/main.c
===================================================================
--- c2s/main.c (revision 310)
+++ c2s/main.c (working copy)
@@ -698,6 +698,7 @@
if(sess->ip != NULL) free(sess->ip);
if(sess->result != NULL) nad_free(sess->result);
if(sess->jid != NULL) jid_free(sess->jid);
+ if(sess->rate != NULL) rate_free(sess->rate);
free(sess);
}
Index: sx/sasl_gsasl.c
===================================================================
--- sx/sasl_gsasl.c (revision 310)
+++ sx/sasl_gsasl.c (working copy)
@@ -338,6 +338,7 @@
if(ret != GSASL_OK && ret != GSASL_NEEDS_MORE) {
_sx_debug(ZONE, "gsasl_step failed, no sasl for this conn; (%d): %s", ret, gsasl_strerror(ret));
_sx_nad_write(s, _sx_sasl_failure(s, _sasl_err_MALFORMED_REQUEST), 0);
+ if(buf != NULL) free(buf);
return;
}
}
@@ -350,6 +351,7 @@
if(ret != GSASL_OK && ret != GSASL_NEEDS_MORE) {
_sx_debug(ZONE, "gsasl_step failed, no sasl for this conn; (%d): %s", ret, gsasl_strerror(ret));
_sx_nad_write(s, _sx_sasl_failure(s, _sasl_err_MALFORMED_REQUEST), 0);
+ if(buf != NULL) free(buf);
return;
}
Index: mio/mio_impl.h
===================================================================
--- mio/mio_impl.h (revision 310)
+++ mio/mio_impl.h (working copy)
@@ -133,6 +133,7 @@
FD(m,fd)->type = type_CLOSED;
FD(m,fd)->app = NULL;
FD(m,fd)->arg = NULL;
+ MIO_FREE_FD(m, fd);
}
/** internally accept an incoming connection from a listen sock */
@@ -259,12 +260,6 @@
if(ACT(m, fd, action_WRITE, NULL) == 0)
MIO_UNSET_WRITE(m, FD(m,fd));
}
-
- /* deferred closing fd */
- if(FD(m,fd)->type == type_CLOSED)
- {
- MIO_FREE_FD(m, fd);
- }
}
}
Index: util/jid.c
===================================================================
--- util/jid.c (revision 310)
+++ util/jid.c (working copy)
@@ -332,7 +332,7 @@
else {
/* allocate new data buffer */
jid->jid_data_len = node_l+domain_l+resource_l+3;
- jid->jid_data = malloc(jid->jid_data_len);
+ jid->jid_data = realloc(jid->jid_data, jid->jid_data_len);
}
/* copy to buffer */