Remove gswitchit now that it has been integrated into gnomecontrolcenter2.

This commit is contained in:
Joe Marcus Clarke 2004-04-05 03:41:18 +00:00
parent cb8beadec3
commit f9d57ebe62
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=106179
7 changed files with 0 additions and 317 deletions

View file

@ -67,7 +67,6 @@
SUBDIR += gnometerminal
SUBDIR += grabc
SUBDIR += gromit
SUBDIR += gswitchit
SUBDIR += gtk-theme-switch
SUBDIR += gtk2-theme-switch
SUBDIR += gxset

View file

@ -1,28 +0,0 @@
# Ports collection Makefile for: gswitchit
# Date created: 15 May 2003
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= gswitchit
PORTVERSION= 2.5.0
PORTREVISION= 4
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gswitchit
MAINTAINER= gnome@FreeBSD.org
COMMENT= A simple keyboard state indicator and switcher for GNOME Desktop
LIB_DEPENDS= xklavier.7:${PORTSDIR}/x11/libxklavier
RUN_DEPENDS= ${X11BASE}/lib/X11/xkb/rules/xfree86.xml:${PORTSDIR}/x11/XFree86-4-clients
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomepanel
USE_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
MD5 (gswitchit-2.5.0.tar.gz) = b86074689c22a017bcb9ab392c3d60bd
SIZE (gswitchit-2.5.0.tar.gz) = 801243

View file

@ -1,16 +0,0 @@
--- applet/gswitchit_applet.c.orig Thu Oct 23 03:06:04 2003
+++ applet/gswitchit_applet.c Thu Oct 23 03:08:53 2003
@@ -520,11 +520,12 @@
unsigned i, nGroups;
char *pname;
BonoboUIComponent *popup;
+ GSList *layout;
popup = panel_applet_get_popup_component( PANEL_APPLET( sia->applet ) );
XklDebug( 160, "Registered group submenu\n" );
nGroups = XklGetNumGroups( );
pname = ( char * ) sia->groupNames;
- GSList *layout = sia->xkbConfig.layouts;
+ layout = sia->xkbConfig.layouts;
for( i = 0; i < nGroups; i++ )
{
char verb[40];

View file

@ -1,21 +0,0 @@
--- configure.orig Fri May 9 18:17:04 2003
+++ configure Thu May 15 01:54:40 2003
@@ -7865,6 +7865,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
@@ -8082,8 +8083,8 @@
-prefix=`$PKG_CONFIG --variable=prefix libgnome-2.0`
-exec_prefix=`$PKG_CONFIG --variable=exec_prefix libgnome-2.0`
+#prefix=`$PKG_CONFIG --variable=prefix libgnome-2.0`
+#exec_prefix=`$PKG_CONFIG --variable=exec_prefix libgnome-2.0`
# Check whether --enable-install_schemas or --disable-install_schemas was given.
if test "${enable_install_schemas+set}" = set; then

View file

@ -1,12 +0,0 @@
GSwitchIt is just a simple keyboard state indicator and switcher for GNOME
panel.
Features:
---------
o Support up to 4 keyboard groups.
o Customizable images for each group.
o Switching using the applet menu or by double-click.
o Audible bell on layout switching (BTW, it can be turned off!).
o Support for "secondary" layouts (i.e. layouts reachable only from popup menu).
WWW: http://gswitchit.sourceforge.net/

View file

@ -1,237 +0,0 @@
bin/gswitchit-plugins-capplet
bin/gswitchit-properties-capplet
bin/xkb-properties-capplet
etc/gconf/gconf.xml.defaults/apps/gswitchit/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/gswitchit/General/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/gswitchit/XKB/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/gswitchit/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/gswitchit/General/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/gswitchit/XKB/%gconf.xml
etc/gconf/schemas/gswitchit.schemas
include/gswitchit/common/gswitchit_plugin.h
include/gswitchit/common/gswitchit_xkb_config.h
lib/libgswitchit.a
lib/libgswitchit.so
lib/libgswitchit.so.0
libdata/bonobo/servers/GNOME_GSwitchItApplet.server
libdata/pkgconfig/gswitchit.pc
libexec/gswitchit-applet
share/gnome/control-center-2.0/capplets/xkb-properties.desktop
share/gnome/gnome-2.0/ui/GNOME_GSwitchItApplet.xml
share/gnome/gswitchit/interfaces/gswitchit-plugins.glade
share/gnome/gswitchit/interfaces/gswitchit-properties.glade
share/gnome/gswitchit/interfaces/xkb-properties.glade
share/gnome/help/gswitchit/C/III.applet.png
share/gnome/help/gswitchit/C/applet.gif
share/gnome/help/gswitchit/C/applet.popup.png
share/gnome/help/gswitchit/C/de.applet.png
share/gnome/help/gswitchit/C/gb.applet.png
share/gnome/help/gswitchit/C/gc.png
share/gnome/help/gswitchit/C/gswitchit-applet.xml
share/gnome/help/gswitchit/C/gswitchit-properties-capplet.xml
share/gnome/help/gswitchit/C/gswitchit.xml
share/gnome/help/gswitchit/C/intro.xml
share/gnome/help/gswitchit/C/legal.xml
share/gnome/help/gswitchit/C/refs.xml
share/gnome/help/gswitchit/C/ru.applet.png
share/gnome/help/gswitchit/C/us.applet.png
share/gnome/help/gswitchit/C/xkb-properties-capplet.xml
share/gnome/help/gswitchit/C/xkb.xml
share/gnome/help/gswitchit/C/xpc.1.png
share/gnome/help/gswitchit/C/xpc.2.png
share/gnome/help/gswitchit/C/xpc.3.png
share/gnome/help/gswitchit/C/xpc.4.png
share/gnome/help/gswitchit/C/xpc.layout_tree.png
share/gnome/help/gswitchit/ru/III.applet.png
share/gnome/help/gswitchit/ru/applet.gif
share/gnome/help/gswitchit/ru/applet.popup.png
share/gnome/help/gswitchit/ru/gb.applet.png
share/gnome/help/gswitchit/ru/gc.png
share/gnome/help/gswitchit/ru/gswitchit-applet.xml
share/gnome/help/gswitchit/ru/gswitchit-properties-capplet.xml
share/gnome/help/gswitchit/ru/gswitchit.xml
share/gnome/help/gswitchit/ru/intro.xml
share/gnome/help/gswitchit/ru/legal.xml
share/gnome/help/gswitchit/ru/refs.xml
share/gnome/help/gswitchit/ru/ru.applet.png
share/gnome/help/gswitchit/ru/us.applet.png
share/gnome/help/gswitchit/ru/xkb-properties-capplet.xml
share/gnome/help/gswitchit/ru/xkb.xml
share/gnome/help/gswitchit/ru/xpc.1.png
share/gnome/help/gswitchit/ru/xpc.2.png
share/gnome/help/gswitchit/ru/xpc.3.png
share/gnome/help/gswitchit/ru/xpc.4.png
share/gnome/help/gswitchit/ru/xpc.5.png
share/gnome/help/gswitchit/ru/xpc.layout_tree.png
share/gnome/omf/gswitchit/gswitchit-C.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/gswitchit/gswitchit-C.omf 2>/dev/null || /usr/bin/true
share/gnome/omf/gswitchit/gswitchit-ru.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/gswitchit/gswitchit-ru.omf 2>/dev/null || /usr/bin/true
share/gnome/pixmaps/gswitchit-applet.png
share/gnome/pixmaps/gswitchit-properties-capplet.png
share/gnome/pixmaps/gswitchit/III.xpm
share/gnome/pixmaps/gswitchit/IV.xpm
share/gnome/pixmaps/gswitchit/ae.xpm
share/gnome/pixmaps/gswitchit/af.xpm
share/gnome/pixmaps/gswitchit/am.xpm
share/gnome/pixmaps/gswitchit/ar.xpm
share/gnome/pixmaps/gswitchit/at.xpm
share/gnome/pixmaps/gswitchit/az.xpm
share/gnome/pixmaps/gswitchit/be.xpm
share/gnome/pixmaps/gswitchit/ben.xpm
share/gnome/pixmaps/gswitchit/bg.xpm
share/gnome/pixmaps/gswitchit/bh.xpm
share/gnome/pixmaps/gswitchit/br.xpm
share/gnome/pixmaps/gswitchit/bs.xpm
share/gnome/pixmaps/gswitchit/bu.xpm
share/gnome/pixmaps/gswitchit/by-alt.xpm
share/gnome/pixmaps/gswitchit/by.xpm
share/gnome/pixmaps/gswitchit/ca.xpm
share/gnome/pixmaps/gswitchit/ca_enhanced.xpm
share/gnome/pixmaps/gswitchit/ch.xpm
share/gnome/pixmaps/gswitchit/cu.xpm
share/gnome/pixmaps/gswitchit/cz.xpm
share/gnome/pixmaps/gswitchit/cz_qwerty.xpm
share/gnome/pixmaps/gswitchit/de.xpm
share/gnome/pixmaps/gswitchit/de_CH.png
share/gnome/pixmaps/gswitchit/dev.xpm
share/gnome/pixmaps/gswitchit/dj.xpm
share/gnome/pixmaps/gswitchit/dk.xpm
share/gnome/pixmaps/gswitchit/dvorak.xpm
share/gnome/pixmaps/gswitchit/dz.xpm
share/gnome/pixmaps/gswitchit/ee.xpm
share/gnome/pixmaps/gswitchit/eg.xpm
share/gnome/pixmaps/gswitchit/el.xpm
share/gnome/pixmaps/gswitchit/en_US.xpm
share/gnome/pixmaps/gswitchit/es.xpm
share/gnome/pixmaps/gswitchit/eu.xpm
share/gnome/pixmaps/gswitchit/fi.xpm
share/gnome/pixmaps/gswitchit/fr-latin9.xpm
share/gnome/pixmaps/gswitchit/fr.xpm
share/gnome/pixmaps/gswitchit/fr_CH.png
share/gnome/pixmaps/gswitchit/gb.xpm
share/gnome/pixmaps/gswitchit/ge.xpm
share/gnome/pixmaps/gswitchit/ge_la.png
share/gnome/pixmaps/gswitchit/ge_ru.png
share/gnome/pixmaps/gswitchit/guj.xpm
share/gnome/pixmaps/gswitchit/gur.xpm
share/gnome/pixmaps/gswitchit/hr.xpm
share/gnome/pixmaps/gswitchit/hu.xpm
share/gnome/pixmaps/gswitchit/hu_qwerty.xpm
share/gnome/pixmaps/gswitchit/ie.xpm
share/gnome/pixmaps/gswitchit/il.xpm
share/gnome/pixmaps/gswitchit/il_phonetic.xpm
share/gnome/pixmaps/gswitchit/init.xpm
share/gnome/pixmaps/gswitchit/iq.xpm
share/gnome/pixmaps/gswitchit/ir.xpm
share/gnome/pixmaps/gswitchit/is.xpm
share/gnome/pixmaps/gswitchit/it.xpm
share/gnome/pixmaps/gswitchit/iu.xpm
share/gnome/pixmaps/gswitchit/jo.xpm
share/gnome/pixmaps/gswitchit/jp.xpm
share/gnome/pixmaps/gswitchit/kan.xpm
share/gnome/pixmaps/gswitchit/km.xpm
share/gnome/pixmaps/gswitchit/kw.xpm
share/gnome/pixmaps/gswitchit/la.xpm
share/gnome/pixmaps/gswitchit/lb.xpm
share/gnome/pixmaps/gswitchit/lo.xpm
share/gnome/pixmaps/gswitchit/lt.xpm
share/gnome/pixmaps/gswitchit/lt_std.xpm
share/gnome/pixmaps/gswitchit/lv.xpm
share/gnome/pixmaps/gswitchit/ly.xpm
share/gnome/pixmaps/gswitchit/ma.xpm
share/gnome/pixmaps/gswitchit/mk.xpm
share/gnome/pixmaps/gswitchit/ml.xpm
share/gnome/pixmaps/gswitchit/mm.xpm
share/gnome/pixmaps/gswitchit/mn.xpm
share/gnome/pixmaps/gswitchit/mt.xpm
share/gnome/pixmaps/gswitchit/mt_us.xpm
share/gnome/pixmaps/gswitchit/mx.xpm
share/gnome/pixmaps/gswitchit/nl.xpm
share/gnome/pixmaps/gswitchit/no.xpm
share/gnome/pixmaps/gswitchit/ogham.png
share/gnome/pixmaps/gswitchit/om.xpm
share/gnome/pixmaps/gswitchit/ori.xpm
share/gnome/pixmaps/gswitchit/pl.xpm
share/gnome/pixmaps/gswitchit/pl2.xpm
share/gnome/pixmaps/gswitchit/ps.xpm
share/gnome/pixmaps/gswitchit/pt.xpm
share/gnome/pixmaps/gswitchit/qc.xpm
share/gnome/pixmaps/gswitchit/ro.xpm
share/gnome/pixmaps/gswitchit/ru.xpm
share/gnome/pixmaps/gswitchit/ru_yawerty.xpm
share/gnome/pixmaps/gswitchit/sapmi.xpm
share/gnome/pixmaps/gswitchit/se.xpm
share/gnome/pixmaps/gswitchit/se_FI.xpm
share/gnome/pixmaps/gswitchit/se_NO.xpm
share/gnome/pixmaps/gswitchit/se_SE.xpm
share/gnome/pixmaps/gswitchit/si.xpm
share/gnome/pixmaps/gswitchit/sk.xpm
share/gnome/pixmaps/gswitchit/sk_qwerty.xpm
share/gnome/pixmaps/gswitchit/so.xpm
share/gnome/pixmaps/gswitchit/sr.xpm
share/gnome/pixmaps/gswitchit/su.xpm
share/gnome/pixmaps/gswitchit/syr.xpm
share/gnome/pixmaps/gswitchit/tel.xpm
share/gnome/pixmaps/gswitchit/th.xpm
share/gnome/pixmaps/gswitchit/tj.xpm
share/gnome/pixmaps/gswitchit/tml.xpm
share/gnome/pixmaps/gswitchit/tn.xpm
share/gnome/pixmaps/gswitchit/tr.xpm
share/gnome/pixmaps/gswitchit/ua.xpm
share/gnome/pixmaps/gswitchit/uk.xpm
share/gnome/pixmaps/gswitchit/us.xpm
share/gnome/pixmaps/gswitchit/us_intl.xpm
share/gnome/pixmaps/gswitchit/uy.xpm
share/gnome/pixmaps/gswitchit/uz.xpm
share/gnome/pixmaps/gswitchit/vn.xpm
share/gnome/pixmaps/gswitchit/ye.xpm
share/gnome/pixmaps/gswitchit/yu.xpm
share/gnome/pixmaps/xkb-properties-capplet.png
share/locale/am/LC_MESSAGES/gswitchit.mo
share/locale/az/LC_MESSAGES/gswitchit.mo
share/locale/be/LC_MESSAGES/gswitchit.mo
share/locale/bg/LC_MESSAGES/gswitchit.mo
share/locale/cs/LC_MESSAGES/gswitchit.mo
share/locale/de/LC_MESSAGES/gswitchit.mo
share/locale/el/LC_MESSAGES/gswitchit.mo
share/locale/es/LC_MESSAGES/gswitchit.mo
share/locale/fa/LC_MESSAGES/gswitchit.mo
share/locale/fr/LC_MESSAGES/gswitchit.mo
share/locale/he/LC_MESSAGES/gswitchit.mo
share/locale/it/LC_MESSAGES/gswitchit.mo
share/locale/ja/LC_MESSAGES/gswitchit.mo
share/locale/lv/LC_MESSAGES/gswitchit.mo
share/locale/ml/LC_MESSAGES/gswitchit.mo
share/locale/mn/LC_MESSAGES/gswitchit.mo
share/locale/ms/LC_MESSAGES/gswitchit.mo
share/locale/nl/LC_MESSAGES/gswitchit.mo
share/locale/no/LC_MESSAGES/gswitchit.mo
share/locale/pl/LC_MESSAGES/gswitchit.mo
share/locale/pt/LC_MESSAGES/gswitchit.mo
share/locale/pt_BR/LC_MESSAGES/gswitchit.mo
share/locale/ru/LC_MESSAGES/gswitchit.mo
share/locale/sq/LC_MESSAGES/gswitchit.mo
share/locale/sr/LC_MESSAGES/gswitchit.mo
share/locale/sr@Latn/LC_MESSAGES/gswitchit.mo
share/locale/sv/LC_MESSAGES/gswitchit.mo
share/locale/uk/LC_MESSAGES/gswitchit.mo
share/locale/vi/LC_MESSAGES/gswitchit.mo
share/locale/zh_CN/LC_MESSAGES/gswitchit.mo
@dirrm share/gnome/pixmaps/gswitchit
@dirrm share/gnome/omf/gswitchit
@dirrm share/gnome/help/gswitchit/ru
@dirrm share/gnome/help/gswitchit/C
@dirrm share/gnome/help/gswitchit
@dirrm share/gnome/gswitchit/interfaces
@dirrm share/gnome/gswitchit
@dirrm include/gswitchit/common
@dirrm include/gswitchit
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gswitchit/XKB
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gswitchit/General
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gswitchit
@dirrm etc/gconf/gconf.xml.defaults/apps/gswitchit/XKB
@dirrm etc/gconf/gconf.xml.defaults/apps/gswitchit/General
@dirrm etc/gconf/gconf.xml.defaults/apps/gswitchit
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gswitchit/gswitchit-C.omf 2>/dev/null || /usr/bin/true
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gswitchit/gswitchit-ru.omf 2>/dev/null || /usr/bin/true