- Update to 0.06

- Now works with perl 5.005_03

PR:		58817
Submitted by:	maintainer
This commit is contained in:
Kirill Ponomarev 2003-11-02 10:13:30 +00:00
parent ec9188d56f
commit fa89266b65
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=92830
3 changed files with 21 additions and 20 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= Email-LocalDelivery
PORTVERSION= 0.05
PORTVERSION= 0.06
CATEGORIES= mail perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Email
@ -16,14 +16,30 @@ MAINTAINER= lars@thegler.dk
COMMENT= Deliver a piece of email - simply
BUILD_DEPENDS= ${SITE_PERL}/Email/Simple.pm:${PORTSDIR}/mail/p5-Email-Simple \
${SITE_PERL}/Email/FolderType.pm:${PORTSDIR}/mail/p5-Email-FolderType
${SITE_PERL}/Email/FolderType.pm:${PORTSDIR}/mail/p5-Email-FolderType \
${SITE_PERL}/File/Path/Expand.pm:${PORTSDIR}/devel/p5-File-Path-Expand
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= Email::LocalDelivery.3
test:
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
post-patch:
${PERL} -pi -e '$$_="" if /require 5/;' \
-e '$$_="" if /use warnings/;' \
-e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1);$$1/;' \
${WRKSRC}/LocalDelivery.pm \
${WRKSRC}/LocalDelivery/Maildir.pm \
${WRKSRC}/LocalDelivery/Mbox.pm
post-configure:
${PERL} -pi -e 's,/usr/local,${PREFIX},g' ${WRKSRC}/Makefile
.endif
test: build
cd ${WRKSRC} ; make test
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -1 +1 @@
MD5 (Email-LocalDelivery-0.05.tar.gz) = 73249763b6619750f3d657b149179059
MD5 (Email-LocalDelivery-0.06.tar.gz) = 97d29eb9b5dfd0ec8f7eb4e170b4d078

View file

@ -1,15 +0,0 @@
--- LocalDelivery.pm.orig Mon Sep 1 20:36:31 2003
+++ LocalDelivery.pm Mon Sep 1 20:30:45 2003
@@ -1,11 +1,10 @@
package Email::LocalDelivery;
-require 5.005_62;
use strict;
-use warnings;
use Email::FolderType qw(folder_type);
use Carp;
-our $VERSION = '0.05';
+use vars qw($VERSION);
+$VERSION = '0.05';
=head1 NAME