science/InsightToolkit521: New port: Fork of science/InsightToolkit
for graphics/elastix
This commit is contained in:
parent
8b652c4015
commit
fa8a770aff
8 changed files with 4383 additions and 0 deletions
74
science/InsightToolkit521/Makefile
Normal file
74
science/InsightToolkit521/Makefile
Normal file
|
@ -0,0 +1,74 @@
|
|||
PORTNAME= InsightToolkit
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 5.2.1
|
||||
CATEGORIES= science biology
|
||||
MASTER_SITES= https://github.com/InsightSoftwareConsortium/ITK/releases/download/v${DISTVERSION}/:data
|
||||
PKGNAMESUFFIX= 521
|
||||
DISTFILES= InsightData-${DISTVERSION}.tar.gz:data
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Insight Toolkit
|
||||
WWW= https://www.itk.org
|
||||
|
||||
LICENSE= APACHE20
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= googletest>=0:devel/googletest
|
||||
LIB_DEPENDS= libgdcmCommon.so:devel/gdcm \
|
||||
libexpat.so:textproc/expat2 \
|
||||
libfftw.so:math/fftw \
|
||||
libhdf5.so:science/hdf5 \
|
||||
libpng.so:graphics/png \
|
||||
libsz.so:science/libaec \
|
||||
libtiff.so:graphics/tiff
|
||||
|
||||
USES= cmake:testing compiler:c++11-lang eigen:3 jpeg pkgconfig python:test
|
||||
USE_LDCONFIG= ${PREFIX}/lib/InsightToolkit
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= InsightSoftwareConsortium
|
||||
GH_PROJECT= ITK
|
||||
|
||||
CMAKE_ON= BUILD_SHARED_LIBS \
|
||||
ITK_FORBID_DOWNLOADS \
|
||||
ITK_LEGACY_SILENT \
|
||||
ITK_USE_SYSTEM_EXPAT \
|
||||
ITK_USE_SYSTEM_FFTW \
|
||||
ITK_USE_SYSTEM_GDCM \
|
||||
ITK_USE_SYSTEM_HDF5 \
|
||||
ITK_USE_SYSTEM_JPEG \
|
||||
ITK_USE_SYSTEM_LIBRARIES \
|
||||
ITK_USE_SYSTEM_PNG \
|
||||
ITK_USE_SYSTEM_TIFF \
|
||||
ITK_USE_SYSTEM_ZLIB \
|
||||
Module_ITKIOMIC \
|
||||
Module_ITKIOTransformMINC \
|
||||
Module_ITKReview
|
||||
CMAKE_ARGS= -DPython3_EXECUTABLE=${PYTHON_CMD}
|
||||
CMAKE_OFF= ITK_USE_KWSTYLE BUILD_TESTING
|
||||
CMAKE_TESTING_ON= BUILD_TESTING # 3 tests are known to fail, see https://github.com/InsightSoftwareConsortium/ITK/issues/3739
|
||||
|
||||
ITK_VER= ${PORTVERSION:R}
|
||||
|
||||
PLIST_SUB+= ITK_VER=${ITK_VER}
|
||||
|
||||
OPTIONS_DEFINE= EXAMPLES TESTING
|
||||
EXAMPLES_DESC= Build examples (very time consuming)
|
||||
TESTING_DESC= Build testing programs (very time consuming)
|
||||
|
||||
EXAMPLES_CMAKE_BOOL= BUILD_EXAMPLES
|
||||
TESTING_CMAKE_BOOL= BUILD_TESTING
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${CHOSEN_COMPILER_TYPE} == gcc
|
||||
PLIST_SUB+= CHOSEN_COMPILER_TYPE="GNU"
|
||||
.else
|
||||
PLIST_SUB+= CHOSEN_COMPILER_TYPE="Clang"
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
${MV} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/.ExternalData/* ${WRKSRC}/.ExternalData/
|
||||
${RM} -r ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
.include <bsd.port.post.mk>
|
3
science/InsightToolkit521/Makefile.version
Normal file
3
science/InsightToolkit521/Makefile.version
Normal file
|
@ -0,0 +1,3 @@
|
|||
# this file is provided for ITK users
|
||||
|
||||
ITK_VER=5.2
|
5
science/InsightToolkit521/distinfo
Normal file
5
science/InsightToolkit521/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
TIMESTAMP = 1668411091
|
||||
SHA256 (InsightData-5.2.1.tar.gz) = b5fcd209f456af289473ccc78f935b910168b852f3d4707d0c1e9dfd508b1757
|
||||
SIZE (InsightData-5.2.1.tar.gz) = 293448802
|
||||
SHA256 (InsightSoftwareConsortium-ITK-v5.2.1_GH0.tar.gz) = 6022b2b64624b8bcec3333fe48d5f74ff6ebceb3bdf98258ba7d7fbbc76b99ab
|
||||
SIZE (InsightSoftwareConsortium-ITK-v5.2.1_GH0.tar.gz) = 20955613
|
|
@ -0,0 +1,10 @@
|
|||
--- CMake/ITKModuleTest.cmake.orig 2019-08-03 09:25:42 UTC
|
||||
+++ CMake/ITKModuleTest.cmake
|
||||
@@ -244,6 +244,7 @@ endfunction()
|
||||
|
||||
function(CreateGoogleTestDriver KIT KIT_LIBS KitTests)
|
||||
set(exe "${KIT}GTestDriver")
|
||||
+ find_package(GTest)
|
||||
add_executable(${exe} ${KitTests} )
|
||||
target_link_libraries(${exe} ${KIT_LIBS} GTest::GTest GTest::Main)
|
||||
itk_module_target_label(${exe})
|
|
@ -0,0 +1,34 @@
|
|||
--- Modules/ThirdParty/MINC/src/libminc/CMakeLists.txt.orig 2019-07-28 10:06:31 UTC
|
||||
+++ Modules/ThirdParty/MINC/src/libminc/CMakeLists.txt
|
||||
@@ -403,11 +403,11 @@ SET(LIBMINC_STATIC_LIBRARIES ${LIBMINC_LIBRARY_STATIC}
|
||||
SET(LIBMINC_STATIC_LIBRARIES_CONFIG ${LIBMINC_LIBRARY_STATIC} ${HDF5_LIBRARY_NAME} ${NIFTI_LIBRARIES} ${ZLIB_LIBRARY_NAME})
|
||||
|
||||
IF(UNIX)
|
||||
- SET(LIBMINC_LIBRARIES ${LIBMINC_LIBRARIES} m dl ${RT_LIBRARY})
|
||||
- SET(LIBMINC_STATIC_LIBRARIES ${LIBMINC_STATIC_LIBRARIES} m dl ${RT_LIBRARY})
|
||||
+ SET(LIBMINC_LIBRARIES ${LIBMINC_LIBRARIES} m ${CMAKE_DL_LIBS} ${RT_LIBRARY})
|
||||
+ SET(LIBMINC_STATIC_LIBRARIES ${LIBMINC_STATIC_LIBRARIES} m ${CMAKE_DL_LIBS} ${RT_LIBRARY})
|
||||
|
||||
- SET(LIBMINC_LIBRARIES_CONFIG ${LIBMINC_LIBRARIES_CONFIG} m dl ${RT_LIBRARY_NAME})
|
||||
- SET(LIBMINC_STATIC_LIBRARIES_CONFIG ${LIBMINC_STATIC_LIBRARIES_CONFIG} m dl ${RT_LIBRARY_NAME})
|
||||
+ SET(LIBMINC_LIBRARIES_CONFIG ${LIBMINC_LIBRARIES_CONFIG} m ${CMAKE_DL_LIBS} ${RT_LIBRARY_NAME})
|
||||
+ SET(LIBMINC_STATIC_LIBRARIES_CONFIG ${LIBMINC_STATIC_LIBRARIES_CONFIG} m ${CMAKE_DL_LIBS} ${RT_LIBRARY_NAME})
|
||||
ENDIF(UNIX)
|
||||
|
||||
SET(minc_LIB_SRCS ${minc2_LIB_SRCS} ${minc_common_SRCS})
|
||||
@@ -447,13 +447,13 @@ ENDIF(NOT LIBMINC_USE_SYSTEM_NIFTI AND NOT LIBMINC_EX
|
||||
#EXPORT(TARGETS ${LIBMINC_LIBRARY} FILE "${LIBMINC_EXPORTED_TARGETS}.cmake")
|
||||
|
||||
IF(UNIX)
|
||||
- TARGET_LINK_LIBRARIES(${LIBMINC_LIBRARY} m dl )
|
||||
+ TARGET_LINK_LIBRARIES(${LIBMINC_LIBRARY} m ${CMAKE_DL_LIBS} )
|
||||
|
||||
#ITK: Skip static library build
|
||||
IF(0)
|
||||
IF(LIBMINC_BUILD_SHARED_LIBS)
|
||||
ADD_LIBRARY(${LIBMINC_LIBRARY_STATIC} STATIC ${minc_LIB_SRCS} ${minc_HEADERS} ${volume_io_LIB_SRCS} ${volume_io_HEADERS} )
|
||||
- TARGET_LINK_LIBRARIES(${LIBMINC_LIBRARY_STATIC} ${HDF5_LIBRARY} ${NIFTI_LIBRARIES} ${ZLIB_LIBRARY} ${RT_LIBRARY} m dl )
|
||||
+ TARGET_LINK_LIBRARIES(${LIBMINC_LIBRARY_STATIC} ${HDF5_LIBRARY} ${NIFTI_LIBRARIES} ${ZLIB_LIBRARY} ${RT_LIBRARY} m ${CMAKE_DL_LIBS} )
|
||||
IF(LIBMINC_MINC1_SUPPORT)
|
||||
TARGET_LINK_LIBRARIES(${LIBMINC_LIBRARY} ${NETCDF_LIBRARY})
|
||||
ENDIF(LIBMINC_MINC1_SUPPORT)
|
8
science/InsightToolkit521/pkg-descr
Normal file
8
science/InsightToolkit521/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
ITK is an open-source software toolkit for performing registration and
|
||||
segmentation. Segmentation is the process of identifying and classifying
|
||||
data found in a digitally sampled representation. Typically the sampled
|
||||
representation is an image acquired from such medical instrumentation as
|
||||
CT or MRI scanners. Registration is the task of aligning or developing
|
||||
correspondences between data. For example, in the medical environment,
|
||||
a CT scan may be aligned with a MRI scan in order to combine the
|
||||
information contained in both.
|
4248
science/InsightToolkit521/pkg-plist
Normal file
4248
science/InsightToolkit521/pkg-plist
Normal file
File diff suppressed because it is too large
Load diff
|
@ -5,6 +5,7 @@
|
|||
SUBDIR += ChipmunkPhysics
|
||||
SUBDIR += InsightToolkit
|
||||
SUBDIR += InsightToolkit501
|
||||
SUBDIR += InsightToolkit521
|
||||
SUBDIR += PETSc
|
||||
SUBDIR += R-cran-DCluster
|
||||
SUBDIR += R-cran-Epi
|
||||
|
|
Loading…
Reference in a new issue