- Fix build with clang
- Support CXXFLAGS properly - Add LICENSE - Support staging PR: ports/184849 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
parent
7eca7b3692
commit
fa94e87031
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=337002
4 changed files with 45 additions and 16 deletions
|
@ -10,22 +10,30 @@ MASTER_SITES= SF/posadis/${PORTNAME}/${PORTVERSION}
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Posadis C++ DNS library
|
||||
|
||||
LICENSE= GPLv2 # (or later)
|
||||
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES
|
||||
|
||||
USE_AUTOTOOLS= libtool
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
PLIST_SUB= VERSION="${PORTVERSION}"
|
||||
|
||||
DOCS= AUTHORS ChangeLog NEWS README TODO
|
||||
EXAMPLES= examples/*.cpp
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e \
|
||||
'/CXXFLAGS/s|-O0|$$CXXFLAGS| ; \
|
||||
/LIBS=/s|-lstdc++||' ${WRKSRC}/configure
|
||||
|
||||
NO_STAGE= yes
|
||||
post-install:
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
|
||||
.endif
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for i in AUTHORS ChangeLog NEWS README TODO
|
||||
(cd ${WRKSRC} && ${INSTALL_DATA} ${i} \
|
||||
${STAGEDIR}${DOCSDIR})
|
||||
.endfor
|
||||
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
(cd ${WRKSRC}/examples && ${INSTALL_DATA} *.cpp \
|
||||
${STAGEDIR}${EXAMPLESDIR})
|
||||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libposlib.so.0 \
|
||||
${STAGEDIR}${PREFIX}/lib/libposserver.so.0
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
11
devel/poslib/files/patch-tools__fileclient.cpp
Normal file
11
devel/poslib/files/patch-tools__fileclient.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- tools/fileclient.cpp.orig
|
||||
+++ tools/fileclient.cpp
|
||||
@@ -20,6 +20,8 @@
|
||||
|
||||
#include <poslib/poslib.h>
|
||||
|
||||
+#include <limits.h>
|
||||
+
|
||||
int main(int argc, char **argv) {
|
||||
DnsMessage *q = NULL, *a = NULL;
|
||||
char q3[PATH_MAX], *q2 = "", *query = q3, *ptr, *ptr2;
|
10
devel/poslib/files/patch-tools__fileserver.cpp
Normal file
10
devel/poslib/files/patch-tools__fileserver.cpp
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- tools/fileserver.cpp.orig
|
||||
+++ tools/fileserver.cpp
|
||||
@@ -32,6 +32,7 @@
|
||||
#include <sys/types.h>
|
||||
#include <dirent.h>
|
||||
#include <errno.h>
|
||||
+#include <limits.h>
|
||||
|
||||
DnsMessage *my_handle_query(pending_query *query);
|
||||
|
|
@ -42,13 +42,13 @@ lib/poslib-%%VERSION%%/include/poslib-config.h
|
|||
%%PORTDOCS%%%%DOCSDIR%%/NEWS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TODO
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dnstimeago.cpp
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/host.cpp
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/server.cpp
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
%%EXAMPLESDIR%%/dnstimeago.cpp
|
||||
%%EXAMPLESDIR%%/host.cpp
|
||||
%%EXAMPLESDIR%%/server.cpp
|
||||
@dirrm %%EXAMPLESDIR%%
|
||||
@dirrm lib/poslib-%%VERSION%%/include
|
||||
@dirrm lib/poslib-%%VERSION%%
|
||||
@dirrm include/poslib-%%VERSION%%/poslib/server
|
||||
@dirrm include/poslib-%%VERSION%%/poslib
|
||||
@dirrm include/poslib-%%VERSION%%
|
||||
@dirrm lib/poslib-%%VERSION%%/include
|
||||
@dirrm lib/poslib-%%VERSION%%
|
||||
|
|
Loading…
Reference in a new issue