* Add support for Korean real-world locales
* Allow libiconv to be built on FreeBSD < 4.3 * Bump PORTREVISION PR: 37271 Submitted by: Hye-Shik Chang <perky@fallin.lv> (Korean locale patch) me (build fix) Reviewed by: sobomax (build fix)
This commit is contained in:
parent
c0354bd791
commit
fade97cdc1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=59768
2 changed files with 34 additions and 6 deletions
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= libiconv
|
||||
PORTVERSION= 1.7
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= converters devel
|
||||
MASTER_SITES= ${MASTER_SITE_GNU} \
|
||||
ftp://ftp.ilog.fr/pub/Users/haible/gnu/
|
||||
|
@ -23,7 +23,16 @@ INSTALLS_SHLIB= yes
|
|||
MAN1= iconv.1
|
||||
MAN3= iconv.3 iconv_open.3 iconv_close.3
|
||||
|
||||
pre-build:
|
||||
@cd ${WRKSRC} ; /usr/bin/gperf -t -L ANSI-C -H aliases_hash -N aliases_lookup -7 -C -k '1,3-11,$$' -i 1 lib/aliases.gperf > lib/aliases.h
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.if ${OSVERSION} < 430000
|
||||
BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/gperf
|
||||
GPERF= ${LOCALBASE}/bin/gperf
|
||||
.else
|
||||
GPERF= /usr/bin/gperf
|
||||
.endif
|
||||
|
||||
pre-build:
|
||||
@cd ${WRKSRC} ; ${GPERF} -t -L ANSI-C -H aliases_hash -N aliases_lookup -7 -C -k '1,3-11,$$' -i 1 lib/aliases.gperf > lib/aliases.h
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- lib/aliases.gperf.orig Mon Jun 25 08:39:41 2001
|
||||
+++ lib/aliases.gperf Mon Apr 29 11:23:40 2002
|
||||
--- lib/aliases.gperf.orig Mon Jun 25 21:39:41 2001
|
||||
+++ lib/aliases.gperf Sun May 19 21:08:32 2002
|
||||
@@ -42,6 +42,7 @@
|
||||
JAVA, ei_java
|
||||
ISO-8859-1, ei_iso8859_1
|
||||
|
@ -105,3 +105,22 @@
|
|||
ISO_8859-16:2000, ei_iso8859_16
|
||||
ISO-IR-226, ei_iso8859_16
|
||||
KOI8-R, ei_koi8_r
|
||||
@@ -251,12 +265,12 @@
|
||||
CHINESE, ei_gb2312
|
||||
ISO-IR-165, ei_isoir165
|
||||
CN-GB-ISOIR165, ei_isoir165
|
||||
-KSC_5601, ei_ksc5601
|
||||
-KS_C_5601-1987, ei_ksc5601
|
||||
-KS_C_5601-1989, ei_ksc5601
|
||||
-ISO-IR-149, ei_ksc5601
|
||||
-CSKSC56011987, ei_ksc5601
|
||||
-KOREAN, ei_ksc5601
|
||||
+KSC_5601, ei_euc_kr
|
||||
+KS_C_5601-1987, ei_euc_kr
|
||||
+KS_C_5601-1989, ei_euc_kr
|
||||
+ISO-IR-149, ei_euc_kr
|
||||
+CSKSC56011987, ei_euc_kr
|
||||
+KOREAN, ei_euc_kr
|
||||
EUC-JP, ei_euc_jp
|
||||
EUCJP, ei_euc_jp
|
||||
EXTENDED_UNIX_CODE_PACKED_FORMAT_FOR_JAPANESE, ei_euc_jp
|
||||
|
|
Loading…
Reference in a new issue