Add emotion 20060719, video playback wrapper library for e17.
PR: ports/100575 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
This commit is contained in:
parent
3ed0939eed
commit
fae2b8227a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=168658
6 changed files with 111 additions and 0 deletions
|
@ -26,6 +26,7 @@
|
|||
SUBDIR += dvdstyler
|
||||
SUBDIR += dvdwizard
|
||||
SUBDIR += dvts
|
||||
SUBDIR += emotion
|
||||
SUBDIR += emovix
|
||||
SUBDIR += enjoympeg
|
||||
SUBDIR += exportvideo
|
||||
|
|
53
multimedia/emotion/Makefile
Normal file
53
multimedia/emotion/Makefile
Normal file
|
@ -0,0 +1,53 @@
|
|||
# New ports collection makefile for: emotion
|
||||
# Date created: 2006-07-16
|
||||
# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
|
||||
#
|
||||
# $MBSDlabs$
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= emotion
|
||||
PORTVERSION= 20060719
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= http://mbsd.msk.ru/dist/
|
||||
|
||||
MAINTAINER= ssedov@mbsd.msk.ru
|
||||
COMMENT= Video playback wrapper library for e17
|
||||
|
||||
LIB_DEPENDS= ecore.1:${PORTSDIR}/x11/ecore \
|
||||
edje.5:${PORTSDIR}/graphics/edje \
|
||||
eet.9:${PORTSDIR}/devel/eet \
|
||||
embryo.9:${PORTSDIR}/lang/embryo \
|
||||
evas.1:${PORTSDIR}/graphics/evas
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gnomehack pkgconfig gnometarget
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
|
||||
|
||||
OPTIONS= XINE "Build Xine module" on \
|
||||
GST "Build GStreamer module" on
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITHOUT_XINE) && defined(WITHOUT_GST)
|
||||
IGNORE= is useless without playback library. Please run 'make config' and choose one of XINE and GST
|
||||
.endif
|
||||
|
||||
.if defined(WITH_XINE)
|
||||
LIB_DEPENDS+= xine.15:${PORTSDIR}/multimedia/libxine
|
||||
PLIST_SUB+= XINE=""
|
||||
.else
|
||||
PLIST_SUB+= XINE="@comment "
|
||||
.endif
|
||||
.if defined(WITH_GST)
|
||||
USE_GSTREAMER= ffmpeg good
|
||||
PLIST_SUB+= GST=""
|
||||
.else
|
||||
PLIST_SUB+= GST="@comment "
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
3
multimedia/emotion/distinfo
Normal file
3
multimedia/emotion/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (emotion-20060719.tar.bz2) = e5536468ace9cd02c31ae7994eca7c1d
|
||||
SHA256 (emotion-20060719.tar.bz2) = 6ec5c3e8e07df8358ef34117eeb90a278d0cab12ffdae0e06c6171c81f439668
|
||||
SIZE (emotion-20060719.tar.bz2) = 1425051
|
30
multimedia/emotion/files/patch-configure
Normal file
30
multimedia/emotion/files/patch-configure
Normal file
|
@ -0,0 +1,30 @@
|
|||
--- configure.orig Tue Jul 18 17:40:53 2006
|
||||
+++ configure Tue Jul 18 17:41:01 2006
|
||||
@@ -21861,27 +21861,6 @@
|
||||
_ACEOF
|
||||
|
||||
|
||||
-function vser
|
||||
-{
|
||||
- v=$1
|
||||
- VSTART=`echo $v | awk -F_ '{printf("%s", $1);}'`
|
||||
- V1=`echo $VSTART | awk -F\. '{printf("%s", $1);}'`
|
||||
- V2=`echo $VSTART | awk -F\. '{printf("%s", $2);}'`
|
||||
- V3=`echo $VSTART | awk -F\. '{printf("%s", $3);}'`
|
||||
- V4="0"
|
||||
- VEND=`echo $v | awk -F_ '{printf("%s", $2);}'`
|
||||
- if test -n "$VEND"; then
|
||||
- V4=`echo $VEND | sed s/pre//`
|
||||
- fi
|
||||
- V3=$(( $V3 * 100 ));
|
||||
- V2=$(( $V2 * 10000 ));
|
||||
- V1=$(( $V1 * 1000000 ));
|
||||
- V=$(( $V4 + $V3 + $V2 + $V1 ));
|
||||
- echo $V
|
||||
-}
|
||||
-
|
||||
-
|
||||
-
|
||||
# Check whether --with-eet-prefix or --without-eet-prefix was given.
|
||||
if test "${with_eet_prefix+set}" = set; then
|
||||
withval="$with_eet_prefix"
|
6
multimedia/emotion/pkg-descr
Normal file
6
multimedia/emotion/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
Emotion library is uses in e17 window manager as wrapper library for
|
||||
various multimedia engines. It features simplified and generalized
|
||||
interface and power.
|
||||
|
||||
Author: The Rasterman (Carsten Haitzler) <raster@rasterman.com>
|
||||
WWW: http://www.enlightenment.org/
|
18
multimedia/emotion/pkg-plist
Normal file
18
multimedia/emotion/pkg-plist
Normal file
|
@ -0,0 +1,18 @@
|
|||
bin/emotion-config
|
||||
bin/emotion_test
|
||||
include/Emotion.h
|
||||
%%GST%%lib/emotion/emotion_decoder_gstreamer.a
|
||||
%%GST%%lib/emotion/emotion_decoder_gstreamer.la
|
||||
%%GST%%lib/emotion/emotion_decoder_gstreamer.so
|
||||
%%XINE%%lib/emotion/emotion_decoder_xine.a
|
||||
%%XINE%%lib/emotion/emotion_decoder_xine.la
|
||||
%%XINE%%lib/emotion/emotion_decoder_xine.so
|
||||
lib/libemotion.a
|
||||
lib/libemotion.la
|
||||
lib/libemotion.so
|
||||
lib/libemotion.so.0
|
||||
libdata/pkgconfig/emotion.pc
|
||||
%%DATADIR%%/data/theme.edj
|
||||
@dirrmtry share/emotion/data
|
||||
@dirrmtry share/emotion
|
||||
@dirrmtry lib/emotion
|
Loading…
Reference in a new issue