Update to nethack 3.3.1.
PR: 21942 Submitted by: Gregory Bond <gnb@itga.com.au> No response from: MAINTAINER (6 weeks timeout)
This commit is contained in:
parent
024a663e1a
commit
fae5a028c5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36166
21 changed files with 123 additions and 204 deletions
|
@ -6,14 +6,17 @@
|
|||
#
|
||||
|
||||
PORTNAME= nethack
|
||||
PORTVERSION= 3.3.0
|
||||
PORTVERSION= 3.3.1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ftp://ftp.nethack.org/pub/nethack/src/ \
|
||||
MASTER_SITES= ftp://ftp.nethack.org/pub/nethack/nh${PORTVERSION2}/src/ \
|
||||
${MASTER_SITE_GNU}
|
||||
MASTER_SITE_SUBDIR= nethack
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= dscheidt@enteract.com
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
USE_XPM= yes
|
||||
USE_GMAKE= yes
|
||||
MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (nethack-3.3.0.tar.gz) = cf9f4039408321f39c3ef733455cb73a
|
||||
MD5 (nethack-331.tgz) = d0600ce4698c80e5ad1f917ded1c36d2
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
--- ./include/config.h.orig Sat Dec 11 00:20:49 1999
|
||||
+++ ./include/config.h Sun Dec 12 20:28:09 1999
|
||||
--- ./include/config.h.orig Sat Jul 22 11:13:51 2000
|
||||
+++ ./include/config.h Fri Oct 13 09:31:24 2000
|
||||
@@ -43,7 +43,7 @@
|
||||
* Some combinations make no sense. See the installation document.
|
||||
*/
|
||||
#define TTY_GRAPHICS /* good old tty based graphics */
|
||||
-/* #define X11_GRAPHICS */ /* X11 interface */
|
||||
+#define X11_GRAPHICS /* X11 interface */
|
||||
-/* #define X11_GRAPHICS */ /* X11 interface */
|
||||
+#define X11_GRAPHICS /* X11 interface */
|
||||
/* #define QT_GRAPHICS */ /* Qt interface */
|
||||
/* #define GNOME_GRAPHICS */ /* Gnome interface */
|
||||
|
||||
/*
|
||||
@@ -92,7 +92,7 @@
|
||||
@@ -110,7 +110,7 @@
|
||||
* would allow:
|
||||
* xpmtoppm <x11tiles.xpm | pnmscale 1.25 | ppmquant 90 >x11tiles_big.xpm
|
||||
*/
|
||||
|
@ -18,7 +18,7 @@
|
|||
# ifdef USE_XPM
|
||||
# define GRAPHIC_TOMBSTONE /* Use graphical tombstone (rip.xpm) */
|
||||
# endif
|
||||
@@ -133,11 +133,11 @@
|
||||
@@ -151,11 +151,11 @@
|
||||
|
||||
#ifdef UNIX
|
||||
/* path and file name extension for compression program */
|
||||
|
@ -34,7 +34,7 @@
|
|||
#endif
|
||||
|
||||
#ifndef COMPRESS
|
||||
@@ -168,7 +168,7 @@
|
||||
@@ -186,7 +186,7 @@
|
||||
* otherwise it will be the current directory.
|
||||
*/
|
||||
# ifndef HACKDIR
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
--- ./include/system.h.orig Sat Dec 11 00:20:51 1999
|
||||
+++ ./include/system.h Sun Dec 12 20:44:40 1999
|
||||
@@ -80,7 +80,7 @@
|
||||
# if !defined(SUNOS4) || defined(RANDOM)
|
||||
E void FDECL(srandom, (unsigned int));
|
||||
# else
|
||||
-# ifndef bsdi
|
||||
+# if !defined(bsdi) && !defined(__FreeBSD__)
|
||||
E int FDECL(srandom, (unsigned int));
|
||||
# endif
|
||||
# endif
|
||||
@@ -516,7 +516,7 @@
|
||||
# if defined(ULTRIX) || defined(SYSV) || defined(MICRO) || defined(VMS) || defined(MAC) || (defined(HPUX) && defined(_POSIX_SOURCE))
|
||||
E time_t FDECL(time, (time_t *));
|
||||
# else
|
||||
-E long FDECL(time, (time_t *));
|
||||
+E time_t FDECL(time, (time_t *));
|
||||
# endif /* ULTRIX */
|
||||
|
||||
#ifdef VMS
|
|
@ -1,15 +1,15 @@
|
|||
--- include/unixconf.h.orig Sat Dec 11 14:20:51 1999
|
||||
+++ include/unixconf.h Sat Jul 29 06:58:37 2000
|
||||
@@ -45,7 +45,7 @@
|
||||
/* #define AIX_31 */ /* In AIX 3.1 (IBM RS/6000) use BSD ioctl's to gain
|
||||
--- ./include/unixconf.h.orig Mon Jul 17 11:03:51 2000
|
||||
+++ ./include/unixconf.h Fri Oct 13 10:06:57 2000
|
||||
@@ -47,7 +47,7 @@
|
||||
* job control (note that AIX is SYSV otherwise)
|
||||
* Also define this for AIX 3.2 */
|
||||
|
||||
-#define TERMINFO /* uses terminfo rather than termcap */
|
||||
+/* #define TERMINFO */ /* uses terminfo rather than termcap */
|
||||
/* Should be defined for most SYSV, SVR4 (including
|
||||
* Solaris 2+), HPUX, and Linux systems. In
|
||||
* particular, it should NOT be defined for the UNIXPC
|
||||
@@ -135,7 +135,7 @@
|
||||
@@ -143,7 +143,7 @@
|
||||
* A stat system call is done on the mailbox every MAILCKFREQ moves.
|
||||
*/
|
||||
|
||||
|
|
|
@ -1,20 +1,20 @@
|
|||
--- ./sys/unix/Makefile.src.orig Sat Dec 11 00:21:05 1999
|
||||
+++ ./sys/unix/Makefile.src Sun Dec 12 20:27:50 1999
|
||||
@@ -132,8 +132,8 @@
|
||||
--- ./sys/unix/Makefile.src.orig Sat Aug 5 20:52:57 2000
|
||||
+++ ./sys/unix/Makefile.src Fri Oct 13 10:10:21 2000
|
||||
@@ -144,8 +144,8 @@
|
||||
# flags for debugging:
|
||||
# CFLAGS = -g -I../include
|
||||
|
||||
-CFLAGS = -O -I../include
|
||||
-LFLAGS =
|
||||
-LFLAGS =
|
||||
+CFLAGS += -O -I../include -I${X11BASE}/include
|
||||
+LFLAGS = -L${X11BASE}/lib
|
||||
+LFLAGS = -L${X11BASE}/lib
|
||||
|
||||
# Only used for Qt interface (other interfaces are standard C)
|
||||
CXXFLAGS = -g $(CFLAGS) -I. -I$(QTDIR)/include
|
||||
@@ -165,8 +165,8 @@
|
||||
# The Qt and Be window systems are written in C++, while the rest of
|
||||
# NetHack is standard C. If using Qt, uncomment the LD line here to get
|
||||
@@ -203,8 +203,8 @@
|
||||
|
||||
#
|
||||
#
|
||||
#
|
||||
-WINSRC = $(WINTTYSRC)
|
||||
-WINOBJ = $(WINTTYOBJ)
|
||||
+WINSRC = $(WINTTYSRC) $(WINX11SRC)
|
||||
|
@ -22,7 +22,7 @@
|
|||
|
||||
# on some systems the termcap library is in -ltermcap or -lcurses
|
||||
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
|
||||
@@ -186,7 +186,7 @@
|
||||
@@ -224,7 +224,7 @@
|
||||
#
|
||||
# libraries for X11
|
||||
# If USE_XPM is defined in config.h, you will also need -lXpm here.
|
||||
|
@ -31,16 +31,16 @@
|
|||
# WINX11LIB = -lXaw -lXmu -lXt -lX11
|
||||
# WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
|
||||
# WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
|
||||
@@ -199,7 +199,7 @@
|
||||
#
|
||||
#
|
||||
@@ -244,7 +244,7 @@
|
||||
# libraries for BeOS
|
||||
WINBELIB = -lbe
|
||||
|
||||
-WINLIB = $(WINTTYLIB)
|
||||
+WINLIB = $(WINTTYLIB) $(WINX11LIB)
|
||||
|
||||
# any other strange libraries your system needs (for Sysunix only -- the more
|
||||
# specialized targets should already be right)
|
||||
@@ -223,7 +223,7 @@
|
||||
@@ -271,7 +271,7 @@
|
||||
# IRIX 4.0.x needs -lsun if NIS (YP) is being used for passwd file lookup
|
||||
# LIBS = -lsun
|
||||
#
|
||||
|
|
|
@ -1,11 +1,12 @@
|
|||
--- ./sys/unix/Makefile.top.orig Sat Dec 11 05:21:05 1999
|
||||
+++ ./sys/unix/Makefile.top Mon Dec 13 11:51:27 1999
|
||||
@@ -14,17 +14,16 @@
|
||||
--- ./sys/unix/Makefile.top.orig Tue Jul 4 10:42:05 2000
|
||||
+++ ./sys/unix/Makefile.top Fri Oct 13 10:13:50 2000
|
||||
@@ -14,18 +14,17 @@
|
||||
# MAKE = make
|
||||
|
||||
# make NetHack
|
||||
-PREFIX = /usr
|
||||
GAME = nethack
|
||||
# GAME = nethack.prg
|
||||
GAMEUID = games
|
||||
-GAMEGRP = bin
|
||||
+GAMEGRP = games
|
||||
|
@ -21,27 +22,16 @@
|
|||
+DIRPERM = 0775
|
||||
|
||||
# GAMEDIR also appears in config.h as "HACKDIR".
|
||||
#
|
||||
@@ -33,8 +32,8 @@
|
||||
# VARDIR may also appear in unixconf.h as "VAR_PLAYGROUND" else GAMEDIR
|
||||
@@ -35,9 +34,9 @@
|
||||
# therefore there should not be anything in GAMEDIR that you want to keep
|
||||
# (if there is, you'll have to do the installation by hand or modify the
|
||||
# instructions)
|
||||
-GAMEDIR = $(PREFIX)/games/lib/$(GAME)dir
|
||||
-SHELLDIR = $(PREFIX)/games
|
||||
+GAMEDIR = $(PREFIX)/share/$(GAME)
|
||||
VARDIR = $(GAMEDIR)
|
||||
-SHELLDIR = $(PREFIX)/games
|
||||
+SHELLDIR = $(PREFIX)/bin
|
||||
|
||||
# per discussion in Install.X11 and Install.Qt
|
||||
VARDATND =
|
||||
@@ -184,9 +183,9 @@
|
||||
|
||||
install: $(GAME) $(VARDAT) dungeon spec_levs
|
||||
# set up the directories
|
||||
- -mkdir $(SHELLDIR)
|
||||
+ -mkdir -p $(SHELLDIR)
|
||||
-rm -rf $(GAMEDIR)
|
||||
- -mkdir $(GAMEDIR) $(GAMEDIR)/save
|
||||
+ -mkdir -p $(GAMEDIR) $(GAMEDIR)/save
|
||||
-$(CHOWN) $(GAMEUID) $(GAMEDIR) $(GAMEDIR)/save
|
||||
$(CHGRP) $(GAMEGRP) $(GAMEDIR) $(GAMEDIR)/save
|
||||
chmod $(DIRPERM) $(GAMEDIR) $(GAMEDIR)/save
|
||||
|
|
|
@ -6,14 +6,17 @@
|
|||
#
|
||||
|
||||
PORTNAME= nethack
|
||||
PORTVERSION= 3.3.0
|
||||
PORTVERSION= 3.3.1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ftp://ftp.nethack.org/pub/nethack/src/ \
|
||||
MASTER_SITES= ftp://ftp.nethack.org/pub/nethack/nh${PORTVERSION2}/src/ \
|
||||
${MASTER_SITE_GNU}
|
||||
MASTER_SITE_SUBDIR= nethack
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= dscheidt@enteract.com
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
USE_XPM= yes
|
||||
USE_GMAKE= yes
|
||||
MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (nethack-3.3.0.tar.gz) = cf9f4039408321f39c3ef733455cb73a
|
||||
MD5 (nethack-331.tgz) = d0600ce4698c80e5ad1f917ded1c36d2
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
--- ./include/config.h.orig Sat Dec 11 00:20:49 1999
|
||||
+++ ./include/config.h Sun Dec 12 20:28:09 1999
|
||||
--- ./include/config.h.orig Sat Jul 22 11:13:51 2000
|
||||
+++ ./include/config.h Fri Oct 13 09:31:24 2000
|
||||
@@ -43,7 +43,7 @@
|
||||
* Some combinations make no sense. See the installation document.
|
||||
*/
|
||||
#define TTY_GRAPHICS /* good old tty based graphics */
|
||||
-/* #define X11_GRAPHICS */ /* X11 interface */
|
||||
+#define X11_GRAPHICS /* X11 interface */
|
||||
-/* #define X11_GRAPHICS */ /* X11 interface */
|
||||
+#define X11_GRAPHICS /* X11 interface */
|
||||
/* #define QT_GRAPHICS */ /* Qt interface */
|
||||
/* #define GNOME_GRAPHICS */ /* Gnome interface */
|
||||
|
||||
/*
|
||||
@@ -92,7 +92,7 @@
|
||||
@@ -110,7 +110,7 @@
|
||||
* would allow:
|
||||
* xpmtoppm <x11tiles.xpm | pnmscale 1.25 | ppmquant 90 >x11tiles_big.xpm
|
||||
*/
|
||||
|
@ -18,7 +18,7 @@
|
|||
# ifdef USE_XPM
|
||||
# define GRAPHIC_TOMBSTONE /* Use graphical tombstone (rip.xpm) */
|
||||
# endif
|
||||
@@ -133,11 +133,11 @@
|
||||
@@ -151,11 +151,11 @@
|
||||
|
||||
#ifdef UNIX
|
||||
/* path and file name extension for compression program */
|
||||
|
@ -34,7 +34,7 @@
|
|||
#endif
|
||||
|
||||
#ifndef COMPRESS
|
||||
@@ -168,7 +168,7 @@
|
||||
@@ -186,7 +186,7 @@
|
||||
* otherwise it will be the current directory.
|
||||
*/
|
||||
# ifndef HACKDIR
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
--- ./include/system.h.orig Sat Dec 11 00:20:51 1999
|
||||
+++ ./include/system.h Sun Dec 12 20:44:40 1999
|
||||
@@ -80,7 +80,7 @@
|
||||
# if !defined(SUNOS4) || defined(RANDOM)
|
||||
E void FDECL(srandom, (unsigned int));
|
||||
# else
|
||||
-# ifndef bsdi
|
||||
+# if !defined(bsdi) && !defined(__FreeBSD__)
|
||||
E int FDECL(srandom, (unsigned int));
|
||||
# endif
|
||||
# endif
|
||||
@@ -516,7 +516,7 @@
|
||||
# if defined(ULTRIX) || defined(SYSV) || defined(MICRO) || defined(VMS) || defined(MAC) || (defined(HPUX) && defined(_POSIX_SOURCE))
|
||||
E time_t FDECL(time, (time_t *));
|
||||
# else
|
||||
-E long FDECL(time, (time_t *));
|
||||
+E time_t FDECL(time, (time_t *));
|
||||
# endif /* ULTRIX */
|
||||
|
||||
#ifdef VMS
|
|
@ -1,15 +1,15 @@
|
|||
--- include/unixconf.h.orig Sat Dec 11 14:20:51 1999
|
||||
+++ include/unixconf.h Sat Jul 29 06:58:37 2000
|
||||
@@ -45,7 +45,7 @@
|
||||
/* #define AIX_31 */ /* In AIX 3.1 (IBM RS/6000) use BSD ioctl's to gain
|
||||
--- ./include/unixconf.h.orig Mon Jul 17 11:03:51 2000
|
||||
+++ ./include/unixconf.h Fri Oct 13 10:06:57 2000
|
||||
@@ -47,7 +47,7 @@
|
||||
* job control (note that AIX is SYSV otherwise)
|
||||
* Also define this for AIX 3.2 */
|
||||
|
||||
-#define TERMINFO /* uses terminfo rather than termcap */
|
||||
+/* #define TERMINFO */ /* uses terminfo rather than termcap */
|
||||
/* Should be defined for most SYSV, SVR4 (including
|
||||
* Solaris 2+), HPUX, and Linux systems. In
|
||||
* particular, it should NOT be defined for the UNIXPC
|
||||
@@ -135,7 +135,7 @@
|
||||
@@ -143,7 +143,7 @@
|
||||
* A stat system call is done on the mailbox every MAILCKFREQ moves.
|
||||
*/
|
||||
|
||||
|
|
|
@ -1,20 +1,20 @@
|
|||
--- ./sys/unix/Makefile.src.orig Sat Dec 11 00:21:05 1999
|
||||
+++ ./sys/unix/Makefile.src Sun Dec 12 20:27:50 1999
|
||||
@@ -132,8 +132,8 @@
|
||||
--- ./sys/unix/Makefile.src.orig Sat Aug 5 20:52:57 2000
|
||||
+++ ./sys/unix/Makefile.src Fri Oct 13 10:10:21 2000
|
||||
@@ -144,8 +144,8 @@
|
||||
# flags for debugging:
|
||||
# CFLAGS = -g -I../include
|
||||
|
||||
-CFLAGS = -O -I../include
|
||||
-LFLAGS =
|
||||
-LFLAGS =
|
||||
+CFLAGS += -O -I../include -I${X11BASE}/include
|
||||
+LFLAGS = -L${X11BASE}/lib
|
||||
+LFLAGS = -L${X11BASE}/lib
|
||||
|
||||
# Only used for Qt interface (other interfaces are standard C)
|
||||
CXXFLAGS = -g $(CFLAGS) -I. -I$(QTDIR)/include
|
||||
@@ -165,8 +165,8 @@
|
||||
# The Qt and Be window systems are written in C++, while the rest of
|
||||
# NetHack is standard C. If using Qt, uncomment the LD line here to get
|
||||
@@ -203,8 +203,8 @@
|
||||
|
||||
#
|
||||
#
|
||||
#
|
||||
-WINSRC = $(WINTTYSRC)
|
||||
-WINOBJ = $(WINTTYOBJ)
|
||||
+WINSRC = $(WINTTYSRC) $(WINX11SRC)
|
||||
|
@ -22,7 +22,7 @@
|
|||
|
||||
# on some systems the termcap library is in -ltermcap or -lcurses
|
||||
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
|
||||
@@ -186,7 +186,7 @@
|
||||
@@ -224,7 +224,7 @@
|
||||
#
|
||||
# libraries for X11
|
||||
# If USE_XPM is defined in config.h, you will also need -lXpm here.
|
||||
|
@ -31,16 +31,16 @@
|
|||
# WINX11LIB = -lXaw -lXmu -lXt -lX11
|
||||
# WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
|
||||
# WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
|
||||
@@ -199,7 +199,7 @@
|
||||
#
|
||||
#
|
||||
@@ -244,7 +244,7 @@
|
||||
# libraries for BeOS
|
||||
WINBELIB = -lbe
|
||||
|
||||
-WINLIB = $(WINTTYLIB)
|
||||
+WINLIB = $(WINTTYLIB) $(WINX11LIB)
|
||||
|
||||
# any other strange libraries your system needs (for Sysunix only -- the more
|
||||
# specialized targets should already be right)
|
||||
@@ -223,7 +223,7 @@
|
||||
@@ -271,7 +271,7 @@
|
||||
# IRIX 4.0.x needs -lsun if NIS (YP) is being used for passwd file lookup
|
||||
# LIBS = -lsun
|
||||
#
|
||||
|
|
|
@ -1,11 +1,12 @@
|
|||
--- ./sys/unix/Makefile.top.orig Sat Dec 11 05:21:05 1999
|
||||
+++ ./sys/unix/Makefile.top Mon Dec 13 11:51:27 1999
|
||||
@@ -14,17 +14,16 @@
|
||||
--- ./sys/unix/Makefile.top.orig Tue Jul 4 10:42:05 2000
|
||||
+++ ./sys/unix/Makefile.top Fri Oct 13 10:13:50 2000
|
||||
@@ -14,18 +14,17 @@
|
||||
# MAKE = make
|
||||
|
||||
# make NetHack
|
||||
-PREFIX = /usr
|
||||
GAME = nethack
|
||||
# GAME = nethack.prg
|
||||
GAMEUID = games
|
||||
-GAMEGRP = bin
|
||||
+GAMEGRP = games
|
||||
|
@ -21,27 +22,16 @@
|
|||
+DIRPERM = 0775
|
||||
|
||||
# GAMEDIR also appears in config.h as "HACKDIR".
|
||||
#
|
||||
@@ -33,8 +32,8 @@
|
||||
# VARDIR may also appear in unixconf.h as "VAR_PLAYGROUND" else GAMEDIR
|
||||
@@ -35,9 +34,9 @@
|
||||
# therefore there should not be anything in GAMEDIR that you want to keep
|
||||
# (if there is, you'll have to do the installation by hand or modify the
|
||||
# instructions)
|
||||
-GAMEDIR = $(PREFIX)/games/lib/$(GAME)dir
|
||||
-SHELLDIR = $(PREFIX)/games
|
||||
+GAMEDIR = $(PREFIX)/share/$(GAME)
|
||||
VARDIR = $(GAMEDIR)
|
||||
-SHELLDIR = $(PREFIX)/games
|
||||
+SHELLDIR = $(PREFIX)/bin
|
||||
|
||||
# per discussion in Install.X11 and Install.Qt
|
||||
VARDATND =
|
||||
@@ -184,9 +183,9 @@
|
||||
|
||||
install: $(GAME) $(VARDAT) dungeon spec_levs
|
||||
# set up the directories
|
||||
- -mkdir $(SHELLDIR)
|
||||
+ -mkdir -p $(SHELLDIR)
|
||||
-rm -rf $(GAMEDIR)
|
||||
- -mkdir $(GAMEDIR) $(GAMEDIR)/save
|
||||
+ -mkdir -p $(GAMEDIR) $(GAMEDIR)/save
|
||||
-$(CHOWN) $(GAMEUID) $(GAMEDIR) $(GAMEDIR)/save
|
||||
$(CHGRP) $(GAMEGRP) $(GAMEDIR) $(GAMEDIR)/save
|
||||
chmod $(DIRPERM) $(GAMEDIR) $(GAMEDIR)/save
|
||||
|
|
|
@ -6,14 +6,17 @@
|
|||
#
|
||||
|
||||
PORTNAME= nethack
|
||||
PORTVERSION= 3.3.0
|
||||
PORTVERSION= 3.3.1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ftp://ftp.nethack.org/pub/nethack/src/ \
|
||||
MASTER_SITES= ftp://ftp.nethack.org/pub/nethack/nh${PORTVERSION2}/src/ \
|
||||
${MASTER_SITE_GNU}
|
||||
MASTER_SITE_SUBDIR= nethack
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= dscheidt@enteract.com
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
USE_XPM= yes
|
||||
USE_GMAKE= yes
|
||||
MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (nethack-3.3.0.tar.gz) = cf9f4039408321f39c3ef733455cb73a
|
||||
MD5 (nethack-331.tgz) = d0600ce4698c80e5ad1f917ded1c36d2
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
--- ./include/config.h.orig Sat Dec 11 00:20:49 1999
|
||||
+++ ./include/config.h Sun Dec 12 20:28:09 1999
|
||||
--- ./include/config.h.orig Sat Jul 22 11:13:51 2000
|
||||
+++ ./include/config.h Fri Oct 13 09:31:24 2000
|
||||
@@ -43,7 +43,7 @@
|
||||
* Some combinations make no sense. See the installation document.
|
||||
*/
|
||||
#define TTY_GRAPHICS /* good old tty based graphics */
|
||||
-/* #define X11_GRAPHICS */ /* X11 interface */
|
||||
+#define X11_GRAPHICS /* X11 interface */
|
||||
-/* #define X11_GRAPHICS */ /* X11 interface */
|
||||
+#define X11_GRAPHICS /* X11 interface */
|
||||
/* #define QT_GRAPHICS */ /* Qt interface */
|
||||
/* #define GNOME_GRAPHICS */ /* Gnome interface */
|
||||
|
||||
/*
|
||||
@@ -92,7 +92,7 @@
|
||||
@@ -110,7 +110,7 @@
|
||||
* would allow:
|
||||
* xpmtoppm <x11tiles.xpm | pnmscale 1.25 | ppmquant 90 >x11tiles_big.xpm
|
||||
*/
|
||||
|
@ -18,7 +18,7 @@
|
|||
# ifdef USE_XPM
|
||||
# define GRAPHIC_TOMBSTONE /* Use graphical tombstone (rip.xpm) */
|
||||
# endif
|
||||
@@ -133,11 +133,11 @@
|
||||
@@ -151,11 +151,11 @@
|
||||
|
||||
#ifdef UNIX
|
||||
/* path and file name extension for compression program */
|
||||
|
@ -34,7 +34,7 @@
|
|||
#endif
|
||||
|
||||
#ifndef COMPRESS
|
||||
@@ -168,7 +168,7 @@
|
||||
@@ -186,7 +186,7 @@
|
||||
* otherwise it will be the current directory.
|
||||
*/
|
||||
# ifndef HACKDIR
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
--- ./include/system.h.orig Sat Dec 11 00:20:51 1999
|
||||
+++ ./include/system.h Sun Dec 12 20:44:40 1999
|
||||
@@ -80,7 +80,7 @@
|
||||
# if !defined(SUNOS4) || defined(RANDOM)
|
||||
E void FDECL(srandom, (unsigned int));
|
||||
# else
|
||||
-# ifndef bsdi
|
||||
+# if !defined(bsdi) && !defined(__FreeBSD__)
|
||||
E int FDECL(srandom, (unsigned int));
|
||||
# endif
|
||||
# endif
|
||||
@@ -516,7 +516,7 @@
|
||||
# if defined(ULTRIX) || defined(SYSV) || defined(MICRO) || defined(VMS) || defined(MAC) || (defined(HPUX) && defined(_POSIX_SOURCE))
|
||||
E time_t FDECL(time, (time_t *));
|
||||
# else
|
||||
-E long FDECL(time, (time_t *));
|
||||
+E time_t FDECL(time, (time_t *));
|
||||
# endif /* ULTRIX */
|
||||
|
||||
#ifdef VMS
|
|
@ -1,15 +1,15 @@
|
|||
--- include/unixconf.h.orig Sat Dec 11 14:20:51 1999
|
||||
+++ include/unixconf.h Sat Jul 29 06:58:37 2000
|
||||
@@ -45,7 +45,7 @@
|
||||
/* #define AIX_31 */ /* In AIX 3.1 (IBM RS/6000) use BSD ioctl's to gain
|
||||
--- ./include/unixconf.h.orig Mon Jul 17 11:03:51 2000
|
||||
+++ ./include/unixconf.h Fri Oct 13 10:06:57 2000
|
||||
@@ -47,7 +47,7 @@
|
||||
* job control (note that AIX is SYSV otherwise)
|
||||
* Also define this for AIX 3.2 */
|
||||
|
||||
-#define TERMINFO /* uses terminfo rather than termcap */
|
||||
+/* #define TERMINFO */ /* uses terminfo rather than termcap */
|
||||
/* Should be defined for most SYSV, SVR4 (including
|
||||
* Solaris 2+), HPUX, and Linux systems. In
|
||||
* particular, it should NOT be defined for the UNIXPC
|
||||
@@ -135,7 +135,7 @@
|
||||
@@ -143,7 +143,7 @@
|
||||
* A stat system call is done on the mailbox every MAILCKFREQ moves.
|
||||
*/
|
||||
|
||||
|
|
|
@ -1,20 +1,20 @@
|
|||
--- ./sys/unix/Makefile.src.orig Sat Dec 11 00:21:05 1999
|
||||
+++ ./sys/unix/Makefile.src Sun Dec 12 20:27:50 1999
|
||||
@@ -132,8 +132,8 @@
|
||||
--- ./sys/unix/Makefile.src.orig Sat Aug 5 20:52:57 2000
|
||||
+++ ./sys/unix/Makefile.src Fri Oct 13 10:10:21 2000
|
||||
@@ -144,8 +144,8 @@
|
||||
# flags for debugging:
|
||||
# CFLAGS = -g -I../include
|
||||
|
||||
-CFLAGS = -O -I../include
|
||||
-LFLAGS =
|
||||
-LFLAGS =
|
||||
+CFLAGS += -O -I../include -I${X11BASE}/include
|
||||
+LFLAGS = -L${X11BASE}/lib
|
||||
+LFLAGS = -L${X11BASE}/lib
|
||||
|
||||
# Only used for Qt interface (other interfaces are standard C)
|
||||
CXXFLAGS = -g $(CFLAGS) -I. -I$(QTDIR)/include
|
||||
@@ -165,8 +165,8 @@
|
||||
# The Qt and Be window systems are written in C++, while the rest of
|
||||
# NetHack is standard C. If using Qt, uncomment the LD line here to get
|
||||
@@ -203,8 +203,8 @@
|
||||
|
||||
#
|
||||
#
|
||||
#
|
||||
-WINSRC = $(WINTTYSRC)
|
||||
-WINOBJ = $(WINTTYOBJ)
|
||||
+WINSRC = $(WINTTYSRC) $(WINX11SRC)
|
||||
|
@ -22,7 +22,7 @@
|
|||
|
||||
# on some systems the termcap library is in -ltermcap or -lcurses
|
||||
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
|
||||
@@ -186,7 +186,7 @@
|
||||
@@ -224,7 +224,7 @@
|
||||
#
|
||||
# libraries for X11
|
||||
# If USE_XPM is defined in config.h, you will also need -lXpm here.
|
||||
|
@ -31,16 +31,16 @@
|
|||
# WINX11LIB = -lXaw -lXmu -lXt -lX11
|
||||
# WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
|
||||
# WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
|
||||
@@ -199,7 +199,7 @@
|
||||
#
|
||||
#
|
||||
@@ -244,7 +244,7 @@
|
||||
# libraries for BeOS
|
||||
WINBELIB = -lbe
|
||||
|
||||
-WINLIB = $(WINTTYLIB)
|
||||
+WINLIB = $(WINTTYLIB) $(WINX11LIB)
|
||||
|
||||
# any other strange libraries your system needs (for Sysunix only -- the more
|
||||
# specialized targets should already be right)
|
||||
@@ -223,7 +223,7 @@
|
||||
@@ -271,7 +271,7 @@
|
||||
# IRIX 4.0.x needs -lsun if NIS (YP) is being used for passwd file lookup
|
||||
# LIBS = -lsun
|
||||
#
|
||||
|
|
|
@ -1,11 +1,12 @@
|
|||
--- ./sys/unix/Makefile.top.orig Sat Dec 11 05:21:05 1999
|
||||
+++ ./sys/unix/Makefile.top Mon Dec 13 11:51:27 1999
|
||||
@@ -14,17 +14,16 @@
|
||||
--- ./sys/unix/Makefile.top.orig Tue Jul 4 10:42:05 2000
|
||||
+++ ./sys/unix/Makefile.top Fri Oct 13 10:13:50 2000
|
||||
@@ -14,18 +14,17 @@
|
||||
# MAKE = make
|
||||
|
||||
# make NetHack
|
||||
-PREFIX = /usr
|
||||
GAME = nethack
|
||||
# GAME = nethack.prg
|
||||
GAMEUID = games
|
||||
-GAMEGRP = bin
|
||||
+GAMEGRP = games
|
||||
|
@ -21,27 +22,16 @@
|
|||
+DIRPERM = 0775
|
||||
|
||||
# GAMEDIR also appears in config.h as "HACKDIR".
|
||||
#
|
||||
@@ -33,8 +32,8 @@
|
||||
# VARDIR may also appear in unixconf.h as "VAR_PLAYGROUND" else GAMEDIR
|
||||
@@ -35,9 +34,9 @@
|
||||
# therefore there should not be anything in GAMEDIR that you want to keep
|
||||
# (if there is, you'll have to do the installation by hand or modify the
|
||||
# instructions)
|
||||
-GAMEDIR = $(PREFIX)/games/lib/$(GAME)dir
|
||||
-SHELLDIR = $(PREFIX)/games
|
||||
+GAMEDIR = $(PREFIX)/share/$(GAME)
|
||||
VARDIR = $(GAMEDIR)
|
||||
-SHELLDIR = $(PREFIX)/games
|
||||
+SHELLDIR = $(PREFIX)/bin
|
||||
|
||||
# per discussion in Install.X11 and Install.Qt
|
||||
VARDATND =
|
||||
@@ -184,9 +183,9 @@
|
||||
|
||||
install: $(GAME) $(VARDAT) dungeon spec_levs
|
||||
# set up the directories
|
||||
- -mkdir $(SHELLDIR)
|
||||
+ -mkdir -p $(SHELLDIR)
|
||||
-rm -rf $(GAMEDIR)
|
||||
- -mkdir $(GAMEDIR) $(GAMEDIR)/save
|
||||
+ -mkdir -p $(GAMEDIR) $(GAMEDIR)/save
|
||||
-$(CHOWN) $(GAMEUID) $(GAMEDIR) $(GAMEDIR)/save
|
||||
$(CHGRP) $(GAMEGRP) $(GAMEDIR) $(GAMEDIR)/save
|
||||
chmod $(DIRPERM) $(GAMEDIR) $(GAMEDIR)/save
|
||||
|
|
Loading…
Reference in a new issue