- Update to 3.2.5 [1]

- Add pkgconfig dependency to fix configure on FreeBSD 9.x and 10.x [2]
- Add USE_GCC=any to fix configure and compile on FreeBSD 10.x
- Convert LIB_DEPENDS to new shlib format
- Remove checks for old EoL FreeBSD versions
- Support staging

PR:		ports/179268 [1]
PR:		ports/183174 [2]
Submitted by:	Hung-Yi Chen <gaod@hychen.org> [1]
Reported by:	Gunnar Flygt <gunnar.flygt@sr.se> [2]
Approved by:	maintainer timeout (19 weeks) [1]
With hat:	portmgr
This commit is contained in:
Bernhard Froehlich 2013-10-23 12:12:40 +00:00
parent 6ae9bc172c
commit faf39b9761
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=331378
5 changed files with 46 additions and 28 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= trafficserver
PORTVERSION= 3.2.4
PORTVERSION= 3.2.5
CATEGORIES= www
MASTER_SITES= APACHE/${PORTNAME}
@ -11,41 +11,28 @@ COMMENT= A fast, scalable and extensible HTTP proxy server
LICENSE= AL2
LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
expat:${PORTSDIR}/textproc/expat2 \
pcre:${PORTSDIR}/devel/pcre
MAN1= traffic_shell.1
LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
libexpat.so:${PORTSDIR}/textproc/expat2 \
libpcre.so:${PORTSDIR}/devel/pcre
USE_AUTOTOOLS= autoconf automake libtool
USE_BZIP2= yes
USES= iconv
USES= pkgconfig
USE_OPENSSL= yes
USE_SQLITE= yes
USE_TCL= yes
USE_RC_SUBR= ${PORTNAME}
USE_LDCONFIG= yes
USE_GCC= any
ONLY_FOR_ARCHS= i386 amd64
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-expat=${LOCALBASE} \
--with-pcre=${LOCALBASE}
--with-pcre=${LOCALBASE} \
--with-openssl=${OPENSSLBASE}
NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
BUILD_DEPENDS= xz>0:${PORTSDIR}/archivers/xz
RUN_DEPENDS= xz>0:${PORTSDIR}/archivers/xz
.endif
.if ${OSVERSION} < 800000 && ${ARCH} == "amd64"
BROKEN= does not compile on 7.X/amd64
.endif
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
post-patch:
@${REINPLACE_CMD} -e 's,|| mv,|| cp -p,' ${WRKSRC}/proxy/config/Makefile.am

View file

@ -1,2 +1,2 @@
SHA256 (trafficserver-3.2.4.tar.bz2) = 0f9246222960144e743dbc04d55820ce7f682cf33e950395d217d6f4cb6efcfc
SIZE (trafficserver-3.2.4.tar.bz2) = 2524893
SHA256 (trafficserver-3.2.5.tar.bz2) = 6cada59cb8d8800d48344fa711aec6964083a182deee21fa445c31227bcd1c90
SIZE (trafficserver-3.2.5.tar.bz2) = 2535498

View file

@ -1,13 +1,30 @@
--- configure.ac.orig 2012-03-17 18:02:10.000000000 -0700
+++ configure.ac 2012-05-03 16:16:05.000000000 -0700
@@ -458,2 +458,6 @@
--- configure.ac.orig 2013-07-03 04:17:28.000000000 +0800
+++ configure.ac 2013-08-30 05:23:44.089882723 +0800
@@ -40,7 +40,7 @@
AC_CONFIG_AUX_DIR([build/aux])
AC_CONFIG_SRCDIR([proxy/Main.cc])
AC_CONFIG_MACRO_DIR([build])
-AM_INIT_AUTOMAKE([-Wall -Werror foreign no-installinfo no-installman 1.9.2])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign no-installinfo no-installman 1.9.2 subdir-objects])
AM_CONFIG_HEADER([lib/ts/ink_autoconf.h])
# Configure with --disable-silent-rules to get verbose output. For more info, see
@@ -497,6 +497,10 @@
[AM_PROG_AR])
+# required by automake-1.12
+m4_pattern_allow([AM_PROG_AR])
+AM_PROG_AR
+
AC_PROG_CPP
@@ -467,3 +471,2 @@
AC_PROG_CXXCPP
AM_PROG_AS
@@ -506,7 +510,6 @@
AC_PROG_LIBTOOL
AC_CHECK_PROG(RM, rm, rm)
AC_CHECK_PROG(ASCPP, cpp, cpp)
-AC_CHECK_TOOL(AR, ar, ar)
AC_ISC_POSIX
AS_IF([test "x$enable_wccp" = "xyes"],
[

View file

@ -0,0 +1,13 @@
--- mgmt/utils/Makefile.am.orig 2013-08-30 06:02:17.979883250 +0800
+++ mgmt/utils/Makefile.am 2013-08-30 06:02:36.918052210 +0800
@@ -40,8 +40,8 @@
libutils_lm_a_CPPFLAGS = $(ink_with_modules_local) $(AM_CPPFLAGS)
libutils_lm_a_SOURCES = \
- $(top_srcdir)/lib/ts/MatcherUtils.cc \
- $(top_srcdir)/proxy/DiagsConfig.cc \
+ ../../lib/ts/MatcherUtils.cc \
+ ../../proxy/DiagsConfig.cc \
EnvBlock.cc \
EnvBlock.h \
ExpandingArray.cc \

View file

@ -52,6 +52,7 @@ libexec/trafficserver/regex_remap.la
libexec/trafficserver/regex_remap.so
libexec/trafficserver/stats_over_http.la
libexec/trafficserver/stats_over_http.so
man/man1/traffic_shell.1.gz
%%ETCDIR%%/ae_ua.config.default
%%ETCDIR%%/body_factory/default/.body_factory_info
%%ETCDIR%%/body_factory/default/README