Update to version 1.0

PR: 33076
Submitted by: MAINTAINER
This commit is contained in:
Kevin Lo 2001-12-22 12:32:05 +00:00
parent f82a372910
commit faf9bb0b7b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=51975
6 changed files with 34 additions and 8 deletions

View file

@ -5,20 +5,30 @@
# $FreeBSD$
PORTNAME= iconv
PORTVERSION= 0.1.2
PORTVERSION= 1.0
CATEGORIES= converters python
MASTER_SITES= http://www.mx1.ru/iconv/
MASTER_SITES= ftp://people.linuxkorea.co.kr/pub/Python/ \
http://cvsup3.kr.freebsd.org/~perky/distfiles/ \
http://www3.kr.freebsd.org/~perky/distfiles/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DIST_SUBDIR= python
MAINTAINER= perky@python.or.kr
BUILD_DEPENDS= ${PYDISTUTILS}
LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
LIB_DEPENDS= iconv:${PORTSDIR}/converters/iconv
USE_PYTHON= yes
SETUP_CMD= cd ${WRKSRC} && ${PYTHON_CMD} setup.py
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S|^${LOCALBASE}/||g}
SETUPINFO= ,libraries=["iconv"],library_dirs=["${LOCALBASE}/lib"],\
include_dirs=["${LOCALBASE}/include"]
post-patch:
cd ${WRKSRC} && ${SED} 's!^\(.*ext_mod.*\)\()]\)$$!\1${SETUPINFO}\2!g'\
setup.py > setup.py.tmp && ${CAT} setup.py.tmp > setup.py
do-build:
${SETUP_CMD} build

View file

@ -1 +1 @@
MD5 (iconv-0.1.2.tar.gz) = b077173868e512453ecec8f45ae8eedc
MD5 (python/iconv-1.0.tar.gz) = 8f97f853d01b0cc0d2007112fcafe28b

View file

@ -0,0 +1,15 @@
--- iconvcodec.py.orig Sat Dec 22 08:04:10 2001
+++ iconvcodec.py Sat Dec 22 08:04:31 2001
@@ -3,11 +3,7 @@
# First we need to find out what the Unicode code set name is
# in this iconv implementation
-if sys.platform.startswith("linux"):
- unicodename = "unicode"+sys.byteorder
-else:
- # may need to try UCS-2, UCS-2-LE/BE, Unicode, ...
- raise ImportError,"cannot establish name of 2-byte Unicode"
+unicodename = "ucs-2-internal"
class Codec(codecs.Codec):
def __init__(self):

View file

@ -1 +1 @@
An iconv wrapper for Python
An iconv wrapper with unicode codec for Python

View file

@ -1,4 +1,3 @@
This is an iconv wrapper for Python.
This is an iconv wrapper with unicode codec for Python.
WWW: http://freshmeat.net/projects/iconv4python/
(author's homepage is http://www.mx1.ru/iconv/ but it's not available now)
WWW: http://sourceforge.net/projects/python-codecs

View file

@ -1 +1,3 @@
%%PYTHON_SITELIBDIR%%/iconv.so
%%PYTHON_SITELIBDIR%%/iconvcodec.py
%%PYTHON_SITELIBDIR%%/iconvcodec.pyc