graphics/mesa-libs: fix build on powerpc64le
Checking if "POWER8 intrinsics" compiles: NO meson.build:720:6: ERROR: Problem encountered: POWER8 intrinsic support required but not found.
This commit is contained in:
parent
e37f7e5ab5
commit
fb107dc4b6
1 changed files with 11 additions and 0 deletions
11
graphics/mesa-dri/files/patch-meson.build
Normal file
11
graphics/mesa-dri/files/patch-meson.build
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- meson.build.orig 2023-09-20 17:15:34 UTC
|
||||
+++ meson.build
|
||||
@@ -709,7 +709,7 @@ if _power8.allowed()
|
||||
int main() {
|
||||
vector unsigned char r;
|
||||
vector unsigned int v = vec_splat_u32 (1);
|
||||
- r = __builtin_vec_vgbbd ((vector unsigned char) v);
|
||||
+ r = __builtin_altivec_vgbbd ((vector unsigned char) v);
|
||||
return 0;
|
||||
}''',
|
||||
args : '-mpower8-vector',
|
Loading…
Reference in a new issue