New port: misc/py-QSpectrumAnalyzer: Spectrum analyzer for multiple SDR platforms
This commit is contained in:
parent
12e2bf8eb4
commit
fb35a6366a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=472767
5 changed files with 60 additions and 0 deletions
|
@ -401,6 +401,7 @@
|
|||
SUBDIR += ptsort
|
||||
SUBDIR += pubs
|
||||
SUBDIR += py-PyUserInput
|
||||
SUBDIR += py-QSpectrumAnalyzer
|
||||
SUBDIR += py-SimpleSoapy
|
||||
SUBDIR += py-SoapySDR
|
||||
SUBDIR += py-YABT
|
||||
|
|
40
misc/py-QSpectrumAnalyzer/Makefile
Normal file
40
misc/py-QSpectrumAnalyzer/Makefile
Normal file
|
@ -0,0 +1,40 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= QSpectrumAnalyzer
|
||||
DISTVERSION= 2.1.0
|
||||
CATEGORIES= misc python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Spectrum analyzer for multiple SDR platforms
|
||||
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
RUN_DEPENDS= ${PYNUMPY} \
|
||||
${PYTHON_PKGNAMEPREFIX}pyqtgraph>=0.10.0:graphics/py-pyqtgraph@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}soapy_power>=1.5.0:misc/py-soapy_power@${PY_FLAVOR}
|
||||
|
||||
USES= fortran python:3.4+ pyqt:5
|
||||
USE_PYQT= core gui widgets
|
||||
USE_PYTHON= distutils concurrent autoplist
|
||||
|
||||
PLIST_FILES= bin/${PORTNAME:tl}.shadow
|
||||
|
||||
post-patch: # change from Qt.py that doesn't work to PyQt5
|
||||
@${FIND} ${WRKSRC} -name "*.py" | ${XARGS} ${REINPLACE_CMD} -i '' -e ' \
|
||||
s|from Qt import |from PyQt5 import | ; \
|
||||
s|, __binding__|| ; \
|
||||
s|QtCore.Signal|QtCore.pyqtSignal| ; \
|
||||
s|QtCore.Slot|QtCore.pyqtSlot|'
|
||||
|
||||
post-install:
|
||||
@${MV} ${STAGEDIR}${PREFIX}/bin/${PORTNAME:tl} ${STAGEDIR}${PREFIX}/bin/${PORTNAME:tl}.shadow
|
||||
@(echo "#!/bin/sh"; \
|
||||
echo ""; \
|
||||
echo "LD_PRELOAD=${PREFIX}/lib/gcc6/libgcc_s.so ${PREFIX}/bin/${PORTNAME:tl}.shadow \"$$@\"" \
|
||||
) > ${STAGEDIR}${PREFIX}/bin/${PORTNAME:tl}
|
||||
@${CHMOD} +x ${STAGEDIR}${PREFIX}/bin/${PORTNAME:tl}
|
||||
|
||||
.include <bsd.port.mk>
|
3
misc/py-QSpectrumAnalyzer/distinfo
Normal file
3
misc/py-QSpectrumAnalyzer/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1529285292
|
||||
SHA256 (QSpectrumAnalyzer-2.1.0.tar.gz) = c042dc2530ee96052ff54a883c4dd4c59fb553dfd1d3a84a2a639f4fee4714ae
|
||||
SIZE (QSpectrumAnalyzer-2.1.0.tar.gz) = 49137
|
12
misc/py-QSpectrumAnalyzer/files/patch-setup.py
Normal file
12
misc/py-QSpectrumAnalyzer/files/patch-setup.py
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- setup.py.orig 2018-06-18 03:27:59 UTC
|
||||
+++ setup.py
|
||||
@@ -31,8 +31,7 @@ setup(
|
||||
},
|
||||
install_requires=[
|
||||
"soapy_power>=1.5.0",
|
||||
- "pyqtgraph>=0.10.0",
|
||||
- "Qt.py"
|
||||
+ "pyqtgraph>=0.10.0"
|
||||
],
|
||||
classifiers=[
|
||||
"Development Status :: 4 - Beta",
|
4
misc/py-QSpectrumAnalyzer/pkg-descr
Normal file
4
misc/py-QSpectrumAnalyzer/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
Spectrum analyzer for multiple SDR platforms (PyQtGraph based GUI for
|
||||
soapy_power, hackrf_sweep, rtl_power, rx_power and other backends).
|
||||
|
||||
WWW: https://github.com/xmikos/qspectrumanalyzer
|
Loading…
Reference in a new issue