Update to 2009.05.09 based on 1.2.5.
o Add support Radeon HD 4790. o Add experimental support Radeon HD 4770. o Add ForceLowPowerMode and LowPowerModeEngineClock options, and Report GPU Core and Memory Clock. e.g. radeonhd driver reports following clocks of my Radeon X1650 Pro: (II) RADEONHD(0): Default Engine Clock: 588000 (II) RADEONHD(0): Default Memory Clock: 694000 It means that GPU Core Clock is 588MHz and Memory Clock is 694MHz. And ForceLowPowerMode xorg-driver option can change Engine Clock. o Fix some bugs on 3D engine and cursor. o Use libpciaccess instead of libpci.
This commit is contained in:
parent
c6eb35f215
commit
fb48eed3a3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=233478
4 changed files with 28 additions and 11 deletions
|
@ -6,8 +6,8 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= xf86-video-radeonhd
|
PORTNAME= xf86-video-radeonhd
|
||||||
PORTVERSION= 1.2.5.20090412
|
PORTVERSION= 1.2.5.20090509
|
||||||
PORTREVISION= 1
|
PORTREVISION= 0
|
||||||
CATEGORIES= x11-drivers
|
CATEGORIES= x11-drivers
|
||||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||||
MASTER_SITE_SUBDIR= nork
|
MASTER_SITE_SUBDIR= nork
|
||||||
|
@ -18,7 +18,7 @@ COMMENT= X.Org ati RadeonHD display driver development version
|
||||||
|
|
||||||
BUILD_DEPENDS= ${LOCALBASE}/share/aclocal/xorg-macros.m4:${PORTSDIR}/devel/xorg-macros \
|
BUILD_DEPENDS= ${LOCALBASE}/share/aclocal/xorg-macros.m4:${PORTSDIR}/devel/xorg-macros \
|
||||||
${LOCALBASE}/libdata/pkgconfig/gl.pc:${PORTSDIR}/graphics/libGL
|
${LOCALBASE}/libdata/pkgconfig/gl.pc:${PORTSDIR}/graphics/libGL
|
||||||
LIB_DEPENDS= pci.2:${PORTSDIR}/devel/libpci
|
LIB_DEPENDS= pciaccess.0:${PORTSDIR}/devel/libpciaccess
|
||||||
|
|
||||||
XORG_CAT= driver
|
XORG_CAT= driver
|
||||||
USE_XORG= damageproto videoproto xextproto xf86driproto
|
USE_XORG= damageproto videoproto xextproto xf86driproto
|
||||||
|
@ -30,9 +30,6 @@ MAN4= radeonhd.4x
|
||||||
|
|
||||||
ACLOCAL_ARGS= --acdir=${LOCALBASE}/share/aclocal
|
ACLOCAL_ARGS= --acdir=${LOCALBASE}/share/aclocal
|
||||||
|
|
||||||
CONFIGURE_ENV+= PCIUTILS_CFLAGS="-I${LOCALBASE}/include" \
|
|
||||||
PCIUTILS_LIBS="-L${LOCALBASE}/lib -lpci -lz"
|
|
||||||
|
|
||||||
pre-configure:
|
pre-configure:
|
||||||
cd ${WRKSRC} && ${AUTORECONF} -i
|
cd ${WRKSRC} && ${AUTORECONF} -i
|
||||||
|
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
MD5 (xorg/driver/xf86-video-radeonhd-1.2.5.20090412.tar.bz2) = 3bec2823c199e6b96f6ccf9bbab691a1
|
MD5 (xorg/driver/xf86-video-radeonhd-1.2.5.20090509.tar.bz2) = a8b94b658b05a7f46b962b7169c3b1d7
|
||||||
SHA256 (xorg/driver/xf86-video-radeonhd-1.2.5.20090412.tar.bz2) = f6d75bde55668d9b8af0018dca49594d6436c4aa46005bba684a26514d55b38c
|
SHA256 (xorg/driver/xf86-video-radeonhd-1.2.5.20090509.tar.bz2) = ea19bcfb73c6f2162264a075490f66e0d26ba91e068567fbf10d9ec12eb6fbc2
|
||||||
SIZE (xorg/driver/xf86-video-radeonhd-1.2.5.20090412.tar.bz2) = 382300
|
SIZE (xorg/driver/xf86-video-radeonhd-1.2.5.20090509.tar.bz2) = 388681
|
||||||
|
|
|
@ -1,5 +1,5 @@
|
||||||
--- configure.ac.orig 2008-11-14 21:27:59.000000000 +0900
|
--- configure.ac.orig 2009-05-09 00:44:27.000000000 +0900
|
||||||
+++ configure.ac 2008-12-08 04:37:01.000000000 +0900
|
+++ configure.ac 2009-05-09 02:21:41.017956544 +0900
|
||||||
@@ -21,6 +21,9 @@
|
@@ -21,6 +21,9 @@
|
||||||
dnl Define SED var without requiring AC_PROG_SED (new in autoconf-2.59b)
|
dnl Define SED var without requiring AC_PROG_SED (new in autoconf-2.59b)
|
||||||
m4_ifdef([AC_PROG_SED], [AC_PROG_SED], [AC_SUBST([SED], [${SED-sed}])])
|
m4_ifdef([AC_PROG_SED], [AC_PROG_SED], [AC_SUBST([SED], [${SED-sed}])])
|
||||||
|
@ -10,3 +10,12 @@
|
||||||
AC_MSG_CHECKING([whether $SED can substitute tabs and newlines for text])
|
AC_MSG_CHECKING([whether $SED can substitute tabs and newlines for text])
|
||||||
dnl One tab, a letter and two newlines
|
dnl One tab, a letter and two newlines
|
||||||
cat>sed-test.1<<EOF
|
cat>sed-test.1<<EOF
|
||||||
|
@@ -314,7 +317,7 @@
|
||||||
|
|
||||||
|
# AtomBios special flags
|
||||||
|
ATOMBIOS_CFLAGS=""
|
||||||
|
-for w in -std=c99 -Wno-unknown-pragmas ; do
|
||||||
|
+for w in -std=gnu99 -Wno-unknown-pragmas ; do
|
||||||
|
AC_PROG_CC_FLAG($w,[ATOMBIOS_CFLAGS="$ATOMBIOS_CFLAGS $w"],)
|
||||||
|
done
|
||||||
|
|
||||||
|
|
|
@ -0,0 +1,11 @@
|
||||||
|
--- src/Makefile.am.orig 2009-05-09 00:44:27.000000000 +0900
|
||||||
|
+++ src/Makefile.am 2009-05-09 02:01:40.761722699 +0900
|
||||||
|
@@ -4,7 +4,7 @@
|
||||||
|
|
||||||
|
EXTRA_DIST = Imakefile
|
||||||
|
|
||||||
|
-AM_CFLAGS = @XORG_CFLAGS@ @DRI_CFLAGS@ @WARN_CFLAGS@
|
||||||
|
+AM_CFLAGS = @XORG_CFLAGS@ @DRI_CFLAGS@ @WARN_CFLAGS@ @ATOMBIOS_CFLAGS@
|
||||||
|
|
||||||
|
driversdir = ${moduledir}/drivers
|
||||||
|
drivers_LTLIBRARIES = radeonhd_drv.la
|
Loading…
Reference in a new issue