Add new port games/quadra:
A tetris like game with single player and multiplayer capabilities (Internet or LAN). WWW: http://code.google.com/p/quadra/ PR: ports/163616 Submitted by: Karsten Brandt <spam_schlucker at web.de>
This commit is contained in:
parent
933defa3d2
commit
fb877597b0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=292051
6 changed files with 95 additions and 0 deletions
53
games/quadra/Makefile
Normal file
53
games/quadra/Makefile
Normal file
|
@ -0,0 +1,53 @@
|
|||
# New ports collection makefile for: quadra
|
||||
# Date created: 2011-12-25
|
||||
# Whom: Karsten Brandt <kbrandt@sdf-eu.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= quadra
|
||||
PORTVERSION= 1.3.0
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://kbrandt.sdf-eu.org/FreeBSD/distfiles/ \
|
||||
ftp://ftp.bsdforen.de/pub/BSDForen/distfiles/ \
|
||||
http://bsd-geek.de/FreeBSD/distfiles/
|
||||
|
||||
MAINTAINER= kbrandt@sdf-eu.org
|
||||
COMMENT= A tetris like game with multiplayer support
|
||||
|
||||
LIB_DEPENDS= png:${PORTSDIR}/graphics/png
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_SDL= sdl
|
||||
USE_XORG= x11 xau xdmcp
|
||||
USE_AUTOTOOLS= autoconf autoheader
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include/libpng
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
PLIST_FILES= bin/${PORTNAME} \
|
||||
share/games/${PORTNAME}.res \
|
||||
share/pixmaps/${PORTNAME}.xpm
|
||||
PLIST_DIRSTRY= share/games
|
||||
|
||||
DESKTOP_ENTRIES= "Quadra" "${COMMENT}" \
|
||||
"${PREFIX}/share/pixmaps/${PORTNAME}.xpm" \
|
||||
"${PORTNAME}" "Application;BlocksGame;Game;" false
|
||||
|
||||
# maintainer relevant make target:
|
||||
SVN_REV= 757
|
||||
SVN_SRC= http://quadra.googlecode.com/svn/trunk/quadra/
|
||||
|
||||
maint-gen-distfile:
|
||||
@if [ -f ${DISTDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} ]; then \
|
||||
${ECHO_CMD} "ERROR: the distfile already exists."; \
|
||||
${FALSE}; \
|
||||
fi
|
||||
svn export -r${SVN_REV} ${SVN_SRC} ${PORTNAME}-${PORTVERSION}
|
||||
${TAR} cjf ${DISTDIR}/${DISTNAME}.tar.bz2 ${PORTNAME}-${PORTVERSION}
|
||||
${RM} -rf ${PORTNAME}-${PORTVERSION}
|
||||
|
||||
.include <bsd.port.mk>
|
2
games/quadra/distinfo
Normal file
2
games/quadra/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (quadra-1.3.0.tar.bz2) = cae617c09c20105181c3849a09b2805c5535bb96f49f27eb2552315e7652332f
|
||||
SIZE (quadra-1.3.0.tar.bz2) = 4616419
|
10
games/quadra/files/patch-config__rules.mk
Normal file
10
games/quadra/files/patch-config__rules.mk
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- ./config/rules.mk.orig 2009-06-19 04:36:47.000000000 +0000
|
||||
+++ ./config/rules.mk 2012-02-17 20:57:40.683844559 +0000
|
||||
@@ -41,7 +41,6 @@
|
||||
|
||||
installdirs:
|
||||
mkdir -p $(DESTDIR)$(bindir)
|
||||
- mkdir -p $(DESTDIR)$(libgamesdir)
|
||||
mkdir -p $(DESTDIR)$(datagamesdir)
|
||||
mkdir -p $(DESTDIR)$(datadir)/pixmaps
|
||||
|
13
games/quadra/files/patch-skelton__svgalib__video.cpp
Normal file
13
games/quadra/files/patch-skelton__svgalib__video.cpp
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- ./skelton/svgalib/video.cpp.orig 2010-08-25 01:55:26.000000000 +0000
|
||||
+++ ./skelton/svgalib/video.cpp 2012-02-17 20:50:29.997843122 +0000
|
||||
@@ -24,7 +24,9 @@
|
||||
#ifdef WIN32
|
||||
#include <malloc.h>
|
||||
#else
|
||||
-#include <alloca.h>
|
||||
+ #if !defined __FreeBSD__ /* alloca is part of stdlib in FreeBSD */
|
||||
+ #include <alloca.h>
|
||||
+ #endif
|
||||
#endif
|
||||
#include "sprite.h"
|
||||
#include "command.h"
|
13
games/quadra/files/patch-source__rules.mk
Normal file
13
games/quadra/files/patch-source__rules.mk
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- source/rules.mk.orig 2008-12-20 08:14:57.000000000 +0100
|
||||
+++ source/rules.mk 2012-02-19 18:04:11.000000000 +0100
|
||||
@@ -18,7 +18,9 @@
|
||||
#
|
||||
# $Id: rules.mk 684 2008-12-20 07:14:57Z pphaneuf $
|
||||
|
||||
-source/quadra: LDLIBS+=$(SDL_LIBS) -lpng -lz
|
||||
+EXT_LIBS := -lcompat # needed in FBSD for the ftime function
|
||||
+
|
||||
+source/quadra: LDLIBS+=$(SDL_LIBS) -lpng -lz $(EXT_LIBS)
|
||||
source/quadra: $(QUADRA_OBJECTS) $(SDL_MAIN_OBJ) skelton/lib/libugs_s.a
|
||||
|
||||
quadra.res: $(shell cat resources.txt) resources.txt skelton/tools/wadder/wadder
|
4
games/quadra/pkg-descr
Normal file
4
games/quadra/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
A tetris like game with single player and multiplayer capabilities
|
||||
(Internet or LAN).
|
||||
|
||||
WWW: http://code.google.com/p/quadra/
|
Loading…
Reference in a new issue