- Fix compilation error in -current

- Support MAN/MLINKS properly

PR: 24545
Submitted by: Ports Fury
This commit is contained in:
Kevin Lo 2001-01-23 08:07:33 +00:00
parent f274f6f192
commit fba196b2db
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=37476
3 changed files with 69 additions and 14 deletions

View file

@ -5,23 +5,30 @@
# $FreeBSD$
#
PORTNAME= nvi-perl
PORTNAME= nvi
PORTVERSION= 1.79
PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= ftp://sleepy.vwh.net/pub/ \
ftp://ftp.foretune.co.jp/pub/tools/nvi-m17n/
DISTNAME= nvi-${PORTVERSION}
PKGNAMESUFFIX= -perl
MAINTAINER= ports@freebsd.org
MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/${DISTNAME}/build
GNU_CONFIGURE= yes
USE_PERL5= yes
# can't say PATCH_DIST_STRIP=-p1 because contains files outside ${WRKSRC}
PATCH_DIST_ARGS=-d ${WRKSRC}/.. --forward --quiet -E -p0
PATCH_ARGS= -d ${WRKSRC}/.. --forward --quiet -E -p0
WRKSRC= ${WRKDIR}/${DISTNAME}/build
USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= OPTFLAG='-D_PATH_SYSEXRC=\"${PREFIX}/etc/vi.exrc\"'
CONFIGURE_ARGS= --enable-perlinterp --program-prefix=pn
MAN1= pnvi.1
MLINKS= pnvi.1 pnex.1 pnvi.1 pnview.1
post-patch:
${LN} -s /usr/include/sys/queue.h ${WRKSRC}/../include/sys/queue_dist.h
.include <bsd.port.mk>

View file

@ -0,0 +1,51 @@
--- include/sys/queue.h.old Wed Jan 10 07:16:01 2001
+++ include/sys/queue.h Wed Jan 10 07:17:02 2001
@@ -33,8 +33,10 @@
* @(#)queue.h 8.5 (Berkeley) 8/20/94
*/
-#ifndef _SYS_QUEUE_H_
-#define _SYS_QUEUE_H_
+#ifndef _SYS_QUEUE_HACK_H_
+#define _SYS_QUEUE_HACK_H_
+
+#include <sys/queue_dist.h>
/*
* This file defines three types of data structures: lists, tail queues,
@@ -65,6 +67,7 @@
* For details on the use of these macros, see the queue(3) manual page.
*/
+#ifndef LIST_HEAD
/*
* List definitions.
*/
@@ -114,7 +117,9 @@
(elm)->field.le_prev; \
*(elm)->field.le_prev = (elm)->field.le_next; \
}
+#endif /* LIST_HEAD */
+#ifndef TAILQ_HEAD
/*
* Tail queue definitions.
*/
@@ -180,7 +185,9 @@
(head)->tqh_last = (elm)->field.tqe_prev; \
*(elm)->field.tqe_prev = (elm)->field.tqe_next; \
}
+#endif /* TAILQ_HEAD */
+#ifndef CIRCLEQ_HEAD
/*
* Circular queue definitions.
*/
@@ -256,4 +263,6 @@
(elm)->field.cqe_prev->field.cqe_next = \
(elm)->field.cqe_next; \
}
-#endif /* !_SYS_QUEUE_H_ */
+#endif /* CIRCLEQ_HEAD */
+
+#endif /* !_SYS_QUEUE_HACK_H_ */

View file

@ -1,10 +1,6 @@
bin/pnvi
bin/pnex
bin/pnvi
bin/pnview
man/man1/pnvi.1
man/man1/pnex.1
man/man1/pnview.1
share/vi/recover
share/vi/catalog/dutch
share/vi/catalog/english
share/vi/catalog/french
@ -12,16 +8,17 @@ share/vi/catalog/german
share/vi/catalog/ru_SU.KOI8-R
share/vi/catalog/spanish
share/vi/catalog/swedish
share/vi/perl/VI.pm
share/vi/perl/forall.pl
share/vi/perl/make.pl
share/vi/perl/tk.pl
share/vi/perl/wc.pl
share/vi/perl/VI.pm
share/vi/recover
share/vi/tcl/errors.tcl
share/vi/tcl/gnats.tcl
share/vi/tcl/mailprocs.tcl
share/vi/tcl/wc.tcl
@dirrm share/vi/catalog
@dirrm share/vi/perl
@dirrm share/vi/tcl
@dirrm share/vi/perl
@dirrm share/vi/catalog
@dirrm share/vi