Drop x11-themes/kde4-icons-oxygen in favor of x11-themes/kf5-oxygen-icons5.
Despite the name, kf5-oxygen-icons5 does not depend on Qt5 and just contains the Oxygen icon set without any architecture-dependent files. As such, we can make all ports depend on it and remove kde4-icons-oxygen altogether and avoid having two conflicting ports for KDE4 and KF5. x11-themes/kf5-oxygen-icons5 was adjusted to have its dependencies reduced even further: - The dependencies on qt5-core and qt5-testlib were removed, as they were only needed to build tests. - We're also passing some CMake arguments to avoid looking for qt5-core altogether. With the changes above, the only port kf5-oxygen-icons5 depends on at runtime is devel/kf5-extra-cmake-modules, which itself does not depend on anything else. Reviewed by: tcberner Differential Revision: https://reviews.freebsd.org/D10237
This commit is contained in:
parent
716a082d8c
commit
fbb904c849
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=437622
12 changed files with 34 additions and 6883 deletions
1
MOVED
1
MOVED
|
@ -9201,3 +9201,4 @@ x11-toolkits/gal2-reference||2017-04-02|Obsolete and not depend on anymore
|
|||
x11-toolkits/vte290|x11-toolkits/vte3|2017-04-02|Obsolete and not depend on anymore
|
||||
x11-toolkits/libgtksourceviewmm||2017-04-03|Obsolete and not depend on anymore
|
||||
graphics/goocanvasmm||2017-04-03|Obsolete and not depend on anymore
|
||||
x11-themes/kde4-icons-oxygen|x11-themes/kf5-icons-oxygen|2017-04-03|Replaced by x11-themes/kf5-icons-oxygen
|
||||
|
|
|
@ -204,7 +204,7 @@ _USE_KDE4_ALL= baloo baloo-widgets baseapps kactivities kate kdelibs \
|
|||
kfilemetadata korundum libkcddb libkcompactdisc \
|
||||
libkdcraw libkdeedu libkdegames libkexiv2 libkipi \
|
||||
libkonq libksane marble nepomuk-core nepomuk-widgets \
|
||||
okular oxygen-icons4 perlkde perlqt pimlibs pykde4 \
|
||||
okular oxygen-icons5 perlkde perlqt pimlibs pykde4 \
|
||||
pykdeuic4 qtruby runtime smokegen smokekde smokeqt \
|
||||
workspace
|
||||
# These components are not part of the Software Compilation.
|
||||
|
@ -321,10 +321,6 @@ nepomuk-widgets_LIB= libnepomukwidgets.so
|
|||
okular_PORT= graphics/okular
|
||||
okular_LIB= libokularcore.so
|
||||
|
||||
oxygen-icons4_PORT= x11-themes/kde4-icons-oxygen
|
||||
oxygen-icons4_PATH= ${KDE_PREFIX}/share/icons/oxygen/index.theme
|
||||
oxygen-icons4_TYPE= run
|
||||
|
||||
perlkde_PORT= devel/p5-perlkde
|
||||
perlkde_PATH= ${KDE_PREFIX}/lib/kde4/kperlpluginfactory.so
|
||||
perlkde_TYPE= run
|
||||
|
@ -538,6 +534,8 @@ notifications_LIB= libKF5Notifications.so
|
|||
notifyconfig_PORT= devel/kf5-knotifyconfig
|
||||
notifyconfig_LIB= libKF5NotifyConfig.so
|
||||
|
||||
# This is a KF5 port used by KDE4 as well, but it's architecture-independent
|
||||
# and only contains icons.
|
||||
oxygen-icons5_PORT= x11-themes/kf5-oxygen-icons5
|
||||
oxygen-icons5_PATH= ${KDE_PREFIX}/share/icons/oxygen/index.theme
|
||||
oxygen-icons5_TYPE= run
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= oxygen
|
||||
PORTVERSION= ${KDE4_VERSION}
|
||||
CATEGORIES= x11-themes kde kde-kde4
|
||||
PKGNAMEPREFIX= kde4-icons-
|
||||
DISTNAME= ${PORTNAME}-icons-${PORTVERSION}
|
||||
|
||||
MAINTAINER= kde@FreeBSD.org
|
||||
COMMENT= The Oxygen icon theme for KDE
|
||||
|
||||
CONFLICTS_INSTALL= kf5-oxygen-icons5-5.*
|
||||
|
||||
USES= cmake:outsource kde:4 tar:xz
|
||||
INSTALL_TARGET= install
|
||||
EXTRACT_AFTER_ARGS= --exclude '${DISTNAME}/scalable'
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (KDE/4.14.3/oxygen-icons-4.14.3.tar.xz) = 9b222399c8c188feb3af342b0744fde12d58cdb4e5b88ee2b056ea082a9392db
|
||||
SIZE (KDE/4.14.3/oxygen-icons-4.14.3.tar.xz) = 229823240
|
|
@ -1,3 +0,0 @@
|
|||
The Oxygen icon theme for KDE.
|
||||
|
||||
WWW: http://www.kde.org
|
File diff suppressed because it is too large
Load diff
|
@ -3,6 +3,7 @@
|
|||
|
||||
PORTNAME= oxygen-icons5
|
||||
PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= x11-themes kde kde-frameworks
|
||||
|
||||
MAINTAINER= kde@FreeBSD.org
|
||||
|
@ -10,7 +11,15 @@ COMMENT= The Oxygen icon theme for KDE
|
|||
|
||||
USES= cmake:outsource kde:5 tar:xz
|
||||
USE_KDE= ecm
|
||||
USE_QT5= buildtools_build core qmake_build testlib
|
||||
|
||||
# The qmake dependency is only needed so that kf5-e-c-m can query qmake for
|
||||
# some installation directories.
|
||||
# We explicitly prevent it from looking for qt5-core and specify qmake's path
|
||||
# to avoid needlessly depending on qt5-core; we're just installing a ton of
|
||||
# icon files and do not even use the paths queried from qmake.
|
||||
USE_QT5= qmake_build
|
||||
CMAKE_ARGS= -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Core=TRUE \
|
||||
-DQMAKE_EXECUTABLE:PATH=${QMAKE}
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
|
|
12
x11-themes/kf5-oxygen-icons5/files/patch-CMakeLists.txt
Normal file
12
x11-themes/kf5-oxygen-icons5/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,12 @@
|
|||
Do not build tests by default to avoid having to depend on Qt5.
|
||||
--- CMakeLists.txt.orig 2017-04-02 18:01:03 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -20,8 +20,6 @@ set(REQUIRED_QT_VERSION 5.6.0)
|
||||
|
||||
set( oxygen_icon_dirs 8x8 16x16 22x22 32x32 48x48 64x64 128x128 256x256 )
|
||||
|
||||
-add_subdirectory(autotests)
|
||||
-
|
||||
########### install files ###############
|
||||
|
||||
set(OXYGEN_INSTALL_DIR ${KDE_INSTALL_ICONDIR}/oxygen/base)
|
|
@ -2,6 +2,7 @@
|
|||
|
||||
PORTNAME= kde-runtime
|
||||
PORTVERSION= ${KDE_APPLICATIONS_VERSION}
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= x11 kde kde-applications
|
||||
|
||||
MAINTAINER= kde@FreeBSD.org
|
||||
|
@ -25,7 +26,7 @@ RUN_DEPENDS= cagibid:net/cagibi
|
|||
|
||||
USES= cmake:outsource gettext gmake jpeg kde:4 samba:lib shared-mime-info \
|
||||
shebangfix tar:xz
|
||||
USE_KDE= kactivities kdelibs oxygen-icons4 \
|
||||
USE_KDE= kactivities kdelibs oxygen-icons5 \
|
||||
attica automoc4 pimlibs soprano strigi nepomuk-core
|
||||
USE_QT4= corelib dbus declarative designer_build gui phonon \
|
||||
network qtestlib script svg webkit xml \
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
PORTNAME= kde-workspace
|
||||
PORTVERSION= ${KDE4_WORKSPACE_VERSION}
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= x11 kde kde-applications
|
||||
|
||||
MAINTAINER= kde@FreeBSD.org
|
||||
|
@ -44,7 +44,7 @@ USES= cmake:outsource compiler:c++11-lib gettext gmake jpeg kde:4 \
|
|||
pkgconfig shebangfix tar:xz
|
||||
USE_GL= gl glu
|
||||
USE_GNOME= glib20 libxml2
|
||||
USE_KDE= kactivities kdelibs nepomuk-core oxygen-icons4 \
|
||||
USE_KDE= kactivities kdelibs nepomuk-core oxygen-icons5 \
|
||||
pimlibs akonadi automoc4 ontologies qimageblitz soprano strigi
|
||||
USE_QT4= corelib dbus declarative designer_build gui network \
|
||||
opengl phonon qtestlib script sql svg webkit xml \
|
||||
|
|
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= kdelibs
|
||||
PORTVERSION= ${KDE4_KDELIBS_VERSION}
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= x11 kde kde-applications
|
||||
|
||||
MAINTAINER= kde@FreeBSD.org
|
||||
|
@ -33,7 +33,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:misc/hicolor-icon-them
|
|||
USES= cmake:outsource fam gettext grantlee:4 jpeg kde:4 perl5 \
|
||||
shared-mime-info shebangfix tar:xz ssl
|
||||
USE_GNOME= libxml2 libxslt
|
||||
USE_KDE= oxygen-icons4 \
|
||||
USE_KDE= oxygen-icons5 \
|
||||
attica automoc4 ontologies soprano strigi
|
||||
USE_QT4= corelib dbus declarative designer_build gui \
|
||||
network opengl phonon qt3support \
|
||||
|
|
|
@ -4,6 +4,7 @@
|
|||
PORTNAME= lumina
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 1.2.0-p1
|
||||
PORTREVISION= 1
|
||||
PORTEPOCH= 2
|
||||
CATEGORIES= x11
|
||||
|
||||
|
@ -13,7 +14,7 @@ COMMENT= Lumina Desktop Environment
|
|||
LICENSE= BSD3CLAUSE
|
||||
|
||||
RUN_DEPENDS= fluxbox>=0:x11-wm/fluxbox \
|
||||
kde4-icons-oxygen>=0:x11-themes/kde4-icons-oxygen \
|
||||
kf5-oxygen-icons5>=0:x11-themes/kf5-oxygen-icons5 \
|
||||
xscreensaver:x11/xscreensaver \
|
||||
xbrightness:x11/xbrightness \
|
||||
compton:x11-wm/compton \
|
||||
|
|
Loading…
Reference in a new issue