Rework this port. Instead of patching the fonts, which come with gd

to have koi8-u support -- each  patch was twice bigger than the font
file, since  they had almost no  identical lines -- provide  our own
complete replacements. This port now  depends on the fetch-target of
x11-fonts/geminifonts  and passes  the  tarball name  and the  fonts
files to the master-port through my new GD_FONTS variable.

This also upgrades the port  to gd-2.0.1, which IMHO everyone should
use by now -- there is no reason to keep the old gd around...

Make myself  a maintainer for  the time being --  unfortunately, the
previous  maintainer  (and the  port  creator)  did not  respond  to
e-mail.
This commit is contained in:
Mikhail Teterin 2002-01-12 08:04:24 +00:00
parent 0d60d8e4c0
commit fbb9944500
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=52967
11 changed files with 5 additions and 34367 deletions

View file

@ -5,19 +5,13 @@
# $FreeBSD$
#
MASTERDIR= ${.CURDIR}/../../graphics/gd
MASTERDIR= ${.CURDIR}/../../graphics/gd2
CATEGORIES= ukrainian
MAINTAINER= mike@LITech.lviv.ua
MAINTAINER= mi@aldan.algebra.com
EXTRA_PATCHES+= ${.CURDIR}/files/patch-gdfontg.c \
${.CURDIR}/files/patch-gdfontl.c \
${.CURDIR}/files/patch-gdfontl.h \
${.CURDIR}/files/patch-gdfontmb.c \
${.CURDIR}/files/patch-gdfontmb.h \
${.CURDIR}/files/patch-gdfonts.c \
${.CURDIR}/files/patch-gdfonts.h \
${.CURDIR}/files/patch-gdfontt.c \
${.CURDIR}/files/patch-gdfontt.h
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/x11-fonts/geminifonts:fetch
GD_FONTS= ${DISTDIR}/x-koi8u.tgz koi6x10.bdf koi6x13.bdf \
koi10x16b.bdf koi9x15.bdf koi10x20.bdf
.include "${MASTERDIR}/Makefile"

File diff suppressed because it is too large Load diff

View file

@ -1,35 +0,0 @@
--- gdfontg.h.orig Tue Feb 6 21:44:01 2001
+++ gdfontg.h Fri May 18 13:11:09 2001
@@ -2,28 +2,20 @@
#ifndef _GDFONTG_H_
#define _GDFONTG_H_ 1
-#ifdef __cplusplus
-extern "C" {
-#endif
-
/*
This is a header file for gd font, generated using
- bdftogd version 0.51 by Jan Pazdziora, adelton@fi.muni.cz
+ bdftogd version 0.60 by Jan Pazdziora, adelton@fi.muni.cz
from bdf font
- -Misc-Fixed-Bold-R-Normal-Sans-15-140-75-75-C-90-ISO8859-2
- at Mon Jan 26 14:45:58 1998.
+ -FreeType-Lucida Console-Medium-R-Normal--19-180-75-75-C-90-KOI8-U
+ at Fri May 18 13:10:28 2001.
The original bdf was holding following copyright:
- "Libor Skarvada, libor@informatics.muni.cz"
+ "Copyright © 1993 Bigelow & Holmes Inc. All rights reserved."
*/
#include "gd.h"
extern gdFontPtr gdFontGiant;
-
-#ifdef __cplusplus
-}
-#endif
#endif

File diff suppressed because it is too large Load diff

View file

@ -1,36 +0,0 @@
--- gdfontl.h.orig Tue Feb 6 21:44:01 2001
+++ gdfontl.h Fri May 18 13:11:09 2001
@@ -2,29 +2,20 @@
#ifndef _GDFONTL_H_
#define _GDFONTL_H_ 1
-#ifdef __cplusplus
-extern "C" {
-#endif
-
/*
This is a header file for gd font, generated using
- bdftogd version 0.5 by Jan Pazdziora, adelton@fi.muni.cz
+ bdftogd version 0.60 by Jan Pazdziora, adelton@fi.muni.cz
from bdf font
- -misc-fixed-medium-r-normal--16-140-75-75-c-80-iso8859-2
- at Tue Jan 6 19:39:27 1998.
-
+ -FreeType-Lucida Console-Medium-R-Normal--17-160-75-75-C-78-KOI8-U
+ at Fri May 18 13:10:26 2001.
The original bdf was holding following copyright:
- "Libor Skarvada, libor@informatics.muni.cz"
+ "Copyright © 1993 Bigelow & Holmes Inc. All rights reserved."
*/
#include "gd.h"
extern gdFontPtr gdFontLarge;
-
-#ifdef __cplusplus
-}
-#endif
#endif

File diff suppressed because it is too large Load diff

View file

@ -1,35 +0,0 @@
--- gdfontmb.h.orig Tue Feb 6 21:44:02 2001
+++ gdfontmb.h Fri May 18 13:11:09 2001
@@ -2,27 +2,20 @@
#ifndef _GDFONTMB_H_
#define _GDFONTMB_H_ 1
-#ifdef __cplusplus
-extern "C" {
-#endif
-
/*
This is a header file for gd font, generated using
- bdftogd version 0.5 by Jan Pazdziora, adelton@fi.muni.cz
+ bdftogd version 0.60 by Jan Pazdziora, adelton@fi.muni.cz
from bdf font
- -misc-fixed-bold-r-normal-sans-13-94-100-100-c-70-iso8859-2
- at Thu Jan 8 13:54:57 1998.
- No copyright info was found in the original bdf.
+ -FreeType-Lucida Console-Medium-R-Normal--12-120-75-75-C-64-KOI8-U
+ at Fri May 18 13:10:25 2001.
+ The original bdf was holding following copyright:
+ "Copyright © 1993 Bigelow & Holmes Inc. All rights reserved."
*/
#include "gd.h"
extern gdFontPtr gdFontMediumBold;
-
-#ifdef __cplusplus
-}
-#endif
#endif

File diff suppressed because it is too large Load diff

View file

@ -1,35 +0,0 @@
--- gdfonts.h.orig Tue Feb 6 21:44:02 2001
+++ gdfonts.h Fri May 18 13:11:09 2001
@@ -2,27 +2,20 @@
#ifndef _GDFONTS_H_
#define _GDFONTS_H_ 1
-#ifdef __cplusplus
-extern "C" {
-#endif
-
/*
This is a header file for gd font, generated using
- bdftogd version 0.5 by Jan Pazdziora, adelton@fi.muni.cz
+ bdftogd version 0.60 by Jan Pazdziora, adelton@fi.muni.cz
from bdf font
- -misc-fixed-medium-r-semicondensed-sans-12-116-75-75-c-60-iso8859-2
- at Thu Jan 8 14:13:20 1998.
- No copyright info was found in the original bdf.
+ -FreeType-Lucida Console-Medium-R-Normal--11-110-75-75-C-57-KOI8-U
+ at Fri May 18 13:10:24 2001.
+ The original bdf was holding following copyright:
+ "Copyright © 1993 Bigelow & Holmes Inc. All rights reserved."
*/
#include "gd.h"
extern gdFontPtr gdFontSmall;
-
-#ifdef __cplusplus
-}
-#endif
#endif

File diff suppressed because it is too large Load diff

View file

@ -1,35 +0,0 @@
--- gdfontt.h.orig Tue Feb 6 21:44:02 2001
+++ gdfontt.h Fri May 18 13:11:09 2001
@@ -2,28 +2,20 @@
#ifndef _GDFONTT_H_
#define _GDFONTT_H_ 1
-#ifdef __cplusplus
-extern "C" {
-#endif
-
/*
This is a header file for gd font, generated using
- bdftogd version 0.5 by Jan Pazdziora, adelton@fi.muni.cz
+ bdftogd version 0.60 by Jan Pazdziora, adelton@fi.muni.cz
from bdf font
- -Misc-Fixed-Medium-R-Normal--8-80-75-75-C-50-ISO8859-2
- at Thu Jan 8 13:49:54 1998.
+ -FreeType-Lucida Console-Medium-R-Normal--9-90-75-75-C-45-KOI8-U
+ at Fri May 18 13:08:56 2001.
The original bdf was holding following copyright:
- "Libor Skarvada, libor@informatics.muni.cz"
+ "Copyright © 1993 Bigelow & Holmes Inc. All rights reserved."
*/
#include "gd.h"
extern gdFontPtr gdFontTiny;
-
-#ifdef __cplusplus
-}
-#endif
#endif