Add new port: devel/hs-ShellCheck
The goals of ShellCheck are: * To point out and clarify typical beginner's syntax issues, that causes a shell to give cryptic error messages. * To point out and clarify typical intermediate level semantic problems, that causes a shell to behave strangely and counter-intuitively. * To point out subtle caveats, corner cases and pitfalls, that may cause an advanced user's otherwise working script to fail under future circumstances. WWW: http://www.shellcheck.net/ PR: 197302 Submitted by: luca.pizzamiglio@gmail.com Obtained from: FreeBSD Haskell
This commit is contained in:
parent
63cc5ce1c4
commit
fbe6366352
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=379051
5 changed files with 62 additions and 0 deletions
18
devel/hs-ShellCheck/Makefile
Normal file
18
devel/hs-ShellCheck/Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ShellCheck
|
||||
PORTVERSION= 0.3.5
|
||||
CATEGORIES= devel haskell
|
||||
|
||||
MAINTAINER= luca.pizzamiglio@gmail.com
|
||||
COMMENT= Shell script analysis tool
|
||||
|
||||
LICENSE= AGPLv3
|
||||
|
||||
USE_CABAL= json>=0.7 parsec QuickCheck>=2.6 regex-posix>=0.95.2 \
|
||||
regex-compat>=0.95.1 tf-random>=0.5
|
||||
|
||||
EXECUTABLE= shellcheck
|
||||
|
||||
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
|
||||
.include <bsd.port.mk>
|
2
devel/hs-ShellCheck/distinfo
Normal file
2
devel/hs-ShellCheck/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (cabal/ShellCheck-0.3.5.tar.gz) = 9289fda0b3683f4e7c2c003f875a9e308897368fe956ed924a76cafc2fdc9974
|
||||
SIZE (cabal/ShellCheck-0.3.5.tar.gz) = 77173
|
28
devel/hs-ShellCheck/files/patch-ShellCheck.cabal
Normal file
28
devel/hs-ShellCheck/files/patch-ShellCheck.cabal
Normal file
|
@ -0,0 +1,28 @@
|
|||
--- ShellCheck.cabal.orig 2014-11-10 01:30:00.000000000 +0100
|
||||
+++ ShellCheck.cabal 2015-02-03 18:19:38.355225341 +0100
|
||||
@@ -42,7 +42,7 @@
|
||||
mtl,
|
||||
parsec,
|
||||
regex-compat,
|
||||
- QuickCheck >= 2.7.4
|
||||
+ QuickCheck >= 2.6
|
||||
exposed-modules:
|
||||
ShellCheck.Analytics
|
||||
ShellCheck.AST
|
||||
@@ -64,7 +64,7 @@
|
||||
parsec,
|
||||
regex-compat,
|
||||
transformers,
|
||||
- QuickCheck >= 2.7.4
|
||||
+ QuickCheck >= 2.6
|
||||
main-is: shellcheck.hs
|
||||
|
||||
test-suite test-shellcheck
|
||||
@@ -79,6 +79,6 @@
|
||||
parsec,
|
||||
regex-compat,
|
||||
transformers,
|
||||
- QuickCheck >= 2.7.4
|
||||
+ QuickCheck >= 2.6
|
||||
main-is: test/shellcheck.hs
|
||||
|
13
devel/hs-ShellCheck/pkg-descr
Normal file
13
devel/hs-ShellCheck/pkg-descr
Normal file
|
@ -0,0 +1,13 @@
|
|||
The goals of ShellCheck are:
|
||||
|
||||
* To point out and clarify typical beginner's syntax issues, that causes
|
||||
a shell to give cryptic error messages.
|
||||
|
||||
* To point out and clarify typical intermediate level semantic problems,
|
||||
that causes a shell to behave strangely and counter-intuitively.
|
||||
|
||||
* To point out subtle caveats, corner cases and pitfalls, that may cause
|
||||
an advanced user's otherwise working script to fail under future
|
||||
circumstances.
|
||||
|
||||
WWW: http://www.shellcheck.net/
|
|
@ -345,6 +345,7 @@ setenv_port= devel/hs-setenv
|
|||
SHA_port= security/hs-SHA # executable
|
||||
shake_port= devel/hs-shake # executable
|
||||
shakespeare_port= www/hs-shakespeare
|
||||
ShellCheck_port= devel/hs-ShellCheck # executable
|
||||
show_port= devel/hs-show
|
||||
silently_port= devel/hs-silently
|
||||
simple-reflect_port= devel/hs-simple-reflect
|
||||
|
|
Loading…
Reference in a new issue