multimedia/transcode: add V4L option
- Add V4L option [1] - Remove support for OS < 7.x - Remove leading article from COMMENT - Add LICENSE (GPLv2) - USES gmake PR: ports/179460 Submitted by: Naram Qashat <cyberbotx cyberbotx.com> (maintainer)
This commit is contained in:
parent
839ef5dcc2
commit
fc2ecf59ae
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=326026
2 changed files with 46 additions and 8 deletions
|
@ -8,15 +8,17 @@ CATEGORIES= multimedia
|
|||
MASTER_SITES= http://cdn.bitbucket.org/france/transcode-tcforge/downloads/
|
||||
|
||||
MAINTAINER= cyberbotx@cyberbotx.com
|
||||
COMMENT= A text-console utility for video stream processing
|
||||
COMMENT= Text-console utility for video stream processing
|
||||
|
||||
LIB_DEPENDS= avcodec:${PORTSDIR}/multimedia/ffmpeg
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
|
||||
|
||||
USE_BZIP2= yes
|
||||
FAKEDIR= ${WRKDIR}/fake
|
||||
PLIST= ${WRKDIR}/plist
|
||||
USE_GMAKE= yes
|
||||
USE_LDCONFIG= yes
|
||||
USES= gmake
|
||||
WANT_SDL= yes
|
||||
WANT_GNOME= yes
|
||||
USE_AUTOTOOLS= libtool
|
||||
|
@ -33,7 +35,7 @@ MAN1= avifix.1 aviindex.1 avimerge.1 avisplit.1 avisync.1 tccat.1 tcdemux.1 \
|
|||
NO_OPTIONS_SORT= yes
|
||||
OPTIONS_DEFINE= OPTIMIZED_CFLAGS X11 MPEG2 BKTR POSTPROC FREETYPE LAME XVID \
|
||||
X264 OGG VORBIS THEORA DVDREAD DV QUICKTIME LZO LIBA52 \
|
||||
FAAC XML MJPEGTOOLS SDL IMAGEMAGICK JPEG ICONV
|
||||
FAAC XML MJPEGTOOLS SDL IMAGEMAGICK JPEG ICONV V4L
|
||||
OPTIONS_DEFAULT= LAME DVDREAD JPEG ICONV
|
||||
BKTR_DESC= Bktr capture card support
|
||||
POSTPROC_DESC= Libpostproc support
|
||||
|
@ -44,10 +46,6 @@ XML_DESC= Libxml2 XML support
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 700000
|
||||
CONFIGURE_ENV+= LIBAVCODEC_EXTRA_LIBS="-pthread"
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MX11}
|
||||
USE_XORG= xv xaw xpm
|
||||
CONFIGURE_ARGS+= --with-x
|
||||
|
@ -206,6 +204,16 @@ CONFIGURE_ARGS+= --with-iconv-prefix=${LOCALBASE} --enable-iconv
|
|||
CONFIGURE_ARGS+= --disable-iconv
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MV4L}
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/include/linux/videodev2.h:${PORTSDIR}/multimedia/v4l_compat
|
||||
CONFIGURE_ARGS+= --enable-v4l
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-v4l
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
@${RM} ${WRKSRC}/import/v4l/videodev*
|
||||
|
||||
post-patch:
|
||||
.if ${PORT_OPTIONS:MLZO}
|
||||
@${REINPLACE_CMD} -e 's|%%NUV%%|nuv|' ${WRKSRC}/import/Makefile.in
|
||||
|
|
30
multimedia/transcode/files/patch-import-v4l
Normal file
30
multimedia/transcode/files/patch-import-v4l
Normal file
|
@ -0,0 +1,30 @@
|
|||
--- import/v4l/import_v4l.c.orig 2011-11-19 11:50:27.000000000 -0500
|
||||
+++ import/v4l/import_v4l.c 2013-06-10 14:51:01.000000000 -0400
|
||||
@@ -29,7 +29,7 @@
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/mman.h>
|
||||
|
||||
-#include "videodev.h"
|
||||
+#include <linux/videodev.h>
|
||||
|
||||
#define MOD_NAME "import_v4l.so"
|
||||
#define MOD_VERSION "v0.2.0 (2008-10-26)"
|
||||
--- import/probe_v4l.c.orig 2011-11-19 11:50:27.000000000 -0500
|
||||
+++ import/probe_v4l.c 2013-06-10 14:54:28.000000000 -0400
|
||||
@@ -31,14 +31,12 @@
|
||||
|
||||
#include <sys/ioctl.h>
|
||||
|
||||
-#include "v4l/videodev.h"
|
||||
+#include <linux/videodev.h>
|
||||
|
||||
#if defined(HAVE_LINUX_VIDEODEV2_H) && defined(HAVE_STRUCT_V4L2_BUFFER)
|
||||
#define _LINUX_TIME_H
|
||||
-#include <linux/videodev2.h>
|
||||
-#else
|
||||
-#include "v4l/videodev2.h"
|
||||
#endif
|
||||
+#include <linux/videodev2.h>
|
||||
|
||||
|
||||
void probe_v4l(info_t *ipipe)
|
Loading…
Reference in a new issue