Upgrade to 0.9.1.
This commit is contained in:
parent
7513fc9753
commit
fc5157c173
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=43931
5 changed files with 41 additions and 2620 deletions
|
@ -6,8 +6,7 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= mozilla
|
PORTNAME= mozilla
|
||||||
PORTVERSION= 0.9
|
PORTVERSION= 0.9.1
|
||||||
PORTREVISON= 1
|
|
||||||
PORTEPOCH= 1
|
PORTEPOCH= 1
|
||||||
PKGNAMESUFFIX= +ipv6
|
PKGNAMESUFFIX= +ipv6
|
||||||
CATEGORIES= www ipv6
|
CATEGORIES= www ipv6
|
||||||
|
@ -38,7 +37,6 @@ CONFIGURE_ARGS= \
|
||||||
--disable-cpp-rtti \
|
--disable-cpp-rtti \
|
||||||
--disable-debug \
|
--disable-debug \
|
||||||
--disable-idltool \
|
--disable-idltool \
|
||||||
--disable-jar-packaging \
|
|
||||||
--disable-md \
|
--disable-md \
|
||||||
--disable-pedantic \
|
--disable-pedantic \
|
||||||
--disable-xterm-updates \
|
--disable-xterm-updates \
|
||||||
|
@ -52,6 +50,7 @@ CONFIGURE_ARGS= \
|
||||||
--enable-tests \
|
--enable-tests \
|
||||||
--enable-toolkit=gtk \
|
--enable-toolkit=gtk \
|
||||||
--enable-x11-shm \
|
--enable-x11-shm \
|
||||||
|
--enable-chrome-format=jar \
|
||||||
--with-jpeg=${LOCALBASE} \
|
--with-jpeg=${LOCALBASE} \
|
||||||
--with-png=${LOCALBASE} \
|
--with-png=${LOCALBASE} \
|
||||||
--with-mng=${LOCALBASE} \
|
--with-mng=${LOCALBASE} \
|
||||||
|
@ -69,6 +68,8 @@ post-build:
|
||||||
${ECHO} skin,install,select,classic/1.0 >> chrome/installed-chrome.txt; \
|
${ECHO} skin,install,select,classic/1.0 >> chrome/installed-chrome.txt; \
|
||||||
${ECHO} locale,install,select,en-US >> chrome/installed-chrome.txt; \
|
${ECHO} locale,install,select,en-US >> chrome/installed-chrome.txt; \
|
||||||
${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regchrome)
|
${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regchrome)
|
||||||
|
@/usr/bin/find ${WRKSRC}/dist/bin -type d | /usr/bin/sort -r | \
|
||||||
|
/usr/bin/xargs ${RMDIR} 2> /dev/null || ${TRUE}
|
||||||
|
|
||||||
do-install:
|
do-install:
|
||||||
${MKDIR} ${PREFIX}/lib/mozilla
|
${MKDIR} ${PREFIX}/lib/mozilla
|
||||||
|
|
|
@ -1 +1 @@
|
||||||
MD5 (mozilla-source-0.9.tar.bz2) = ebe1d6bae2182e2a096a714dd54303ec
|
MD5 (mozilla-source-0.9.1.tar.bz2) = 1026af0ec03db33f3095c2c17d002749
|
||||||
|
|
|
@ -1,38 +0,0 @@
|
||||||
--- security/coreconf/config.mk.orig Tue Mar 13 21:00:48 2001
|
|
||||||
+++ security/coreconf/config.mk Mon May 14 18:13:01 2001
|
|
||||||
@@ -56,7 +56,7 @@
|
|
||||||
# each OS release. #
|
|
||||||
#######################################################################
|
|
||||||
|
|
||||||
-ifeq (,$(filter-out BSD_OS NetBSD OS2,$(OS_TARGET)))
|
|
||||||
+ifeq (,$(filter-out BSD_OS NetBSD OS2 FreeBSD,$(OS_TARGET)))
|
|
||||||
include $(CORE_DEPTH)/coreconf/$(OS_TARGET).mk
|
|
||||||
else
|
|
||||||
include $(CORE_DEPTH)/coreconf/$(OS_CONFIG).mk
|
|
||||||
--- security/psm/server/Makefile.orig Fri Mar 30 21:46:06 2001
|
|
||||||
+++ security/psm/server/Makefile Mon May 14 18:03:23 2001
|
|
||||||
@@ -67,11 +67,11 @@
|
|
||||||
endif
|
|
||||||
endif
|
|
||||||
|
|
||||||
-ifeq ($(OS_ARCH), Linux)
|
|
||||||
+ifeq ($(OS_ARCH), FreeBSD)
|
|
||||||
ifdef USE_PTHREADS
|
|
||||||
# Replace OS_LIBS, because the order of libpthread, libdl, and libc are
|
|
||||||
# very important. Otherwise you get horrible crashes.
|
|
||||||
-OS_LIBS = -lpthread -ldl -lc
|
|
||||||
+OS_LIBS = -pthread
|
|
||||||
endif
|
|
||||||
endif
|
|
||||||
|
|
||||||
@@ -165,8 +165,8 @@
|
|
||||||
XPCOM_LINK_LIBS = -lxpcom
|
|
||||||
XPCOM_LIBS += $(DIST)/lib/libz.$(DLL_SUFFIX)
|
|
||||||
else
|
|
||||||
-NSPR_LINK_LIBS = $(NSPR_LIBS)
|
|
||||||
-XPCOM_LINK_LIBS = $(XPCOM_LIBS)
|
|
||||||
+NSPR_LINK_LIBS = -L$(DIST)/lib -lnspr4 -lplc4 -lplds4
|
|
||||||
+XPCOM_LINK_LIBS = -lxpcom
|
|
||||||
endif
|
|
||||||
|
|
||||||
ifndef MOZ_DIST
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- security/manager/Makefile.in.orig Mon Apr 16 09:50:16 2001
|
|
||||||
+++ security/manager/Makefile.in Wed May 16 16:02:06 2001
|
|
||||||
@@ -84,7 +84,7 @@
|
|
||||||
cd $(MOZ_BUILD_ROOT)/security/nss; $(MAKE) $(DEFAULT_GMAKE_FLAGS) moz_import
|
|
||||||
cd $(MOZ_BUILD_ROOT)/security/nss; $(INSTALL) $(DIST)/include $(DIST)/public/dbm
|
|
||||||
cd $(MOZ_BUILD_ROOT)/security/nss/lib; $(MAKE) $(DEFAULT_GMAKE_FLAGS)
|
|
||||||
- $(INSTALL) -m 755 $(CORECONF_INSTALL)/lib/$(LOADABLE_ROOT_MODULE) $(DIST)/bin
|
|
||||||
+# $(INSTALL) -m 755 $(CORECONF_INSTALL)/lib/$(LOADABLE_ROOT_MODULE) $(DIST)/bin
|
|
||||||
$(MAKE) -C ssl $@
|
|
||||||
$(MAKE) -C pki $@
|
|
||||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue