Update to 3.5.0
Changelog: https://github.com/caffeine-ng/caffeine-ng/compare/v3.4.2...v3.5.0
This commit is contained in:
parent
9e4bc6e64a
commit
fc644a2c98
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=562002
4 changed files with 31 additions and 25 deletions
|
@ -1,8 +1,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= caffeine-ng
|
||||
DISTVERSION= 3.4.2
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 3.5.0
|
||||
CATEGORIES= x11 python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -26,9 +25,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docopt>=0.6.2:devel/py-docopt@${PY_FLAVOR} \
|
|||
${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR}
|
||||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tox>0:devel/py-tox@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}flake8>0:devel/py-flake8@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}flake8-bugbear>0:devel/py-flake8-bugbear@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}flake8-import-order>0:devel/py-flake8-import-order@${PY_FLAVOR}
|
||||
|
||||
USES= desktop-file-utils gettext-tools gnome python:3.3+
|
||||
USES= desktop-file-utils gettext-tools gnome python:3.6+
|
||||
USE_GNOME= gdkpixbuf2 gtk30 pygobject3
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1547976230
|
||||
SHA256 (caffeine-ng-3.4.2.tar.gz) = 9cf843f9359b4b8cdb2ad4a14bb433641a100e25206274eb638c494765d56816
|
||||
SIZE (caffeine-ng-3.4.2.tar.gz) = 145797
|
||||
TIMESTAMP = 1611015884
|
||||
SHA256 (caffeine-ng-3.5.0.tar.gz) = 4c32652cdbec42abf0d44f7ab8a3f4a44c3d6215d07aa4b6362a58c654d0e38f
|
||||
SIZE (caffeine-ng-3.5.0.tar.gz) = 155294
|
||||
|
|
|
@ -1,13 +1,22 @@
|
|||
--- caffeine/main.py.orig 2018-05-17 01:08:07 UTC
|
||||
--- caffeine/main.py.orig 2021-01-01 14:03:23 UTC
|
||||
+++ caffeine/main.py
|
||||
@@ -412,8 +412,8 @@ def main():
|
||||
@@ -30,7 +30,7 @@ Options:
|
||||
-p --preferences Start with the Preferences dialog open.
|
||||
"""
|
||||
# TODO: add a -v --verbosity flag.
|
||||
-import ctypes
|
||||
+# import ctypes
|
||||
import logging
|
||||
import os
|
||||
import signal
|
||||
@@ -429,8 +429,8 @@ def main():
|
||||
GObject.threads_init()
|
||||
|
||||
# register the process id as 'caffeine'
|
||||
- libc = ctypes.cdll.LoadLibrary('libc.so.6')
|
||||
- libc.prctl(15, 'caffeine', 0, 0, 0)
|
||||
+ # libc = ctypes.cdll.LoadLibrary('libc.so.6')
|
||||
+ # libc.prctl(15, 'caffeine', 0, 0, 0)
|
||||
- libc = ctypes.cdll.LoadLibrary("libc.so.6")
|
||||
- libc.prctl(15, "caffeine", 0, 0, 0)
|
||||
+ # libc = ctypes.cdll.LoadLibrary("libc.so.6")
|
||||
+ # libc.prctl(15, "caffeine", 0, 0, 0)
|
||||
|
||||
arguments = docopt(__doc__, version=__version__)
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- setup.py.orig 2018-05-17 01:08:07 UTC
|
||||
--- setup.py.orig 2021-01-01 14:03:23 UTC
|
||||
+++ setup.py
|
||||
@@ -7,14 +7,18 @@ from setuptools import find_packages, setup
|
||||
@@ -7,13 +7,16 @@ from setuptools import setup
|
||||
|
||||
|
||||
def get_data_files():
|
||||
|
@ -8,17 +8,14 @@
|
|||
+ black_list = ['net.launchpad.caffeine.gschema.xml']
|
||||
data_files = []
|
||||
|
||||
for path, dirs, files in walk('share'):
|
||||
target_path = os.path.join('/usr', path)
|
||||
for path, _dirs, files in walk("share"):
|
||||
target_path = os.path.join("/usr", path)
|
||||
|
||||
- data_files.append((
|
||||
- target_path, [os.path.join(path, f) for f in files]
|
||||
- ))
|
||||
- if files:
|
||||
- data_files.append((target_path, [os.path.join(path, f) for f in files]))
|
||||
+ tl = [os.path.join(path, f) for f in files if f not in black_list]
|
||||
+ if tl != []:
|
||||
+ data_files.append((
|
||||
+ target_path, tl
|
||||
+ ))
|
||||
+ if tl:
|
||||
+ data_files.append((target_path, tl))
|
||||
|
||||
data_files.append(
|
||||
("/etc/xdg/autostart", ["share/applications/caffeine.desktop"])
|
||||
# Install all icons for the package into /usr/share as well.
|
||||
# This is because the .desktop file actually uses them too.
|
||||
|
|
Loading…
Reference in a new issue