- Support staging
- EXTRACT_SUFX -> USES=tar:tgz - Use @sample for sample config and remove note to copy it from pkg-message Approved by: portmgr (blanket approval)
This commit is contained in:
parent
274eea4d0d
commit
fc65d01d20
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=359469
7 changed files with 37 additions and 34 deletions
|
@ -7,24 +7,19 @@ PORTREVISION= 1
|
|||
CATEGORIES= net ipv6
|
||||
MASTER_SITES= http://go6.net/4105/file.asp?file_id=166&
|
||||
DISTNAME= tspc-${PORTVERSION}-src
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= edwin@mavetju.org
|
||||
COMMENT= Hexago Freenet6 Tunnel Setup Protocol Client - Free IPv6 tunnel
|
||||
|
||||
USES= gmake
|
||||
USES= gmake tar:tgz
|
||||
MAKE_ARGS= target=freebsd CC="${CC}" CXX="${CXX}" \
|
||||
installdir="${PREFIX}" ETCDIR="${ETCDIR}"
|
||||
installdir="${STAGEDIR}${PREFIX}" ETCDIR="${ETCDIR}"
|
||||
|
||||
WRKSRC= ${WRKDIR}/gw6c-${DISTVERSION}/tspc-advanced
|
||||
|
||||
USE_RC_SUBR= freenet6
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
MAN5= gw6c.conf.5
|
||||
MAN8= gw6c.8
|
||||
|
||||
NO_STAGE= yes
|
||||
MAKE_JOBS_UNSAFE=yes
|
||||
|
||||
post-fetch:
|
||||
|
@ -33,9 +28,4 @@ post-fetch:
|
|||
${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}; \
|
||||
fi
|
||||
|
||||
post-install:
|
||||
@${ECHO_MSG}
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
@${ECHO_MSG}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,20 +1,5 @@
|
|||
--- template/Makefile.orig 2009-11-15 19:42:51.000000000 +0100
|
||||
+++ template/Makefile 2009-11-15 19:43:01.000000000 +0100
|
||||
@@ -17,8 +17,10 @@
|
||||
|
||||
install:
|
||||
@echo "Installing templates ..."
|
||||
- @for template_var in README $(PLATFORM).sh; do \
|
||||
- cp $${template_var} $(INSTALL_TEMPL)/$${template_var}; \
|
||||
+ @for template_var in $(PLATFORM).sh; do \
|
||||
+ cp $${template_var} $(INSTALL_BIN)/gw6c-$${template_var}; \
|
||||
done
|
||||
+ @mkdir -p $(ETCDIR)
|
||||
+ @cp README $(ETCDIR)
|
||||
|
||||
clean:
|
||||
--- Makefile.orig 2009-11-15 19:50:40.000000000 +0100
|
||||
+++ Makefile 2009-11-15 19:50:57.000000000 +0100
|
||||
--- ./Makefile.orig 2009-05-19 12:51:11.000000000 -0400
|
||||
+++ ./Makefile 2014-06-27 04:03:52.000000000 -0400
|
||||
@@ -74,7 +74,7 @@
|
||||
#
|
||||
.PHONY: all platform-check check-gw6c-pal check-gw6c-config check-gw6c-messaging build-gw6c check-gw6c-install install clean cleanall
|
||||
|
@ -61,13 +46,14 @@
|
|||
$(MAKE) -C $$dir install || exit 1; \
|
||||
done
|
||||
|
||||
@cp $(TARGET) $(INSTALL_BIN)
|
||||
- @cp $(TARGET) $(INSTALL_BIN)
|
||||
- @cp $(BIN_DIR)/gw6c.conf.sample $(INSTALL_BIN)
|
||||
- @[ -f $(INSTALL_BIN)/gw6c.conf ] || { \
|
||||
- cp $(INSTALL_BIN)/gw6c.conf.sample $(INSTALL_BIN)/gw6c.conf; \
|
||||
- }
|
||||
+ @mkdir -p $(ETCDIR)
|
||||
+ @cp $(BIN_DIR)/gw6c.conf.sample $(ETCDIR)
|
||||
+ ${BSD_INSTALL_PROGRAM} $(TARGET) $(INSTALL_BIN)
|
||||
+ @mkdir -p $(DESTDIR)$(ETCDIR)
|
||||
+ ${BSD_INSTALL_DATA} $(BIN_DIR)/gw6c.conf.sample $(DESTDIR)$(ETCDIR)
|
||||
|
||||
|
||||
# This makefile target will clean the build tree of the Gateway6 Client.
|
11
net/freenet6/files/patch-conf__Makefile
Normal file
11
net/freenet6/files/patch-conf__Makefile
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./conf/Makefile.orig 2009-05-19 12:50:14.000000000 -0400
|
||||
+++ ./conf/Makefile 2014-06-27 03:51:00.000000000 -0400
|
||||
@@ -32,7 +32,7 @@
|
||||
-e "s+@ifname_v6udpv4@+$(PLATFORM_V6UDPV4)+" \
|
||||
-e "s+@ifname_v6v4@+$(PLATFORM_V6V4)+" \
|
||||
-e "s+@conf_template@+$(PLATFORM)+" \
|
||||
- -e "s+@conf_gw6_dir@+$(INSTALL_DIR)+" \
|
||||
+ -e "s+@conf_gw6_dir@+$(PREFIX)+" \
|
||||
gw6c.conf.in > $(BIN_DIR)/gw6c.conf.sample
|
||||
@chmod 700 $(BIN_DIR)/gw6c.conf.sample
|
||||
|
15
net/freenet6/files/patch-template__Makefile
Normal file
15
net/freenet6/files/patch-template__Makefile
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- ./template/Makefile.orig 2008-01-09 10:09:18.000000000 -0500
|
||||
+++ ./template/Makefile 2014-06-27 03:51:00.000000000 -0400
|
||||
@@ -17,8 +17,10 @@
|
||||
|
||||
install:
|
||||
@echo "Installing templates ..."
|
||||
- @for template_var in README $(PLATFORM).sh; do \
|
||||
- cp $${template_var} $(INSTALL_TEMPL)/$${template_var}; \
|
||||
+ @for template_var in $(PLATFORM).sh; do \
|
||||
+ cp $${template_var} $(INSTALL_BIN)/gw6c-$${template_var}; \
|
||||
done
|
||||
+ @mkdir -p $(DESTDIR)$(ETCDIR)
|
||||
+ ${BSD_INSTALL_DATA} README $(DESTDIR)$(ETCDIR)
|
||||
|
||||
clean:
|
|
@ -1,6 +1,5 @@
|
|||
Now that the package is installed, please finish it with the following steps:
|
||||
|
||||
- Copy %%PREFIX%%/etc/gw6c.conf.example to %%PREFIX%%/etc/gw6c.conf
|
||||
- Check the values of %%PREFIX%%/etc/gw6c.conf. If you have registered at
|
||||
the website, fill in your userid and password there.
|
||||
- Add 'freenet6_enable="YES"' to your /etc/rc.conf to make it start
|
||||
|
|
|
@ -1,5 +1,7 @@
|
|||
bin/gw6c
|
||||
bin/gw6c-freebsd.sh
|
||||
etc/freenet6/README
|
||||
etc/freenet6/gw6c.conf.sample
|
||||
@sample etc/freenet6/gw6c.conf.sample
|
||||
man/man5/gw6c.conf.5.gz
|
||||
man/man8/gw6c.8.gz
|
||||
@dirrmtry etc/freenet6
|
||||
|
|
Loading…
Reference in a new issue