Update to 0.1.8.

Thanks for edwin for informing me of the new version, and super duper thanks
to marcus for tracking down and fixing a memory bug.
This commit is contained in:
Adam Weinberger 2004-01-17 20:37:00 +00:00
parent 58708c8147
commit fc697244cb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=98416
8 changed files with 64 additions and 55 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= monkeybubble
PORTVERSION= 0.1.7
PORTREVISION= 1
PORTVERSION= 0.1.8
CATEGORIES= games gnome
MASTER_SITES= http://monkey-bubble.tuxfamily.org/
DISTNAME= monkey-bubble-${PORTVERSION}
@ -15,20 +14,14 @@ DISTNAME= monkey-bubble-${PORTVERSION}
MAINTAINER= adamw@FreeBSD.org
COMMENT= GTK2 Puzzle Bobble clone with monkeys
LIB_DEPENDS= gstplay-0.6:${PORTSDIR}/multimedia/gstreamer-plugins
USE_X_PREFIX= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix librsvg2 libgnomeui
USE_GNOME= gnomehack gnomeprefix librsvg2 libgnomeui \
gstreamerplugins intlhack
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
post-patch:
@${REINPLACE_CMD} -e "s|/usr/share|${LOCALBASE}/share| ; \
s|lang or die|lang, 0777 or die|" ${WRKSRC}/intltool-merge.in
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (monkey-bubble-0.1.7.tar.gz) = d7a74cd347a2f132c7d233ef5cc5f31b
MD5 (monkey-bubble-0.1.8.tar.gz) = 6c97b5e2ec52fc8ea4c30bd04b0ee590

View file

@ -1,10 +0,0 @@
--- configure.orig Mon Oct 6 16:05:40 2003
+++ configure Mon Oct 6 16:06:43 2003
@@ -19131,6 +19131,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'

View file

@ -1,11 +0,0 @@
--- data/Makefile.in.orig Thu Jan 1 20:37:25 2004
+++ data/Makefile.in Thu Jan 1 20:37:35 2004
@@ -323,7 +323,7 @@
install-data-local:
if test -z "$(DESTDIR)" ; then \
- for p in $(schema_DATA) ; do \
+ for p in $(schemas_DATA) ; do \
GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p; \
done \
fi

View file

@ -0,0 +1,11 @@
--- src/audio/sound-manager.c.orig Sat Jan 17 15:26:09 2004
+++ src/audio/sound-manager.c Sat Jan 17 15:26:16 2004
@@ -145,7 +145,7 @@
g_object_set( G_OBJECT( PRIVATE(m)->filesrc), "location",path,NULL);
- gst_element_link_many( PRIVATE(m)->filesrc, PRIVATE(m)->vorbis_dec, PRIVATE(m)->output);
+ gst_element_link_many( PRIVATE(m)->filesrc, PRIVATE(m)->vorbis_dec, PRIVATE(m)->output, NULL);
PRIVATE(m)->is_playing = TRUE;

View file

@ -0,0 +1,18 @@
--- src/ui/ui-main.c.orig Fri Jan 16 20:28:27 2004
+++ src/ui/ui-main.c Fri Jan 16 20:28:45 2004
@@ -587,6 +587,7 @@
const char *message_format, ...) {
char *message;
va_list args;
+ GtkWidget *dialog;
if (message_format) {
va_start (args, message_format);
@@ -596,7 +597,6 @@
message = NULL;
}
- GtkWidget *dialog;
dialog = gtk_message_dialog_new (transient_parent,
GTK_DIALOG_DESTROY_WITH_PARENT,
GTK_MESSAGE_ERROR,

View file

@ -1,5 +1,7 @@
GTK2 Puzzle Bobble clone. With monkeys. Frozen Bubble, but
with monkeys. It's a game, except SO MUCH MORE, because
it has monkeys.
Think Puzzle Bobble, but with monkeys. Monkeys that throw
colourful things. It's a game, except SO MUCH MORE, because
it has monkeys. It has sound and network play and a spiffy
GTK+-2 interface, but that's all irrelevant because, come on...
monkeys!
WWW: http://monkey-bubble.tuxfamily.org/

View file

@ -1,20 +1,12 @@
bin/monkey-bubble
etc/gconf/gconf.xml.defaults/apps/monkey-bubble-game/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/monkey-bubble-game/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/monkey-bubble/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/monkey-bubble/%gconf.xml
etc/gconf/schemas/monkey-bubble.schemas
lib/libgdkview.a
lib/libgdkview.so
lib/libgdkview.so.0
lib/libgstaudio.a
lib/libgstaudio.so
lib/libgstaudio.so.0
lib/libmonkey.a
lib/libmonkey.so
lib/libmonkey.so.0
lib/libmonkeyutil.a
lib/libmonkeyutil.so
lib/libmonkeyutil.so.0
share/gnome/applications/monkey-bubble.desktop
share/gnome/help/monkey-bubble/C/empty.xml
share/gnome/help/monkey-bubble/C/monkey-bubble.xml
share/gnome/help/monkey-bubble/fr/empty.xml
share/gnome/help/monkey-bubble/fr/monkey-bubble.xml
share/gnome/monkey-bubble/gfx/banana.svg
share/gnome/monkey-bubble/gfx/bubbles/bubble_01.svg
share/gnome/monkey-bubble/gfx/bubbles/bubble_02.svg
@ -26,11 +18,13 @@ share/gnome/monkey-bubble/gfx/bubbles/bubble_07.svg
share/gnome/monkey-bubble/gfx/bubbles/bubble_08.svg
share/gnome/monkey-bubble/gfx/frozen-bubble/back_hiscores.png
share/gnome/monkey-bubble/gfx/harm.svg
share/gnome/monkey-bubble/gfx/harm_down.svg
share/gnome/monkey-bubble/gfx/harm_shoot.svg
share/gnome/monkey-bubble/gfx/harm_up.svg
share/gnome/monkey-bubble/gfx/layout_1_player.svg
share/gnome/monkey-bubble/gfx/layout_2_players.svg
share/gnome/monkey-bubble/gfx/looser.svg
share/gnome/monkey-bubble/gfx/lost.svg
share/gnome/monkey-bubble/gfx/monkey-bubble-icon.xpm
share/gnome/monkey-bubble/gfx/monkey.png
share/gnome/monkey-bubble/gfx/monkeys.svg
share/gnome/monkey-bubble/gfx/number/0.svg
@ -129,17 +123,24 @@ share/gnome/monkey-bubble/gfx/snake/snake_6.svg
share/gnome/monkey-bubble/gfx/snake/snake_7.svg
share/gnome/monkey-bubble/gfx/snake/snake_8.svg
share/gnome/monkey-bubble/gfx/snake/snake_9.svg
share/gnome/monkey-bubble/gfx/splash.svg
share/gnome/monkey-bubble/gfx/star.svg
share/gnome/monkey-bubble/gfx/tomato.svg
share/gnome/monkey-bubble/gfx/win.svg
share/gnome/monkey-bubble/glade/keybinding.glade
share/gnome/monkey-bubble/glade/monkey-bubble.glade
share/gnome/monkey-bubble/levels
share/gnome/monkey-bubble/sounds/game.ogg
share/gnome/monkey-bubble/sounds/splash.ogg
share/gnome/omf/monkey-bubble/monkey-bubble-C.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/monkey-bubble/monkey-bubble-C.omf 2>/dev/null || /usr/bin/true
share/gnome/omf/monkey-bubble/monkey-bubble-fr.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/monkey-bubble/monkey-bubble-fr.omf 2>/dev/null || /usr/bin/true
share/gnome/pixmaps/monkey-bubble-icon.png
share/locale/de/LC_MESSAGES/monkey-bubble.mo
share/locale/es/LC_MESSAGES/monkey-bubble.mo
share/locale/eu/LC_MESSAGES/monkey-bubble.mo
share/locale/fr/LC_MESSAGES/monkey-bubble.mo
@dirrm share/gnome/omf/monkey-bubble
@dirrm share/gnome/monkey-bubble/sounds
@dirrm share/gnome/monkey-bubble/glade
@dirrm share/gnome/monkey-bubble/gfx/snake
@dirrm share/gnome/monkey-bubble/gfx/number
@ -147,5 +148,10 @@ share/locale/fr/LC_MESSAGES/monkey-bubble.mo
@dirrm share/gnome/monkey-bubble/gfx/bubbles
@dirrm share/gnome/monkey-bubble/gfx
@dirrm share/gnome/monkey-bubble
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/monkey-bubble-game
@dirrm etc/gconf/gconf.xml.defaults/apps/monkey-bubble-game
@dirrm share/gnome/help/monkey-bubble/fr
@dirrm share/gnome/help/monkey-bubble/C
@dirrm share/gnome/help/monkey-bubble
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/monkey-bubble
@dirrm etc/gconf/gconf.xml.defaults/apps/monkey-bubble
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/monkey-bubble/monkey-bubble-C.omf 2>/dev/null || /usr/bin/true
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/monkey-bubble/monkey-bubble-fr.omf 2>/dev/null || /usr/bin/true