Upgrade to 0.8.
PR: ports/182502 Submitted by: maintainer
This commit is contained in:
parent
1fc4a4c21f
commit
fc6ba6c023
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=329526
6 changed files with 34 additions and 106 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= rust
|
||||
PORTVERSION= 0.7
|
||||
PORTVERSION= 0.8
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://static.rust-lang.org/dist/:src \
|
||||
http://static.rust-lang.org/stage0-snapshots/:boot
|
||||
|
@ -15,7 +15,7 @@ COMMENT= A language with a focus on memory safety and concurrency
|
|||
|
||||
RUST_SOURCE= ${DISTNAME}${EXTRACT_SUFX}
|
||||
RUST_BOOT= rust-stage0-${RUST_BOOT_SIG}.tar.bz2
|
||||
RUST_BOOT_SIG= 2013-06-23-f827561-freebsd-x86_64-a05bdda2d9ec0e66336d81b98bee8a95442a501f
|
||||
RUST_BOOT_SIG= 2013-09-23-348d844-freebsd-x86_64-8b99ec197e441f013c5ba0788f8bcfa689bfc75e
|
||||
RUST_TARGET= x86_64-unknown-freebsd
|
||||
|
||||
ONLY_FOR_ARCHS= amd64
|
||||
|
@ -25,9 +25,11 @@ USES= gmake perl5
|
|||
USE_PERL5= build
|
||||
USE_PYTHON_BUILD= 2.6-2.7
|
||||
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
MAN1= rustc.1
|
||||
MAN1= rust.1 \
|
||||
rustc.1 \
|
||||
rustdoc.1 \
|
||||
rusti.1 \
|
||||
rustpkg.1
|
||||
|
||||
OPTIONS_DEFINE= RUSTPKG
|
||||
RUSTPKG_DESC= Build with package manager
|
||||
|
@ -37,18 +39,13 @@ NO_STAGE= yes
|
|||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 900044
|
||||
EXTRA_PATCHES+= ${FILESDIR}/log2.patch \
|
||||
${FILESDIR}/llvm.patch
|
||||
BROKEN= Only compiles on 9.0-RELEASE and later
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} >= 900044
|
||||
LIB_DEPENDS+= unwind:${PORTSDIR}/devel/libunwind
|
||||
CC= clang
|
||||
CXX= clang++
|
||||
CONFIGURE_ARGS+= --enable-clang
|
||||
.else
|
||||
USE_GCC= yes
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MRUSTPKG}
|
||||
RUN_DEPENDS+= git:${PORTSDIR}/devel/git
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
SHA256 (rust-0.7.tar.gz) = 0b88b8a4489382e0a69214eaab88e2e7c316ec33c164af0d3b53630b17590df0
|
||||
SIZE (rust-0.7.tar.gz) = 14494878
|
||||
SHA256 (rust-stage0-2013-06-23-f827561-freebsd-x86_64-a05bdda2d9ec0e66336d81b98bee8a95442a501f.tar.bz2) = 7fb723176c88539311692406f80817300f87560d47f96d229ab5efa527cc6fe2
|
||||
SIZE (rust-stage0-2013-06-23-f827561-freebsd-x86_64-a05bdda2d9ec0e66336d81b98bee8a95442a501f.tar.bz2) = 19028080
|
||||
SHA256 (rust-0.8.tar.gz) = 42f791ab1537357fe0f63d67ffe6bcb64ecf16b2bd3f1484ab589823f5914182
|
||||
SIZE (rust-0.8.tar.gz) = 16720822
|
||||
SHA256 (rust-stage0-2013-09-23-348d844-freebsd-x86_64-8b99ec197e441f013c5ba0788f8bcfa689bfc75e.tar.bz2) = 5e55044af98f5d7489cd2231736f48c18fa945639de75d1a0cf5565f17eabd01
|
||||
SIZE (rust-stage0-2013-09-23-348d844-freebsd-x86_64-8b99ec197e441f013c5ba0788f8bcfa689bfc75e.tar.bz2) = 21350020
|
||||
|
|
|
@ -1,8 +0,0 @@
|
|||
--- src/llvm/unittests/ExecutionEngine/JIT/JITTests.def.orig 2013-07-09 08:30:41.112596275 +0800
|
||||
+++ src/llvm/unittests/ExecutionEngine/JIT/JITTests.def 2013-07-09 09:57:30.773783840 +0800
|
||||
@@ -2,3 +2,5 @@
|
||||
getPointerToNamedFunction
|
||||
JITTest_AvailableExternallyFunction
|
||||
JITTest_AvailableExternallyGlobal
|
||||
+__progname
|
||||
+environ
|
|
@ -1,62 +0,0 @@
|
|||
--- src/libstd/num/cmath.rs.orig 2013-07-09 10:33:09.079593770 +0800
|
||||
+++ src/libstd/num/cmath.rs 2013-07-09 10:33:30.174857926 +0800
|
||||
@@ -66,7 +66,6 @@
|
||||
// renamed: to be consitent with log as ln
|
||||
#[link_name="log1p"] unsafe fn ln_1p(n: c_double) -> c_double;
|
||||
unsafe fn log10(n: c_double) -> c_double;
|
||||
- unsafe fn log2(n: c_double) -> c_double;
|
||||
#[link_name="ilogb"] unsafe fn ilog_radix(n: c_double) -> c_int;
|
||||
unsafe fn modf(n: c_double, iptr: &mut c_double) -> c_double;
|
||||
unsafe fn pow(n: c_double, e: c_double) -> c_double;
|
||||
@@ -150,7 +149,6 @@
|
||||
#[link_name="logf"] unsafe fn ln(n: c_float) -> c_float;
|
||||
#[link_name="logbf"] unsafe fn log_radix(n: c_float) -> c_float;
|
||||
#[link_name="log1pf"] unsafe fn ln_1p(n: c_float) -> c_float;
|
||||
- #[link_name="log2f"] unsafe fn log2(n: c_float) -> c_float;
|
||||
#[link_name="log10f"] unsafe fn log10(n: c_float) -> c_float;
|
||||
#[link_name="ilogbf"] unsafe fn ilog_radix(n: c_float) -> c_int;
|
||||
#[link_name="modff"] unsafe fn modf(n: c_float,
|
||||
--- src/libstd/num/f32.rs.orig 2013-07-09 10:33:13.385594163 +0800
|
||||
+++ src/libstd/num/f32.rs 2013-07-09 10:43:27.147593687 +0800
|
||||
@@ -60,7 +60,6 @@
|
||||
fn floor(x: f32) -> f32 = intrinsics::floorf32,
|
||||
fn ln(n: f32) -> f32 = intrinsics::logf32,
|
||||
fn log10(n: f32) -> f32 = intrinsics::log10f32,
|
||||
- fn log2(n: f32) -> f32 = intrinsics::log2f32,
|
||||
fn mul_add(a: f32, b: f32, c: f32) -> f32 = intrinsics::fmaf32,
|
||||
fn pow(n: f32, e: f32) -> f32 = intrinsics::powf32,
|
||||
fn powi(n: f32, e: c_int) -> f32 = intrinsics::powif32,
|
||||
@@ -158,6 +157,11 @@
|
||||
if x <= y || y.is_NaN() { x } else { y }
|
||||
}
|
||||
|
||||
+#[inline]
|
||||
+pub fn log2(n: f32) -> f32 {
|
||||
+ ln(n) / consts::ln_2
|
||||
+}
|
||||
+
|
||||
|
||||
// FIXME (#1999): replace the predicates below with llvm intrinsics or
|
||||
// calls to the libmath macros in the rust runtime for performance.
|
||||
--- src/libstd/num/f64.rs.orig 2013-07-09 10:33:18.415594640 +0800
|
||||
+++ src/libstd/num/f64.rs 2013-07-09 10:41:42.289594525 +0800
|
||||
@@ -62,7 +62,6 @@
|
||||
fn floor(x: f64) -> f64 = intrinsics::floorf64,
|
||||
fn ln(n: f64) -> f64 = intrinsics::logf64,
|
||||
fn log10(n: f64) -> f64 = intrinsics::log10f64,
|
||||
- fn log2(n: f64) -> f64 = intrinsics::log2f64,
|
||||
fn mul_add(a: f64, b: f64, c: f64) -> f64 = intrinsics::fmaf64,
|
||||
fn pow(n: f64, e: f64) -> f64 = intrinsics::powf64,
|
||||
fn powi(n: f64, e: c_int) -> f64 = intrinsics::powif64,
|
||||
@@ -184,6 +183,11 @@
|
||||
if x <= y || y.is_NaN() { x } else { y }
|
||||
}
|
||||
|
||||
+#[inline]
|
||||
+pub fn log2(n: f64) -> f64 {
|
||||
+ ln(n) / consts::ln_2
|
||||
+}
|
||||
+
|
||||
// FIXME (#1999): add is_normal, is_subnormal, and fpclassify
|
||||
|
||||
/* Module: consts */
|
|
@ -1,14 +1,14 @@
|
|||
--- configure.orig 2013-04-06 12:44:15.918202587 +0800
|
||||
+++ configure 2013-04-06 12:45:10.302044128 +0800
|
||||
@@ -401,7 +401,6 @@
|
||||
--- configure.orig 2013-09-27 13:30:39.473857288 +0800
|
||||
+++ configure 2013-09-27 13:30:56.427856617 +0800
|
||||
@@ -405,7 +405,6 @@
|
||||
step_msg "looking for build programs"
|
||||
|
||||
probe_need CFG_PERL perl
|
||||
-probe_need CFG_CURL curl
|
||||
-probe_need CFG_CURLORWGET curl wget
|
||||
probe_need CFG_PYTHON python2.7 python2.6 python2 python
|
||||
|
||||
python_version=$($CFG_PYTHON -V 2>&1)
|
||||
@@ -511,15 +510,6 @@
|
||||
@@ -520,15 +519,6 @@
|
||||
fi
|
||||
fi
|
||||
|
||||
|
|
|
@ -3,26 +3,27 @@ bin/rustc
|
|||
bin/rustdoc
|
||||
bin/rusti
|
||||
%%RUSTPKG%%bin/rustpkg
|
||||
lib/libextra-a7c050cfd46b2c9a-0.7.so
|
||||
lib/librust-8d2fe0c0fe8188b-0.7.so
|
||||
lib/librustc-d3cb8c2ccd84a7a7-0.7.so
|
||||
lib/librustdoc-6b49af4948607d84-0.7.so
|
||||
lib/librusti-53e0ef2ae196aaff-0.7.so
|
||||
lib/libextra-a7c050cfd46b2c9a-0.8.so
|
||||
lib/librust-5828c92a27389871-0.8.so
|
||||
lib/librustc-d3cb8c2ccd84a7a7-0.8.so
|
||||
lib/librustdoc-a437806a76c5f37a-0.8.so
|
||||
lib/librusti-53e0ef2ae196aaff-0.8.so
|
||||
lib/librustllvm.so
|
||||
lib/librustpkg-38a86178bd95e7e1-0.7.so
|
||||
lib/librustpkg-45c3eae3148fd21-0.8.so
|
||||
lib/librustrt.so
|
||||
lib/libstd-6c65cf4b443341b1-0.7.so
|
||||
lib/libsyntax-64629f7f0c6a9bc-0.7.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/libextra-a7c050cfd46b2c9a-0.7.so
|
||||
lib/libstd-6c65cf4b443341b1-0.8.so
|
||||
lib/libsyntax-64629f7f0c6a9bc-0.8.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/libextra-a7c050cfd46b2c9a-0.8.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/libmorestack.a
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/librust-8d2fe0c0fe8188b-0.7.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/librustc-d3cb8c2ccd84a7a7-0.7.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/librustdoc-6b49af4948607d84-0.7.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/librusti-53e0ef2ae196aaff-0.7.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/librustpkg-38a86178bd95e7e1-0.7.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/librust-5828c92a27389871-0.8.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/librustc-d3cb8c2ccd84a7a7-0.8.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/librustdoc-a437806a76c5f37a-0.8.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/librusti-53e0ef2ae196aaff-0.8.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/librustllvm.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/librustpkg-45c3eae3148fd21-0.8.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/librustrt.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/libstd-6c65cf4b443341b1-0.7.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/libsyntax-64629f7f0c6a9bc-0.7.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/libstd-6c65cf4b443341b1-0.8.so
|
||||
lib/rustc/x86_64-unknown-freebsd/lib/libsyntax-64629f7f0c6a9bc-0.8.so
|
||||
@dirrm lib/rustc/x86_64-unknown-freebsd/lib
|
||||
@dirrm lib/rustc/x86_64-unknown-freebsd
|
||||
@dirrm lib/rustc
|
||||
|
|
Loading…
Reference in a new issue