Initial import of qmailanalog version 0.70.
A collection of tools to analyze qmail-send's activity. PR: 8900 Submitted by: Neil Blakey-Milner <nbm@rucus.ru.ac.za>
This commit is contained in:
parent
a63d37261e
commit
fc76415ee8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=18373
6 changed files with 118 additions and 0 deletions
56
mail/qmailanalog/Makefile
Normal file
56
mail/qmailanalog/Makefile
Normal file
|
@ -0,0 +1,56 @@
|
|||
# New ports collection makefile for: qmailanalog
|
||||
# Version required: 0.70
|
||||
# Date created: 29 November 1998
|
||||
# Whom: Neil Blakey-Milner <nbm@rucus.ru.ac.za>
|
||||
#
|
||||
# $Id$
|
||||
|
||||
DISTNAME= qmailanalog-0.70
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ftp://ftp.qmail.org/pub/software/
|
||||
|
||||
MAINTAINER= ports@freebsd.org
|
||||
|
||||
RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail
|
||||
|
||||
ALL_TARGET= it
|
||||
INSTALL_TARGET= setup
|
||||
|
||||
MANPREFIX= ${QMPREFIX}
|
||||
MAN1= matchup.1 xqp.1 xsender.1 xrecipient.1 columnt.1
|
||||
|
||||
PLIST_SUB+= MYSUBDIR=${MYSUBDIR}
|
||||
|
||||
DIFF_MSG= Cannot Make and Install with different PREFIX or QMAIL_DIR
|
||||
|
||||
.if exists(${PREFIX}/qmail/bin/qmail-send)
|
||||
QMAIL_DIR?= ${PREFIX}/qmail
|
||||
.else
|
||||
QMAIL_DIR?= /var/qmail
|
||||
.endif
|
||||
|
||||
.if !defined(NOSUBDIR)
|
||||
MYSUBDIR?= qmailanalog/
|
||||
.else
|
||||
MYSUBDIR?=
|
||||
.endif
|
||||
|
||||
QMPREFIX?= ${PREFIX}/${MYSUBDIR}
|
||||
|
||||
NO_MTREE= yes
|
||||
|
||||
post-patch:
|
||||
@perl -pi.bak -e "s|.usr.local.qmailanalog|${QMPREFIX}|" ${WRKSRC}/conf-home
|
||||
@perl -pi.bak -e "s|-O2|${CFLAGS}|" ${WRKSRC}/conf-cc
|
||||
@perl -pi.bak -e '$$_ = "" if /cat/' ${WRKSRC}/hier.c
|
||||
@echo ${PREFIX} > ${WRKDIR}/.PPREFIX
|
||||
@echo ${QMAIL_DIR} >> ${WRKDIR}/.PPREFIX
|
||||
|
||||
pre-install:
|
||||
@echo ${PREFIX} > ${WRKDIR}/.IPREFIX
|
||||
@echo ${QMAIL_DIR} >> ${WRKDIR}/.IPREFIX
|
||||
@diff ${WRKDIR}/.[PI]PREFIX > /dev/null \
|
||||
|| (echo ${DIFF_MSG} && exit 1)
|
||||
@mkdir -p ${QMPREFIX}
|
||||
|
||||
.include <bsd.port.mk>
|
1
mail/qmailanalog/distinfo
Normal file
1
mail/qmailanalog/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (qmailanalog-0.70.tar.gz) = 84a3d44cbf2dbd88e8b97edd98c65732
|
11
mail/qmailanalog/files/patch-aa
Normal file
11
mail/qmailanalog/files/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.orig Sun Nov 29 18:06:06 1998
|
||||
+++ Makefile Sun Nov 29 18:06:16 1998
|
||||
@@ -214,7 +214,7 @@
|
||||
./compile instcheck.c
|
||||
|
||||
it: \
|
||||
-man prog install instcheck
|
||||
+prog install instcheck
|
||||
|
||||
load: \
|
||||
make-load warn-auto.sh systype
|
1
mail/qmailanalog/pkg-comment
Normal file
1
mail/qmailanalog/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A collection of tools to analyze qmail-send's activity
|
18
mail/qmailanalog/pkg-descr
Normal file
18
mail/qmailanalog/pkg-descr
Normal file
|
@ -0,0 +1,18 @@
|
|||
qmailanalog is a collection of tools to help you analyze qmail-send's
|
||||
activity record. It supplies statistics to answer a wide variety of
|
||||
questions:
|
||||
|
||||
* overall: how many messages? recipients? attempts? etc.
|
||||
|
||||
* ddist: how soon were 50% of the messages delivered? 90%? 95%? 99%?
|
||||
|
||||
* rxdelay: what's the best order of recipients for mailing lists?
|
||||
|
||||
* recipients, rhosts: who's getting mail? bytes? messages? attempts?
|
||||
|
||||
* successes, failures, deferrals: why? how often? how much delay?
|
||||
|
||||
* senders, suids: messages? bytes? load? recipients? attempts? delay?
|
||||
|
||||
qmailanalog also includes several tools to focus attention on particular
|
||||
senders, recipients, or messages.
|
31
mail/qmailanalog/pkg-plist
Normal file
31
mail/qmailanalog/pkg-plist
Normal file
|
@ -0,0 +1,31 @@
|
|||
%%MYSUBDIR%%bin/matchup
|
||||
%%MYSUBDIR%%bin/columnt
|
||||
%%MYSUBDIR%%bin/zoverall
|
||||
%%MYSUBDIR%%bin/zsendmail
|
||||
%%MYSUBDIR%%bin/xqp
|
||||
%%MYSUBDIR%%bin/xsender
|
||||
%%MYSUBDIR%%bin/xrecipient
|
||||
%%MYSUBDIR%%bin/ddist
|
||||
%%MYSUBDIR%%bin/deferrals
|
||||
%%MYSUBDIR%%bin/failures
|
||||
%%MYSUBDIR%%bin/successes
|
||||
%%MYSUBDIR%%bin/rhosts
|
||||
%%MYSUBDIR%%bin/recipients
|
||||
%%MYSUBDIR%%bin/rxdelay
|
||||
%%MYSUBDIR%%bin/senders
|
||||
%%MYSUBDIR%%bin/suids
|
||||
%%MYSUBDIR%%bin/zddist
|
||||
%%MYSUBDIR%%bin/zdeferrals
|
||||
%%MYSUBDIR%%bin/zfailures
|
||||
%%MYSUBDIR%%bin/zsuccesses
|
||||
%%MYSUBDIR%%bin/zrhosts
|
||||
%%MYSUBDIR%%bin/zrecipients
|
||||
%%MYSUBDIR%%bin/zrxdelay
|
||||
%%MYSUBDIR%%bin/zsenders
|
||||
%%MYSUBDIR%%bin/zsuids
|
||||
%%MYSUBDIR%%doc/MATCHUP
|
||||
%%MYSUBDIR%%doc/ACCOUNTING
|
||||
@dirrm %%MYSUBDIR%%doc
|
||||
@dirrm %%MYSUBDIR%%bin
|
||||
@dirrm %%MYSUBDIR%%man/man1
|
||||
@dirrm %%MYSUBDIR%%man
|
Loading…
Reference in a new issue