Really add xoj back to head. (The previous one went to the vendor branch....)

This commit is contained in:
Satoshi Asami 2000-01-03 09:45:37 +00:00
parent 2bad83f0ad
commit fc772f9f89
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=24382
7 changed files with 57 additions and 0 deletions

View file

@ -194,6 +194,7 @@
SUBDIR += xnibbles
SUBDIR += xoct
SUBDIR += xoids
SUBDIR += xoj
SUBDIR += xonix
SUBDIR += xosmulti
SUBDIR += xothello

22
games/xoj/Makefile Normal file
View file

@ -0,0 +1,22 @@
# New ports collection makefile for: xoj
# Version required: 1.0
# Date created: 30 March 1998
# Whom: Andrey Zakhvatov
#
# $FreeBSD$
#
DISTNAME= xoj-1.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= X11/demos
EXTRACT_SUFX= .tgz
MAINTAINER= andy@icc.surw.chel.su
USE_IMAKE= yes
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/xoj ${PREFIX}/bin
.include <bsd.port.mk>

1
games/xoj/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (xoj-1.0.tgz) = 590e0d06454812a0714482b9831841b7

28
games/xoj/files/patch-aa Normal file
View file

@ -0,0 +1,28 @@
--- xoj.c.orig Tue Jul 26 09:10:19 1994
+++ xoj.c Sun Dec 19 22:32:12 1999
@@ -106,7 +106,9 @@
void UpdateCop();
void DrawCop();
void EraseCop();
+#ifndef __FreeBSD__
void usleep();
+#endif
Pixel AllocNamedColor();
void
@@ -584,6 +586,7 @@
/*
* sleep for a number of micro-seconds
*/
+#ifndef __FreeBSD__
void usleep(usec)
unsigned long usec;
{
@@ -596,6 +599,7 @@
select(0, (void *)0, (void *)0, (void *)0, &t);
#endif
}
+#endif

1
games/xoj/pkg-comment Normal file
View file

@ -0,0 +1 @@
O. J. Simpson Simulator root window demo

3
games/xoj/pkg-descr Normal file
View file

@ -0,0 +1,3 @@
Another root window demo. Lots of pretty icons scurry around
your screen, chasing O.J. Simpson and degrading your systems
performance no doubt! "Relive the experience".

1
games/xoj/pkg-plist Normal file
View file

@ -0,0 +1 @@
bin/xoj