- update libnet to 1.1.6
- build shared lib - fix dependend ports when libnet.so.8 was linked in - fix dependend ports when includes where missing
This commit is contained in:
parent
154ea12c2b
commit
fcb98a504a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=312526
32 changed files with 175 additions and 249 deletions
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= ettercap
|
||||
PORTVERSION= 0.7.4.1
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net-mgmt security
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}-Lazarus \
|
||||
|
@ -12,7 +12,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}-Lazarus \
|
|||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= A network sniffer/interceptor/injector/logger for switched LANs
|
||||
|
||||
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
|
||||
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
|
||||
|
||||
# GTK -> GTK2, ICONV -> UTF8
|
||||
OPTIONS_DEFINE= DOCS GTK2 PCRE PLUGINS SSL UTF8
|
||||
|
@ -43,7 +43,7 @@ LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
|
|||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MGTK2}
|
||||
PKGNAMESUFFIX+= -gtk2
|
||||
PKGNAMESUFFIX?= -gtk2
|
||||
CONFIGURE_ARGS+=--enable-gtk
|
||||
USE_GNOME= atk glib20 gtk20 pango
|
||||
.else
|
||||
|
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= isic
|
||||
PORTVERSION= 0.07
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= net-mgmt
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/ISIC%20v${PORTVERSION}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
@ -15,7 +15,7 @@ EXTRACT_SUFX= .tgz
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= IP Stack Integrity Checker
|
||||
|
||||
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
|
||||
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
|
18
net-mgmt/isic/files/patch-isic.h
Normal file
18
net-mgmt/isic/files/patch-isic.h
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- isic.h.orig 2006-12-16 01:08:44.000000000 +0100
|
||||
+++ isic.h 2013-02-18 07:36:38.000000000 +0100
|
||||
@@ -5,11 +5,15 @@
|
||||
#endif
|
||||
|
||||
#include <libnet.h>
|
||||
+#include <libnet/libnet-headers.h>
|
||||
|
||||
+#include <netinet/ip.h>
|
||||
#include <netinet/ip_icmp.h>
|
||||
#include <netinet/icmp6.h>
|
||||
#include <netinet/ip6.h>
|
||||
#include <netinet/if_ether.h>
|
||||
+#include <netinet/udp.h>
|
||||
+#include <netinet/tcp.h>
|
||||
|
||||
#ifndef ETHER_FRAME_SIZE
|
||||
#define ETHER_FRAME_SIZE 1500
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= packit
|
||||
PORTVERSION= 1.0
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= net-mgmt
|
||||
MASTER_SITES= http://packit.sourceforge.net/downloads/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
@ -15,7 +15,7 @@ EXTRACT_SUFX= .tgz
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Network auditing tool
|
||||
|
||||
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
|
||||
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CPPFLAGS+= `${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --cflags`
|
||||
|
|
|
@ -6,14 +6,14 @@
|
|||
|
||||
PORTNAME= pixilate
|
||||
PORTVERSION= 0.4.2
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= net-mgmt
|
||||
MASTER_SITES= SF/winfingerprint/${PORTNAME}/${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Generates packets to match a list of Cisco PIX access lists
|
||||
|
||||
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
|
||||
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
|
||||
|
||||
WRKSRC= ${WRKDIR}/pixilate
|
||||
|
||||
|
|
|
@ -8,7 +8,7 @@
|
|||
|
||||
PORTNAME= arp-sk
|
||||
PORTVERSION= 0.0.16
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://sid.rstack.org/arp-sk/files/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
@ -16,7 +16,7 @@ EXTRACT_SUFX= .tgz
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A tool designed to manipulate ARP tables of all kinds of equipment
|
||||
|
||||
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
|
||||
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CFLAGS+= `${LIBNET_CONFIG} --cflags`
|
||||
|
|
|
@ -7,14 +7,14 @@
|
|||
|
||||
PORTNAME= arping
|
||||
PORTVERSION= 2.09
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.habets.pp.se/synscan/files/
|
||||
|
||||
MAINTAINER= gavin@FreeBSD.org
|
||||
COMMENT= ARP level "ping" utility
|
||||
|
||||
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
|
||||
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= LIBS="`${LIBNET_CONFIG} --libs` -lpcap"
|
||||
|
|
|
@ -7,14 +7,14 @@
|
|||
|
||||
PORTNAME= arprelease
|
||||
PORTVERSION= 1.2
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= SF
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Libnet tool to flush arp cache entries from devices (eg. routers)
|
||||
|
||||
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
|
||||
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
|
|
|
@ -5,14 +5,14 @@
|
|||
|
||||
PORTNAME= gspoof
|
||||
PORTVERSION= 3.2
|
||||
PORTREVISION= 14
|
||||
PORTREVISION= 15
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= SF/${PORTNAME}/Gspoof-3/${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Console/GTK+ TCP/IP Packets Forger
|
||||
|
||||
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
|
||||
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
|
||||
|
||||
USE_GNOME= gtk20
|
||||
USE_GMAKE= yes
|
||||
|
|
|
@ -2,39 +2,84 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libnet
|
||||
PORTVERSION= 1.1.2.1
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 1.1.6
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.packetfactory.net/libnet/dist/ \
|
||||
${MASTER_SITE_GENTOO}
|
||||
MASTER_SITES= SF/libnet-dev
|
||||
MASTER_SITE_SUBDIR= distfiles
|
||||
PKGNAMESUFFIX= 11
|
||||
PKGNAMESUFFIX= 11${PKGNAMESUFFIX2}
|
||||
|
||||
MAINTAINER= dinoex@FreeBSD.org
|
||||
COMMENT= A C library for creating IP packets
|
||||
|
||||
LATEST_LINK= ${PORTNAME}${SHORT_VER}
|
||||
|
||||
USE_AUTOTOOLS= libtool
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CFLAGS+= -fPIC
|
||||
USE_CSTD= gnu89
|
||||
#CFLAGS+= -fPIC
|
||||
#USE_CSTD= gnu89
|
||||
CONFIGURE_ARGS= --with-link-layer=${LIBNET_LINK}
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
|
||||
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}${PKGNAMESUFFIX}
|
||||
SHORT_VER= 11
|
||||
SHORT_NAME= ${PORTNAME}${SHORT_VER}
|
||||
DOCSDIR= ${PREFIX}/share/doc/${SHORT_NAME}
|
||||
EXAMPLESDIR= ${PREFIX}/share/examples/${SHORT_NAME}
|
||||
USE_LDCONFIG= ${PREFIX}/lib/${SHORT_NAME}
|
||||
PLIST_SUB= SVER=${SHORT_VER} SNAME=${SHORT_NAME} VERSION=${PORTVERSION}
|
||||
|
||||
DOCS= README doc/BUGS doc/CHANGELOG doc/CONTRIB doc/COPYING \
|
||||
MAN3= libnet-functions.h.3 libnet-macros.h.3 libnet.h.3
|
||||
DOCS= README doc/CHANGELOG doc/CONTRIB doc/COPYING \
|
||||
doc/DESIGN_NOTES doc/MIGRATION doc/PACKET_BUILDING doc/PORTED \
|
||||
doc/RAWSOCKET_NON_SEQUITUR doc/TODO doc/html/*
|
||||
doc/RAWSOCKET_NON_SEQUITUR doc/TODO
|
||||
EXAMPLES= sample/*.c
|
||||
|
||||
OPTIONS_DEFINE= EXAMPLES DOCS
|
||||
OPTIONS_RADIO= LINK
|
||||
OPTIONS_RADIO_LINK= SNOOP PF BPF
|
||||
OPTIONS_DEFAULT= BPF
|
||||
SNOOP_DESC= link layer (snoop.h)
|
||||
PF_DESC= link layer pf
|
||||
BPF_DESC= link layer bpf
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
LIBNET_LINK= none
|
||||
|
||||
.if ${PORT_OPTIONS:MSNOOP}
|
||||
LIBNET_LINK= snoop
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MPF}
|
||||
LIBNET_LINK= pf
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MBPF}
|
||||
LIBNET_LINK= bpf
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} \
|
||||
-e 's|@LIBNET_CONFIG_LIBS@|@LIBNET_CONFIG_LIBS@ -L@prefix@/lib/${SHORT_NAME}|' \
|
||||
-e 's|@LIBNET_CONFIG_CFLAGS@|@LIBNET_CONFIG_CFLAGS@ -I@prefix@/include/${SHORT_NAME}|' \
|
||||
${WRKSRC}/libnet-config.in
|
||||
${REINPLACE_CMD} -e 's|^includedir =.*|includedir = @includedir@/${SHORT_NAME}|' \
|
||||
${WRKSRC}/include/Makefile.in \
|
||||
${WRKSRC}/include/libnet/Makefile.in
|
||||
${REINPLACE_CMD} -e 's|^libdir =.*|libdir = @libdir@/${SHORT_NAME}|' \
|
||||
-e 's|^libnet_la_LDFLAGS =\(.*\)|libnet_la_LDFLAGS =\1 -soname=libnet-${SHORT_NAME}.so.1|' \
|
||||
${WRKSRC}/src/Makefile.in
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/libnet-config \
|
||||
${PREFIX}/bin/libnet${PKGNAMESUFFIX}-config
|
||||
.if !defined(NOPORTEXAMPLES)
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/libnet-config ${PREFIX}/bin/${SHORT_NAME}-config
|
||||
@cd ${PREFIX}/lib && \
|
||||
${LN} -sf ${SHORT_NAME}/libnet.so libnet-${PORTVERSION}.so.8 && \
|
||||
${LN} -sf libnet-${PORTVERSION}.so.8 libnet-${PORTVERSION}.so
|
||||
.if ${PORT_OPTIONS:MEXAMPLES}
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
|
||||
.endif
|
||||
.if !defined(NOPORTDOCS)
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
|
||||
.endif
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (libnet-1.1.2.1.tar.gz) = ab01882a3d0556176018c09342cd0731f7cbc8e687795009894c3326942c76ff
|
||||
SIZE (libnet-1.1.2.1.tar.gz) = 1021236
|
||||
SHA256 (libnet-1.1.6.tar.gz) = d392bb5825c4b6b672fc93a0268433c86dc964e1500c279dc6d0711ea6ec467a
|
||||
SIZE (libnet-1.1.6.tar.gz) = 1202970
|
||||
|
|
10
net/libnet/files/patch-Makefile.in
Normal file
10
net/libnet/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- ./Makefile.in.orig Thu Dec 2 21:27:39 2004
|
||||
+++ ./Makefile.in Sat Jan 20 14:10:35 2007
|
||||
@@ -208,7 +208,6 @@
|
||||
DISTCLEANFILES = *~
|
||||
SUBDIRS = include src sample
|
||||
EXTRA_DIST = Makefile.am.common
|
||||
-bin_SCRIPTS = libnet-config
|
||||
all: all-recursive
|
||||
|
||||
.SUFFIXES:
|
|
@ -1,80 +0,0 @@
|
|||
|
||||
--- configure.orig 2004-03-02 04:02:37.000000000 +0800
|
||||
+++ configure 2008-04-29 11:48:34.000000000 +0800
|
||||
@@ -3852,38 +3852,10 @@
|
||||
echo "$as_me:$LINENO: checking link-layer packet interface type" >&5
|
||||
echo $ECHO_N "checking link-layer packet interface type... $ECHO_C" >&6
|
||||
|
||||
-if test -r /dev/bpf0 ; then
|
||||
- LIBOBJS="$LIBOBJS libnet_link_bpf.$ac_objext"
|
||||
- echo "$as_me:$LINENO: result: found bpf" >&5
|
||||
+#if test -r /dev/bpf0 ; then
|
||||
+LIBOBJS="$LIBOBJS libnet_link_bpf.$ac_objext"
|
||||
+echo "$as_me:$LINENO: result: bpf has been here evar since da world began ..." >&5
|
||||
echo "${ECHO_T}found bpf" >&6
|
||||
-elif test -r /usr/include/net/pfilt.h ; then
|
||||
- LIBOBJS="$LIBOBJS libnet_link_pf.$ac_objext"
|
||||
- echo "$as_me:$LINENO: result: found pf" >&5
|
||||
-echo "${ECHO_T}found pf" >&6
|
||||
-elif test -r /dev/nit ; then
|
||||
- LIBOBJS="$LIBOBJS libnet_link_snit.$ac_objext"
|
||||
- echo "$as_me:$LINENO: result: found snit" >&5
|
||||
-echo "${ECHO_T}found snit" >&6
|
||||
-elif test -r /usr/include/sys/net/nit.h ; then
|
||||
- LIBOBJS="$LIBOBJS libnet_link_nit.$ac_objext"
|
||||
- echo "$as_me:$LINENO: result: found nit" >&5
|
||||
-echo "${ECHO_T}found nit" >&6
|
||||
-elif test -r /usr/include/net/raw.h ; then
|
||||
- LIBOBJS="$LIBOBJS libnet_link_snoop.$ac_objext"
|
||||
- echo "$as_me:$LINENO: result: found snoop" >&5
|
||||
-echo "${ECHO_T}found snoop" >&6
|
||||
-elif test -r /usr/include/sys/dlpi.h ; then
|
||||
- LIBOBJS="$LIBOBJS libnet_link_dlpi.$ac_objext"
|
||||
- echo "$as_me:$LINENO: result: found dlpi" >&5
|
||||
-echo "${ECHO_T}found dlpi" >&6
|
||||
- cat >>confdefs.h <<\_ACEOF
|
||||
-#define HAVE_DLPI 1
|
||||
-_ACEOF
|
||||
-
|
||||
-elif test -r /usr/include/linux/socket.h ; then
|
||||
- LIBOBJS="$LIBOBJS libnet_link_linux.$ac_objext"
|
||||
- echo "$as_me:$LINENO: result: found linux primitives" >&5
|
||||
-echo "${ECHO_T}found linux primitives" >&6
|
||||
|
||||
echo "$as_me:$LINENO: checking for packet socket (PF_SOCKET)" >&5
|
||||
echo $ECHO_N "checking for packet socket (PF_SOCKET)... $ECHO_C" >&6
|
||||
@@ -3987,32 +3959,6 @@
|
||||
|
||||
echo "$as_me:$LINENO: result: $ac_cv_libnet_linux_procfs" >&5
|
||||
echo "${ECHO_T}$ac_cv_libnet_linux_procfs" >&6
|
||||
- if test $ac_cv_libnet_linux_procfs = yes ; then
|
||||
-
|
||||
-cat >>confdefs.h <<\_ACEOF
|
||||
-#define HAVE_LINUX_PROCFS 1
|
||||
-_ACEOF
|
||||
-
|
||||
- fi
|
||||
-elif test -c /dev/bpf0 ; then # check again in case not readable
|
||||
- LIBOBJS="$LIBOBJS libnet_link_bpf.$ac_objext"
|
||||
- echo "$as_me:$LINENO: result: found bpf" >&5
|
||||
-echo "${ECHO_T}found bpf" >&6
|
||||
-elif test -c /dev/nit ; then # check again in case not readable
|
||||
- LIBOBJS="$LIBOBJS libnet_link_snit.$ac_objext"
|
||||
- echo "$as_me:$LINENO: result: found snit" >&5
|
||||
-echo "${ECHO_T}found snit" >&6
|
||||
-elif test "$target_os" = "cygwin" ; then
|
||||
- LIBOBJS="$LIBOBJS libnet_link_win32.$ac_objext"
|
||||
- echo "$as_me:$LINENO: result: found win32 wpcap" >&5
|
||||
-echo "${ECHO_T}found win32 wpcap" >&6
|
||||
-else
|
||||
- LIBOBJS="$LIBOBJS libnet_link_none.$ac_objext"
|
||||
- { echo "$as_me:$LINENO: WARNING: could not find a link-layer packet interface" >&5
|
||||
-echo "$as_me: WARNING: could not find a link-layer packet interface" >&2;}
|
||||
- { echo "$as_me:$LINENO: WARNING: link-layer packet injection will not be available" >&5
|
||||
-echo "$as_me: WARNING: link-layer packet injection will not be available" >&2;}
|
||||
-fi
|
||||
|
||||
echo -n "scanning available packet construction modules: "
|
||||
for dir in src/*build*c ; do
|
||||
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- ./include/Makefile.in.orig Thu Mar 11 15:50:20 2004
|
||||
+++ ./include/Makefile.in Tue Sep 26 15:23:43 2006
|
||||
@@ -40,7 +40,7 @@
|
||||
libdir = @libdir@
|
||||
infodir = @infodir@
|
||||
mandir = @mandir@
|
||||
-includedir = @includedir@
|
||||
+includedir = @includedir@/libnet11
|
||||
oldincludedir = /usr/include
|
||||
pkgdatadir = $(datadir)/@PACKAGE@
|
||||
pkglibdir = $(libdir)/@PACKAGE@
|
|
@ -1,11 +0,0 @@
|
|||
--- ./include/libnet/Makefile.in.orig Thu Mar 11 15:50:20 2004
|
||||
+++ ./include/libnet/Makefile.in Tue Sep 26 15:19:23 2006
|
||||
@@ -40,7 +40,7 @@
|
||||
libdir = @libdir@
|
||||
infodir = @infodir@
|
||||
mandir = @mandir@
|
||||
-includedir = @includedir@
|
||||
+includedir = @includedir@/libnet11
|
||||
oldincludedir = /usr/include
|
||||
pkgdatadir = $(datadir)/@PACKAGE@
|
||||
pkglibdir = $(libdir)/@PACKAGE@
|
|
@ -1,13 +0,0 @@
|
|||
--- ./libnet-config.in.orig Sat Jan 3 17:31:00 2004
|
||||
+++ ./libnet-config.in Tue Sep 26 15:19:23 2006
|
||||
@@ -8,8 +8,8 @@
|
||||
# @configure_input@
|
||||
|
||||
libnet_defines="@LIBNET_CONFIG_DEFINES@"
|
||||
-libnet_cflags="@LIBNET_CONFIG_CFLAGS@"
|
||||
-libnet_libs="@LIBNET_CONFIG_LIBS@ -lnet"
|
||||
+libnet_cflags="@LIBNET_CONFIG_CFLAGS@ -I@prefix@/include/libnet11"
|
||||
+libnet_libs="@LIBNET_CONFIG_LIBS@ -L@prefix@/lib/libnet11 -lnet"
|
||||
|
||||
usage()
|
||||
{
|
12
net/libnet/files/patch-libnet.h.in
Normal file
12
net/libnet/files/patch-libnet.h.in
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- include/libnet.h.in.orig 2012-03-06 01:45:46.000000000 +0100
|
||||
+++ include/libnet.h.in 2012-04-18 20:37:06.000000000 +0200
|
||||
@@ -81,6 +81,9 @@
|
||||
#if !defined(__WIN32__)
|
||||
# include <sys/socket.h>
|
||||
# include <net/if.h>
|
||||
+# if (__FreeBSD__)
|
||||
+# include <netinet/in.h>
|
||||
+# endif
|
||||
#else /* __WIN32__ */
|
||||
# if (__CYGWIN__)
|
||||
# include <sys/socket.h>
|
|
@ -1,23 +0,0 @@
|
|||
--- src/libnet_checksum.c.orig Mon Mar 1 22:26:12 2004
|
||||
+++ src/libnet_checksum.c Mon Aug 25 15:44:12 2008
|
||||
@@ -42,8 +42,10 @@
|
||||
libnet_in_cksum(u_int16_t *addr, int len)
|
||||
{
|
||||
int sum;
|
||||
+ u_int16_t last_byte;
|
||||
|
||||
sum = 0;
|
||||
+ last_byte = 0;
|
||||
|
||||
while (len > 1)
|
||||
{
|
||||
@@ -52,7 +54,8 @@
|
||||
}
|
||||
if (len == 1)
|
||||
{
|
||||
- sum += *(u_int16_t *)addr;
|
||||
+ *(u_int8_t*)&last_byte = *(u_int8_t*)addr;
|
||||
+ sum += last_byte;
|
||||
}
|
||||
|
||||
return (sum);
|
|
@ -1,11 +0,0 @@
|
|||
--- ./src/Makefile.in.orig Thu Mar 11 15:50:20 2004
|
||||
+++ ./src/Makefile.in Tue Sep 26 15:19:23 2006
|
||||
@@ -43,7 +43,7 @@
|
||||
sysconfdir = @sysconfdir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
localstatedir = @localstatedir@
|
||||
-libdir = @libdir@
|
||||
+libdir = @libdir@/libnet11
|
||||
infodir = @infodir@
|
||||
mandir = @mandir@
|
||||
includedir = @includedir@
|
|
@ -1,13 +1,17 @@
|
|||
bin/libnet11-config
|
||||
include/libnet11/libnet.h
|
||||
include/libnet11/libnet/libnet-asn1.h
|
||||
include/libnet11/libnet/libnet-functions.h
|
||||
include/libnet11/libnet/libnet-headers.h
|
||||
include/libnet11/libnet/libnet-macros.h
|
||||
include/libnet11/libnet/libnet-structures.h
|
||||
include/libnet11/libnet/libnet-types.h
|
||||
lib/libnet11/libnet.a
|
||||
%%PORTDOCS%%%%DOCSDIR%%/BUGS
|
||||
bin/%%SNAME%%-config
|
||||
include/%%SNAME%%/libnet.h
|
||||
include/%%SNAME%%/libnet/libnet-asn1.h
|
||||
include/%%SNAME%%/libnet/libnet-functions.h
|
||||
include/%%SNAME%%/libnet/libnet-headers.h
|
||||
include/%%SNAME%%/libnet/libnet-macros.h
|
||||
include/%%SNAME%%/libnet/libnet-structures.h
|
||||
include/%%SNAME%%/libnet/libnet-types.h
|
||||
lib/%%SNAME%%/libnet.a
|
||||
lib/%%SNAME%%/libnet.la
|
||||
lib/%%SNAME%%/libnet.so
|
||||
lib/%%SNAME%%/libnet.so.8
|
||||
lib/libnet-%%VERSION%%.so
|
||||
lib/libnet-%%VERSION%%.so.8
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CONTRIB
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
||||
|
@ -18,39 +22,6 @@ lib/libnet11/libnet.a
|
|||
%%PORTDOCS%%%%DOCSDIR%%/RAWSOCKET_NON_SEQUITUR
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TODO
|
||||
%%PORTDOCS%%%%DOCSDIR%%/acconfig_8h-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/annotated.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/bpf_8h-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config_8h-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doxygen.css
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doxygen.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/files.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/functions.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/functions_vars.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/getopt_8h-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/globals.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/globals_defs.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/globals_func.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/gnuc_8h-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/graph_legend.dot
|
||||
%%PORTDOCS%%%%DOCSDIR%%/graph_legend.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ifaddrlist_8h-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/in__systm_8h-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libnet-asn1_8h-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libnet-functions_8h-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libnet-functions_8h.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libnet-headers_8h-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libnet-headers_8h.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libnet-macros_8h-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libnet-macros_8h.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libnet-structures_8h-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libnet-types_8h-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libnet_8h-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libnet_8h.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/structlibnet__802__1q__hdr.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/structlibnet__802__1x__hdr.html
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arp-new.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arp.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bgp4_hdr.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bgp4_notification.c
|
||||
|
@ -64,7 +35,9 @@ lib/libnet11/libnet.a
|
|||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fddi_tcp2.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/get_addr.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gre.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hsrp.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/icmp6_echoreq.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/icmp6_unreach.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/icmp_echo_cq.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/icmp_redirect.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/icmp_timeexceed.c
|
||||
|
@ -89,6 +62,9 @@ lib/libnet11/libnet.a
|
|||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synflood6_frag.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tcp1.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tcp2.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_ipv4.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_ipv4_options.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_ipv6_icmpv4.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tftp.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tring_tcp1.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tring_tcp2.c
|
||||
|
@ -96,6 +72,6 @@ lib/libnet11/libnet.a
|
|||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/udp2.c
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm lib/libnet11
|
||||
@dirrm include/libnet11/libnet
|
||||
@dirrm include/libnet11
|
||||
@dirrm lib/%%SNAME%%
|
||||
@dirrm include/%%SNAME%%/libnet
|
||||
@dirrm include/%%SNAME%%
|
||||
|
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= nast
|
||||
PORTVERSION= 0.2.0
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= BERLIOS
|
||||
|
||||
|
@ -17,7 +17,7 @@ COMMENT= A packet sniffer
|
|||
LICENSE= GPLv2 # (or later)
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
|
||||
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
|
||||
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
|
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= pynids
|
||||
PORTVERSION= 0.6.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= net python
|
||||
MASTER_SITES= http://jon.oberheide.org/pynids/downloads/
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -16,7 +17,7 @@ MAINTAINER= corsmith@gmail.com
|
|||
COMMENT= Python interface to libnids
|
||||
|
||||
PATCH_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
|
||||
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
|
||||
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
|
||||
|
||||
USE_GNOME= pkgconfig glib20
|
||||
USE_PYTHON= yes
|
||||
|
|
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= rtpbreak
|
||||
PORTVERSION= 1.3a
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://dallachiesa.com/code/rtpbreak/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
@ -14,7 +15,7 @@ EXTRACT_SUFX= .tgz
|
|||
MAINTAINER= prudhvi-krishna-bsd@surapaneni.in
|
||||
COMMENT= Detects, reconstructs, and analyzes any RTP session
|
||||
|
||||
BUILD_DEPENDS= libnet11-config:${PORTSDIR}/net/libnet
|
||||
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
|
||||
|
||||
MAKE_ARGS+= CFLAGS="-Wall -O3 -I${LOCALBASE}/include/libnet11" \
|
||||
LIBS="-L${LOCALBASE}/lib/libnet11 -lpcap -lnet"
|
||||
|
|
10
net/rtpbreak/files/patch-net.h
Normal file
10
net/rtpbreak/files/patch-net.h
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/net.h.orig 2008-05-05 19:05:21.000000000 +0200
|
||||
+++ src/net.h 2013-02-18 07:48:54.000000000 +0100
|
||||
@@ -26,6 +26,7 @@
|
||||
#include <netdb.h>
|
||||
#include <sys/socket.h>
|
||||
#include <netinet/in.h>
|
||||
+#include <netinet/udp.h>
|
||||
#include <arpa/inet.h>
|
||||
#include <pcap.h>
|
||||
#include <libnet.h>
|
|
@ -12,6 +12,7 @@ MAINTAINER= sbz@FreeBSD.org
|
|||
COMMENT= Various sniffing utilities for penetration testing
|
||||
|
||||
LICENSE= BSD
|
||||
BROKEN= tries to link with both libnet1.0 and libnet1.1
|
||||
|
||||
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10 \
|
||||
${LOCALBASE}/lib/libnids.a:${PORTSDIR}/net/libnids
|
||||
|
|
|
@ -7,16 +7,16 @@
|
|||
|
||||
PORTNAME= fiked
|
||||
PORTVERSION= 0.0.5
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://mirror.roe.ch/dist/fiked/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A fake IKE PSK+XAUTH daemon based on VPNC
|
||||
|
||||
LIB_DEPENDS= gcrypt.18:${PORTSDIR}/security/libgcrypt
|
||||
LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
|
||||
.if !defined(WITHOUT_LIBNET)
|
||||
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
|
||||
LIB_DEPENDS+= net:${PORTSDIR}/net/libnet
|
||||
.endif
|
||||
|
||||
USE_BZIP2= yes
|
||||
|
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= firewalk
|
||||
PORTVERSION= 5.0
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.packetfactory.net/firewalk/dist/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
@ -15,9 +15,8 @@ EXTRACT_SUFX= .tgz
|
|||
MAINTAINER= onatan@gmail.com
|
||||
COMMENT= A remote firewall auditing tool
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libdnet.a:${PORTSDIR}/net/libdnet \
|
||||
${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
|
||||
RUN_DEPENDS:= ${BUILD_DEPENDS}
|
||||
LIB_DEPENDS= dnet:${PORTSDIR}/net/libdnet \
|
||||
net:${PORTSDIR}/net/libnet
|
||||
|
||||
WRKSRC= ${WRKDIR}/Firewalk
|
||||
|
||||
|
|
|
@ -7,13 +7,14 @@
|
|||
|
||||
PORTNAME= ipguard
|
||||
PORTVERSION= 1.04
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= security net
|
||||
MASTER_SITES= http://ipguard.deep.perm.ru/files/ http://deep.perm.ru/files/ipguard/
|
||||
|
||||
MAINTAINER= sead@deep.perm.ru
|
||||
COMMENT= Tool designed to protect LAN IP address space by ARP spoofing
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libnet11/libnet.a:${PORTSDIR}/net/libnet
|
||||
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
|
||||
|
||||
USE_RC_SUBR= ${PORTNAME}
|
||||
MAN8= ${PORTNAME}.8
|
||||
|
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= sasp
|
||||
PORTVERSION= 0.1
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL} \
|
||||
http://people.freebsd.org/~ahze/distfiles/
|
||||
|
@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= ahze
|
|||
MAINTAINER= sviat@OpenGEEKS.it
|
||||
COMMENT= A tool that permits to use a gateway whatever IP we have
|
||||
|
||||
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
|
||||
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
MAKE_ENV= LIBNET_CONFIG="${LIBNET_CONFIG}"
|
||||
|
|
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= suricata
|
||||
PORTVERSION= 1.3.4
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.openinfosecfoundation.org/download/ \
|
||||
http://mirrors.rit.edu/zi/
|
||||
|
@ -18,7 +18,7 @@ LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre \
|
|||
yaml:${PORTSDIR}/textproc/libyaml \
|
||||
htp:${PORTSDIR}/devel/libhtp
|
||||
|
||||
BUILD_DEPENDS+= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
|
||||
LIB_DEPENDS+= net:${PORTSDIR}/net/libnet
|
||||
|
||||
USE_AUTOTOOLS= automake autoconf libtool
|
||||
USE_PKGCONFIG= yes
|
||||
|
|
|
@ -7,14 +7,14 @@
|
|||
|
||||
PORTNAME= unicornscan
|
||||
PORTVERSION= 0.4.2
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.unicornscan.org/releases/
|
||||
|
||||
MAINTAINER= cykyc@yahoo.com
|
||||
COMMENT= Next-generation of udpscan plus a high-speed TCP scanner
|
||||
|
||||
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
|
||||
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
|
||||
|
||||
USE_GMAKE= yes
|
||||
MAKE_ENV= LIBNET_CONFIG="${LIBNET_CONFIG}"
|
||||
|
|
|
@ -7,13 +7,14 @@
|
|||
|
||||
PORTNAME= yersinia
|
||||
PORTVERSION= 0.7.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.yersinia.net/download/
|
||||
|
||||
MAINTAINER= ayu@commun.jp
|
||||
COMMENT= Layer 2 vulnerability scanner (switches, spanning tree, 802.1q ...)
|
||||
|
||||
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
|
||||
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
|
||||
|
||||
.if !defined(WITHOUT_GTK)
|
||||
.if exists(${LOCALBASE}/include/gtk-2.0/gtk/gtk.h)
|
||||
|
|
Loading…
Reference in a new issue