Add p5-Sendmail-Milter 0.18, a module to write mail filters in Perl

using sendmail's mail filter API.
This commit is contained in:
Maxim Sobolev 2003-04-01 12:32:57 +00:00
parent b169298681
commit fcc7498b5d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=77917
6 changed files with 99 additions and 0 deletions

View file

@ -189,6 +189,7 @@
SUBDIR += p5-Mail-Tools
SUBDIR += p5-Mail-Verify
SUBDIR += p5-Net-SMTP-Server
SUBDIR += p5-Sendmail-Milter
SUBDIR += p5-vpopmail
SUBDIR += pantomime
SUBDIR += pantomime-ssl

View file

@ -0,0 +1,23 @@
# New ports collection makefile for: Sendmail::Milter
# Date created: 25 March 2003
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= Sendmail-Milter
PORTVERSION= 0.18
CATEGORIES= mail perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Sendmail
PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A module to write mail filters in Perl using sendmail's mail filter API
PERL_CONFIGURE= yes
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Sendmail::Milter.3
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (Sendmail-Milter-0.18.tar.gz) = e7ec468d51f699601e0fb1c0bd544c9d

View file

@ -0,0 +1,56 @@
$FreeBSD$
--- Makefile.PL.orig Wed Sep 19 12:42:17 2001
+++ Makefile.PL Tue Apr 1 14:28:44 2003
@@ -5,30 +5,16 @@
use ExtUtils::MakeMaker;
use Config;
-if ((not $ARGV[0]) or (not $ARGV[1]))
-{
- print "Usage: perl Makefile.PL <path-to-sendmail-source> <path-to-sendmail-obj.dir>\n";
- print "(e.g. 'perl Makefile.PL ../sendmail ../sendmail/obj.FreeBSD.4.0-RELEASE.i386')\n";
- print "\n";
- exit;
-}
-
if (not $Config{usethreads})
{
print "To use this module, your perl interpreter must have been compiled with\n";
print "\t-Dusethreads.\n";
print "\n";
- exit;
+ exit 1;
}
-my $SENDMAIL_PATH = MM->canonpath($ARGV[0]);
-my $SENDMAIL_OBJ_PATH = MM->canonpath($ARGV[1]);
-
-my $MILTER_LIB = MM->catdir($SENDMAIL_OBJ_PATH, "libmilter");
-my $SMUTIL_LIB = MM->catdir($SENDMAIL_OBJ_PATH, "libsmutil");
-my $SM_LIB = MM->catdir($SENDMAIL_OBJ_PATH, "libsm");
-my $MILTER_INCLUDE = MM->catdir($SENDMAIL_PATH, "include");
-my $SENDMAIL_INCLUDE = MM->catdir($SENDMAIL_PATH, "sendmail");
+my $MILTER_LIB = "/usr/lib";
+my $MILTER_INCLUDE = "/usr/include/libmilter";
sub milter_configure
{
@@ -37,7 +23,7 @@
my $ccflags;
# Standard milter libraries
- $libs = "-L$MILTER_LIB -L$SMUTIL_LIB -L$SM_LIB -lmilter -lsmutil -lsm";
+ $libs = "-L$MILTER_LIB -lmilter";
# POSIX threads support.
if ($Config{libs} =~ /-lpthread/)
@@ -82,6 +68,6 @@
'CONFIGURE' => \&milter_configure,
'OBJECT' => '$(BASEEXT)$(OBJ_EXT) intpools$(OBJ_EXT) callbacks$(OBJ_EXT)',
'DEFINE' => '',
- 'INC' => "-I$SENDMAIL_INCLUDE -I$MILTER_INCLUDE",
+ 'INC' => "-I$MILTER_INCLUDE",
);

View file

@ -0,0 +1,9 @@
Sendmail::Milter provides users with the ability to write mail filters in Perl
that tightly integrate with sendmail's mail filter API.
With this module, you can define and register Perl callbacks with the Milter
engine. This module calls your perl callbacks using interpreters from a
threaded persistent interpreter pool. Milter contexts are presented using an
object-oriented style interface for performing operations on a Milter context.
WWW: http://sourceforge.net/projects/sendmail-milter/

View file

@ -0,0 +1,9 @@
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Sendmail/Milter.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Sendmail/sample.pl
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Sendmail/Milter/.packlist
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Sendmail/Milter/Milter.bs
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Sendmail/Milter/Milter.so
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Sendmail/Milter/autosplit.ix
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Sendmail/Milter
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Sendmail
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Sendmail