- Update to 0.9.2

- Pass maintainership to submitter
- Mark MAKE_JOBS_SAFE
- Add LICENSE (GPLv2)
- Remove MD5 checksum

PR:		ports/154783
Submitted by:	Jason E. Hale <bsdkaffee@gmail.com>
This commit is contained in:
Dennis Herrmann 2011-02-17 21:31:17 +00:00
parent 76569348df
commit fd33828961
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=269290
8 changed files with 30 additions and 480 deletions

View file

@ -6,12 +6,11 @@
#
PORTNAME= libofx
PORTVERSION= 0.9.1
PORTREVISION= 4
PORTVERSION= 0.9.2
CATEGORIES= finance
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
MAINTAINER= bsdkaffee@gmail.com
COMMENT= OpenSource implementation of the OFX (Open Financial eXchange)
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
@ -24,19 +23,32 @@ USE_AUTOTOOLS= aclocal autoheader automake autoconf libtool
ACLOCAL_ARGS= -I m4
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-doxygen --disable-dot --disable-gengetopt \
--with-opensp-includes=${LOCALBASE}/include/OpenSP
--with-opensp-includes=${LOCALBASE}/include/OpenSP \
--with-opensp-libs=${LOCALBASE}/lib
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
PORTDOCS= *
OPTIONS= APIDOC "Install full API documentation" off
.include <bsd.port.options.mk>
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in AUTHORS ChangeLog INSTALL NEWS README totest.txt
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.if defined(WITH_APIDOC)
@(cd ${WRKSRC}/doc; ${COPYTREE_SHARE} html ${DOCSDIR})
.endif
.endif
.include <bsd.port.mk>

View file

@ -1,3 +1,2 @@
MD5 (libofx-0.9.1.tar.gz) = e634f47ca12e82d860912d48c93b8e50
SHA256 (libofx-0.9.1.tar.gz) = 321b34bf3036c5af6a2ab44607decee38b2c7e79bb64c9ec6d98ddb18fb2ca3f
SIZE (libofx-0.9.1.tar.gz) = 1177818
SHA256 (libofx-0.9.2.tar.gz) = f6d690d3c5305a414b332b814e6c86f2200e809702ae7dffed9331a445e52d6d
SIZE (libofx-0.9.2.tar.gz) = 1162303

View file

@ -1,70 +0,0 @@
--- inc/libofx.h.orig Sat Feb 12 16:40:57 2005
+++ inc/libofx.h Sat Feb 12 16:39:46 2005
@@ -38,8 +38,12 @@
#ifdef __cplusplus
#define CFCT extern "C"
+#define CFCT_start extern "C" {
+#define CFCT_end }
#else
#define CFCT
+#define CFCT_start
+#define CFCT_end
#define true 1
#define false 0
#endif
@@ -207,7 +211,9 @@
other events). An OfxStatusData structure is passed to this event, as well as
a pointer to an arbitrary data structure.
*/
-CFCT typedef int (*LibofxProcStatusCallback)(const struct OfxStatusData data, void * status_data);
+CFCT_start
+typedef int (*LibofxProcStatusCallback)(const struct OfxStatusData data, void * status_data);
+CFCT_end
/**
* \brief An abstraction of an account
@@ -264,7 +270,9 @@
part of OfxStatementData structure passed to ofx_proc_statement event,
as well as a pointer to an arbitrary data structure.
*/
-CFCT typedef int (*LibofxProcAccountCallback)(const struct OfxAccountData data, void * account_data);
+CFCT_start
+typedef int (*LibofxProcAccountCallback)(const struct OfxAccountData data, void * account_data);
+CFCT_end
/**
* \brief An abstraction of a security, such as a stock, mutual fund, etc.
@@ -320,7 +328,9 @@
An OfxSecurityData structure is passed to this event, as well as
a pointer to an arbitrary data structure.
*/
-CFCT typedef int (*LibofxProcSecurityCallback)(const struct OfxSecurityData data, void * security_data);
+CFCT_start
+typedef int (*LibofxProcSecurityCallback)(const struct OfxSecurityData data, void * security_data);
+CFCT_end
typedef enum {
OFX_CREDIT, /**< Generic credit */
@@ -498,7 +508,9 @@
generated. An OfxTransactionData structure is passed to this event, as well as
a pointer to an arbitrary data structure.
*/
-CFCT typedef int (*LibofxProcTransactionCallback)(const struct OfxTransactionData data, void * transaction_data);
+CFCT_start
+typedef int (*LibofxProcTransactionCallback)(const struct OfxTransactionData data, void * transaction_data);
+CFCT_end
/**
* \brief An abstraction of an account statement.
@@ -567,7 +579,9 @@
events have been sent. An OfxStatementData is passed to this event, as well as
a pointer to an arbitrary data structure.
*/
-CFCT typedef int (*LibofxProcStatementCallback)(const struct OfxStatementData data, void * statement_data);
+CFCT_start
+typedef int (*LibofxProcStatementCallback)(const struct OfxStatementData data, void * statement_data);
+CFCT_end
/**
\brief NOT YET SUPPORTED

View file

@ -1,17 +1,9 @@
$FreeBSD$
--- lib/ofx_preproc.cpp.orig 2008-12-07 07:22:57.000000000 +0900
+++ lib/ofx_preproc.cpp 2009-03-16 03:31:53.000000000 +0900
@@ -23,6 +23,7 @@
#include <stdlib.h>
#include <stdio.h>
#include <string>
+#include <unistd.h>
#include "ParserEventGeneratorKit.h"
#include "libofx.h"
#include "messages.hh"
@@ -185,7 +186,7 @@
--- ./lib/ofx_preproc.cpp.orig 2011-02-12 11:51:02.000000000 -0500
+++ ./lib/ofx_preproc.cpp 2011-02-14 13:04:17.000000000 -0500
@@ -194,7 +194,7 @@
memset(iconv_buffer,0,READ_BUFFER_SIZE * 2);
size_t inbytesleft = strlen(s_buffer.c_str());
size_t outbytesleft = READ_BUFFER_SIZE * 2 - 1;

View file

@ -1,20 +1,15 @@
--- lib/ofx_utilities.cpp.orig 2007-10-27 14:15:58.000000000 +0200
+++ lib/ofx_utilities.cpp 2009-11-08 01:02:47.000000000 +0100
@@ -16,6 +16,7 @@
* *
***************************************************************************/
#include <config.h>
+#include <locale.h>
#include <iostream>
#include <assert.h>
@@ -113,6 +114,9 @@
char time_zone_specified = false;
--- ./lib/ofx_utilities.cpp.orig 2011-02-12 11:51:02.000000000 -0500
+++ ./lib/ofx_utilities.cpp 2011-02-14 22:24:26.000000000 -0500
@@ -115,9 +115,10 @@
time_t temptime;
+
- time.tm_isdst = daylight; // iniitialize dst setting
+ bzero(&time, sizeof(time));
+
std::time(&temptime);
local_offset = difftime(mktime(localtime(&temptime)), mktime(gmtime(&temptime)));
- local_offset = difftime(mktime(localtime(&temptime)), mktime(gmtime(&temptime))) + (3600*daylight);
+ local_offset = difftime(mktime(localtime(&temptime)), mktime(gmtime(&temptime)));
if(ofxdate.size()!=0){
if (ofxdate.substr(0,8).find_first_not_of("0123456789") != string::npos ){

View file

@ -1,19 +0,0 @@
--- ofx2qif/ofx2qif.c.orig Sat Feb 12 16:38:24 2005
+++ ofx2qif/ofx2qif.c Sat Feb 12 16:38:45 2005
@@ -207,6 +207,7 @@
extern int ofx_ERROR_msg;
extern int ofx_INFO_msg;
extern int ofx_STATUS_msg;
+LibofxContextPtr libofx_context;
ofx_PARSER_msg = false;
ofx_DEBUG_msg = false;
ofx_WARNING_msg = false;
@@ -214,7 +215,7 @@
ofx_INFO_msg = false;
ofx_STATUS_msg = false;
- LibofxContextPtr libofx_context = libofx_get_new_context();
+ libofx_context = libofx_get_new_context();
ofx_set_statement_cb(libofx_context, ofx_proc_statement_cb, 0);
ofx_set_account_cb(libofx_context, ofx_proc_account_cb, 0);
ofx_set_transaction_cb(libofx_context, ofx_proc_transaction_cb, 0);

View file

@ -1,34 +0,0 @@
add file attached as files/patch-utf8_fix and recompile it.
Patch attached with submission follows:
--- lib/ofx_preproc.cpp.orig 2009-07-24 18:48:05.000000000 +0900
+++ lib/ofx_preproc.cpp 2009-07-24 20:34:52.000000000 +0900
@@ -151,7 +151,7 @@
fromcode=LIBOFX_DEFAULT_INPUT_ENCODING;
}
}
- else if(ofx_encoding.compare("USASCII")==0) {
+ else if(ofx_encoding.compare("UTF-8")==0) {
fromcode="UTF-8";
}
else
@@ -170,6 +170,16 @@
header_name.assign(s_buffer.substr(0,header_separator_idx));
header_value.assign(s_buffer.substr(header_separator_idx+1));
message_out(DEBUG,"ofx_proc_file():Header: "+header_name+" with value: "+header_value+" has been found");
+
+ if((header_separator_idx = header_value.find('\r', 0))
+ != std::string::npos)
+ header_value.resize(header_separator_idx);
+
+ if((header_separator_idx = header_value.find('\n', 0))
+ != std::string::npos)
+ header_value.resize(header_separator_idx);
+
+
if(header_name.compare("ENCODING")==0) {
ofx_encoding.assign(header_value);
}

View file

@ -7,335 +7,10 @@ lib/libofx.la
lib/libofx.so
lib/libofx.so.4
libdata/pkgconfig/libofx.pc
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/html/annotated.html
%%PORTDOCS%%%%DOCSDIR%%/html/classLibofxContext.html
%%PORTDOCS%%%%DOCSDIR%%/html/classNodeParser.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOFCApplication.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOFXApplication.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxAccountContainer.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxAccountContainer.png
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxAccountInfoRequest.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxAccountInfoRequest.png
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxAggregate.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxAggregate.png
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxBalanceContainer.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxBalanceContainer.png
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxBankTransactionContainer.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxBankTransactionContainer.png
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxDummyContainer.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxDummyContainer.png
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxGenericContainer.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxGenericContainer.png
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxInvestmentTransactionContainer.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxInvestmentTransactionContainer.png
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxMainContainer.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxMainContainer.png
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxPaymentRequest.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxPaymentRequest.png
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxPushUpContainer.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxPushUpContainer.png
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxRequest.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxRequest.png
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxSecurityContainer.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxSecurityContainer.png
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxStatementContainer.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxStatementContainer.png
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxStatementRequest.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxStatementRequest.png
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxStatusContainer.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxStatusContainer.png
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxTransactionContainer.html
%%PORTDOCS%%%%DOCSDIR%%/html/classOfxTransactionContainer.png
%%PORTDOCS%%%%DOCSDIR%%/html/classtree.html
%%PORTDOCS%%%%DOCSDIR%%/html/classtree_1_1fixed__depth__iterator.html
%%PORTDOCS%%%%DOCSDIR%%/html/classtree_1_1fixed__depth__iterator.png
%%PORTDOCS%%%%DOCSDIR%%/html/classtree_1_1iterator__base.html
%%PORTDOCS%%%%DOCSDIR%%/html/classtree_1_1iterator__base.png
%%PORTDOCS%%%%DOCSDIR%%/html/classtree_1_1iterator__base__less.html
%%PORTDOCS%%%%DOCSDIR%%/html/classtree_1_1post__order__iterator.html
%%PORTDOCS%%%%DOCSDIR%%/html/classtree_1_1post__order__iterator.png
%%PORTDOCS%%%%DOCSDIR%%/html/classtree_1_1pre__order__iterator.html
%%PORTDOCS%%%%DOCSDIR%%/html/classtree_1_1pre__order__iterator.png
%%PORTDOCS%%%%DOCSDIR%%/html/classtree_1_1sibling__iterator.html
%%PORTDOCS%%%%DOCSDIR%%/html/classtree_1_1sibling__iterator.png
%%PORTDOCS%%%%DOCSDIR%%/html/classtree__node__.html
%%PORTDOCS%%%%DOCSDIR%%/html/cmdline_8c-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/cmdline_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/cmdline_8h.html
%%PORTDOCS%%%%DOCSDIR%%/html/config_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/context_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/context_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/deprecated.html
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.png
%%PORTDOCS%%%%DOCSDIR%%/html/file__preproc_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/file__preproc_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/file__preproc_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/file__preproc_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/files.html
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2blank.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2doc.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2folderclosed.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2folderopen.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2lastnode.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2link.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2mlastnode.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2mnode.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2node.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2plastnode.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2pnode.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2vertline.png
%%PORTDOCS%%%%DOCSDIR%%/html/functions.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x62.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x63.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x64.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x65.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x66.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x67.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x68.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x69.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x6c.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x6d.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x6e.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x6f.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x70.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x72.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x73.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x74.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x75.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x76.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x77.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x7e.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_enum.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_func.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_type.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x62.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x63.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x64.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x65.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x66.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x68.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x69.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x6c.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x6d.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x6e.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x6f.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x70.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x72.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x73.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x74.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x75.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x76.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2context_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2context_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2file__preproc_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2file__preproc_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2file__preproc_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2file__preproc_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2getopt1_8c-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2getopt_8c-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2gnugetopt_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2messages_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2messages_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2messages_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2messages_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofc__sgml_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofc__sgml_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofc__sgml_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofc__sgml_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__aggregate_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__aggregate_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__container__account_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__container__account_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__container__generic_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__container__generic_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__container__main_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__container__main_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__container__security_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__container__security_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__container__statement_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__container__statement_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__container__transaction_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__container__transaction_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__containers_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__containers_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__containers__misc_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__containers__misc_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__error__msg_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__error__msg_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__preproc_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__preproc_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__preproc_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__preproc_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__request_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__request_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__request_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__request_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__request__accountinfo_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__request__accountinfo_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__request__accountinfo_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__request__accountinfo_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__request__statement_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__request__statement_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__request__statement_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__request__statement_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__sgml_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__sgml_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__sgml_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__sgml_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__utilities_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__utilities_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__utilities_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2ofx__utilities_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2tree_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2win32_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/fx-0_89_81_2lib_2win32_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/getopt1_8c-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/getopt_8c-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x62.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x63.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x64.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x65.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x66.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x67.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x69.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x6b.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x6c.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x6d.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x6f.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x70.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x71.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x72.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x73.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x74.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x75.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x76.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_0x77.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_enum.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_eval.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_func.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_type.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_vars.html
%%PORTDOCS%%%%DOCSDIR%%/html/gnugetopt_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/hierarchy.html
%%PORTDOCS%%%%DOCSDIR%%/html/inc_2libofx_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/inc_2libofx_8h.html
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
%%PORTDOCS%%%%DOCSDIR%%/html/libofx-0_89_81_2inc_2libofx_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/libofx-0_89_81_2inc_2libofx_8h.html
%%PORTDOCS%%%%DOCSDIR%%/html/main.html
%%PORTDOCS%%%%DOCSDIR%%/html/main__doc_8c-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/messages_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/messages_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/messages_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/messages_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/namespaceOfxPartner.html
%%PORTDOCS%%%%DOCSDIR%%/html/namespacekp.html
%%PORTDOCS%%%%DOCSDIR%%/html/namespacemembers.html
%%PORTDOCS%%%%DOCSDIR%%/html/namespacemembers_func.html
%%PORTDOCS%%%%DOCSDIR%%/html/namespacemembers_vars.html
%%PORTDOCS%%%%DOCSDIR%%/html/namespaces.html
%%PORTDOCS%%%%DOCSDIR%%/html/nodeparser_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/nodeparser_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/nodeparser_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/nodeparser_8h.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofc__sgml_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofc__sgml_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofc__sgml_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofc__sgml_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx2qif_8c-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx2qif_8c.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__aggregate_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__aggregate_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__container__account_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__container__account_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__container__generic_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__container__generic_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__container__main_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__container__main_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__container__security_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__container__security_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__container__statement_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__container__statement_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__container__transaction_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__container__transaction_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__containers_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__containers_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__containers__misc_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__containers__misc_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__error__msg_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__error__msg_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__preproc_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__preproc_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__preproc_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__preproc_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__request_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__request_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__request_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__request_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__request__accountinfo_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__request__accountinfo_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__request__accountinfo_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__request__accountinfo_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__request__statement_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__request__statement_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__request__statement_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__request__statement_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__sgml_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__sgml_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__sgml_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__sgml_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__utilities_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__utilities_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__utilities_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofx__utilities_8hh.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofxconnect_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofxconnect_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofxdump_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofxdump_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofxpartner_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofxpartner_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofxpartner_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/ofxpartner_8h.html
%%PORTDOCS%%%%DOCSDIR%%/html/pages.html
%%PORTDOCS%%%%DOCSDIR%%/html/structErrorMsg.html
%%PORTDOCS%%%%DOCSDIR%%/html/structLibofxFileFormatInfo.html
%%PORTDOCS%%%%DOCSDIR%%/html/structOfxAccountData.html
%%PORTDOCS%%%%DOCSDIR%%/html/structOfxCurrency.html
%%PORTDOCS%%%%DOCSDIR%%/html/structOfxFiLogin.html
%%PORTDOCS%%%%DOCSDIR%%/html/structOfxFiServiceInfo.html
%%PORTDOCS%%%%DOCSDIR%%/html/structOfxPayee.html
%%PORTDOCS%%%%DOCSDIR%%/html/structOfxPayment.html
%%PORTDOCS%%%%DOCSDIR%%/html/structOfxSecurityData.html
%%PORTDOCS%%%%DOCSDIR%%/html/structOfxStatementData.html
%%PORTDOCS%%%%DOCSDIR%%/html/structOfxStatusData.html
%%PORTDOCS%%%%DOCSDIR%%/html/structOfxTransactionData.html
%%PORTDOCS%%%%DOCSDIR%%/html/structcmdline__parser__params.html
%%PORTDOCS%%%%DOCSDIR%%/html/structgengetopt__args__info.html
%%PORTDOCS%%%%DOCSDIR%%/html/structoption.html
%%PORTDOCS%%%%DOCSDIR%%/html/tab_b.gif
%%PORTDOCS%%%%DOCSDIR%%/html/tab_l.gif
%%PORTDOCS%%%%DOCSDIR%%/html/tab_r.gif
%%PORTDOCS%%%%DOCSDIR%%/html/tabs.css
%%PORTDOCS%%%%DOCSDIR%%/html/tree.html
%%PORTDOCS%%%%DOCSDIR%%/html/tree_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/win32_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/win32_8hh-source.html
%%PORTDOCS%%%%DOCSDIR%%/totest.txt
%%DATADIR%%/dtd/ofc.dtd
%%DATADIR%%/dtd/ofx160.dtd
%%DATADIR%%/dtd/ofx201.dtd
%%DATADIR%%/dtd/opensp.dcl
@dirrm %%DATADIR%%/dtd
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/libofx