upgrade to 0.9.2

PR:		26555
Submitted by:	tkato@prontomail.ne.jp
This commit is contained in:
Ying-Chieh Liao 2001-04-14 11:21:15 +00:00
parent a6e83641c7
commit fd41396e56
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=41369
9 changed files with 26 additions and 98 deletions

View file

@ -7,7 +7,7 @@
#
PORTNAME= gman
PORTVERSION= 0.9.0
PORTVERSION= 0.9.2
CATEGORIES= misc
MASTER_SITES= http://homex.coolconnect.com/user/xkwang/gman/
@ -19,7 +19,8 @@ USE_GTK= yes
MAN1= gman.1x
post-patch:
@${PERL} -pi -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gman ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/gman.1x ${MANPREFIX}/man/man1
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (gman-0.9.0.tar.gz) = b00c5308095acd146e19a49dc5897bb9
MD5 (gman-0.9.2.tar.gz) = 7e573cda5d58e3fe4d24d04a295ff0ac

View file

@ -1,23 +1,25 @@
--- Makefile.orig Sat Mar 31 00:33:31 2001
+++ Makefile Sat Mar 31 00:34:53 2001
@@ -1,17 +1,17 @@
--- Makefile.orig Sat Mar 31 19:05:24 2001
+++ Makefile Sat Apr 14 04:19:15 2001
@@ -1,18 +1,18 @@
# Gman Makefile
# You can adjust the following variables.
CXX = g++
-CXXFLAGS = -DVERSION=\"0.9.0\" `gtk-config --cflags` -O2 #-Wall
+CXXFLAGS += -DVERSION=\"0.9.0\" `${GTK_CONFIG} --cflags`
-CXX = g++
-CXXFLAGS = -DVERSION=\"0.9.2\" `gtk-config --cflags` -O2 #-Wall
+CXX ?= g++
+CXXFLAGS += -DVERSION=\"0.9.2\" `${GTK_CONFIG} --cflags gthread` #-Wall
CC = $(CXX) $(CXXFLAGS)
GNOMELIB = #`gnome-config --libs gnomeui`
-prefix = /usr
+prefix = ${PREFIX}
cgi_bin_prefix = /home/httpd/cgi-bin
# There shouldn't be any need to edit anything below this point.
all: gman
gman: menu.o mandata.o util.o gman.o list.o context.o task.o taskfunc.o window2.o
- $(CC) -lgtk -lgdk -lpthread $(GNOMELIB) menu.o mandata.o util.o gman.o list.o context.o task.o taskfunc.o window2.o -o gman
+ $(CC) -lpthread `${GTK_CONFIG} --libs` $(GNOMELIB) menu.o mandata.o util.o gman.o list.o context.o task.o taskfunc.o window2.o -o gman
+ $(CC) `${GTK_CONFIG} --libs gthread` $(GNOMELIB) menu.o mandata.o util.o gman.o list.o context.o task.o taskfunc.o window2.o -o gman
gman.o: gman.c menu.h
$(CC) -c gman.c

View file

@ -1,5 +1,5 @@
--- gman.c.orig Mon Mar 26 17:08:28 2001
+++ gman.c Fri Mar 30 23:46:22 2001
--- gman.c.orig Sat Mar 31 18:38:43 2001
+++ gman.c Sat Apr 14 05:10:14 2001
@@ -83,7 +83,7 @@
context = new AppContext();
// context->set_default_value("v_size",(void*)400);
@ -12,9 +12,9 @@
@@ -91,7 +91,7 @@
context->set_default_value("show_warning","int",(void*)0);
context->set_default_value("show_mode","int",(void*)0); // 0 = xterm, 1 = ghostview
context->set_default_value("xterm_command","char*",(void*)"xterm");
context->set_default_value("xterm_command","char*",(void*)"xterm"); // rxvt, Eterm also works
- context->set_default_value("gv_command","char*",(void*)"gv");
+ context->set_default_value("gv_command","char*",(void*)"ghostview");
context->set_default_value("print_command","char*",(void*)"lpr");
attach(buffer,getenv("HOME"),".gman");
context->set_default_value("browser_command","char*",(void*)"netscape"); // kfm also works
context->set_default_value("cgi_host","char*",(void*)"localhost");
context->set_default_value("cgi_location","char*",(void*)"/cgi-bin/gman/gman.pl");

View file

@ -1,43 +1,7 @@
--- mandata.c.orig Mon Mar 26 16:40:49 2001
+++ mandata.c Sat Mar 31 00:21:55 2001
@@ -58,7 +58,7 @@
if(path_name) free(path_name);
}
-ManPath::GetSize(int section_ID)
+int ManPath::GetSize(int section_ID)
{
int count;
int i;
@@ -67,7 +67,7 @@
return count;
}
-ManPath::GetItems(int section_ID, ManItem * buffer[])
+int ManPath::GetItems(int section_ID, ManItem * buffer[])
{
int count;
int i;
@@ -80,7 +80,7 @@
struct stat state;
-ManPath::LoadManPath(char * path_name)
+int ManPath::LoadManPath(char * path_name)
{
DIR *dirp;
#if defined(SYS_DIR)||defined(NDIR)
@@ -125,7 +125,7 @@
return 0;
}
-ManPath::LoadManSubPath(char * sub_name)
+int ManPath::LoadManSubPath(char * sub_name)
{
DIR *dirp;
#if defined(SYS_DIR)||defined(NDIR)
@@ -242,11 +242,11 @@
char loc_name[BUFFER_SIZE];
--- mandata.c.orig Sat Mar 31 19:16:19 2001
+++ mandata.c Sat Apr 14 05:12:49 2001
@@ -243,11 +243,11 @@
char buffer2[BUFFER_SIZE];
switch ((int)context->get_value("show_mode")) {
case 0:
- sprintf(buffer,"%s -T '%s manual page' -n GMan -e man ",
@ -52,7 +16,7 @@
//g_warning(buffer);
if(!fork())
{
@@ -257,9 +257,9 @@
@@ -258,9 +258,9 @@
break;
case 1:
sprintf(loc_name," ~/.gman.%s.ps ",get_display_name(buffer1));

View file

@ -1,17 +0,0 @@
--- mandata.h.orig Fri Mar 30 09:35:42 2001
+++ mandata.h Fri Mar 30 09:35:56 2001
@@ -17,12 +17,12 @@
char * path_name;
List * section[MAX_MAN_SECTION]; //1:2:3:4:5:6:7:8:9:tcl:n:l:p:o
private:
- LoadManSubPath(char *);
+ int LoadManSubPath(char *);
public:
int active;
ManPath(char * path_name);
~ManPath();
- LoadManPath(char *);
+ int LoadManPath(char *);
const char * GetPath();
int GetSize(int section_ID);
int GetItems(int section_ID, ManItem **buffer);

View file

@ -1,11 +0,0 @@
--- menu.c.orig Fri Mar 30 09:36:30 2001
+++ menu.c Fri Mar 30 09:36:47 2001
@@ -588,7 +588,7 @@
}
}
-static status_bar_callback (GtkWidget *widget, gpointer data)
+static int status_bar_callback (GtkWidget *widget, gpointer data)
{
int k,k2;
if(signal_menu_change>0) {signal_menu_change--;return 1;}

View file

@ -1,11 +0,0 @@
--- window2.c.orig Fri Mar 30 09:40:02 2001
+++ window2.c Fri Mar 30 09:40:50 2001
@@ -172,7 +172,7 @@
for (i = 0;i<j;i++) {
p = (ManPath*) man_paths->get_value(i);
if (p) {
- clist_item[0] = p->active?"o":"";
+ clist_item[0] = (gchar *)(p->active?"o":"");
clist_item[1] = man_paths->get_name(i);
sprintf(buffer,"%d",p->GetSize(-1));
clist_item[2] = buffer;

View file

@ -1 +1 @@
G-man is a user-friendly graphical front end for the man system
A user-friendly graphical front end for the man system