- Do not link ruby18 agains librt.
- Bump portrevision. PR: ports/149003 Submitted by: Anonymous <swell.k@gmail.com>
This commit is contained in:
parent
014d1898d9
commit
fd4e416769
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=262809
2 changed files with 22 additions and 6 deletions
|
@ -171,7 +171,7 @@ RUBY?= ${LOCALBASE}/bin/${RUBY_NAME}
|
|||
# Ruby 1.8
|
||||
#
|
||||
RUBY_RELVERSION= 1.8.7
|
||||
RUBY_PORTREVISION= 4
|
||||
RUBY_PORTREVISION= 5
|
||||
RUBY_PORTEPOCH= 1
|
||||
RUBY_PATCHLEVEL= 248
|
||||
|
||||
|
|
|
@ -1,6 +1,15 @@
|
|||
--- configure.in.orig 2009-01-19 12:25:38.000000000 +0300
|
||||
+++ configure.in 2009-06-19 15:35:22.000000000 +0400
|
||||
@@ -1020,7 +1020,7 @@
|
||||
--- configure.in.orig 2009-12-24 01:10:03.000000000 -0800
|
||||
+++ configure.in 2010-10-10 23:21:07.000000000 -0700
|
||||
@@ -502,7 +502,7 @@
|
||||
AC_CHECK_LIB(crypt, crypt)
|
||||
AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/Solaris and SYSV
|
||||
AC_CHECK_LIB(dld, shl_load) # Dynamic linking for HP-UX
|
||||
-AC_CHECK_LIB(rt, clock_gettime) # GNU/Linux
|
||||
+AC_SEARCH_LIBS(clock_gettime, rt) # GNU/Linux
|
||||
|
||||
case "$target_cpu" in
|
||||
alpha*) case "$target_os"::"$GCC" in
|
||||
@@ -1021,7 +1021,7 @@
|
||||
case $pthread_lib in
|
||||
c)
|
||||
;;
|
||||
|
@ -9,7 +18,14 @@
|
|||
MAINLIBS="-pthread $MAINLIBS"
|
||||
;;
|
||||
*)
|
||||
@@ -1037,6 +1037,14 @@
|
||||
@@ -1033,11 +1033,19 @@
|
||||
fi
|
||||
AC_CHECK_FUNCS(nanosleep)
|
||||
if test x"$ac_cv_func_nanosleep" = xno; then
|
||||
- AC_CHECK_LIB(rt, nanosleep)
|
||||
- if test x"$ac_cv_lib_rt_nanosleep" = xyes; then
|
||||
+ AC_SEARCH_LIBS(nanosleep, rt)
|
||||
+ if test x"$ac_cv_search_nanosleep" != xno; then
|
||||
AC_DEFINE(HAVE_NANOSLEEP)
|
||||
fi
|
||||
fi
|
||||
|
@ -24,7 +40,7 @@
|
|||
fi
|
||||
if test x"$ac_cv_header_ucontext_h" = xyes; then
|
||||
if test x"$rb_with_pthread" = xyes; then
|
||||
@@ -1441,7 +1449,7 @@
|
||||
@@ -1446,7 +1454,7 @@
|
||||
SOLIBS=
|
||||
|
||||
case "$target_os" in
|
||||
|
|
Loading…
Reference in a new issue