Update to 2.0.6
Remove MD5 PR: 152410 Submitted by: Rainer Hurling <rhurlin@gwdg.de> (maintainer) Approved by: itetcu
This commit is contained in:
parent
e2915a9c81
commit
fd4eccfb67
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=265061
5 changed files with 29 additions and 44 deletions
|
@ -3,13 +3,12 @@
|
|||
# Whom: Rainer Hurling <rhurlin@gwdg.de>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= saga
|
||||
PORTVERSION= 2.0.5
|
||||
PORTVERSION= 2.0.6
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]*$//}/SAGA%20${PORTVERSION}
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}_src
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}
|
||||
|
||||
MAINTAINER= rhurlin@gwdg.de
|
||||
COMMENT= System for Automated Geoscientific Analyses
|
||||
|
@ -18,7 +17,9 @@ LIB_DEPENDS= proj.6:${PORTSDIR}/graphics/proj \
|
|||
gdal.15:${PORTSDIR}/graphics/gdal \
|
||||
jasper.4:${PORTSDIR}/graphics/jasper \
|
||||
tiff.4:${PORTSDIR}/graphics/tiff \
|
||||
iodbc.3:${PORTSDIR}/databases/libiodbc
|
||||
iodbc.3:${PORTSDIR}/databases/libiodbc \
|
||||
las.1:${PORTSDIR}/devel/liblas \
|
||||
cv.2:${PORTSDIR}/graphics/opencv
|
||||
|
||||
USE_WX= 2.8
|
||||
USE_LDCONFIG= yes
|
||||
|
@ -40,6 +41,9 @@ OPTIONS= UNICODE "Enable Unicode Support" On \
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
|
||||
.if defined(WITH_UNICODE)
|
||||
WITH_UNICODE= yes
|
||||
CONFIGURE_ARGS+= --enable-unicode
|
||||
|
@ -50,8 +54,9 @@ CONFIGURE_ARGS+= --disable-unicode
|
|||
.if defined(WITH_HARU)
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/lib/libhpdf.so:${PORTSDIR}/print/libharu
|
||||
RUN_DEPENDS+= ${LOCALBASE}/lib/libhpdf.so:${PORTSDIR}/print/libharu
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
PLIST_SUB+= HARU=""
|
||||
.else
|
||||
PLIST_SUB+= HARU="@comment "
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
|
@ -59,13 +64,11 @@ post-patch:
|
|||
${WRKSRC}/configure; do \
|
||||
${REINPLACE_CMD} -e's|wx-config |${WX_CONFIG} |g' "$$f"; \
|
||||
done
|
||||
@${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,' \
|
||||
${WRKSRC}/configure \
|
||||
@${REINPLACE_CMD} -e 's|#if !defined(__APPLE__) && !defined(__BSD__)|#ifdef HAVE_MALLOC_H|' \
|
||||
${WRKSRC}/src/saga_core/saga_api/api_core.h \
|
||||
${WRKSRC}/src/saga_core/saga_api/api_memory.cpp \
|
||||
${WRKSRC}/src/modules_io/esri_e00/io_esri_e00/e00compr/cpl_port.h \
|
||||
${WRKSRC}/src/modules_io/grid/io_grid_grib2/g2clib-1.0.4/enc_png.c \
|
||||
${WRKSRC}/src/modules_projection/pj_georeference/pj_georeference/lmdif0.c
|
||||
@${REINPLACE_CMD} -e 's,<cv.h>,<opencv/cv.h>,' \
|
||||
${WRKSRC}/src/modules_images/modules_opencv/opencv/opencv.h
|
||||
.if ${ARCH} == "i386"
|
||||
@${REINPLACE_CMD} -e 's|typedef unsigned long DWORD;|typedef unsigned int DWORD;|' \
|
||||
${WRKSRC}/src/saga_core/saga_api/api_core.h
|
||||
|
|
|
@ -1,3 +1,2 @@
|
|||
MD5 (saga_2.0.5_src.tar.gz) = 4a9d15db2cabc4ccb60946fda40eaf92
|
||||
SHA256 (saga_2.0.5_src.tar.gz) = 064fbf69f43038e2a6a4bfb349c20352eb4ed04b3f46fed5832519bf3145927f
|
||||
SIZE (saga_2.0.5_src.tar.gz) = 2960764
|
||||
SHA256 (saga_2.0.6.tar.gz) = 9e3e8a69eb65483a9be65b31be96179918ab5a16e39c5ff5812acd7935aebe7f
|
||||
SIZE (saga_2.0.6.tar.gz) = 3327054
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
--- src/saga_core/saga_cmd/Makefile.in 2010-08-18 14:28:14.000000000 +0200
|
||||
+++ src/saga_core/saga_cmd/Makefile.in 2010-08-29 14:11:13.000000000 +0200
|
||||
@@ -239,9 +239,9 @@
|
||||
#
|
||||
@DEBUG_TRUE@DBGFLAGS = -g -DDEBUG
|
||||
MLIBPATH = "MODULE_LIBRARY_PATH=\"$(prefix)/lib/saga\""
|
||||
-BASEFLAGS = -D_SAGA_LINUX -D_SAGA_UNICODE -D_TYPEDEF_BYTE -D_TYPEDEF_WORD $(DBGFLAGS) -I.. -D$(MLIBPATH)
|
||||
+BASEFLAGS = -D_SAGA_LINUX -D_TYPEDEF_BYTE -D_TYPEDEF_WORD $(DBGFLAGS) -I.. -D$(MLIBPATH)
|
||||
@SAGA_UNICODE_FALSE@AM_CXXFLAGS = -fPIC `wx-config --unicode=no --cxxflags` $(BASEFLAGS)
|
||||
-@SAGA_UNICODE_TRUE@AM_CXXFLAGS = -fPIC `wx-config --unicode=yes --cxxflags` $(BASEFLAGS)
|
||||
+@SAGA_UNICODE_TRUE@AM_CXXFLAGS = -fPIC `wx-config --unicode=yes --cxxflags` $(BASEFLAGS) -D_SAGA_UNICODE
|
||||
@SAGA_UNICODE_FALSE@AM_LDFLAGS = -fPIC `wx-config --unicode=no --libs` -lm
|
||||
@SAGA_UNICODE_TRUE@AM_LDFLAGS = -fPIC `wx-config --unicode=yes --libs` -lm
|
||||
saga_cmd_LDADD = ../saga_api/libsaga_api.la
|
|
@ -1,11 +0,0 @@
|
|||
--- src/saga_core/saga_gui/dlg_about.cpp 2009-10-01 18:18:30.000000000 +0200
|
||||
+++ src/saga_core/saga_gui/dlg_about.cpp 2010-08-30 16:25:31.000000000 +0200
|
||||
@@ -256,7 +256,7 @@
|
||||
);
|
||||
|
||||
s.Append(
|
||||
- CSG_Doc_PDF::Get_Version()
|
||||
+ wxT("Haru Free PDF Library, Version 2.1.0")
|
||||
);
|
||||
|
||||
s.Append(
|
|
@ -1,17 +1,21 @@
|
|||
bin/saga_cmd
|
||||
bin/saga_gui
|
||||
lib/libsaga_api-2.0.5.so
|
||||
lib/libsaga_api-2.0.6.so
|
||||
lib/libsaga_api.la
|
||||
lib/libsaga_api.so
|
||||
lib/libsaga_gdi-2.0.5.so
|
||||
lib/libsaga_gdi-2.0.6.so
|
||||
lib/libsaga_gdi.la
|
||||
lib/libsaga_gdi.so
|
||||
lib/libsaga_odbc-2.0.5.so
|
||||
lib/libsaga_odbc-2.0.6.so
|
||||
lib/libsaga_odbc.a
|
||||
lib/libsaga_odbc.la
|
||||
lib/libsaga_odbc.so
|
||||
lib/saga/libcontrib_a_perego.la
|
||||
lib/saga/libcontrib_a_perego.so
|
||||
lib/saga/libdocs_html.la
|
||||
lib/saga/libdocs_html.so
|
||||
%%HARU%%lib/saga/libdocs_pdf.la
|
||||
%%HARU%%lib/saga/libdocs_pdf.so
|
||||
lib/saga/libgeostatistics_grid.la
|
||||
lib/saga/libgeostatistics_grid.so
|
||||
lib/saga/libgeostatistics_kriging.la
|
||||
|
@ -40,6 +44,8 @@ lib/saga/libgrid_visualisation.la
|
|||
lib/saga/libgrid_visualisation.so
|
||||
lib/saga/libihacres.la
|
||||
lib/saga/libihacres.so
|
||||
lib/saga/libimagery_segmentation.la
|
||||
lib/saga/libimagery_segmentation.so
|
||||
lib/saga/libio_esri_e00.la
|
||||
lib/saga/libio_esri_e00.so
|
||||
lib/saga/libio_gdal.la
|
||||
|
@ -59,10 +65,14 @@ lib/saga/libio_shapes.la
|
|||
lib/saga/libio_shapes.so
|
||||
lib/saga/libio_shapes_dxf.la
|
||||
lib/saga/libio_shapes_dxf.so
|
||||
lib/saga/libio_shapes_las.la
|
||||
lib/saga/libio_shapes_las.so
|
||||
lib/saga/libio_table.la
|
||||
lib/saga/libio_table.so
|
||||
lib/saga/liblectures_introduction.la
|
||||
lib/saga/liblectures_introduction.so
|
||||
lib/saga/libopencv.la
|
||||
lib/saga/libopencv.so
|
||||
lib/saga/libpj_georeference.la
|
||||
lib/saga/libpj_georeference.so
|
||||
lib/saga/libpj_proj4.la
|
||||
|
@ -95,8 +105,6 @@ lib/saga/libsim_hydrology.la
|
|||
lib/saga/libsim_hydrology.so
|
||||
lib/saga/libta_channels.la
|
||||
lib/saga/libta_channels.so
|
||||
lib/saga/libta_compound.la
|
||||
lib/saga/libta_compound.so
|
||||
lib/saga/libta_hydrology.la
|
||||
lib/saga/libta_hydrology.so
|
||||
lib/saga/libta_lighting.la
|
||||
|
|
Loading…
Reference in a new issue