New port: py-Automat

Automat is a library for concise, idiomatic Python expression of
finite-state automata (particularly deterministic finite-state
transducers).

PR:		217186
Submitted by:	John W. O'Brien <john@saltant.com>
This commit is contained in:
Dmitry Sivachenko 2017-02-18 07:34:43 +00:00
parent c408fd25a1
commit fd59e8bd1b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=434330
5 changed files with 48 additions and 0 deletions

View file

@ -3995,6 +3995,7 @@
SUBDIR += pwlib
SUBDIR += py-Acquisition
SUBDIR += py-AddOns
SUBDIR += py-Automat
SUBDIR += py-Breve
SUBDIR += py-BytecodeAssembler
SUBDIR += py-DateTime

26
devel/py-Automat/Makefile Normal file
View file

@ -0,0 +1,26 @@
# Created by: John W. O'Brien <john@saltant.com>
# $FreeBSD$
PORTNAME= Automat
PORTVERSION= 0.5.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= john@saltant.com
COMMENT= Finite-state machines in Python
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm \
${PYTHON_PKGNAMEPREFIX}m2r>0:textproc/py-m2r
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}attrs>0:devel/py-attrs \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six
USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1487351142
SHA256 (Automat-0.5.0.tar.gz) = 4889ec6763377432ec4db265ad552bbe956768ea3fff39014855308ba79dd7c2
SIZE (Automat-0.5.0.tar.gz) = 32599

View file

@ -0,0 +1,13 @@
--- setup.py.orig 2017-02-18 00:40:15 UTC
+++ setup.py
@@ -39,8 +39,8 @@ setup(
"automat-visualize = automat._visualize:tool"
],
},
- author_name='Glyph',
- author_mail='glyph@twistedmatrix.com',
+ author='Glyph',
+ author_email='glyph@twistedmatrix.com',
include_package_data=True,
license="MIT",
keywords='fsm finite state machine automata',

View file

@ -0,0 +1,5 @@
Automat is a library for concise, idiomatic Python expression of
finite-state automata (particularly deterministic finite-state
transducers).
WWW: https://github.com/glyph/Automat