Fix problems when upgrading using packages:

- Always install sudoers.sample.
 - There is no need for pkg-install anymore.
 - Bump PORTREVISION.
This commit is contained in:
Wesley Shields 2010-08-16 13:06:02 +00:00
parent b35856bf03
commit fd5d554e16
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=259350
3 changed files with 7 additions and 20 deletions

View file

@ -7,6 +7,7 @@
PORTNAME= sudo
PORTVERSION= 1.7.4.2
PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.sudo.ws/sudo/dist/ \
ftp://obsd.isc.org/pub/sudo/ \

View file

@ -1,14 +1,15 @@
--- ./Makefile.in.orig 2010-07-30 11:58:54.000000000 -0400
+++ ./Makefile.in 2010-08-15 21:33:54.000000000 -0400
@@ -493,11 +493,9 @@
--- Makefile.in.orig 2010-07-30 17:58:54.000000000 +0200
+++ Makefile.in 2010-08-16 10:21:01.000000000 +0200
@@ -493,11 +493,8 @@
if [ -f .libs/lib$(noexecfile) ]; then $(INSTALL) -b~ -O $(install_uid) -G $(install_gid) -M 0755 .libs/lib$(noexecfile) $(DESTDIR)$(noexecdir)/$(noexecfile); fi
install-sudoers: install-dirs
- $(INSTALL) -d -O $(sudoers_uid) -G $(sudoers_gid) -M 0750 \
- $(DESTDIR)$(sudoersdir)/sudoers.d
test -f $(DESTDIR)$(sudoersdir)/sudoers || \
$(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -M $(sudoers_mode) \
- test -f $(DESTDIR)$(sudoersdir)/sudoers || \
- $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -M $(sudoers_mode) \
- $(srcdir)/sudoers $(DESTDIR)$(sudoersdir)/sudoers
+ $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -M $(sudoers_mode) \
+ $(srcdir)/sudoers $(DESTDIR)$(sudoersdir)/sudoers.sample
install-doc: install-dirs ChangeLog

View file

@ -1,15 +0,0 @@
#!/bin/sh
if [ $2 != "POST-INSTALL" ]; then
exit 0
fi
if [ -e ${PKG_PREFIX}/etc/sudoers ]; then
echo "Will not overwrite existing ${PKG_PREFIX}/etc/sudoers file."
else
cp -p ${PKG_PREFIX}/etc/sudoers.default ${PKG_PREFIX}/etc/sudoers
chmod 440 ${PKG_PREFIX}/etc/sudoers
fi
if [ -e ${PKG_PREFIX}/etc/pam.d/sudo ]; then
echo "Will not overwrite existing ${PKG_PREFIX}/etc/pam.d/sudo file."
else
cp -p ${PKG_PREFIX}/etc/pam.d/sudo.default ${PKG_PREFIX}/etc/pam.d/sudo
fi