- Update to 3.0.0.
This commit is contained in:
parent
7ffd405a3e
commit
fd62795f95
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=391944
8 changed files with 30 additions and 55 deletions
|
@ -2,7 +2,7 @@
|
||||||
# $FreeBSD$
|
# $FreeBSD$
|
||||||
|
|
||||||
PORTNAME= octave-forge-parallel
|
PORTNAME= octave-forge-parallel
|
||||||
PORTVERSION= 2.2.1
|
PORTVERSION= 3.0.0
|
||||||
CATEGORIES= math
|
CATEGORIES= math
|
||||||
|
|
||||||
MAINTAINER= stephen@FreeBSD.org
|
MAINTAINER= stephen@FreeBSD.org
|
||||||
|
@ -17,8 +17,6 @@ OCTSRC= ${DISTNAME}
|
||||||
|
|
||||||
WRKSRC= ${WRKDIR}/${OCTSRC}/src
|
WRKSRC= ${WRKDIR}/${OCTSRC}/src
|
||||||
GNU_CONFIGURE= yes
|
GNU_CONFIGURE= yes
|
||||||
CONFIGURE_ENV+= HOME=${WRKSRC}
|
|
||||||
MAKE_JOBS_UNSAFE= yes
|
|
||||||
|
|
||||||
.include "${.CURDIR}/../../Mk/bsd.octave.mk"
|
.include "${.CURDIR}/../../Mk/bsd.octave.mk"
|
||||||
|
|
||||||
|
|
|
@ -1,2 +1,2 @@
|
||||||
SHA256 (octave-forge/parallel-2.2.1.tar.gz) = 1faf36a7c1750c364ec8089c78cdecbcdbf47c40410c2463e8f3e44dc4d92f33
|
SHA256 (octave-forge/parallel-3.0.0.tar.gz) = 7ba3105da8e0fab71554bfd50a0b34832d5f12aca3760f7395115083499cb7e1
|
||||||
SIZE (octave-forge/parallel-2.2.1.tar.gz) = 85110
|
SIZE (octave-forge/parallel-3.0.0.tar.gz) = 113702
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- configure-orig 2012-03-30 23:58:04.000000000 +0000
|
|
||||||
+++ configure 2012-03-30 23:58:24.000000000 +0000
|
|
||||||
@@ -4208,7 +4208,7 @@
|
|
||||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
|
||||||
$as_echo "yes" >&6; }
|
|
||||||
|
|
||||||
-$as_echo "#define OCTAVE_LE_3_2_4 1" >>confdefs.h
|
|
||||||
+$as_echo "#undef OCTAVE_LE_3_2_4" >>confdefs.h
|
|
||||||
|
|
||||||
fi
|
|
||||||
|
|
|
@ -1,12 +0,0 @@
|
||||||
--- connect.cc.orig 2013-11-16 22:26:59.000000000 +0100
|
|
||||||
+++ connect.cc 2013-11-16 22:27:54.000000000 +0100
|
|
||||||
@@ -25,7 +25,9 @@
|
|
||||||
#include <octave/oct.h>
|
|
||||||
#include <oct-env.h>
|
|
||||||
|
|
||||||
+#include <sys/types.h>
|
|
||||||
#include <sys/socket.h>
|
|
||||||
+#include <unistd.h>
|
|
||||||
#include <errno.h>
|
|
||||||
#include <netdb.h>
|
|
||||||
#include <netinet/in.h> // reported necessary for FreeBSD-8
|
|
11
math/octave-forge-parallel/files/patch-parallel-gnutls.h
Normal file
11
math/octave-forge-parallel/files/patch-parallel-gnutls.h
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- parallel-gnutls.h.orig 2015-07-12 11:10:04 UTC
|
||||||
|
+++ parallel-gnutls.h
|
||||||
|
@@ -41,7 +41,7 @@ along with this program; If not, see <ht
|
||||||
|
|
||||||
|
#include <stdio.h>
|
||||||
|
|
||||||
|
-#include <malloc.h>
|
||||||
|
+#include <stdlib.h>
|
||||||
|
|
||||||
|
/*
|
||||||
|
not necessary with current Octave
|
|
@ -1,19 +1,19 @@
|
||||||
--- pserver.cc.orig 2013-11-16 22:30:37.000000000 +0100
|
--- pserver.cc.orig 2015-07-12 11:10:04 UTC
|
||||||
+++ pserver.cc 2013-11-16 22:31:47.000000000 +0100
|
+++ pserver.cc
|
||||||
@@ -27,6 +27,7 @@
|
@@ -32,6 +32,7 @@ along with this program; If not, see <ht
|
||||||
#include <cmd-edit.h>
|
#include <cmd-edit.h>
|
||||||
#include <toplev.h>
|
#include <toplev.h>
|
||||||
|
|
||||||
+#include <sys/types.h>
|
+#include <sys/types.h>
|
||||||
#include <sys/socket.h>
|
#include <sys/socket.h>
|
||||||
#include <iostream>
|
#include <sys/types.h>
|
||||||
#include <sys/stat.h>
|
#include <sys/wait.h>
|
||||||
@@ -34,6 +35,8 @@
|
@@ -42,6 +43,8 @@ along with this program; If not, see <ht
|
||||||
#include <errno.h>
|
|
||||||
#include <netdb.h>
|
#include <netdb.h>
|
||||||
|
#include <sys/utsname.h>
|
||||||
#include <netinet/in.h> // reported necessary for FreeBSD-8
|
#include <netinet/in.h> // reported necessary for FreeBSD-8
|
||||||
+#include <unistd.h>
|
+#include <unistd.h>
|
||||||
+#include <stdlib.h>
|
+#include <stdlib.h>
|
||||||
|
|
||||||
#include "sock-stream.h"
|
#if HAVE_UNISTD_H
|
||||||
|
#include <unistd.h>
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
--- send.cc.orig 2013-11-16 22:35:29.000000000 +0100
|
--- send.cc.orig 2015-07-12 11:10:04 UTC
|
||||||
+++ send.cc 2013-11-16 22:35:56.000000000 +0100
|
+++ send.cc
|
||||||
@@ -21,10 +21,12 @@
|
@@ -25,10 +25,12 @@
|
||||||
#include <octave/ls-oct-binary.h>
|
|
||||||
#include <octave/oct-stream.h>
|
#include "parallel-gnutls.h"
|
||||||
|
|
||||||
+#include <sys/types.h>
|
+#include <sys/types.h>
|
||||||
#include <sys/socket.h>
|
#include <sys/socket.h>
|
||||||
|
@ -11,5 +11,5 @@
|
||||||
#include <netdb.h>
|
#include <netdb.h>
|
||||||
+#include <unistd.h>
|
+#include <unistd.h>
|
||||||
|
|
||||||
|
#if HAVE_UNISTD_H
|
||||||
DEFUN_DLD (send, args, , "send (X, sockets)\n\
|
#include <unistd.h>
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- sock-stream.h-orig 2010-08-25 20:47:40.000000000 -0500
|
|
||||||
+++ sock-stream.h 2010-08-25 20:48:19.000000000 -0500
|
|
||||||
@@ -25,6 +25,8 @@
|
|
||||||
|
|
||||||
int socket_to_oct_iostream (int sd);
|
|
||||||
|
|
||||||
+#include <netinet/in.h>
|
|
||||||
+
|
|
||||||
#endif
|
|
||||||
|
|
||||||
/*
|
|
Loading…
Reference in a new issue