- Update to 3.0.0
This commit is contained in:
parent
e2bb4aa191
commit
fd6452cbc3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=427948
4 changed files with 37 additions and 20 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= liblouis
|
||||
PORTVERSION= 2.6.5
|
||||
PORTVERSION= 3.0.0
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= devel
|
||||
|
||||
|
@ -18,5 +18,6 @@ USE_GITHUB= yes
|
|||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1465373318
|
||||
SHA256 (liblouis-liblouis-v2.6.5_GH0.tar.gz) = d539da64cc6cc4f6cb69ebe519d1eb1213127478aa6e7a4f4db16569aa685fb6
|
||||
SIZE (liblouis-liblouis-v2.6.5_GH0.tar.gz) = 22643913
|
||||
TIMESTAMP = 1481012976
|
||||
SHA256 (liblouis-liblouis-v3.0.0_GH0.tar.gz) = b1f5f4d50c39ea3e1aba0325baf64a7efed437e95d96b5a7ed41c4e86a958487
|
||||
SIZE (liblouis-liblouis-v3.0.0_GH0.tar.gz) = 12038628
|
||||
|
|
10
devel/liblouis/files/patch-tools_lou__compare.c
Normal file
10
devel/liblouis/files/patch-tools_lou__compare.c
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- tools/lou_compare.c.orig 2016-12-06 08:48:04 UTC
|
||||
+++ tools/lou_compare.c
|
||||
@@ -6,6 +6,7 @@
|
||||
#include <fcntl.h>
|
||||
#include "liblouis.h"
|
||||
#include "louis.h"
|
||||
+#include <sys/stat.h>
|
||||
|
||||
#ifdef _WIN32
|
||||
#define S_IRUSR 0
|
|
@ -1,20 +1,22 @@
|
|||
bin/lou_allround
|
||||
bin/lou_checkhyphens
|
||||
bin/lou_checktable
|
||||
bin/lou_checkyaml
|
||||
bin/lou_compare
|
||||
bin/lou_debug
|
||||
bin/lou_harnessGenerator
|
||||
bin/lou_trace
|
||||
bin/lou_translate
|
||||
include/liblouis/liblouis.h
|
||||
include/liblouis/louis.h
|
||||
lib/liblouis.a
|
||||
lib/liblouis.so
|
||||
lib/liblouis.so.10
|
||||
lib/liblouis.so.10.0.0
|
||||
lib/liblouis.so.12
|
||||
lib/liblouis.so.12.0.0
|
||||
libdata/pkgconfig/liblouis.pc
|
||||
man/man1/lou_allround.1.gz
|
||||
man/man1/lou_checkhyphens.1.gz
|
||||
man/man1/lou_checktable.1.gz
|
||||
man/man1/lou_checkyaml.1.gz
|
||||
man/man1/lou_debug.1.gz
|
||||
man/man1/lou_trace.1.gz
|
||||
man/man1/lou_translate.1.gz
|
||||
|
@ -57,19 +59,19 @@ man/man1/lou_translate.1.gz
|
|||
%%DATADIR%%/tables/cs-translation.cti
|
||||
%%DATADIR%%/tables/cy-cy-g1.utb
|
||||
%%DATADIR%%/tables/cy-cy-g2.ctb
|
||||
%%DATADIR%%/tables/da-ansi8.dis
|
||||
%%DATADIR%%/tables/da-chardefs6.cti
|
||||
%%DATADIR%%/tables/da-chardefs8.cti
|
||||
%%DATADIR%%/tables/da-dk-common6.uti
|
||||
%%DATADIR%%/tables/da-dk-g16.utb
|
||||
%%DATADIR%%/tables/da-dk-g18.utb
|
||||
%%DATADIR%%/tables/da-dk-g08.ctb
|
||||
%%DATADIR%%/tables/da-dk-g16.ctb
|
||||
%%DATADIR%%/tables/da-dk-g18.ctb
|
||||
%%DATADIR%%/tables/da-dk-g26-patches.cti
|
||||
%%DATADIR%%/tables/da-dk-g26.ctb
|
||||
%%DATADIR%%/tables/da-dk-g28-patches.cti
|
||||
%%DATADIR%%/tables/da-dk-g26l.ctb
|
||||
%%DATADIR%%/tables/da-dk-g28.ctb
|
||||
%%DATADIR%%/tables/da-dk-g28caps.cti
|
||||
%%DATADIR%%/tables/da-dk-g28l.ctb
|
||||
%%DATADIR%%/tables/da-dk-g2core.cti
|
||||
%%DATADIR%%/tables/da-dk-nocaps.uti
|
||||
%%DATADIR%%/tables/da-dk-octobraille.dis
|
||||
%%DATADIR%%/tables/da-dk.dis
|
||||
%%DATADIR%%/tables/da-lt.ctb
|
||||
%%DATADIR%%/tables/de-ch-accents.cti
|
||||
|
@ -153,8 +155,8 @@ man/man1/lou_translate.1.gz
|
|||
%%DATADIR%%/tables/hu-hu-comp8.ctb
|
||||
%%DATADIR%%/tables/hu-hu-g1.ctb
|
||||
%%DATADIR%%/tables/hy.ctb
|
||||
%%DATADIR%%/tables/hyph_brl_da_dk.dic
|
||||
%%DATADIR%%/tables/hyph_cs_CZ.dic
|
||||
%%DATADIR%%/tables/hyph_da_DK.dic
|
||||
%%DATADIR%%/tables/hyph_de_DE.dic
|
||||
%%DATADIR%%/tables/hyph_en_US.dic
|
||||
%%DATADIR%%/tables/hyph_eo.dic
|
||||
|
@ -203,8 +205,8 @@ man/man1/lou_translate.1.gz
|
|||
%%DATADIR%%/tables/marburg_single_cell_defs.cti
|
||||
%%DATADIR%%/tables/marburg_unicode_defs.cti
|
||||
%%DATADIR%%/tables/ml-in-g1.utb
|
||||
%%DATADIR%%/tables/mn-in-g1.utb
|
||||
%%DATADIR%%/tables/mn-MN.utb
|
||||
%%DATADIR%%/tables/mn-in-g1.utb
|
||||
%%DATADIR%%/tables/mr-in-g1.utb
|
||||
%%DATADIR%%/tables/mt.ctb
|
||||
%%DATADIR%%/tables/mun.ctb
|
||||
|
@ -213,13 +215,15 @@ man/man1/lou_translate.1.gz
|
|||
%%DATADIR%%/tables/nemeth.ctb
|
||||
%%DATADIR%%/tables/nemeth_edit.ctb
|
||||
%%DATADIR%%/tables/nemethdefs.cti
|
||||
%%DATADIR%%/tables/nl-BE-chardefs.cti
|
||||
%%DATADIR%%/tables/nl-BE-g1.ctb
|
||||
%%DATADIR%%/tables/nl-BE-g0.utb
|
||||
%%DATADIR%%/tables/nl-BE.dis
|
||||
%%DATADIR%%/tables/nl-NL-chardefs.cti
|
||||
%%DATADIR%%/tables/nl-NL-g1.ctb
|
||||
%%DATADIR%%/tables/nl-NL-g0.utb
|
||||
%%DATADIR%%/tables/nl-chardefs.uti
|
||||
%%DATADIR%%/tables/nl-g0.utb
|
||||
%%DATADIR%%/tables/no-no-8dot-fallback-6dot-g0.utb
|
||||
%%DATADIR%%/tables/no-no-8dot.utb
|
||||
%%DATADIR%%/tables/no-no-chardefs6.uti
|
||||
%%DATADIR%%/tables/no-no-comp8.ctb
|
||||
%%DATADIR%%/tables/no-no-g0.utb
|
||||
%%DATADIR%%/tables/no-no-g1.ctb
|
||||
%%DATADIR%%/tables/no-no-g2.ctb
|
||||
|
@ -227,7 +231,6 @@ man/man1/lou_translate.1.gz
|
|||
%%DATADIR%%/tables/no-no-generic.ctb
|
||||
%%DATADIR%%/tables/no-no-generic.dis
|
||||
%%DATADIR%%/tables/no-no-latinLetterDef6Dots_diacritics.uti
|
||||
%%DATADIR%%/tables/no-no.ctb
|
||||
%%DATADIR%%/tables/no-no.dis
|
||||
%%DATADIR%%/tables/np-in-g1.utb
|
||||
%%DATADIR%%/tables/or-in-g1.utb
|
||||
|
@ -251,8 +254,11 @@ man/man1/lou_translate.1.gz
|
|||
%%DATADIR%%/tables/se-se.ctb
|
||||
%%DATADIR%%/tables/se-se.dis
|
||||
%%DATADIR%%/tables/si-in-g1.utb
|
||||
%%DATADIR%%/tables/sk-chardefs.cti
|
||||
%%DATADIR%%/tables/sk-g1.ctb
|
||||
%%DATADIR%%/tables/sk-sk-g1.utb
|
||||
%%DATADIR%%/tables/sk-sk.utb
|
||||
%%DATADIR%%/tables/sk-translation.cti
|
||||
%%DATADIR%%/tables/sl-si-comp8.ctb
|
||||
%%DATADIR%%/tables/sl-si-g1.utb
|
||||
%%DATADIR%%/tables/sot-za-g1.ctb
|
||||
|
|
Loading…
Reference in a new issue