- Update to 0.35.r1
PR: ports/85456 Submitted by: Alejandro Pulver <alejandro@varnet.biz> (maintainer)
This commit is contained in:
parent
d32b42a78c
commit
fdbb5ac0f8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=141375
4 changed files with 30 additions and 62 deletions
|
@ -6,11 +6,13 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= generator
|
PORTNAME= generator
|
||||||
PORTVERSION= 0.35
|
PORTVERSION= 0.35.r1
|
||||||
|
PORTEPOCH= 1
|
||||||
CATEGORIES= emulators
|
CATEGORIES= emulators
|
||||||
MASTER_SITES= http://www.ghostwhitecrab.com/generator/
|
MASTER_SITES= http://www.ghostwhitecrab.com/generator/ \
|
||||||
|
http://www.ghostwhitecrab.de/generator/
|
||||||
PKGNAMESUFFIX= -cbiere
|
PKGNAMESUFFIX= -cbiere
|
||||||
DISTNAME= ${PORTNAME}-${PORTVERSION}${PKGNAMESUFFIX}
|
DISTNAME= ${PORTNAME}-0.35${PKGNAMESUFFIX}-r1
|
||||||
|
|
||||||
MAINTAINER= alejandro@varnet.biz
|
MAINTAINER= alejandro@varnet.biz
|
||||||
COMMENT= SEGA Genesis emulator
|
COMMENT= SEGA Genesis emulator
|
||||||
|
@ -26,12 +28,11 @@ OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
|
||||||
RAZE "Use RAZE z80 emulation (only for i386)" on \
|
RAZE "Use RAZE z80 emulation (only for i386)" on \
|
||||||
SDL_AUDIO "Use SDL for audio" off
|
SDL_AUDIO "Use SDL for audio" off
|
||||||
|
|
||||||
GNU_CONFIGURE= yes
|
GNU_CONFIGURE= yes
|
||||||
CONFIGURE_ARGS= --program-transform-name=s/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/
|
CONFIGURE_ARGS= --program-transform-name=s/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/
|
||||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
|
||||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
|
||||||
LDFLAGS="-L${LOCALBASE}/lib"
|
|
||||||
CONFIGURE_ARGS+= --with-gtk
|
CONFIGURE_ARGS+= --with-gtk
|
||||||
|
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||||
|
LDFLAGS="-L${LOCALBASE}/lib"
|
||||||
|
|
||||||
PLIST_FILES= bin/${PORTNAME}${PKGNAMESUFFIX}-gtk
|
PLIST_FILES= bin/${PORTNAME}${PKGNAMESUFFIX}-gtk
|
||||||
|
|
||||||
|
@ -44,33 +45,6 @@ post-install:
|
||||||
|
|
||||||
.include <bsd.port.pre.mk>
|
.include <bsd.port.pre.mk>
|
||||||
|
|
||||||
.if ${ARCH} != "amd64" && ${ARCH} != "i386"
|
|
||||||
USE_REINPLACE= yes
|
|
||||||
|
|
||||||
post-patch:
|
|
||||||
# These architectures do not support "-minline-all-stringops"
|
|
||||||
@${REINPLACE_CMD} -e 's|-minline-all-stringops||g' \
|
|
||||||
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
|
|
||||||
.if ${ARCH} == "alpha"
|
|
||||||
# "-ffast-math" does not work on alpha
|
|
||||||
@${REINPLACE_CMD} -e 's|-ffast-math||g' \
|
|
||||||
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
|
|
||||||
.endif
|
|
||||||
.endif
|
|
||||||
|
|
||||||
# Generator needs GCC 2.95.x or GCC >= 3.4.2 to work properly.
|
|
||||||
# Generator-CBiere automatically determines the GCC version.
|
|
||||||
|
|
||||||
.if ${OSVERSION} < 400012
|
|
||||||
# GCC < 2.95 is in the base system.
|
|
||||||
USE_GCC= 2.95
|
|
||||||
.endif
|
|
||||||
|
|
||||||
.if ${OSVERSION} >= 500035 && ${OSVERSION} < 502126
|
|
||||||
# GCC > 2.95 (3.X) && GCC < 3.4.2 is in the base system.
|
|
||||||
USE_GCC= 3.4
|
|
||||||
.endif
|
|
||||||
|
|
||||||
.if defined(WITHOUT_OPTIMIZED_CFLAGS)
|
.if defined(WITHOUT_OPTIMIZED_CFLAGS)
|
||||||
CONFIGURE_ARGS+= --without-gcc
|
CONFIGURE_ARGS+= --without-gcc
|
||||||
.endif
|
.endif
|
||||||
|
|
|
@ -1,2 +1,2 @@
|
||||||
MD5 (generator-0.35-cbiere.tar.bz2) = bce3326c165d74e8a00e50355b653e08
|
MD5 (generator-0.35-cbiere-r1.tar.bz2) = 94cbc31f778f5ec6cc2979520aae26d6
|
||||||
SIZE (generator-0.35-cbiere.tar.bz2) = 454740
|
SIZE (generator-0.35-cbiere-r1.tar.bz2) = 445802
|
||||||
|
|
|
@ -1,10 +0,0 @@
|
||||||
--- configure.orig Sun Apr 17 03:19:27 2005
|
|
||||||
+++ configure Fri Jun 17 20:12:41 2005
|
|
||||||
@@ -4179,7 +4179,6 @@
|
|
||||||
fi
|
|
||||||
|
|
||||||
if [ "x$GCCVER" != "xno" ]; then
|
|
||||||
- CFLAGS="$CFLAGS -W -Wall -Wformat=2"
|
|
||||||
if [ "x$WARN" != "xno" ]; then
|
|
||||||
CFLAGS="$CFLAGS -Wstrict-prototypes -Wunused"
|
|
||||||
fi
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- hdr/generator.h.orig Mon Jan 3 19:07:55 2005
|
--- hdr/generator.h.orig Sun Aug 28 14:44:26 2005
|
||||||
+++ hdr/generator.h Thu Jun 16 22:56:43 2005
|
+++ hdr/generator.h Sun Aug 28 22:33:12 2005
|
||||||
@@ -257,14 +257,22 @@
|
@@ -257,17 +257,26 @@
|
||||||
#include "registers.h"
|
#include "registers.h"
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
|
@ -9,18 +9,22 @@
|
||||||
+#endif
|
+#endif
|
||||||
+
|
+
|
||||||
#if defined(linux)
|
#if defined(linux)
|
||||||
#include <byteswap.h>
|
|
||||||
#define SWAP16(x) bswap_16((x))
|
#include <byteswap.h>
|
||||||
#define SWAP32(x) bswap_32((x))
|
#define SWAP16(x) bswap_16((x))
|
||||||
|
#define SWAP32(x) bswap_32((x))
|
||||||
|
|
||||||
-#elif defined(__FreeBSD__)
|
-#elif defined(__FreeBSD__)
|
||||||
+#elif defined(__FreeBSD__) && __FreeBSD_version >= 500000
|
+#elif defined(__FreeBSD__) && __FreeBSD_version >=500000
|
||||||
#include <sys/endian.h>
|
|
||||||
#define SWAP16(x) bswap16((x))
|
#include <sys/endian.h>
|
||||||
#define SWAP32(x) bswap32((x))
|
#define SWAP16(x) bswap16((x))
|
||||||
|
#define SWAP32(x) bswap32((x))
|
||||||
|
+
|
||||||
+#elif defined(__FreeBSD__)
|
+#elif defined(__FreeBSD__)
|
||||||
+ #include <sys/endian.h>
|
+#include <sys/endian.h>
|
||||||
+ #define SWAP16(x) (be16toh(x))
|
+#define SWAP16(x) (be16toh(x))
|
||||||
+ #define SWAP32(x) (be32toh(x))
|
+#define SWAP32(x) (be32toh(x))
|
||||||
|
|
||||||
#elif defined(__NetBSD__)
|
#elif defined(__NetBSD__)
|
||||||
#include <sys/bswap.h>
|
|
||||||
#define SWAP16(x) bswap16((x))
|
|
||||||
|
|
Loading…
Reference in a new issue