Fix build on 4.x
Reported by: kris
This commit is contained in:
parent
2664912cd1
commit
fdd1538a7b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=160898
6 changed files with 56 additions and 0 deletions
|
@ -30,6 +30,10 @@ MAN1= kst.1
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
|
||||
.endif
|
||||
|
||||
.if defined(WITH_NETCDF)
|
||||
LIB_DEPENDS+= netcdf.1:${PORTSDIR}/science/netcdf
|
||||
PLIST_SUB+= NETCDF=""
|
||||
|
@ -47,6 +51,7 @@ PLIST_SUB+= CDF="@comment "
|
|||
.endif
|
||||
|
||||
post-patch:
|
||||
@${TOUCH} ${WRKSRC}/kst/kst/ksttimers.h.in
|
||||
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
.if !defined(WITH_NETCDF)
|
||||
@${REINPLACE_CMD} -e 's| netcdf||g' ${WRKSRC}/kst/kst/datasources/Makefile.in
|
||||
|
|
|
@ -0,0 +1,12 @@
|
|||
--- kst/kst/datasources/dirfile/getdata.c.orig Sun Apr 30 01:25:45 2006
|
||||
+++ kst/kst/datasources/dirfile/getdata.c Sun Apr 30 01:45:10 2006
|
||||
@@ -1012,8 +1012,8 @@
|
||||
/* */
|
||||
/***************************************************************************/
|
||||
static void *AllocTmpbuff(char type, int n) {
|
||||
- assert(n > 0);
|
||||
void *buff=NULL;
|
||||
+ assert(n > 0);
|
||||
switch(type) {
|
||||
case 'n':
|
||||
buff = NULL;
|
11
science/kst/files/patch-kst-kst-kst.cpp
Normal file
11
science/kst/files/patch-kst-kst-kst.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- kst/kst/kst.cpp.orig Sun Apr 30 00:32:11 2006
|
||||
+++ kst/kst/kst.cpp Sun Apr 30 00:40:06 2006
|
||||
@@ -1489,7 +1489,7 @@
|
||||
bool firstPage = true;
|
||||
while (it->currentItem()) {
|
||||
KstViewWindow *win = dynamic_cast<KstViewWindow*>(it->currentItem());
|
||||
- KstTopLevelViewPtr tlv = win ? kst_cast<KstTopLevelView>(win->view()) : 0L;
|
||||
+ KstTopLevelViewPtr tlv = win ? kst_cast<KstTopLevelView>(win->view()) : static_cast<KstTopLevelViewPtr>(0L);
|
||||
if (win && tlv && !tlv->children().isEmpty()) {
|
||||
++pages;
|
||||
#if KDE_VERSION < KDE_MAKE_VERSION(3,3,0)
|
|
@ -30,6 +30,10 @@ MAN1= kst.1
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
|
||||
.endif
|
||||
|
||||
.if defined(WITH_NETCDF)
|
||||
LIB_DEPENDS+= netcdf.1:${PORTSDIR}/science/netcdf
|
||||
PLIST_SUB+= NETCDF=""
|
||||
|
@ -47,6 +51,7 @@ PLIST_SUB+= CDF="@comment "
|
|||
.endif
|
||||
|
||||
post-patch:
|
||||
@${TOUCH} ${WRKSRC}/kst/kst/ksttimers.h.in
|
||||
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
.if !defined(WITH_NETCDF)
|
||||
@${REINPLACE_CMD} -e 's| netcdf||g' ${WRKSRC}/kst/kst/datasources/Makefile.in
|
||||
|
|
|
@ -0,0 +1,12 @@
|
|||
--- kst/kst/datasources/dirfile/getdata.c.orig Sun Apr 30 01:25:45 2006
|
||||
+++ kst/kst/datasources/dirfile/getdata.c Sun Apr 30 01:45:10 2006
|
||||
@@ -1012,8 +1012,8 @@
|
||||
/* */
|
||||
/***************************************************************************/
|
||||
static void *AllocTmpbuff(char type, int n) {
|
||||
- assert(n > 0);
|
||||
void *buff=NULL;
|
||||
+ assert(n > 0);
|
||||
switch(type) {
|
||||
case 'n':
|
||||
buff = NULL;
|
11
science/kst2/files/patch-kst-kst-kst.cpp
Normal file
11
science/kst2/files/patch-kst-kst-kst.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- kst/kst/kst.cpp.orig Sun Apr 30 00:32:11 2006
|
||||
+++ kst/kst/kst.cpp Sun Apr 30 00:40:06 2006
|
||||
@@ -1489,7 +1489,7 @@
|
||||
bool firstPage = true;
|
||||
while (it->currentItem()) {
|
||||
KstViewWindow *win = dynamic_cast<KstViewWindow*>(it->currentItem());
|
||||
- KstTopLevelViewPtr tlv = win ? kst_cast<KstTopLevelView>(win->view()) : 0L;
|
||||
+ KstTopLevelViewPtr tlv = win ? kst_cast<KstTopLevelView>(win->view()) : static_cast<KstTopLevelViewPtr>(0L);
|
||||
if (win && tlv && !tlv->children().isEmpty()) {
|
||||
++pages;
|
||||
#if KDE_VERSION < KDE_MAKE_VERSION(3,3,0)
|
Loading…
Reference in a new issue