Upgrade to 1.3.1.
Changelog at <http://sourceforge.net/project/shownotes.php?release_id=647191>.
This commit is contained in:
parent
5d4936352f
commit
fdd6beb59f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=225064
4 changed files with 611 additions and 1332 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= torcs
|
||||
DISTVERSION= 1.3.0
|
||||
PORTREVISION= 4
|
||||
DISTVERSION= 1.3.1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF
|
||||
|
||||
|
@ -55,12 +54,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include -DHAVE_DE
|
|||
LIBS="${PTHREAD_LIBS}" LDFLAGS="${LDFLAGS}"
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_FREEGLUT)
|
||||
.if defined(WITH_FREEGLUT)
|
||||
LIB_DEPENDS+= glut.11:${PORTSDIR}/graphics/freeglut
|
||||
.else
|
||||
USE_GL= yes
|
||||
.endif
|
||||
|
||||
EMPTYDIR= champ dtmrace endrace ncrace practice quickrace
|
||||
|
||||
post-patch:
|
||||
.for FILE in ${BASH2FIX}
|
||||
@${REINPLACE_CMD} -E -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
|
||||
|
@ -75,5 +76,8 @@ post-install:
|
|||
@${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/faq/|} ${DOCSDIR}
|
||||
.endif
|
||||
.for ed in ${EMPTYDIR}
|
||||
${TOUCH} ${INSTDIR}/results/${ed}/.keep_me
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (torcs-1.3.0.tar.bz2) = b1f8f3293e408a33c89791ac1f12b179
|
||||
SHA256 (torcs-1.3.0.tar.bz2) = 354b1e34475b6579f493f8a1344788659973add3e7c2e7d087870909067625d7
|
||||
SIZE (torcs-1.3.0.tar.bz2) = 153890028
|
||||
MD5 (torcs-1.3.1.tar.bz2) = f3efd94fb52e9963e176bf441cdab7b3
|
||||
SHA256 (torcs-1.3.1.tar.bz2) = 901b7baddbdc6c0aa343be1b35fe3ef2eb30100279ba9189d8ec8ed4b33d51fd
|
||||
SIZE (torcs-1.3.1.tar.bz2) = 211422481
|
||||
|
|
|
@ -1,19 +1,18 @@
|
|||
--- configure.orig Sat Oct 7 23:02:55 2006
|
||||
+++ configure Mon Oct 9 22:24:36 2006
|
||||
@@ -4931,13 +4931,13 @@
|
||||
--- configure.orig 2008-11-23 14:50:12.000000000 +0100
|
||||
+++ configure 2008-12-30 12:51:52.000000000 +0100
|
||||
@@ -5633,12 +5633,12 @@
|
||||
fi
|
||||
|
||||
#CFLAGS="-ansi -Wall -Wstrict-prototypes -W"
|
||||
-ADDCFLAGS="-Wall -fPIC -fno-strict-aliasing"
|
||||
+ADDCFLAGS="$CFLAGS -Wall -fPIC -fno-strict-aliasing"
|
||||
# Check whether --enable-debug or --disable-debug was given.
|
||||
# Check whether --enable-debug was given.
|
||||
if test "${enable_debug+set}" = set; then
|
||||
enableval="$enable_debug"
|
||||
ADDCFLAGS="$ADDCFLAGS -g -DDEBUG -DDEBUG_OUT"
|
||||
enableval=$enable_debug; ADDCFLAGS="$ADDCFLAGS -g -DDEBUG -DDEBUG_OUT"
|
||||
-else
|
||||
- ADDCFLAGS="$ADDCFLAGS -O2"
|
||||
+#else
|
||||
+# ADDCFLAGS="$ADDCFLAGS -O2"
|
||||
fi;
|
||||
fi
|
||||
|
||||
|
||||
# Check whether --enable-xrandr or --disable-xrandr was given.
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue