- Update to 1.241 [1]
- Prevent test failures without threaded perl - Warn users about threaded perl PR: ports/162734 [1] Submitted by: sunpoet@ [1]
This commit is contained in:
parent
ab60de8b2d
commit
fe21665c97
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=287696
3 changed files with 35 additions and 3 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= Glib2
|
||||
PORTVERSION= 1.240
|
||||
PORTVERSION= 1.241
|
||||
CATEGORIES= devel perl5
|
||||
MASTER_SITES= CPAN/Glib SF/gtk2-perl/Glib/${PORTVERSION}
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
@ -26,4 +26,11 @@ post-install:
|
|||
@cd ${WRKSRC}/blib/man3 && ${FIND} * -name "*.3" | ${SED} \
|
||||
's,^,${MAN3PREFIX:S,^${PREFIX}/,,}/man/man3/,' >> ${TMPPLIST}
|
||||
|
||||
pre-everything::
|
||||
@${ECHO_MSG} "--------------------------------------------------------"
|
||||
@${ECHO_MSG} "Some functions of this module require a threaded perl."
|
||||
@${ECHO_MSG} "If you intend to use them or experience hangs when"
|
||||
@${ECHO_MSG} "using this module, enable the THREADS option in perl."
|
||||
@${ECHO_MSG} "--------------------------------------------------------"
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (Glib-1.240.tar.gz) = f47b3a6821133df3303c09057a2747df1fcfb022dc1cff007a9a8435a3ff5611
|
||||
SIZE (Glib-1.240.tar.gz) = 278781
|
||||
SHA256 (Glib-1.241.tar.gz) = b5a3a52d6c030af9754f13c7752bdba6dbdb752107543e24909854382afc22ec
|
||||
SIZE (Glib-1.241.tar.gz) = 275706
|
||||
|
|
25
devel/p5-Glib2/files/patch-threadstest
Normal file
25
devel/p5-Glib2/files/patch-threadstest
Normal file
|
@ -0,0 +1,25 @@
|
|||
--- t/9.t.orig Sat Nov 26 17:45:25 2011
|
||||
+++ t/9.t Sat Nov 26 17:46:06 2011
|
||||
@@ -32,6 +32,7 @@
|
||||
}
|
||||
}
|
||||
|
||||
+my $can_use_threads = eval 'use threads; 1';
|
||||
|
||||
print "ok 1\n";
|
||||
|
||||
@@ -210,6 +211,14 @@
|
||||
|
||||
|
||||
{
|
||||
+ if (! $can_use_threads) {
|
||||
+ print "ok 26 # skip, no threads\n";
|
||||
+ print "ok 27 # skip\n";
|
||||
+ print "ok 28 # skip\n";
|
||||
+ print "ok 29 # skip\n";
|
||||
+ print "ok 30 # skip\n";
|
||||
+ goto SKIP_CHILD_TESTS;
|
||||
+ }
|
||||
if (! $have_fork) {
|
||||
print "ok 26 # skip, no fork: $fork_excuse\n";
|
||||
print "ok 27 # skip\n";
|
Loading…
Reference in a new issue