Switch MASTER_SITES to a repository, which contains FreeBSD patches

I've created a repository, which incorporates our patches into the build
system of Rarian so that we could use CONFIGURE_ARGS instead of patches and
REINPLACE_CMD's.

Also, while here, drop the patch replacing LINK with CXXLINK in the build
system of the port. It's just not needed anymore.

I'm leaving the patch modifying --version behavior as it is. It's probably
a bad idea that we decided to modify upstream behavior in the first place
but at this point it probably makes little sense to change the behavior
after so many years.
This commit is contained in:
Mateusz Piotrowski 2020-10-09 20:16:36 +00:00
parent cc012dfe93
commit fe3807ac97
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=551816
5 changed files with 14 additions and 56 deletions

View file

@ -4,9 +4,8 @@
PORTNAME= rarian
PORTVERSION= 0.8.1
PORTREVISION= 5
PORTREVISION= 6
CATEGORIES= textproc gnome
MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
COMMENT= OMF help system based on the Freedesktop specification
@ -26,26 +25,21 @@ RUN_DEPENDS= ${LOCALBASE}/bin/getopt:misc/getopt \
docbook-xml>0:textproc/docbook-xml
USES= gmake gnome libtool localbase pathfix python tar:bzip2
USE_GITHUB= yes
GH_ACCOUNT= 0mp
GH_TAGNAME= 00fa779
USE_GNOME= libxslt
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var \
--with-convert-dir=${LOCALBASE}/share/omf
--with-convert-dir=${LOCALBASE}/share/omf \
--with-default-data-dirs="${LOCALBASE}/share:/usr/share" \
--with-default-infopath="${LOCALBASE}/info:${LOCALBASE}/share/info" \
--with-default-manpath="/usr/share/man:${LOCALBASE}/share/man:${LOCALBASE}/man" \
--with-gnu-getopt=${LOCALBASE}/bin/getopt \
--with-localstate-subdir=db/rarian \
--with-metadata-dir=${DOCSDIR}
INSTALL_TARGET= install-strip
post-patch:
@${REINPLACE_CMD} -e 's|/lib/rarian|/db/rarian|' \
${WRKSRC}/util/Makefile.in
@${REINPLACE_CMD} -e 's|@localstatedir@/lib/rarian|@localstatedir@/db/rarian|g ; \
s|getopt|${LOCALBASE}/bin/getopt|' \
${WRKSRC}/util/rarian-sk-config.in \
${WRKSRC}/util/rarian-sk-extract.in \
${WRKSRC}/util/rarian-sk-rebuild.in \
${WRKSRC}/util/rarian-sk-update.in
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/librarian/rarian-main.c \
${WRKSRC}/librarian/rarian-man.c \
${WRKSRC}/librarian/rarian-info.c
.include <bsd.port.mk>

View file

@ -1,2 +1,3 @@
SHA256 (rarian-0.8.1.tar.bz2) = aafe886d46e467eb3414e91fa9e42955bd4b618c3e19c42c773026b205a84577
SIZE (rarian-0.8.1.tar.bz2) = 324441
TIMESTAMP = 1602273811
SHA256 (0mp-rarian-0.8.1-00fa779_GH0.tar.gz) = 533e4553815a0e6f87847cc312aabd459fe0d922a423f59e84242f74659fdb28
SIZE (0mp-rarian-0.8.1-00fa779_GH0.tar.gz) = 506710

View file

@ -1,11 +0,0 @@
--- docs/Makefile.in.orig 2007-08-02 01:37:06.000000000 -0400
+++ docs/Makefile.in 2007-08-02 01:37:22.000000000 -0400
@@ -183,7 +183,7 @@ target_alias = @target_alias@
EXTRA_DIST = help-spec-0.2.xml index.xhtml rar-mdf.xhtml rar-lib.xhtml rar-skcompat.xhtml rarian.document.in
manualdir = $(datadir)/librarian/manual
manual_DATA = help-spec-0.2.xml index.xhtml rar-mdf.xhtml rar-lib.xhtml rar-skcompat.xhtml
-metadatadir = $(datadir)/help
+metadatadir = $(datadir)/doc/rarian
metadata_DATA = rarian.document
all: all-am

View file

@ -1,11 +0,0 @@
--- librarian/rarian-main.c.orig 2007-08-02 16:04:45.000000000 -0400
+++ librarian/rarian-main.c 2007-08-02 16:12:58.000000000 -0400
@@ -212,7 +212,7 @@ past:
path = getenv ("XDG_DATA_DIRS");
if (!path || !strcmp (path, "")) {
- path = "/usr/local/share/:/usr/share/";
+ path = "/usr/local/share/";
}
cur_path = path;
do {

View file

@ -1,15 +0,0 @@
--- util/Makefile.in.orig 2010-10-03 11:23:55.000000000 +0200
+++ util/Makefile.in 2010-10-03 11:24:58.000000000 +0200
@@ -401,10 +401,10 @@
done
rarian-example$(EXEEXT): $(rarian_example_OBJECTS) $(rarian_example_DEPENDENCIES)
@rm -f rarian-example$(EXEEXT)
- $(LINK) $(rarian_example_OBJECTS) $(rarian_example_LDADD) $(LIBS)
+ $(CXXLINK) $(rarian_example_OBJECTS) $(rarian_example_LDADD) $(LIBS)
rarian-sk-gen-uuid$(EXEEXT): $(rarian_sk_gen_uuid_OBJECTS) $(rarian_sk_gen_uuid_DEPENDENCIES)
@rm -f rarian-sk-gen-uuid$(EXEEXT)
- $(LINK) $(rarian_sk_gen_uuid_OBJECTS) $(rarian_sk_gen_uuid_LDADD) $(LIBS)
+ $(CXXLINK) $(rarian_sk_gen_uuid_OBJECTS) $(rarian_sk_gen_uuid_LDADD) $(LIBS)
rarian-sk-get-cl$(EXEEXT): $(rarian_sk_get_cl_OBJECTS) $(rarian_sk_get_cl_DEPENDENCIES)
@rm -f rarian-sk-get-cl$(EXEEXT)
$(rarian_sk_get_cl_LINK) $(rarian_sk_get_cl_OBJECTS) $(rarian_sk_get_cl_LDADD) $(LIBS)