Update to 2.1.1
PR: 19362 Submitted by: maintainer
This commit is contained in:
parent
81faedf826
commit
fe7d808a96
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=29940
9 changed files with 93 additions and 87 deletions
|
@ -6,17 +6,16 @@
|
|||
#
|
||||
|
||||
PORTNAME= dap
|
||||
PORTVERSION= 2.0.2
|
||||
PORTVERSION= 2.1.1
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www.cee.hw.ac.uk/~richardk/
|
||||
DISTNAME= DAPSource
|
||||
EXTRACT_SUFX=.tgz
|
||||
|
||||
MAINTAINER= yoshiaki@kt.rim.or.jp
|
||||
|
||||
LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms \
|
||||
Xpm.4:${PORTSDIR}/graphics/xpm
|
||||
|
||||
WRKSRC= ${WRKDIR}/dap
|
||||
USE_X_PREFIX= yes
|
||||
|
||||
do-install:
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (DAPSource.tar.gz) = 971561d3e26f30db398d51b6b3d8d018
|
||||
MD5 (dap-2.1.1.tgz) = 513b11421fd78cdd1f9bf45e7348191a
|
||||
|
|
|
@ -1,7 +1,10 @@
|
|||
Index: Makefile
|
||||
@@ -0,0 +1,83 @@
|
||||
diff -urN ../dap-2.1.1.orig/Makefile ./Makefile
|
||||
--- ../dap-2.1.1.orig/Makefile Thu Jan 1 09:00:00 1970
|
||||
+++ ./Makefile Sat Jun 10 21:12:24 2000
|
||||
@@ -0,0 +1,101 @@
|
||||
+BACKDIR = ./bak
|
||||
+HOMEDIR = $(HOME)
|
||||
+DAPVER = dap-2.1.1
|
||||
+
|
||||
+all: DAP
|
||||
+
|
||||
|
@ -14,40 +17,51 @@ Index: Makefile
|
|||
+
|
||||
+release: DAP
|
||||
+ strip main/DAP
|
||||
+ (cd ..; tar -cf $(HOMEDIR)/LinuxDAP.tar dap/main/DAP dap/main/effects \
|
||||
+ dap/README dap/INSTALL dap/COPYING dap/CHANGES dap/TODO dap/THANKS);
|
||||
+ gzip $(HOMEDIR)/LinuxDAP.tar
|
||||
+ (cd ..; tar -cf $(HOMEDIR)/bin-linux-$(DAPVER).tar $(DAPVER)/main/DAP $(DAPVER)/main/effects \
|
||||
+ $(DAPVER)/README $(DAPVER)/INSTALL $(DAPVER)/COPYING $(DAPVER)/CHANGES $(DAPVER)/TODO $(DAPVER)/THANKS);
|
||||
+ gzip $(HOMEDIR)/bin-linux-$(DAPVER).tar; \
|
||||
+ mv $(HOMEDIR)/bin-linux-$(DAPVER).tar.gz $(HOMEDIR)/bin-linux-$(DAPVER).tgz
|
||||
+
|
||||
+source:
|
||||
+ (cd ..; tar -cf $(HOMEDIR)/DAPSource.tar \
|
||||
+ dap/README dap/INSTALL dap/COPYING dap/CHANGES dap/TODO dap/THANKS \
|
||||
+ dap/Makefile.* dap/main/*.c dap/main/*.cc dap/main/*.h dap/main/*.fd \
|
||||
+ dap/main/icons/*.gif dap/main/icons/*.xpm dap/main/Makefile.* \
|
||||
+ dap/main/effects dap/sound/*.h dap/sound/*.cc dap/sound/*.inl \
|
||||
+ dap/sound/Makefile.* dap/spkit/spkit/*.cc dap/spkit/spkit/*.h \
|
||||
+ dap/spkit/spkit/Makefile.* dap/tooltips/CHANGES dap/tooltips/COPYING \
|
||||
+ dap/tooltips/Makefile dap/tooltips/README dap/tooltips/THANKS \
|
||||
+ dap/tooltips/TODO dap/tooltips/*.c dap/tooltips/*.h dap/tooltips/*.fd \
|
||||
+ dap/tooltips/examples/menu/Makefile dap/tooltips/examples/menu/*.c \
|
||||
+ dap/tooltips/examples/menu/*.h dap/tooltips/examples/menu/*.fd);
|
||||
+ gzip $(HOMEDIR)/DAPSource.tar
|
||||
+ (cd ..; tar -cf $(HOMEDIR)/$(DAPVER).tar $(DAPVER)/main/effects \
|
||||
+ $(DAPVER)/README $(DAPVER)/INSTALL $(DAPVER)/COPYING $(DAPVER)/CHANGES $(DAPVER)/TODO $(DAPVER)/THANKS \
|
||||
+ $(DAPVER)/Makefile.* $(DAPVER)/main/*.c $(DAPVER)/main/*.cc $(DAPVER)/main/*.h $(DAPVER)/main/*.fd \
|
||||
+ $(DAPVER)/main/icons/*.gif $(DAPVER)/main/icons/*.xpm $(DAPVER)/main/Makefile.* \
|
||||
+ $(DAPVER)/main/effects $(DAPVER)/sound/*.h $(DAPVER)/sound/*.cc $(DAPVER)/sound/*.inl \
|
||||
+ $(DAPVER)/sound/Makefile.* $(DAPVER)/spkit/spkit/*.cc $(DAPVER)/spkit/spkit/*.h \
|
||||
+ $(DAPVER)/libaudio/*.c $(DAPVER)/libaudio/*.h $(DAPVER)/libaudio/Makefile.* \
|
||||
+ $(DAPVER)/libaudiofile/*.c $(DAPVER)/libaudiofile/*.h $(DAPVER)/libaudiofile/Makefile.* \
|
||||
+ $(DAPVER)/spkit/spkit/Makefile.* $(DAPVER)/tooltips/CHANGES $(DAPVER)/tooltips/COPYING \
|
||||
+ $(DAPVER)/tooltips/Makefile.* $(DAPVER)/tooltips/README $(DAPVER)/tooltips/THANKS \
|
||||
+ $(DAPVER)/tooltips/TODO $(DAPVER)/tooltips/*.c $(DAPVER)/tooltips/*.h $(DAPVER)/tooltips/*.fd \
|
||||
+ $(DAPVER)/tooltips/examples/menu/Makefile $(DAPVER)/tooltips/examples/menu/*.c \
|
||||
+ $(DAPVER)/tooltips/examples/menu/*.h $(DAPVER)/tooltips/examples/menu/*.fd);
|
||||
+ gzip $(HOMEDIR)/$(DAPVER).tar; \
|
||||
+ mv $(HOMEDIR)/$(DAPVER).tar.gz $(HOMEDIR)/$(DAPVER).tgz
|
||||
+
|
||||
+cleanall:
|
||||
+ (cd tooltips; make -f Makefile clean);
|
||||
+ (cd main; make -f Makefile.freebsd clean);
|
||||
+ (cd sound; make -f Makefile.freebsd clean);
|
||||
+ (cd spkit/spkit; make -f Makefile.freebsd clean);
|
||||
+ (cd tooltips; make -f Makefile.linux clean);
|
||||
+ (cd libaudio; make -f Makefile.linux clean);
|
||||
+ (cd libaudiofile; make -f Makefile.linux clean);
|
||||
+ (cd sound; make -f Makefile.linux clean);
|
||||
+ (cd spkit/spkit; make -f Makefile.linux clean);
|
||||
+ (cd main; make -f Makefile.linux clean);
|
||||
+
|
||||
+emptyall:
|
||||
+ (cd tooltips; make -f Makefile clean);
|
||||
+ (cd main; make -f Makefile.freebsd empty);
|
||||
+ (cd sound; make -f Makefile.freebsd empty);
|
||||
+ (cd spkit/spkit; make -f Makefile.freebsd empty);
|
||||
+ (cd tooltips; make -f Makefile.linux empty);
|
||||
+ (cd libaudio; make -f Makefile.linux empty);
|
||||
+ (cd libaudiofile; make -f Makefile.linux empty);
|
||||
+ (cd sound; make -f Makefile.linux empty);
|
||||
+ (cd spkit/spkit; make -f Makefile.linux empty);
|
||||
+ (cd main; make -f Makefile.linux empty);
|
||||
+
|
||||
+backall: back
|
||||
+ (cd main; make -f Makefile.freebsd back);
|
||||
+ (cd sound; make -f Makefile.freebsd back);
|
||||
+ (cd spkit/spkit; make -f Makefile.freebsd back);
|
||||
+ (cd tooltips; make -f Makefile.linux back);
|
||||
+ (cd libaudio; make -f Makefile.linux back);
|
||||
+ (cd libaudiofile; make -f Makefile.linux back);
|
||||
+ (cd sound; make -f Makefile.linux back);
|
||||
+ (cd spkit/spkit; make -f Makefile.linux back);
|
||||
+ (cd main; make -f Makefile.linux back);
|
||||
+
|
||||
+back:
|
||||
+ "cp" README $(BACKDIR)
|
||||
|
@ -61,17 +75,23 @@ Index: Makefile
|
|||
+ README INSTALL COPYING CHANGES TODO THANKS Makefile.*
|
||||
+
|
||||
+restoreall: restore
|
||||
+ (cd main; make -f Makefile.freebsd restore);
|
||||
+ (cd sound; make -f Makefile.freebsd restore);
|
||||
+ (cd spkit/spkit; make -f Makefile.freebsd restore);
|
||||
+ (cd tooltips; make -f Makefile.linux restore);
|
||||
+ (cd libaudio; make -f Makefile.linux restore);
|
||||
+ (cd libaudiofile; make -f Makefile.linux restore);
|
||||
+ (cd sound; make -f Makefile.linux restore);
|
||||
+ (cd spkit/spkit; make -f Makefile.linux restore);
|
||||
+ (cd main; make -f Makefile.linux restore);
|
||||
+
|
||||
+restore:
|
||||
+ lha x $(HOMEDIR)/tich4.lzh
|
||||
+
|
||||
+printall: print
|
||||
+ (cd main; make -f Makefile.linux print);
|
||||
+ (cd tooltips; make -f Makefile.linux print);
|
||||
+ (cd libaudio; make -f Makefile.linux print);
|
||||
+ (cd libaudiofile; make -f Makefile.linux print);
|
||||
+ (cd sound; make -f Makefile.linux print);
|
||||
+ (cd spkit/spkit; make -f Makefile.linux print);
|
||||
+ (cd main; make -f Makefile.linux print);
|
||||
+
|
||||
+print:
|
||||
+ a2ps \
|
||||
|
|
|
@ -1,28 +1,15 @@
|
|||
--- libaudio/audio.h.orig Fri Nov 12 11:35:21 1999
|
||||
+++ libaudio/audio.h Sat Dec 11 13:36:15 1999
|
||||
@@ -17,13 +17,15 @@
|
||||
|
|
||||
****************************************************************************/
|
||||
|
||||
-#ifdef LINUX
|
||||
+#if defined(LINUX) || defined(__FreeBSD__)
|
||||
|
||||
#ifndef _audio_h
|
||||
diff -urN ../dap-2.1.1.orig/libaudio/audio.h ./libaudio/audio.h
|
||||
--- ../dap-2.1.1.orig/libaudio/audio.h Tue Feb 29 10:16:06 2000
|
||||
+++ ./libaudio/audio.h Sun Jun 11 14:22:12 2000
|
||||
@@ -20,7 +20,11 @@
|
||||
#define _audio_h
|
||||
|
||||
#include <stdio.h>
|
||||
+#ifndef __FreeBSD__
|
||||
+#ifdef __FreeBSD__
|
||||
+#include <stdlib.h>
|
||||
+#else
|
||||
#include <malloc.h>
|
||||
+#endif
|
||||
#include <unistd.h>
|
||||
#include <fcntl.h>
|
||||
#include <limits.h>
|
||||
@@ -33,6 +35,8 @@
|
||||
#include <sys/ioctl.h>
|
||||
#ifdef __NetBSD__
|
||||
#include <soundcard.h>
|
||||
+#elif defined(__FreeBSD__)
|
||||
+#include <machine/soundcard.h>
|
||||
#else
|
||||
#include <sys/soundcard.h>
|
||||
#endif
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
--- libaudio/Makefile.linux.orig Sun Jan 10 04:25:03 1999
|
||||
+++ libaudio/Makefile.linux Sat Oct 2 09:21:01 1999
|
||||
diff -urN ../dap-2.1.1.orig/libaudio/Makefile.linux ./libaudio/Makefile.linux
|
||||
--- ../dap-2.1.1.orig/libaudio/Makefile.linux Tue Feb 22 09:28:50 2000
|
||||
+++ ./libaudio/Makefile.linux Sun Jun 11 13:51:44 2000
|
||||
@@ -1,11 +1,11 @@
|
||||
-CC = gcc
|
||||
-CXX = g++
|
||||
|
@ -8,8 +9,8 @@
|
|||
BACKDIR = ../bak/libaudio
|
||||
HOMEDIR = $(HOME)
|
||||
INCDIR = -I.
|
||||
-CCFLAGS = $(INCDIR) $(DEBUG) $(OPTIM) -DLINUX -DBIGENDIAN -DUSINGGCC -Wall
|
||||
+CCFLAGS = $(INCDIR) $(OPTIM) -DLINUX -DUSINGGCC -Wall
|
||||
-CCFLAGS = $(INCDIR) $(DEBUG) $(OPTIM) -DLINUX -DBIGENDIAN -DUSINGGCC -Wall -Wno-unused
|
||||
+CCFLAGS = $(INCDIR) $(OPTIM) -DLINUX -DUSINGGCC -Wall -Wno-unused
|
||||
DEBUG = -g3
|
||||
-OPTIM = -O1
|
||||
+OPTIM = ${CXXFLAGS}
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
--- spkit/spkit/Makefile.linux.orig Sun Jan 10 04:41:18 1999
|
||||
+++ spkit/spkit/Makefile.linux Sat Oct 2 09:23:46 1999
|
||||
diff -urN ../dap-2.1.1.orig/spkit/spkit/Makefile.linux ./spkit/spkit/Makefile.linux
|
||||
--- ../dap-2.1.1.orig/spkit/spkit/Makefile.linux Tue Feb 22 09:28:14 2000
|
||||
+++ ./spkit/spkit/Makefile.linux Sun Jun 11 13:52:20 2000
|
||||
@@ -1,5 +1,5 @@
|
||||
-CC = gcc
|
||||
-CXX = g++
|
||||
|
@ -12,8 +13,8 @@
|
|||
HOMEDIR = $(HOME)
|
||||
X11DIR = /usr/X11R6
|
||||
INCDIR = -I. -I.. -I../.. -I$(SOUND) -I$(FORMS) -I$(MAINDIR) -I$(TOOLTIP) -I$(X11DIR)/include
|
||||
-CCFLAGS = $(INCDIR) $(DEBUG) $(OPTIM) -DLINUX -DBIGENDIAN -DUSINGGCC -Wall
|
||||
+CCFLAGS = $(INCDIR) $(OPTIM) -DLINUX -DUSINGGCC -Wall
|
||||
-CCFLAGS = $(INCDIR) $(DEBUG) $(OPTIM) -DLINUX -DBIGENDIAN -DUSINGGCC -Wall -Wno-unused
|
||||
+CCFLAGS = $(INCDIR) $(OPTIM) -DLINUX -DBIGENDIAN -DUSINGGCC -Wall -Wno-unused
|
||||
DEBUG = -g3
|
||||
-OPTIM = -O2
|
||||
+OPTIM = ${CXXFLAGS}
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
--- main/Makefile.linux.orig Sun Jan 10 04:23:53 1999
|
||||
+++ main/Makefile.linux Sat Oct 2 09:31:48 1999
|
||||
diff -urN ../dap-2.1.1.orig/main/Makefile.linux ./main/Makefile.linux
|
||||
--- ../dap-2.1.1.orig/main/Makefile.linux Thu May 25 17:52:37 2000
|
||||
+++ ./main/Makefile.linux Sun Jun 11 13:51:02 2000
|
||||
@@ -1,5 +1,5 @@
|
||||
-CC = gcc
|
||||
-CXX = g++
|
||||
|
@ -12,8 +13,8 @@
|
|||
X11DIR = /usr/X11R6
|
||||
INCDIR = -I. -I.. -I$(SOUND) -I$(SPKIT) -I$(FORMS) -I$(TOOLTIP) -I$(X11DIR)/include
|
||||
LIBDIR = -L$(SPKIT)/spkit -L$(FORMS) -L$(AUDIO) -L$(AUDIOF) -L$(TOOLTIP) -L$(X11DIR)/lib
|
||||
-CCFLAGS = $(INCDIR) $(DEBUG) $(OPTIM) -DLINUX -DBIGENDIAN -DUSINGGCC -Wall
|
||||
+CCFLAGS = $(INCDIR) $(OPTIM) -DLINUX -DUSINGGCC -Wall
|
||||
-CCFLAGS = $(INCDIR) $(DEBUG) $(OPTIM) -DLINUX -DBIGENDIAN -DUSINGGCC -DSIGNALWORKAROUND -Wall -Wno-unused
|
||||
+CCFLAGS = $(INCDIR) $(OPTIM) -DLINUX -DUSINGGCC -Wall -Wno-unused
|
||||
DEBUG = -g3
|
||||
-OPTIM = -O1
|
||||
-LDFLAGS = $(LIBDIR) -ldsp -laudio -laudiofile -ltooltips -lforms -lXpm -lX11 -lm
|
||||
|
|
|
@ -1,19 +1,15 @@
|
|||
--- sound/Makefile.linux.orig Mon Nov 15 07:28:21 1999
|
||||
+++ sound/Makefile.linux Sat Dec 11 13:45:25 1999
|
||||
@@ -1,5 +1,5 @@
|
||||
-CC = gcc
|
||||
-CXX = g++
|
||||
+CC ?= gcc
|
||||
+CXX ?= g++
|
||||
FORMS = ../../xforms/FORMS
|
||||
SPKIT = ../spkit
|
||||
AUDIO = ../libaudio
|
||||
@@ -9,7 +9,7 @@
|
||||
diff -urN ../dap-2.1.1.orig/sound/Makefile.linux ./sound/Makefile.linux
|
||||
--- ../dap-2.1.1.orig/sound/Makefile.linux Tue Feb 22 09:27:33 2000
|
||||
+++ ./sound/Makefile.linux Sun Jun 11 13:54:11 2000
|
||||
@@ -9,9 +9,9 @@
|
||||
HOMEDIR = $(HOME)
|
||||
INCDIR = -I. -I.. -I$(SPKIT) -I$(MAINDIR)
|
||||
LIBDIR = -L$(SPKIT)/spkit -L$(AUDIO) -L$(AUDIOF)
|
||||
-CCFLAGS = $(DEBUG) $(OPTIM) -DNOFORMS -DLINUX -DBIGENDIAN -DUSINGGCC -Wall
|
||||
+CCFLAGS = $(CXXFLAGS) -DNOFORMS -DLINUX -DUSINGGCC -Wall
|
||||
-CCFLAGS = $(DEBUG) $(OPTIM) -DNOFORMS -DLINUX -DBIGENDIAN -DUSINGGCC -Wall -Wno-unused
|
||||
+CCFLAGS = $(OPTIM) -DNOFORMS -DLINUX -DUSINGGCC -Wall -Wno-unused
|
||||
DEBUG = -g3
|
||||
OPTIM = -O1
|
||||
-OPTIM = -O1
|
||||
+OPTIM = ${CXXFLAGS}
|
||||
LDFLAGS = $(LIBDIR) -laudio -laudiofile -lm
|
||||
|
||||
PROGS = SampleTest
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
--- libaudiofile/Makefile.linux.orig Sun Jan 10 04:24:25 1999
|
||||
+++ libaudiofile/Makefile.linux Sat Oct 2 09:25:01 1999
|
||||
diff -urN ../dap-2.1.1.orig/libaudiofile/Makefile.linux ./libaudiofile/Makefile.linux
|
||||
--- ../dap-2.1.1.orig/libaudiofile/Makefile.linux Tue Feb 29 08:49:10 2000
|
||||
+++ ./libaudiofile/Makefile.linux Sun Jun 11 14:27:36 2000
|
||||
@@ -1,11 +1,11 @@
|
||||
-CC = gcc
|
||||
-CXX = g++
|
||||
|
@ -8,11 +9,11 @@
|
|||
BACKDIR = ../bak/libaudiofile
|
||||
HOMEDIR = $(HOME)
|
||||
INCDIR = -I.
|
||||
-CCFLAGS = $(INCDIR) $(DEBUG) $(OPTIM) -DLINUX -DBIGENDIAN -DUSINGGCC -Wall
|
||||
+CCFLAGS = $(INCDIR) $(OPTIM) -DLINUX -DUSINGGCC -Wall
|
||||
-CCFLAGS = $(INCDIR) $(DEBUG) $(OPTIM) -DLINUX -DBIGENDIAN -DUSINGGCC -Wall -Wno-unused
|
||||
+CCFLAGS = $(INCDIR) $(OPTIM) -DLINUX -DUSINGGCC -Wall -Wno-unused
|
||||
DEBUG = -g3
|
||||
-OPTIM = -O1
|
||||
+OPTIM = ${CXXFLAGS}
|
||||
+OPTIM = ${CXXFLAGS}
|
||||
|
||||
LIBNAME = libaudiofile.a
|
||||
OBJS = audiofile.o ieee.o macros.o raw.o wav.o
|
||||
|
|
Loading…
Reference in a new issue